Questions tagged [login]

For questions related to login in Sitecore, covering questions about login using Sitecore membership and membership integration, login to the Sitecore Client or admin pages, etc.

22 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
7 votes
0 answers
515 views

How to enable custom hashing algorithm on identity server?

I have sitecore 9.1 and I added pipeline which add new hashing algorithm (pbkdf2 implementation from Zetetic team with 5000 iterations) to CryptoConfig and changed hashAlgorithmType to pbkdf2 in ...
user avatar
  • 163
2 votes
0 answers
38 views

Sitecore10 .Net Core Getting Started Template Architecture for Creating Action Methods

I am quite new to Sitecore 10, .Net Core , Docker, so asking this silly question :) I have followed the Sitecore 10 .Net core getting started template and able to create base setup. Now I understand ...
user avatar
2 votes
0 answers
327 views

User externallogin redirect to public host after login

We have azure appservice for CD witch can be access through private url and public url. Private url is accessible just from internal network, and public url should be used by customer users. Customer ...
user avatar
  • 21
2 votes
0 answers
116 views

Preview and edit links causes ERR_TOO_MANY_REDIRECTS if not logged in

Quirky thing that I've noticed while working on a client's CMS. When I send them preview links in the format of https://campaigns.redacted.com/?sc_itemid=%7B0EA000BF-8F51-482C-9F67-6AE044B64F2F%7D&...
user avatar
  • 535
2 votes
0 answers
138 views

Social Login Not Working

We have Sitecore 8.0 with Update 5. Social Login used to work fine till yesterday. Its not working today. Is it because it is using Graph API 2.2 and it is obsoleted on 27th March? What is the better ...
user avatar
1 vote
1 answer
127 views

Virtual User causing error with AntiForgeryToken, The provided anti-forgery token was meant for user "extranet\user", but the current user is ""

My site uses SSO for login so most site users do not have Sitecore accounts, as such when a user logs in a virtual user is created: protected void CreateVirtualUser(SSOCentralUser user) { ...
user avatar
1 vote
0 answers
189 views

Random Sitecore Logout Issues

Running Sitecore version 8.1 Hello, I've been trying to figure out this issue for a while now and was curious to see if anyone has experienced something similar. Issue: Content publishers get kicked ...
user avatar
  • 11
1 vote
0 answers
375 views

Sitecore login redirects to website and not Launchpad

We are using azure alias URL "https://abc.com/sitecore/login" to access our prod CM site "https://abc-1001-cm.azurewebsites.net/sitecore/login". Earlier we had Sitecore 9.0.1 ...
user avatar
1 vote
0 answers
53 views

Sitecore Virtual login and accessing userProfile.context during layout service execution

we are working on custom personlization rules with user data available outside sitecore. App is developed in jss in ssr mode. With sitecore login setting up virtual user context when user logged in to ...
user avatar
1 vote
0 answers
72 views

Can't call login-page from JSS app

I tried to follow this guide to login from the JSS-app, but I get an error when posting: Access to XMLHttpRequest at 'https://myApp/sitecore/api/ssc/auth/login?sc_apikey={APIKey}' from origin 'http://...
user avatar
1 vote
1 answer
232 views

Sitecore domain and sub domain authentication

Parent Site Url: www.site1.com Sub Domain Url: www.abc.site1.com We have the requirement like create the sub domain(abc.site1.com) in separate instance and use the login & registration ...
user avatar
  • 183
1 vote
0 answers
79 views

Users forced to log into Sitecore to go to home page

I've encountered an oddity related to preview/edit mode that could totally be by design, but is really annoying some of the user base (including myself). When a user logs into Sitecore and then opens ...
user avatar
  • 535
0 votes
2 answers
70 views

Identity Service - error on CM

On my local machine I have Sitecore 10.2, XP0. I have problem with Identity Service. Upon entering the address: .cm / sitecore, he is redirected to the page .cm/sitecore/login?Fbc=1. I should have ...
user avatar
  • 181
0 votes
1 answer
30 views

Forms Authentication Error CD cluster - The current user cannot be resolved from the authentication cookie. The cookie will be removed

We are using Forms based authentication in our Sitecore 10 solution. We have configured ``Redis as our Private and Shared Session Store. The authentication and user login works fine in a single CD ...
user avatar
0 votes
0 answers
40 views

OAuth2.0 Federated authentication with Sitecore 9.3

We are upgrading our existing site from Sitecore 8.2 to Sitecore 9.3. We are using federated authentication for our CD site with OAuth2.0. The login to the site is working as expected but in the ...
user avatar
0 votes
1 answer
148 views

Sitecore services client 403 when login called from different web application

TL;DR: Sitecore services client 403 when login called from different web application (IIS process), but not when called from Postman PROBLEM: RESTful Web API (web service) written in C# running on IIS/...
user avatar
  • 101
0 votes
1 answer
57 views

Unable to find any CM login information in Sitecore 10.1

I cannot find any login messages in my Azure application insights. Only found a logout message like this: AUDIT (sitecore\foo.bar): Logout: sitecore\foo.bar. Does anyone know where to find the login ...
user avatar
0 votes
0 answers
118 views

Sitecore login is not working

We created a new Sitecore environment on Azure, we are facing a problem with a login on the CM server When we enter https://cmserver/sitecore/login it gets redirected to https://siserver/Account/...
user avatar
0 votes
0 answers
155 views

Sitecore 9.3 XP1-CM Post Installation Issue - Sorry there was an error

I am installing Sitecore 9.3 XP1-CM on Windows 2016 Server. Trying to set up our UAT Servers. The installation succeeded and I can see the login page. But, if I try to login to the Sitecore Instance, ...
user avatar
0 votes
0 answers
247 views

401 unauthorized on POST to /identity/externallogin

I am trying to enable federated authentication in my Sitecore 9.3 solution to login using Google Authentication. I have configued Sitecore more or less like this: https://blog.nikkipunjabi.com/2018/02/...
user avatar
0 votes
0 answers
2k views

Sitecore OKTA Integration

Our System needs to Integration with OKTA SSO Provider. Here is the Problem statement 1) OKTA is used as the IDP in Identity Management for performing SSO authentication. 2) Okta gets UserId and ...
user avatar
-1 votes
1 answer
100 views

Restrict all users from login to Sitecore except admin

I want to provide an option to admin so that they can allow or restrict all users (except admin) from logging in to Sitecore. Custom error message should be displayed on Sitecore login screen if ...
user avatar
  • 485