A message from our CEO about the future of Stack Overflow and Stack Exchange. Read now.

Questions tagged [media-library]

Anything related to media stored in the database or file system and created as items in the Media Library.

Filter by
Sorted by
Tagged with
1
vote
1answer
37 views

Image hash in URL causes image to have black background in normal mode

I have a case where a PNG image appears differently in edit and preview mode versus normal mode. The normal mode image has black bars at the top and bottom of the image. The edit / preview image does ...
1
vote
0answers
43 views

Media from media library getting detached

Sitecore version: 9.0.2 Scaled What is happening: No image or media file has been changed. But the images from a folder in the media library stopped getting rendered on the site. Upon investigation,...
0
votes
0answers
24 views

Restrict upload size [duplicate]

I am using Sitecore 8.2 and looking around I have been unable to find a solution for restricting file size by extension and Sitecore role. E.g. A content editor with the role of "Home" should not be ...
1
vote
2answers
41 views

MediaCreator.CreateFromStream creates an item with the template “File”

I'm using Sitecore.Resources.Media.MediaCreatorOptions and Sitecore.Resources.Media.MediaCreator to programmatically create media items. I've set the MediaCreatorOptions.FileBased property to false ...
1
vote
2answers
46 views

Packaging and installing media items not working - items are created but have no attached file

My content authors uploaded a ton of media items in our UAT environment. I'm trying to package these and install in prod, but the installation isn't working. I'm created a regular Sitecore package ...
2
votes
0answers
43 views

Images are broken on Safari Browser [closed]

I'm using Sitecore 9.1, JSS and ReactJS. Some of the images are not showing on Safari but working fine on Chrome. Here's a sample url: /-/media/Intelligence-Bank/Folder/Folder/Logo/Logo.png?h=422&...
1
vote
1answer
44 views

Facing the challenge while adding the custom styling related to font in the SXA Site

I am building a SXA site and I have created the custom theme by following the Link I have created my custom stylesheet and added in the theme. But, it is not getting reflected when I preview the ...
3
votes
2answers
116 views

“Not Found” error when uploading media files [closed]

I have a photo item with a file field that I can upload to a specific folder in my media library just fine on our development server, but when I try to do this on our staging server, It allows me to ...
2
votes
1answer
110 views

localized filenames for downloads like pfd files

I am using the displayname for my files to localize the filename, I've written a pipeline that it shows the displayname in the html (that works), but when I try to download the files like pdf's then, ...
1
vote
0answers
15 views

Does this error MediaRequestProtection: An invalid/missing hash value was encountered show only in logs or a Yellow Page? [duplicate]

We are seeing this logs in our Sitecore application, we already saw some of the fixes and we are just wandering if this error makes the page in exception(yellow) page? or this has nothing to do in the ...
0
votes
0answers
55 views

Media cache issue after adding version to the query string as part of the cache bust mechanism on CDN

Background: Recently, we implemented CDN and as part of that version is added to the query string to bust the cache. After that, we started noticing an issue where a web page is loading a random image ...
0
votes
0answers
58 views

Is there a way to use a custom MediaRequestHandler for certain folders in the media library?

I have a special folder in the Sitecore media library (v9.1.1) that I would like to run a custom MediaRequestHandler on. The path to the folder is /media library/files/securefiles. I read this post ...
5
votes
1answer
96 views

How to generate Sitecore Media Handler Hash?

How can I generate Sitecore Media Handler Hash to append it to URL in JSS? I'm trying to resize the image on the fly but image URL query string like /blah/blah/myimagename.jpg?w=548&h=202 ...
0
votes
1answer
44 views

Fixing media items with wrong extension

There have been some suspect manipulations in our media library (for example, detaching and reattaching of images), such that we now have images in our library which are linked to the wrong template. ...
4
votes
2answers
102 views

Rendering images through TreelistEx

Environment: Sitecore 9.0.2 + Glassmapper I am trying to create a component like this. So in the template, for the images (stored in Sitecore Media Library), I have taken a field of type TreeListEx. ...
2
votes
1answer
39 views

Date Uploaded filter doesn't work in Media Library

When trying to select a Media item for a field the Date Uploaded filter returns no results. This is in Sitecore 9.1.1. Here are the steps to reproduce: Navigate to a content item with an Image field ...
1
vote
1answer
128 views

Image src attribute stripped from Responsive Image

I have an issue where the src attribute suddenly is missing from img tags when using the built in Responsive Image in SXA 1.9 on Sitecore 9.2. However the alt, srcset and sizes attribute works as ...
1
vote
1answer
153 views

Large folder with images created on reindex: \App_Data\mediaIndexing

When reindexing on Sitecore 9.1, a folder with all the images is created ..\App_Data\mediaIndexing. My problem is that it gets very big in size, > 55GB of images in my case. Has anyone encountered ...
1
vote
1answer
53 views

“ForceDownload” downloads images in CM even when set to false [closed]

I'm using Sitecore 9.1.1 and SXA 1.8.1. I needed to make .png and .txt files downloadable in my site, so I followed the answer here, and added a config patch where forceDownload is set to true for ...
0
votes
2answers
43 views

Trigger an action when attaching file to Media Library

I'm using sitecore 9.1.1. I have a scenario in which i want to trigger an action when a file is uploaded to the media library and trigger another action when i re attach a file to the previously ...
0
votes
1answer
48 views

Where can I see in C# that a media item is versionable?

I need to know if a uploaded media item is versionable uploaded or not? But I can't find a property on the Imagefield or MediaItem itself where I can see if the media item was uploaded versionable. ...
0
votes
0answers
19 views

“Drag & Drop” Media not working in IE11

We would like to have "Drag & Drop" functionality in Sitecore v8.1 I can see option of "Drag & Drop" in the media library but when dialog opens it gives below message "Please wait while Drag &...
1
vote
3answers
126 views

How to move media items to new folder without impacting references programmatically?

We have lot of items in the one of the image folder so we are planning to move these images in multiple folder. We would like to do this programmatically however we are not sure if it will impact the ...
1
vote
1answer
136 views

Sitecore image optimizer (to get responsive images)

What is the proper way to do responsive images in Sitecore? At the moment, we are using two images fields: one for desktop and another for mobile. Is that a good way? As a separate (but related) ...
0
votes
2answers
134 views

Update Missing Title, Alt Text,Description for Images

We are using Sitecore 8.2 Update 2 and it has a lot of images which has missing Title, ALt text and Description for Images. We performed below action Wrote a Pipeline which inherits from Render field ...
2
votes
1answer
57 views

Media path not updated after renaming the media item in Sitecore 7

We are using Sitecore 7 SP1. I have renamed a media folder, both its item & display name. The item with the image field still shows the media path with the old name, but somehow the image is ...
2
votes
1answer
200 views

How can I override the serving of Media Files? (Implementing authentication for media items)

I'm using Sitecore 9.0.2 What I want I'm having an issue serving media files. I would like to check if an user is authenticated before it is served. What I tried I'm currently doing this for all ...
2
votes
1answer
107 views

Could not create instance of type (My implementation of FilterUrlExtensions) No matching constructor was found

I'm using Sitecore 9.0.2. I am implementing Sitecore.Pipelines.PreprocessRequest.FilterUrlExtensions, that in Sitecore 9.0.2 has a constructor with the following signature: public ...
0
votes
2answers
204 views

How to remove media item from both blobs table and items table at the same time from sitecore master db?

I have added some images in sitecore media library. Those images are getting added in both dbo.Blobs and dbo.Items tables. I wanted to delete the image data from both the tables.But I don't know how ...
0
votes
2answers
57 views

Force download .txt files from UI

I'm using Sitecore 9.1.1 and SXA 1.8.1. I have a case in which i need to make some files downloadable for the user when he clicks on it. I was able to make the files with "pdf and docx" extensions ...
2
votes
1answer
258 views

Assign media item to sitecore item using powershell script

I want to add an image to an item using powershell script and here is my code. I don't know what i'm missing.. $item.Editing.BeginEdit() [Sitecore.Data.Fields.ImageField]$fieldValueLink = $Item....
1
vote
1answer
34 views

Can I include image URL options with Synthesis field rendering helpers?

I'm on Sitecore 8.2 with Synthesis 8.2.6. I'm currently using the provided helpers Field.RenderedValue and Field.Url. I'd like to request the images with specific size parameters depending on the ...
-1
votes
1answer
56 views

Sitecore not allowing WebP image to attached in an image field

Sitecore not allowing WebP image to attached in an image field. Can anyone suggest how to enable that feature so that we can attached webP format image
1
vote
1answer
46 views

Programmatically uploaded media files are not showing in CD Server

Sitecore Version : 9.0.2 Environment: Azure PaaS CD If upload any media file manually in Content editor, it uploads the media and the filepath field is empty. In program, I need to upload the media ...
0
votes
0answers
20 views

Admin users not able to see non English assets

We are using Sitecore 9.1, SXA 1.7.1 and it is multi Site architecture (English and Italian Sites).As a Admin user when i am setting up an content for Italian site, by default the assets are mapped ...
0
votes
0answers
19 views

Transfer Meta data info from “eng” region to another region in Media Library

For Korean region, we are importing asset from a DAM (Digital Asset Management) source to Sitecore Media Library but by default, it is mapped to English region, can anyone assist how to transfer the ...
0
votes
1answer
56 views

How do you avoid showing the media library path to images and documents when rendering the url?

we are using Sitecore 9.0.2, sitecore sxa 1.7.1 In Content Delivery site, we are showing full image path like: /-/media/Project/MyTest/MyTenant/mytestsite/TestImage.jpg?h=168&la=en&w=300&...
2
votes
0answers
75 views

Sitecore invalid hash value seems to be failing. there are multiple hash queries in the query string

ERROR MediaRequestProtection: An invalid/missing hash value was encountered. The expected hash value: **3B2EEFF3A17529C1E25F9A4C6136A7EC**. Media URL: /-/media/images/features/navigation/support/...
0
votes
1answer
51 views

Is it possible to link all contents of a media folder on a page?

New to working with sitecore, and not really sure if what I'm looking into trying to do is even possible. I certainly can't figure it out myself. In short, I want a page which will list all the ...
-1
votes
1answer
49 views

How to calculate time for Sitecore media library activities?

Client is complaining regarding slowness of the Sitecore media library, activities like opening media folder, uploading image, saving image, using media in Experience editor. Before making any ...
4
votes
1answer
180 views

MediaManager throwing null error

I am facing an issue while fetching the media item URL. This is my code snippet: @{ Sitecore.Data.Fields.ImageField imageItem = (Sitecore.Data.Fields.ImageField)Sitecore.Context.Item.Fields["...
0
votes
0answers
46 views

Media Folders are not visible in Experience Editor while using Content Builder/Content Editor profile in French language

I am working with SXA in Sitecore 9.0.2. While trying to edit a French language version item in Experience Editor mode with Content Builder/Content Editor user profile, media content (also subfolders) ...
0
votes
1answer
152 views

How to get the specific version of media item in Sitecore 9.1?

How to get the specific version of media item in Sitecore 9.1? I tried the following url http://hostname/~/media/mediaitem.aspx?vs=1. But it is not working, still getting the latest version of ...
-1
votes
1answer
93 views

Get all the media items on the current page [closed]

I want to get all the Sitecore media items on the current page. This could be an image, video, pdf ,mp3 or docx Has anyone done something similar to this? What i am currently doing is Getting all ...
2
votes
1answer
144 views

Media Attach command ignores UploadAsFiles

We have <setting name="Media.UploadAsFiles" value="true">. In most scenarios it's working as expected; media items' data bits are stored as files on the server rather than in the Sitecore DB. ...
0
votes
1answer
54 views

Customer Uploaded Image Management Strategy in Sitecore [closed]

Our website is currently having a Custom Reviews functionality where customers can review the product and upload images (just like Amazon reviews) We are currently saving the images in a separate SQL ...
1
vote
1answer
158 views

Media item rename doesn't publish

When we rename a media item in Content Editor, and then publish, the published item in Web DB still has the old name. I expect that the published item's name should change to the new name, so I assume ...
0
votes
1answer
167 views

ERROR Could not run the 'getMediaStream' pipeline for '/sitecore/media library/Images/test '. Original media data will be used

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests. I’ve taken reference from below GitHub project: https://github.com/aweber1/Sitecore....
1
vote
1answer
175 views

Upload as a File Check box not showing

I am using Sitecore 9.1 and I want to configure the Media Item save behavior. I want to save all Media Items in File Systems instead of Database. As of now i want to store in the same server. I have ...
0
votes
0answers
84 views

Default ZIP icon is not loading for the Sitecore Media Item

In Sitecore 9 when we are uploading the zip file in Sitecore Media library. Icon is loading from the template "/sitecore/templates/System/Media/Unversioned/Zip" instead of taking from the temp folder. ...