Skip to main content

Questions tagged [media-library]

Anything related to media stored in the database or file system and created as items in the Media Library.

67 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
6 votes
1 answer
445 views

Transparent PNGs lose transparency when uploaded to media library (8.2)

I have some PNGs that I created in Photoshop which have transparent backgrounds. I've saved these as PNGs and when I view the images in my file stystem in my browser, the background is transparent as ...
Erica Stockwell-Alpert's user avatar
4 votes
0 answers
3k views

SXA Video, Youtube doesn't show thumbnail on mobile?

I am using a Video component and I've created a couple examples, 1 video uses a YouTube source, the other uses a video in the media library. On mobile devices, the Youtube video doesn't show the ...
Ben Davies's user avatar
4 votes
0 answers
527 views

How do you update an attachment in the Media Library using Sitecore's Web API?

I am currently using Sitecore's RESTful ItemService API and CURL to create assets in the Media Library and have that working just fine. However, in some cases, I need to update the attachment (i.e. ...
bushland25's user avatar
3 votes
0 answers
62 views

Can Digizuite for Sitecore be configured to be closed for public access

Is it possible to configure Digizuite for Sitecore (DFS) to be closed to the public and only accessible by a Sitecore CD server (and any other necessary clients)? We would like to force all assets (...
Matthew Dresser's user avatar
3 votes
0 answers
160 views

ShowFieldEditor on a media item detaching media

I have a simple script that we're running, where a content editor has bulk uploaded media and they want to go back through and provide attribution to the images (caption, alt text, photo credit) and ...
Chad Rickman's user avatar
3 votes
0 answers
387 views

How to set Media Cache Folder per site?

Context In my Sitecore (8.2.u7) instance I have 2 websites that share the same images. For this reason, I have setup Media.MediaLinkServerUrl e.g. cdn.mysite.com. This will also help me to integrate ...
Efthymios Dimopoulos's user avatar
3 votes
0 answers
1k views

Disabling Media Request Protection isn't working

I just experienced (what I believe is) an issue on one of our sites in which disabling Media Request Protection in a Sitecore 8.0 site isn't working. I set the Media.RequestProtection.Enabled ...
Zachary Kniebel's user avatar
2 votes
0 answers
71 views

How to replace/register 'ResizeImageStream' method of class 'Sitecore.Resources.Media.ImageEffectsResize' from Sitecore.kernel dll

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests.Everything works fine but Sitecore.Resources.Media.ThumbnailProcessor throws an error in ...
Hina Thakkar's user avatar
2 votes
1 answer
603 views

Add a version when uploading media by overwriting

There are media approved for version 1. The template is VersionedTempate. Check Overwrite existing media items in Upload files (advanced) of the media library and upload. Then, the approved media is ...
m.kawasaki's user avatar
2 votes
0 answers
498 views

Sitecore invalid hash value seems to be failing. there are multiple hash queries in the query string

ERROR MediaRequestProtection: An invalid/missing hash value was encountered. The expected hash value: **3B2EEFF3A17529C1E25F9A4C6136A7EC**. Media URL: /-/media/images/features/navigation/support/...
Tay's user avatar
  • 69
2 votes
0 answers
83 views

Encrypt zip file while uploading to media library folder sitecore 8.2

i have followed the sitecore link and create my custom processor for (Sitecore.Pipelines.Upload.Save). i have faced issues while saving all media items. it gives error on file.SaveAs(filename); ...
meyank's user avatar
  • 161
2 votes
0 answers
389 views

Video Media item is not loading as per language query string parameter?

I have created media item and uploaded two different video in "English" and "Spanish" version. When accessing this media item, it is not loading the video as per the query string parameter, please ...
Thenmozhi Subramaniam's user avatar
1 vote
1 answer
94 views

Error (404) Loading Images Published to Experience Edge Using Image Sizing Parameters

I'm troubleshooting an issue loading images published to Experience Edge using the image sizing parameters, e.g. mw= (reference). As an example, let's say the Experience Edge URL for a published image ...
nsturdivant's user avatar
1 vote
0 answers
51 views

Apply authentication to media files

We are using Sitecore 9.3 with SXA. I have some pdf files stored in the media library in sitecore. These files can be downloaded by users after logging in to the site. There is a security finding that ...
NewbieHere's user avatar
1 vote
3 answers
512 views

How to require alt text when uploading an image in the experience editor?

How can I make this field required so that a user can't upload an image without the alternate text box having a value?
Pinpaho's user avatar
  • 61
1 vote
1 answer
123 views

Issues while generating the media item url with space in item name

we have the below configuration with Sitecore 9.3 <encodeNameReplacements> <replace mode="on" find=" " replaceWith="-" /> </encodeNameReplacements> ...
D J's user avatar
  • 385
1 vote
2 answers
349 views

Disable Media.RequestProtection when page is in preview mode

I have Media.RequestProtection enabled in my Sitecore 10.0 instance. Is there way to disable this only for preview and experience editor mode.
rahul's user avatar
  • 21
1 vote
4 answers
969 views

Media Library File Upload Fails

In Sitecore 9.2, our user is trying to upload a fairly large file (Large, but within configured limits.) In the Media Library, we navigate to the desired folder, click Upload, select the desired ...
Ron Ritchie's user avatar
1 vote
2 answers
111 views

Scanning files under media for vulnerability

We would like to scan our solution for security vulnerabilities. We already have a tool for static analysis. The problem is as follows: We are using the Sitecore media library to host the jQuery files ...
NutsAndBolts's user avatar
  • 1,342
1 vote
2 answers
629 views

How to download media item from media library in sitecore?

I tried to download a media item from media library to my local storage using the Item ID. But it downloaded only in cache storage. I want to download it in downloads folder. public void downloadform(...
Raviraja's user avatar
1 vote
1 answer
217 views

How to Programatically attach a Media File of System.IO.File type

We are trying to programmatically attach Media File to a Media Item at the latest version. Our requirement is to programmatically extract the file (System.IO.File) from the Local System and attach to ...
Sylesh JL's user avatar
  • 191
1 vote
0 answers
186 views

Dianoga errors in the logs for temporary file paths

Getting the below errors related to Dianoga in log files related to temporary file paths. Dianoga version used is 5.4.1 ERROR Dianoga: Unable to optimize {Image path} due to a processing error! It ...
Swathi's user avatar
  • 11
1 vote
0 answers
74 views

Rendering SVG as XML using Glass Mapper

I was curious if anyone has a good solution for rendering SVGs using Glass mapper so that the result is XML embedded into the HTML instead of an tag. I know that I can use Editable() with a ...
Alex's user avatar
  • 545
1 vote
0 answers
119 views

Undefined Javascript Error on Media Upload

In Sitecore 8.2, we have an item template featuring an image field. The preferred workflow for creating an instance of this template is the use of the Browse trigger on the image field and the Upload ...
Ron Ritchie's user avatar
1 vote
0 answers
179 views

Link external resource in sitecore 9.3 media library

We have a Sitecore 9.3 instance running a site. Our problem is that resources uploaded on the Media Library occupy too much disk space. We want to create a custom media library object that links to a ...
Swinz's user avatar
  • 11
1 vote
0 answers
104 views

Media.DefaultImageBackgroundColor

We have a custom import tool that programmatically imports content into a Sitecore 8.2 (rev. 170614) instance. In addition to the content, images are imported and attached to items as they are created....
sh1rts's user avatar
  • 143
1 vote
0 answers
204 views

Upload Media Item to Media Library Folder Through HTTP Request via ItemWebAPI

I am using the ItemWebAPI and attempting to create a media item in a subfolder of my Media Library. The documentation I am referencing for this is here: https://doc.sitecore.com/SdnArchive/upload/sdn5/...
abowden1's user avatar
1 vote
0 answers
1k views

In MediaManager, how to get image's full url with specifed site's domain included?

The reason why I want to change the domain of an image url is because I'm providing an API to a third party. And the regulation is all media url and internal link url, needs to replace the default ...
wtf512's user avatar
  • 143
1 vote
0 answers
93 views

Media from media library getting detached

Sitecore version: 9.0.2 Scaled What is happening: No image or media file has been changed. But the images from a folder in the media library stopped getting rendered on the site. Upon investigation,...
NutsAndBolts's user avatar
  • 1,342
1 vote
0 answers
65 views

Media datasource using Sitecore SXA

How do I add media datasource (I want customers to able to select images from a particular folder) in Sitecore SXA using experience editor. Currently,I have added datasource in the template and works ...
Niti Chauhan's user avatar
1 vote
0 answers
224 views

Could not save posted file exception while uploading an image to media library that ends with (number).extension

When I upload an image to media library that ends with (number).extension Sitecore gives an error - log looks like below. No error if it ends with just () or (letter) or if (number) has a letter ...
Lau Frie's user avatar
1 vote
0 answers
773 views

Custom parameters in media URL query string - Sitecore render method/pipeline

I am using Sitecore's render method to construct the query strings for image assets, but I have a small challenge parsing custom parameters into the rendered query string in the HTML. It seems that ...
Mark Wulff's user avatar
1 vote
0 answers
405 views

Media items not appearing on website after deployment

We are facing an issue with media library during our deployment using Octopus. We have a publish site step in the deployment steps. The issue is media items are not showing in the website after the ...
Sreekrishnan's user avatar
1 vote
0 answers
1k views

Download Sitecore Media file from UI

In our application we have an excel (xlsx/xls) file in medial library. We are trying to create a functionality to be able to download this excel using an html anchor or button. But when we click on ...
Praveen K Dubey's user avatar
1 vote
0 answers
368 views

Media item (image) and RTE

I'm running into an issue with using images in RTE. Images upload as expected into the medialibrary so no issues there. But when I insert the newly uploaded image in RTE it'll appear in Experience ...
Esther's user avatar
  • 31
1 vote
1 answer
292 views

If I add a CSV file to the media library and visit that item in Sitecore, a file is downloaded automatically with the content of that media item

I want to upload a CSV file into our media library. In our Dev environment, this works as expected, the file uploads, shows up in the content tree, mime-type/extension is getting set appropriately, ...
AmoebaMan17's user avatar
0 votes
0 answers
58 views

Images are not getting displayed on Vercel site but are visible in sitecore xmc pages editor

After publishing the item, images are NOT loading on the Vercel site. When I try to click on image link from the edge it gives following error - ERROR 9404: Could not fetch the image — the server ...
shrutika shete's user avatar
0 votes
1 answer
134 views

Sitecore Media Items not showing up in List view of dialogue box

I have recently updated my local Sitecore setup to 10.3 from 10.1 and found out that the media items are not loading in the list view of the Select Media dialogue box while the tree view working fine. ...
Tabbuu's user avatar
  • 75
0 votes
0 answers
53 views

Error message in EXM when using the external image hosting link

I have created an Email campaign via Sitecore, and in my HTML code for the E-mail I used an external link for the image (from the media hosting). When I wanted to send it out via list delivery, I got ...
Lizaveta Andryukhina's user avatar
0 votes
0 answers
42 views

Zip files not being bucketed

When uploading a .zip file to a bucket in the media library, the .zip file does not get put in a bucket. I can't figure out why. E.g. The zip item is set to be bucketable: And I have created a ...
Linas's user avatar
  • 88
0 votes
0 answers
51 views

Sitecore Select Media return empty in Experience Editor - Multisite SXA

We have recently upgraded the Site from v9.2 to 10.2. We have maintained multisite with SXA. In the old Site, we used Azure Search and now converted it into Solr search. After integrating all the ...
Rameshkumar's user avatar
0 votes
1 answer
388 views

How to Programatically update the media attachment in the specific version of a media item in Sitecore 9.3

I am currently trying to update a media item programmatically. Methods like Create From File or Create From Stream are removing all the versions of the media item item and restarting from Version 1. I ...
user11803's user avatar
0 votes
0 answers
327 views

Sitecore Media images with path "/sitecore/shell/themes/standard/-/media" throwing 500 error

We can see 500 errors in the log files for the media files. Those files are having urls with /sitecore/shell/themes/standard/ in it. Why the media Urls uploaded in Sitecore are getting created with ...
Vinod Chavan's user avatar
0 votes
0 answers
144 views

Sitecore media library does not render with sc_language

I uploaded Versioned image in Sitecore 10.0.1 media library. Template used is - /sitecore/templates/System/Media/Versioned/Image the image URL is also correctly rendered with sc_lang. But when I ...
user11324's user avatar
0 votes
1 answer
100 views

Few media files getting downloaded

We are working on Sitecore 8.1 instance where we have got a security issue. As per the issue, few media files are getting downloaded directly when we hit the url. Example - https://hostname/-/media/...
NewbieHere's user avatar
0 votes
4 answers
603 views

Alt text in custom image bind

We are creating image tag from the programming in Sitecore 9.1.1. Using the below code. var image = new MediaItem(imageField.MediaItem); src = StringUtil.EnsurePrefix('/', ...
Ashu's user avatar
  • 402
0 votes
0 answers
47 views

Media Upload Not Triggering for Crowded Media Path

In Sitecore 8.2, we have an item template featuring an image field. The preferred workflow for creating an instance of this template is the use the Browse trigger on the image field and the Upload ...
Ron Ritchie's user avatar
0 votes
0 answers
524 views

Images not showing on preview mode in sitecore 9.1.1

I have a website on sitecore version 9.1.1 and sxa 1.8 Several components and pages contain image fields, when I open the page in edit mode everything looks fine but when I open the page in preview ...
BasantA's user avatar
  • 41
0 votes
0 answers
77 views

Sitecore ProcessMediaRequest is giving 404 for restricted media

I recently had a requirement to restrict secure media items to download so that only certain logged in users could download them. So to achieve that I have remove read access from the extranet\...
Sanket Phating's user avatar
0 votes
0 answers
157 views

Packaging and installing media items not working - items are created but have no attached file, media is NOT stored in file system

I've created a package of media items on my prod environment and installed it on my local. The media files are NOT stored in the file system But when I install the package, the items are created but ...
Erica Stockwell-Alpert's user avatar