Questions tagged [media-library]

Anything related to media stored in the database or file system and created as items in the Media Library.

57 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
6
votes
1answer
296 views

Transparent PNGs lose transparency when uploaded to media library (8.2)

I have some PNGs that I created in Photoshop which have transparent backgrounds. I've saved these as PNGs and when I view the images in my file stystem in my browser, the background is transparent as ...
4
votes
0answers
2k views

SXA Video, Youtube doesn't show thumbnail on mobile?

I am using a Video component and I've created a couple examples, 1 video uses a YouTube source, the other uses a video in the media library. On mobile devices, the Youtube video doesn't show the ...
4
votes
0answers
439 views

How do you update an attachment in the Media Library using Sitecore's Web API?

I am currently using Sitecore's RESTful ItemService API and CURL to create assets in the Media Library and have that working just fine. However, in some cases, I need to update the attachment (i.e. ...
3
votes
0answers
114 views

ShowFieldEditor on a media item detaching media

I have a simple script that we're running, where a content editor has bulk uploaded media and they want to go back through and provide attribution to the images (caption, alt text, photo credit) and ...
3
votes
0answers
258 views

How to set Media Cache Folder per site?

Context In my Sitecore (8.2.u7) instance I have 2 websites that share the same images. For this reason, I have setup Media.MediaLinkServerUrl e.g. cdn.mysite.com. This will also help me to integrate ...
3
votes
0answers
1k views

Disabling Media Request Protection isn't working

I just experienced (what I believe is) an issue on one of our sites in which disabling Media Request Protection in a Sitecore 8.0 site isn't working. I set the Media.RequestProtection.Enabled ...
2
votes
0answers
33 views

How to replace/register 'ResizeImageStream' method of class 'Sitecore.Resources.Media.ImageEffectsResize' from Sitecore.kernel dll

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests.Everything works fine but Sitecore.Resources.Media.ThumbnailProcessor throws error in ...
2
votes
0answers
41 views

Can Digizuite for Sitecore be configured to be closed for public access

Is it possible to configure Digizuite for Sitecore (DFS) to be closed to the public and only accessible by a Sitecore CD server (and any other necessary clients)? We would like to force all assets (...
2
votes
0answers
275 views

Sitecore invalid hash value seems to be failing. there are multiple hash queries in the query string

ERROR MediaRequestProtection: An invalid/missing hash value was encountered. The expected hash value: **3B2EEFF3A17529C1E25F9A4C6136A7EC**. Media URL: /-/media/images/features/navigation/support/...
2
votes
0answers
79 views

Encrypt zip file while uploading to media library folder sitecore 8.2

i have followed the sitecore link and create my custom processor for (Sitecore.Pipelines.Upload.Save). i have faced issues while saving all media items. it gives error on file.SaveAs(filename); ...
2
votes
0answers
295 views

Video Media item is not loading as per language query string parameter?

I have created media item and uploaded two different video in "English" and "Spanish" version. When accessing this media item, it is not loading the video as per the query string parameter, please ...
1
vote
0answers
28 views

Rendering SVG as XML using Glass Mapper

I was curious if anyone has a good solution for rendering SVGs using Glass mapper so that the result is XML embedded into the HTML instead of an tag. I know that I can use Editable() with a ...
1
vote
0answers
50 views

Undefined Javascript Error on Media Upload

In Sitecore 8.2, we have an item template featuring an image field. The preferred workflow for creating an instance of this template is the use of the Browse trigger on the image field and the Upload ...
1
vote
2answers
124 views

Media library item (pdf) reachable after unpublish/not publishable

In Sitecore 9.1.1 I have some PDF documents in the media library that i've "unpublished" (unchecked the publishable publish setting) Then smart-publish parent folder, subitems and all ...
1
vote
0answers
68 views

Media.DefaultImageBackgroundColor

We have a custom import tool that programmatically imports content into a Sitecore 8.2 (rev. 170614) instance. In addition to the content, images are imported and attached to items as they are created....
1
vote
0answers
82 views

Upload Media Item to Media Library Folder Through HTTP Request via ItemWebAPI

I am using the ItemWebAPI and attempting to create a media item in a subfolder of my Media Library. The documentation I am referencing for this is here: https://doc.sitecore.com/SdnArchive/upload/sdn5/...
1
vote
0answers
464 views

In MediaManager, how to get image's full url with specifed site's domain included?

The reason why I want to change the domain of an image url is because I'm providing an API to a third party. And the regulation is all media url and internal link url, needs to replace the default ...
1
vote
0answers
140 views

If I add a CSV file to the media library and visit that item in Sitecore, a file is downloaded automatically with the content of that media item

I want to upload a CSV file into our media library. In our Dev environment, this works as expected, the file uploads, shows up in the content tree, mime-type/extension is getting set appropriately, ...
1
vote
1answer
295 views

Add a version when uploading media by overwriting

There are media approved for version 1. The template is VersionedTempate. Check Overwrite existing media items in Upload files (advanced) of the media library and upload. Then, the approved media is ...
1
vote
0answers
60 views

Media from media library getting detached

Sitecore version: 9.0.2 Scaled What is happening: No image or media file has been changed. But the images from a folder in the media library stopped getting rendered on the site. Upon investigation,...
1
vote
0answers
47 views

Media datasource using Sitecore SXA

How do I add media datasource (I want customers to able to select images from a particular folder) in Sitecore SXA using experience editor. Currently,I have added datasource in the template and works ...
1
vote
0answers
157 views

Could not save posted file exception while uploading an image to media library that ends with (number).extension

When I upload an image to media library that ends with (number).extension Sitecore gives an error - log looks like below. No error if it ends with just () or (letter) or if (number) has a letter ...
1
vote
0answers
495 views

Custom parameters in media URL query string - Sitecore render method/pipeline

I am using Sitecore's render method to construct the query strings for image assets, but I have a small challenge parsing custom parameters into the rendered query string in the HTML. It seems that ...
1
vote
0answers
320 views

Media items not appearing on website after deployment

We are facing an issue with media library during our deployment using Octopus. We have a publish site step in the deployment steps. The issue is media items are not showing in the website after the ...
1
vote
0answers
1k views

Download Sitecore Media file from UI

In our application we have an excel (xlsx/xls) file in medial library. We are trying to create a functionality to be able to download this excel using an html anchor or button. But when we click on ...
1
vote
0answers
295 views

Media item (image) and RTE

I'm running into an issue with using images in RTE. Images upload as expected into the medialibrary so no issues there. But when I insert the newly uploaded image in RTE it'll appear in Experience ...
0
votes
0answers
20 views

Images don't reflect versioning in Rich Text Fields

The Sitecore version for this issue is 9.1.0 (rev. 001564). In content editor, if I add a versioned image with only 1 version created added to a rich text field on an item, I encounter issues when I ...
0
votes
1answer
22 views

Where does SXA store css and js files on CM server

We can see css and js files in content tree under /sitecore/media library/Themes/ and if we view source code of a web page we can also see the links. However I am not able to find those files in ...
0
votes
1answer
29 views

Sitecore 8.1 - few media files getting downloaded

We are working on Sitecore 8.1 instance where we have got a security issue. As per the issue, few media files are getting downloaded directly when we hit the url. Example - https://hostname/-/media/...
0
votes
1answer
48 views

Alt text in custom image bind

We are creating image tag from the programming in Sitecore 9.1.1. Using the below code. var image = new MediaItem(imageField.MediaItem); src = StringUtil.EnsurePrefix('/', ...
0
votes
1answer
25 views

Can we bind image component source through programming?

We would like to bind image component src thorough programming and would like to get Hash value as well. Need this output : <img src="/-/XXXXXX?h=192&amp;w=192&amp;hash=...
0
votes
0answers
40 views

Media Upload Not Triggering for Crowded Media Path

In Sitecore 8.2, we have an item template featuring an image field. The preferred workflow for creating an instance of this template is the use the Browse trigger on the image field and the Upload ...
0
votes
0answers
135 views

Images not showing on preview mode in sitecore 9.1.1

I have a website on sitecore version 9.1.1 and sxa 1.8 Several components and pages contain image fields, when I open the page in edit mode everything looks fine but when I open the page in preview ...
0
votes
0answers
24 views

Custom Image field button stop working after Chrome update

I have custom image field button in order to be able to choose image from outside media storage. Everything worked well until recently Chrome update. My .aspx file for Field popup. <body> &...
0
votes
0answers
42 views

Headless JSS with Sitecore Image URLs

So just need clarification on this image issue I am running into, so my site is www.site.com and some of my images that are located in my media library are coming to my site is showing up as www....
0
votes
0answers
21 views

Uploading SVG images into AWS connection within Sitecore's Media Library

I am working with a client where we use AWS (Amazon Web Services) to manage uploaded images in Sitecore 9.0.2, rather than loading them directly into the media library. When I tried to upload the SVG ...
0
votes
0answers
33 views

Sitecore ProcessMediaRequest is giving 404 for restricted media

I recently had a requirement to restrict secure media items to download so that only certain logged in users could download them. So to achieve that I have remove read access from the extranet\...
0
votes
0answers
32 views

Upload media failing with 'Not Found' error

We are working on Sitecore 8.1 (rev. 160519), and trying to upload images into Sitecore from Image fields is resulting in a Not Found error. I am using the admin account, and as seen, file size is ...
0
votes
0answers
64 views

Packaging and installing media items not working - items are created but have no attached file, media is NOT stored in file system

I've created a package of media items on my prod environment and installed it on my local. The media files are NOT stored in the file system But when I install the package, the items are created but ...
0
votes
0answers
120 views

Sitecore Media Item getting downloaded on click of media item

Media item are getting stored on azure, for this I have overridden Media library classes. Now what happen when I am selecting any media in Media Library to see, It gets automatically downloaded. It ...
0
votes
0answers
105 views

Link external resource in sitecore 9.3 media library

We have a Sitecore 9.3 instance running a site. Our problem is that resources uploaded on the Media Library occupy too much disk space. We want to create a custom media library object that links to a ...
0
votes
1answer
342 views

Media file item looses blob value after publish

This is in Sitecore 9.1 where I have a pdf file media item in sitecore, that is browsable all good from the CM site (master DB) but when I try to browse to it on the CD site (web DB), it gave me a 404 ...
0
votes
0answers
106 views

How to stop download Sitecore media items (png)?

When I click on Sitecore items that have an image field with png image uploaded in it, pop-up appears to download the image. How can I stop the pop-up from appearing? even though I put the force ...
0
votes
0answers
32 views

PDF font and Header not showing on load

I have one PDF file(Content in chinese) stored in sitecore media library but when i try to view it from website(in chrome and microsoft edge) then at first the header logo and some characters of the ...
0
votes
0answers
135 views

Media cache issue after adding version to the query string as part of the cache bust mechanism on CDN

Background: Recently, we implemented CDN and as part of that version is added to the query string to bust the cache. After that, we started noticing an issue where a web page is loading a random image ...
0
votes
1answer
578 views

Is there a way to use a custom MediaRequestHandler for certain folders in the media library?

I have a special folder in the Sitecore media library (v9.1.1) that I would like to run a custom MediaRequestHandler on. The path to the folder is /media library/files/securefiles. I read this post ...
0
votes
0answers
20 views

Admin users not able to see non English assets

We are using Sitecore 9.1, SXA 1.7.1 and it is multi Site architecture (English and Italian Sites).As a Admin user when i am setting up an content for Italian site, by default the assets are mapped ...
0
votes
1answer
468 views

ERROR Could not run the 'getMediaStream' pipeline for '/sitecore/media library/Images/test '. Original media data will be used

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests. I’ve taken reference from below GitHub project: https://github.com/aweber1/Sitecore....
0
votes
0answers
112 views

Default ZIP icon is not loading for the Sitecore Media Item

In Sitecore 9 when we are uploading the zip file in Sitecore Media library. Icon is loading from the template "/sitecore/templates/System/Media/Unversioned/Zip" instead of taking from the temp folder. ...
0
votes
0answers
430 views

Set CDN Media.AlwaysIncludeServerUrl to FALSE when user is in Experience Editor mode

I use the following configuration for setting the CDN prefix for media files in my sitecore. But when viewing a page within the experience editor, none of the images can be reached by the CMS as the ...