Questions tagged [media-library]

Anything related to media stored in the database or file system and created as items in the Media Library.

Filter by
Sorted by
Tagged with
2 votes
1 answer
20 views

Creating media library packages when using Azuire Blob Storage

We are working on an upgrade project and are considering using the Azure Blob Storage module to store media outside of the database. Since the media is no longer stored in the database and is instead ...
user avatar
  • 13.7k
0 votes
0 answers
27 views

How do you maintain context when adding images to an RTE?

Sitecore 9.3 When you add an image through with the toolbar button in an RTE, the popup dialog defaults to the Media Library root. Is there a way to change this so that the context when you click the ...
user avatar
0 votes
1 answer
42 views

How to get all the media library items that are used/displayed on a page?

So we already have a custom site map generation service in our Sitecore 9.2 solution, to generate standard sitemap.xml files, which is working absolutely perfectly. However, we now want to extend it ...
user avatar
0 votes
1 answer
34 views

Sitecore media with AlwaysAppendVersion set to true adds the revision to -1 for non default language versions

Environment: Sc 10, SXA 10x, Azure PaaS Sitecore adds query string param rev=-1 to the media url whenever there is no language version available for asset other than default Language. ex: /-/media/...
user avatar
0 votes
1 answer
41 views

How to Programatically update the media attachment in the specific version of a media item in Sitecore 9.3

I am currently trying to update a media item programmatically. Methods like Create From File or Create From Stream are removing all the versions of the media item item and restarting from Version 1. I ...
user avatar
2 votes
4 answers
103 views

Is it possible to preload an image for the hero banner in Sitecore to improve LCP?

We are trying to improve the LCP score of our site and one of the elements we want to optimize is the large image used in the hero banner of each page. Is there a way to set this image to be preloaded?...
user avatar
0 votes
0 answers
46 views

Dianoga jpeg/png image covering the entire viewport of the page

Dianoga version used is 5.4.1. Dianoga jpeg/png image covering the entire viewport of the page. Clearing the media cache folder renders the image fine for the first time and subsequent loading of the ...
user avatar
  • 11
1 vote
2 answers
105 views

How to update Item's Media Properties using SPE (Sitecore Powershell Extensions)

I have an Image Field in an Item. When the image is uploaded to Media Library, the Alt field is not updated and hence when we look at the Image properties from Item, it is Blank. So far so good. The ...
user avatar
1 vote
0 answers
81 views

Dianoga errors in the logs for temporary file paths

Getting the below errors related to Dianoga in log files related to temporary file paths. Dianoga version used is 5.4.1 ERROR Dianoga: Unable to optimize {Image path} due to a processing error! It ...
user avatar
  • 11
0 votes
2 answers
69 views

Dianoga image optimization error for few of the images

Getting the below error in Dianoga logs. The version used is 5.4.1 - ERROR Dianoga: Could not resize image as it was larger than the maximum size allowed for memory processing Also, the load time of ...
user avatar
  • 11
1 vote
2 answers
149 views

How to get all image field that is included in a page using Sitecore PowerShell and create new language version for images

I would like to know how to get all related media id's from page using Sitecore PowerShell module and create new language definition for media items. So we have a page that have image field in data ...
user avatar
0 votes
1 answer
50 views

Media item upload request

Is there a way to check if the request is coming from Browse for media files Or is it coming upload file or upload files I have code to check upload image size public class ImageSizeCheck : ...
user avatar
0 votes
0 answers
125 views

Sitecore Media images with path "/sitecore/shell/themes/standard/-/media" throwing 500 error

We can see 500 errors in the log files for the media files. Those files are having urls with /sitecore/shell/themes/standard/ in it. Why the media Urls uploaded in Sitecore are getting created with ...
user avatar
0 votes
0 answers
49 views

Sitecore media library does not render with sc_language

I uploaded Versioned image in Sitecore 10.0.1 media library. Template used is - /sitecore/templates/System/Media/Versioned/Image the image URL is also correctly rendered with sc_lang. But when I ...
user avatar
3 votes
1 answer
124 views

Sitecore 10.0.1 Unversioned Images not rendering across languages

I created an image in Media library using Sitecore Unversioned Media Template. After addign image in say En, if I add a diffrent image for Spanish and come back and check English image, it shows the ...
user avatar
0 votes
1 answer
43 views

Supress MediaRequestProtection errors at site level

I have a multisite setup in sitecore 9.1 and getting the below error on ERROR MediaRequestProtection: An invalid/missing hash value was encountered. The expected hash value I know the reason for ...
user avatar
0 votes
1 answer
48 views

How to upload single file into theme

I wanted to change one js file from theme so I downloaded it. Now when I made those changes I am not able to see any option to upload it. Can someone please guide me on this? Update As Raman ...
user avatar
  • 153
0 votes
1 answer
92 views

Getting Dianoga to work with the jssmedia urls

I've been at it a couple of days now and gotten Dianoga working, converting all of our "old media" images to shiny new webp format images. It works great for the standard ~/media url ...
user avatar
  • 103
0 votes
1 answer
202 views

Dianoga v5 with WebP, CDN and Sitecore HTML Cache

As part of a Sitecore upgrade to v10 we also upgraded to Dianoga V5.4.1. This site uses output/HTML cache extensively. We need to support browsers with and without webp support. The WebP CDN config ...
user avatar
  • 1,154
0 votes
0 answers
56 views

Images don't reflect versioning in Rich Text Fields

The Sitecore version for this issue is 9.1.0 (rev. 001564). In content editor, if I add a versioned image with only 1 version created added to a rich text field on an item, I encounter issues when I ...
user avatar
0 votes
1 answer
47 views

Where does SXA store css and js files on CM server

We can see css and js files in content tree under /sitecore/media library/Themes/ and if we view source code of a web page we can also see the links. However I am not able to find those files in ...
user avatar
  • 153
0 votes
1 answer
39 views

Sitecore 8.1 - few media files getting downloaded

We are working on Sitecore 8.1 instance where we have got a security issue. As per the issue, few media files are getting downloaded directly when we hit the url. Example - https://hostname/-/media/...
user avatar
0 votes
0 answers
13 views

BlobProviderException - Can't publish media items from Master to Web database [duplicate]

When I am publishing many media items from the master to the web database, it crashes at some point in the process with the following exception: Job started: Publish to 'web'|#Exception: System....
user avatar
0 votes
3 answers
153 views

Alt text in custom image bind

We are creating image tag from the programming in Sitecore 9.1.1. Using the below code. var image = new MediaItem(imageField.MediaItem); src = StringUtil.EnsurePrefix('/', ...
user avatar
  • 1
0 votes
1 answer
32 views

Can we bind image component source through programming?

We would like to bind image component src thorough programming and would like to get Hash value as well. Need this output : <img src="/-/XXXXXX?h=192&amp;w=192&amp;hash=...
user avatar
  • 1
0 votes
2 answers
65 views

Possible to retrieve PDFs deleted from the media library or retain their URL for new version?

I have deleted some PDFs from the Sitecore media library by replacing them with new PDFs which were already added to the library. As a result, the media URL is now changed. The owner now says they ...
user avatar
  • 1
1 vote
1 answer
246 views

How to add Custom CSS File and why it is not rendering to page

I have installed Sitecore 10 on my laptop recently and I am facing the following issues. Issue 1: I have created a site and I am trying to add a "custom css file" but I am not able to upload ...
user avatar
1 vote
0 answers
41 views

Rendering SVG as XML using Glass Mapper

I was curious if anyone has a good solution for rendering SVGs using Glass mapper so that the result is XML embedded into the HTML instead of an tag. I know that I can use Editable() with a ...
user avatar
  • 535
1 vote
0 answers
70 views

Undefined Javascript Error on Media Upload

In Sitecore 8.2, we have an item template featuring an image field. The preferred workflow for creating an instance of this template is the use of the Browse trigger on the image field and the Upload ...
user avatar
0 votes
0 answers
41 views

Media Upload Not Triggering for Crowded Media Path

In Sitecore 8.2, we have an item template featuring an image field. The preferred workflow for creating an instance of this template is the use the Browse trigger on the image field and the Upload ...
user avatar
0 votes
0 answers
252 views

Images not showing on preview mode in sitecore 9.1.1

I have a website on sitecore version 9.1.1 and sxa 1.8 Several components and pages contain image fields, when I open the page in edit mode everything looks fine but when I open the page in preview ...
user avatar
  • 31
0 votes
1 answer
76 views

Add query string to all Media item in Sitecore SXA 9.3

Is there any way by which I can add a query string in each media item requested in SXA include CSS, js, images, fonts, etc. Current URL - http://us.dev.local/-/media/base-themes/core-libraries/...
user avatar
0 votes
2 answers
555 views

How to find unused images /files in the media library and clean them up?

We have been using Sitecore as CMS for quite some time. We would like to clean up the images and files which are not linked with any items and archive them. Is there any approach you have used for ...
user avatar
  • 384
1 vote
1 answer
183 views

How can I automate the upload Media Library files available in folder under App_Data?

I build my frontend artifacts (theme files, including pre-optimized-min versions of my CSS and JavaScript) using SXA Umbrella, and in my DevOps release pipeline I make them available in the folder ...
user avatar
1 vote
1 answer
53 views

Is there a way to set my image URLs to my node server url instead of my CD instance

So I havent been able to track down a article of how you change the name of my images coming out of my media library. The mynewsite is the site running my node server calling my prod-cd content. ...
user avatar
1 vote
2 answers
262 views

Can't access Media Library folder items from within Content Editor despite folder containing items

When attempting to set an image for a field in Content Editor, the media library shows no items to pick from: However there are in fact items in this location: I am also able to access these items ...
user avatar
  • 121
1 vote
1 answer
274 views

ON PUBLISH , Pdf media item is not clearing the cache from CD server in 9.3

ON PUBLISH, Pdf media item is not clearing the cache from CD server in 9.3 and still shows the old pdf. The HTML Cache clears as expected in the CD but not the media item. Eventqueue folder in the CD ...
user avatar
  • 49
1 vote
2 answers
344 views

General Link (Insert media item) add custom property when click from Experience Editor

We would like to add custom property when we click on General link from Experience Editor. Would like to add custom property below "Alternate Text" and append custom property values in URL.
user avatar
  • 199
0 votes
1 answer
62 views

How to Fake a Media Library Item and return an image from external provider instead

The scenario is the following: For a single component we're getting the html content from an external provider. Including images. For each image we have to call a separate endpoint of the external ...
user avatar
1 vote
1 answer
68 views

Solve copy and paste image path

I created a custom image field, so far its working fine. but when I take an image path and add it manually to the field without clicking browse. It disappears which is not the normal behavior in OOTB ...
user avatar
2 votes
1 answer
99 views

How to hide specific photos to be viewed in browse image

I'm trying to hide specific photos from browse image dialog. For example "Assets" is my source folder, I want to get all first level photos only which is "Image1" and to hide &...
user avatar
0 votes
0 answers
43 views

Sitecore ProcessMediaRequest is giving 404 for restricted media

I recently had a requirement to restrict secure media items to download so that only certain logged in users could download them. So to achieve that I have remove read access from the extranet\...
user avatar
1 vote
2 answers
189 views

Media library item (pdf) reachable after unpublish/not publishable

In Sitecore 9.1.1 I have some PDF documents in the media library that i've "unpublished" (unchecked the publishable publish setting) Then smart-publish parent folder, subitems and all ...
user avatar
0 votes
0 answers
85 views

Packaging and installing media items not working - items are created but have no attached file, media is NOT stored in file system

I've created a package of media items on my prod environment and installed it on my local. The media files are NOT stored in the file system But when I install the package, the items are created but ...
user avatar
0 votes
1 answer
77 views

Opening HTML microsite from Sitecore Media Library v9.1.1

Looking for settings to open microsite uploaded to the media library in the browser. In the past, we would take an Adobe Captivate HTML export load it into a folder in the media library, and run the ....
user avatar
0 votes
0 answers
243 views

Sitecore Media Item getting downloaded on click of media item

Media item are getting stored on azure, for this I have overridden Media library classes. Now what happen when I am selecting any media in Media Library to see, It gets automatically downloaded. It ...
user avatar
  • 141
0 votes
0 answers
108 views

ERROR MediaRequestProtection: An invalid/missing hash value was encountered. The expected hash value: [duplicate]

For all uses of MediaManager I have code like: string mediaItem = MediaManager.GetMediaUrl(sourceItem, mediaUrlOptions); itemUrl = HashingUtils.ProtectAssetUrl(mediaItem); I do have setting set: ...
user avatar
2 votes
0 answers
43 views

How to replace/register 'ResizeImageStream' method of class 'Sitecore.Resources.Media.ImageEffectsResize' from Sitecore.kernel dll

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests.Everything works fine but Sitecore.Resources.Media.ThumbnailProcessor throws an error in ...
user avatar
4 votes
1 answer
865 views

Sitecore media library - unable to load large files ( > 8MB) via Azure Front Door

We've run into an issue in Sitecore 9.3 where it's not serving media items properly via Azure FrontDoor with caching enabled. (Front Door works exceptionally well for 99.95% of the website). But a ...
user avatar
0 votes
0 answers
123 views

Link external resource in sitecore 9.3 media library

We have a Sitecore 9.3 instance running a site. Our problem is that resources uploaded on the Media Library occupy too much disk space. We want to create a custom media library object that links to a ...
user avatar
  • 1

1
2 3 4 5 6