Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [multisite]

For questions relating to multiple sites in a single Sitecore instance.

0
votes
0answers
20 views

Sitecore SXA Multisite Robots.txt is returning 404 on one of CD servers

I have an issue on production environment that robots.txt is returning 404 on one CD server while it is working on the other. Any suggestion if there is any missing configuration?
0
votes
0answers
19 views

WFFM Placeholder not listing on inserting a form Multisite

I'm working on installing the WFFM 8.1 rev. 160523 for Sitecore 8.1 rev. 160519. Forms are working fine when I'm using on the single site node. But the same steps when I follow on the multisite site ...
1
vote
0answers
32 views

404s and Sitecore login redirect to a different site in the Sitecore instance

Having an odd problem with a production instance. When I enter a page that doesn't exist, such as www.mysite.com/asdijdsiajdi, the typical Sitecore "Document Not Found" page appears, however the ...
0
votes
0answers
12 views

Sitecore AD configuration of component 1.3 without domain name Login

I have integrated with Active Directory 1.3 and Login is happening perfectly fine with with the username as domain\username and password. My requirement is to just sign in without with domain. For ...
0
votes
0answers
30 views

Sitecore is setting same language cookie multiple times in response headers

Our multi-site Sitecore instance (7.0.- rev-130424) is setting same language cookie multiple times like below in response headers: Set-Cookie: SiteName#lang=de-DE; path=/; secure; HttpOnly Set-...
1
vote
1answer
72 views

SXA: 'Insert Link' link is not pointing to Site Home item

We are having multiple SXA sites under a tenant. For all the sites, when we click 'Insert link' on General Link field, able to see Home item of current Site. But, for one site (whose language is de-DE)...
1
vote
1answer
56 views

How to manage domains in Multi-site environment with Sitecore PaaS

We are working on Sitecore 9.0.2 in PaaS with multi-site environment. The domain for first site was created when we provisioned the environment using ARM templates. Now question here is for second ...
4
votes
0answers
105 views

Login to sitecore across multiple subdomains

I am trying to login to Sitecore across multiple domains. I mean, i have two different sites abc.x.com and xyz.x.com. is there a way to set the auth cookies at parent domain level, in my case at x....
0
votes
0answers
35 views

error when creating site in sxa

we are using sitcore 9 update 2 and SXA 1.7.1 when I create site getting below error. I fixed this error by following this blog at initial level(SXA error when creating a site: Unrecognized Guid ...
1
vote
0answers
33 views

Search index not updating for new site nodes

I have created new site node and my web site search functionality is not working for the new site. I have rebuilt the search index from the Indexing Manager and I have checked the indexes, it seems ...
2
votes
1answer
86 views

Multiple websites hosted in the same app pool

Is it possible to have two or more Sitecore instances with different code bases running in the same (single) application pool?
1
vote
0answers
30 views

Multilist with Search to return descendant items

I am working on Multisite Sitecore instance and For "multilist with search" field I am trying to return all descendant items under folder item from a specific template using these queries ...
1
vote
1answer
80 views

How to use multiple themes in Sitecore SXA?

We already have a theme per site. We would like to create a common/shared theme and configure for few SXA sites.
1
vote
2answers
50 views

Canonical url generation not using the correct hostname

I am currently using a html helper to generate a canonical url but the problem is the server url. The url is fetched from targetHostName (please correct me if I am wrong) The problem arrives in the ...
2
votes
3answers
114 views

OWIN sign-in links only working for SXA sites NOT configured in MapEntry of IdentityProvidersPerSite

On Sitecore 9.0.1 and SXA 1.6 I'm trying to get federated authentication to work for website visitors using OWIN WSFed following this guide in a multi-site SXA solution. I've gotten everything to ...
1
vote
1answer
55 views

Navigation between sites using same lang cookie

I'm trying to navigate between sites but current language is not consistent between sites under the same tenant, how to unify lang cookie?
0
votes
0answers
48 views

Cross sites links are resolving as a context site link (Sitecore 9 Update 2) [duplicate]

I am having an issue in Sitecore 9.0.2 that cross sites links are not resolving properly. The link is resolved as a context site link and when I click on that link it gives me 404 so anyone has any ...
3
votes
0answers
63 views

Using Experience Editor on a multisite solution. Custom linkProvider to solve problems?

We have multiple sites in sitecore but all are edited by the same editors and they want to be able to edit it all in one place. The majority of our editors use EE. Problems: When you follow a link (...
5
votes
2answers
126 views

What is the best approach for zero downtime deployments for Multi-Site implementations?

I have a Single Sitecore Instance, where multi-site implemented for 3 countries. - Content - Country 1 - Home - About Us - Country 2 - Home - About Us - Country ...
1
vote
0answers
51 views

Membership provider per domain in multisite configuration

we have multisite settup with two websites pointing to two domains in sites.config, and trying to map custom membership provider to each of the domains. here is the configuration: Web.config: &...
0
votes
1answer
51 views

What is the use of Flush Event in Multi-site manager?

I want to understand the multi-site manager Flush event. Because of flush event triggered every time after successful creation of site, IIS reset's which makes the site outage and not able to ...
2
votes
0answers
62 views

How to set Media Cache Folder per site?

Context In my Sitecore (8.2.u7) instance I have 2 websites that share the same images. For this reason, I have setup Media.MediaLinkServerUrl e.g. cdn.mysite.com. This will also help me to integrate ...
5
votes
1answer
91 views

Multisite publishing issue in SXA

Using SXA 1.6 and Sitecore 9.0.1 , we have an environment with single tenant and multi sites ex: site1 , site2 ,.. we setup OOB security so only users in site1 can edit their content only and same for ...
1
vote
1answer
104 views

Map SXA multi site to single domain with different ports

Is there any way to attach two SXA sites from one Sitecore instance (IIS instance) to different port number of one domain name? For example: http://abc.com is on port 80 and pointing to one sxa site. ...
0
votes
0answers
65 views

VisitorIdentificationCSS fails for 1 of 2 sites in the same deployment

I have a single SC 8.2 rev 170278 deployment with 2 sites, each have their own url. My template contains a @Html.Sitecore().VisitorIdentification() for both sites. On both sites, this results in ...
2
votes
1answer
259 views

SXA site not detected on content delivery - url goes to default home

On our Content Delivery server, the published URL is redirecting to the default home page of Sitecore and I need it to redirect to the SXA site home. Are there specific steps I should take?
1
vote
1answer
53 views

How to create a new website from an existing website with only the content items different?

I am using Sitecore 9.0 without SXA. I have an existing website (20-30 pages - mainly brochureware) for a certain brand and for a specific country. I now need to create another website with the same ...
4
votes
2answers
385 views

Sitecore multisite cross links not resolved with proper hostname

I've multisite solution setup, and sites config looks like below: <sites> <site name="localhost" hostName="local.com" scheme="http" notFoundItem="not-found" enableTracking="true" ...
2
votes
3answers
101 views

Sitecore Multidomain Similar Language possible?

We have implemented multisite & multilingual Sitecore implementation and now we are going to implement new website which will support 4 languages. Sitecore8.1 in use. Code base( VS solution) &...
0
votes
0answers
112 views

Virtual folder setting is not working for multi lingual site

On Sitecore 7.2 (MVC) we are in process of introducing en-CA and fr-CA in our multi-site with multi-lingual project. Where we want to leverage the Virtual Folder concept. Like we want https://abcd.com/...
8
votes
1answer
229 views

Sitecore Site using custom database on custom site

Sitecore 9.0.1 I've tried to create a new site definition that's associated with a custom publishing target database. I have the database registered, publishing targets built, content completely ...
5
votes
1answer
282 views

SXA multisite question

We are using Sitecore 9.0 and are currently investigating SXA multisites posibilities. Our dream scenario would be like this : One tenant severals sites, siteA, siteB etc. each site uses same host ...
3
votes
2answers
178 views

How to create multisite solution in SXA 1.6 with different themes

We have created master site using SXA 1.6 in Sitecore 9.0.1. We are aiming to have different sites for different "brands" based on this master site. We want to reuse content from the master site as ...
-1
votes
0answers
76 views

How can alias resolution issues for a site be debugged?

I am working on an MVC app deployed on Sitecore 8.2. Sitecore is setup to handle multiple sites. In the development environment, we have an integration instance of Sitecore deployed to a server. Each ...
2
votes
2answers
632 views

SC_ANALYTICS_GLOBAL_COOKIE domain name in multisite

I have a multisite configuration running SC8.2u2. All sites have a common domain name xxx.com, however the SC_ANALYTICS_GLOBAL_COOKIE domain name on sub-sites is set to the sub-domain accounts.xxx.com ...
1
vote
1answer
563 views

How/Why would the scheduler website be getting redirected to the 404 page?

Looking at the log file on our CM server, I noticed that there are a lot of warnings getting logged as follows: 6128 00:01:09 WARN Request is redirected to document not found page. Requested url: /...
1
vote
0answers
60 views

sitecore strange behavior for only space in url [duplicate]

I have a strange issue, and it seems like related to configuration but I don't know how to fix it. when user add space to url like http://my.local/%20/ I see an error like Configuration Error ...
17
votes
3answers
487 views

Issue related to %20 in URL

I have two languages on my site: en and de. When I'm trying to open http://{HOSTNAME}/%20/ - I'm recieving error: Question: How can I fix this issue and process this request in correct way?
5
votes
0answers
161 views

How Sitecore 9 Forms Module is featured for Multi-Site and Multi-Lingual?

Recently while exploring Sitecore 9 Forms Module, came up with some queries hence thought of asking on community. When we select a form, in the bottom right corner we see list of the items where the ...
0
votes
1answer
230 views

Sitecore using multiple IIS Websites configured with same physical path

We have a multiple sites Sitecore instance at our client. The architect is attempting to reconfigure that each sub-site has a dedicated IIS Website pointing to one physical path where the instance is ...
0
votes
1answer
436 views

Site definition for multi-site in Sitecore habitat

Currently we have a one Sitecore instance on Sitecore 8.1 with 9 sites hosted using habitat framework. The site definitions are mentioned as follows: site name="Site1" loginPage="/home" requireLogin=...
1
vote
1answer
380 views

Language Fallback not taking effect on my sites

Language fallback not working in Sitecore 9.0 with SXA 1.5. I have done the below changes to enable language fallback(en) for all added languages. On the System Languages in Sitecore Select the ...
4
votes
1answer
1k views

Sitecore client user login failed: You don't have access permission error

I installed sitecore 8.2 and after installation I logged in with admin account. Then i followed below procedure to create user and roles. 1) In the User manager I created one user - tom (not selected ...
4
votes
1answer
344 views

Dynamic Site Provider Experience Editor Resolves to Website

The current site I am working with has a custom site provider that does not resolve the context site correctly when trying to open a page in experience editor mode. The parameter sc_site is set to ...
4
votes
1answer
353 views

Sitecore MVC Routing and Virtual Folders

I have a multi-site Sitecore instance with several sites defined using the physicalFolder/virtualFolder attributes defined on the <site> nodes all done with MVC. There is some functionality I ...
1
vote
1answer
220 views

How to force download media based on business logic?

In our solution we have some particular cases where we want to provide a "download media" link instead of a straightforward media link. We don't want to force download for any particular file types, ...
3
votes
2answers
303 views

Blank/Empty Page in sitecore 8.1 application

Using Sitecore 8.1 update 3 for our multilingual web application. Here all the items (using the same template, ex : Product template) are rendered as empty/blank page with no error message and don't ...
2
votes
2answers
223 views

WFFM - Forms in other language getting redirected to parent language after submitting

I am facing an issue with WFFM form submit action. When there are more than one language version for forms and when I navigate to the version other than the parent language version and on submitting ...
3
votes
1answer
104 views

Execute a site dependent sitecore task

I would like to have a sitecore task to run differently depending on the current site. My task is scheduled to run every 24h to regenerate the sitemap.xml file. Im working on a multisite environement ...
4
votes
1answer
243 views

How do I remove the root directory from a subdomain url

I am trying to create a subdomain for my current site in Sitecore that is simply a mirror or my primary site. The reason for this is that our partner CDN provider is requiring us to host a copy of our ...