Skip to main content

Questions tagged [multisite]

For questions relating to multiple sites in a single Sitecore instance.

Filter by
Sorted by
Tagged with
2 votes
1 answer
553 views

Adding static site to Multisite

I am trying to have a static HTML site rendered off the host name of our Sitecore site, such as mysite.com/_demo/index.html. All of this site is stored on the file system and is not part of Sitecore. ...
Nathan S's user avatar
  • 137
1 vote
0 answers
122 views

Multi-site analytics tracking

We have a Sitecore multi-site, multi-server solution, exposed for the moment on the following domains: www.mywebsite.com and lang.mywebsite.com. We expect to add more site nodes in the current ...
Aura Petric's user avatar
2 votes
3 answers
372 views

Site-specific value for an appsetting in a multisite solution

I have a multisite solution with two sites, xyz.com and abc.com. For a given appsetting variable I want to have different values. Is it something which is possible out of the box in Sitecore? The ...
rdhaundiyal's user avatar
0 votes
0 answers
30 views

navigate to particular site home page when click XE button in launch pad [duplicate]

we are using sitecore 9 update 2 and SXA 1.7.1 and we have 2 sites called site1(english) and site2(Korean). both sites created separately in SXA. when click Experience Editor button in launch pad ...
Erwin Paul's user avatar
1 vote
1 answer
43 views

Work Flow Security Permissions

I have a template and apply Publishing workflow on this template, I created items from this template in 2 different sites, I created 2 different users for each site,I want when the item in "site 1" ...
shimaa elsayed's user avatar
1 vote
1 answer
386 views

How to Update Sitedefinition.config Dynamically?

I am working on building a tool for multi-site implementation, right now when ever i am adding a new site i need to go and change the site definition file manually but i want to make it dynamically as ...
vinay kumar singh's user avatar
0 votes
1 answer
596 views

Extending site.config with custom value not working

I am trying to get custom values for my site. So I've extended just the site.config with the "blubb" Attribute and "test12" value: <site patch:before="site[@name='modules_website']" ...
squadwuschel's user avatar
  • 1,165
5 votes
1 answer
2k views

SXA Site Manager missing

I want to view the local sites in my SXA site installation. In the following documentation it is mention to use Sitecore SXA Site Manager tool to view what are the SXA sites and if they are accessible ...
scFootsteps's user avatar
  • 3,851
2 votes
1 answer
664 views

Unexpected merge of robots.txt from different sites

In a SXA based multi-site environment, the values of the 'Robots content' (/sitecore/templates/Project/SampleTenant/Settings) fields are unexpectedly merged from two different site. Let's say the '...
Friederike Heinze's user avatar
0 votes
1 answer
584 views

sitecore language selector in site header

i have multi-language sitecore website and i m trying to create a language selector in my site header to change site language . im trying this code but not working : @{ string siteurl = string....
marwen's user avatar
  • 15
3 votes
0 answers
444 views

Sitecore SXA Multisite Robots.txt is returning 404 on one of CD servers

I have an issue on production environment that robots.txt is returning 404 on one CD server while it is working on the other. Any suggestion if there is any missing configuration?
NAli's user avatar
  • 875
1 vote
0 answers
470 views

404s and Sitecore login redirect to a different site in the Sitecore instance

Having an odd problem with a production instance. When I enter a page that doesn't exist, such as www.mysite.com/asdijdsiajdi, the typical Sitecore "Document Not Found" page appears, however the ...
Paul's user avatar
  • 555
0 votes
0 answers
30 views

Sitecore AD configuration of component 1.3 without domain name Login

I have integrated with Active Directory 1.3 and Login is happening perfectly fine with with the username as domain\username and password. My requirement is to just sign in without with domain. For ...
user2007879's user avatar
0 votes
1 answer
575 views

Sitecore is setting same language cookie multiple times in response headers

Our multi-site Sitecore instance (7.0.- rev-130424) is setting same language cookie multiple times like below in response headers: Set-Cookie: SiteName#lang=de-DE; path=/; secure; HttpOnly Set-...
Dheeraj Palagiri's user avatar
1 vote
1 answer
445 views

'Insert Link' link is not pointing to Site Home item

We are having multiple SXA sites under a tenant. For all the sites, when we click 'Insert link' on General Link field, able to see Home item of current Site. But, for one site (whose language is de-DE)...
Manideep Yechuri's user avatar
1 vote
1 answer
378 views

How to manage domains in Multi-site environment with Sitecore PaaS

We are working on Sitecore 9.0.2 in PaaS with multi-site environment. The domain for first site was created when we provisioned the environment using ARM templates. Now question here is for second ...
Alivor Tikos's user avatar
8 votes
2 answers
1k views

Login to Sitecore 9.1 across multiple subdomains

I am trying to login to Sitecore across multiple domains. I mean, I have two different sites abc.x.com and xyz.x.com. is there a way to set the auth cookies at parent domain level, in my case at x....
Gobinath Saminathan's user avatar
2 votes
1 answer
439 views

Error when creating site in SXA - Unrecognized Guid format

We are using sitcore 9 update 2 and SXA 1.7.1 when I create site getting below error. I fixed this error by following this blog at initial level (SXA error when creating a site: Unrecognized Guid ...
Erwin Paul's user avatar
1 vote
0 answers
48 views

Search index not updating for new site nodes

I have created new site node and my web site search functionality is not working for the new site. I have rebuilt the search index from the Indexing Manager and I have checked the indexes, it seems ...
LittleDragon's user avatar
2 votes
1 answer
310 views

Multiple websites hosted in the same app pool

Is it possible to have two or more Sitecore instances with different code bases running in the same (single) application pool?
Aura Boldizsar's user avatar
1 vote
1 answer
734 views

How to use multiple themes in Sitecore SXA?

We already have a theme per site. We would like to create a common/shared theme and configure for few SXA sites.
ss0326's user avatar
  • 13
1 vote
2 answers
557 views

Canonical url generation not using the correct hostname

I am currently using a html helper to generate a canonical url but the problem is the server url. The url is fetched from targetHostName (please correct me if I am wrong) The problem arrives in the ...
Shabaaz Shaikh's user avatar
3 votes
3 answers
1k views

OWIN sign-in links only working for SXA sites NOT configured in MapEntry of IdentityProvidersPerSite

On Sitecore 9.0.1 and SXA 1.6 I'm trying to get federated authentication to work for website visitors using OWIN WSFed following this guide in a multi-site SXA solution. I've gotten everything to ...
Mark-Danney's user avatar
1 vote
1 answer
451 views

Navigation between sites using same lang cookie

I'm trying to navigate between sites but current language is not consistent between sites under the same tenant, how to unify lang cookie?
Tareq Mansour's user avatar
0 votes
0 answers
100 views

Cross sites links are resolving as a context site link (Sitecore 9 Update 2) [duplicate]

I am having an issue in Sitecore 9.0.2 that cross sites links are not resolving properly. The link is resolved as a context site link and when I click on that link it gives me 404 so anyone has any ...
Ravindra S. Rathore's user avatar
4 votes
0 answers
163 views

Using Experience Editor on a multisite solution. Custom linkProvider to solve problems?

We have multiple sites in sitecore but all are edited by the same editors and they want to be able to edit it all in one place. The majority of our editors use EE. Problems: When you follow a link (...
Erik Melkersson's user avatar
7 votes
2 answers
759 views

What is the best approach for zero downtime deployments for Multi-Site implementations?

I have a Single Sitecore Instance, where multi-site implemented for 3 countries. - Content - Country 1 - Home - About Us - Country 2 - Home - About Us - Country ...
Sivalingaamorthy's user avatar
1 vote
0 answers
486 views

Membership provider per domain in multisite configuration

We have multisite setup with two websites pointing to two domains in sites.config and we are trying to map custom membership provider to each of the domains. Here is the configuration: Web.config: ...
nari447's user avatar
  • 407
0 votes
1 answer
121 views

What is the use of Flush Event in Multi-site manager?

I want to understand the multi-site manager Flush event. Because of flush event triggered every time after successful creation of site, IIS reset's which makes the site outage and not able to ...
Prakash's user avatar
  • 49
3 votes
0 answers
387 views

How to set Media Cache Folder per site?

Context In my Sitecore (8.2.u7) instance I have 2 websites that share the same images. For this reason, I have setup Media.MediaLinkServerUrl e.g. cdn.mysite.com. This will also help me to integrate ...
Efthymios Dimopoulos's user avatar
5 votes
1 answer
237 views

Multisite publishing issue in SXA

Using SXA 1.6 and Sitecore 9.0.1 , we have an environment with single tenant and multi sites ex: site1 , site2 ,.. we setup OOB security so only users in site1 can edit their content only and same for ...
user1534066's user avatar
1 vote
1 answer
623 views

Map SXA multi site to single domain with different ports

Is there any way to attach two SXA sites from one Sitecore instance (IIS instance) to different port number of one domain name? For example: http://abc.com is on port 80 and pointing to one sxa site. ...
Amit Kumar's user avatar
3 votes
2 answers
2k views

SXA site not detected on content delivery - url goes to default home

On our Content Delivery server, the published URL is redirecting to the default home page of Sitecore and I need it to redirect to the SXA site home. Are there specific steps I should take?
NAli's user avatar
  • 875
1 vote
1 answer
309 views

How to create a new website from an existing website with only the content items different?

I am using Sitecore 9.0 without SXA. I have an existing website (20-30 pages - mainly brochureware) for a certain brand and for a specific country. I now need to create another website with the same ...
Sandeep's user avatar
  • 13
5 votes
2 answers
4k views

Sitecore multisite cross links not resolved with proper hostname

I've multisite solution setup, and sites config looks like below: <sites> <site name="localhost" hostName="local.com" scheme="http" notFoundItem="not-found" enableTracking="true" ...
nari447's user avatar
  • 407
2 votes
3 answers
353 views

Sitecore Multidomain Similar Language possible?

We have implemented multisite & multilingual Sitecore implementation and now we are going to implement new website which will support 4 languages. Sitecore8.1 in use. Code base( VS solution) &...
Ashita's user avatar
  • 53
0 votes
0 answers
508 views

Virtual folder setting is not working for multi lingual site

On Sitecore 7.2 (MVC) we are in process of introducing en-CA and fr-CA in our multi-site with multi-lingual project. Where we want to leverage the Virtual Folder concept. Like we want https://abcd.com/...
Rathan M's user avatar
  • 361
8 votes
1 answer
561 views

Sitecore Site using custom database on custom site

Sitecore 9.0.1 I've tried to create a new site definition that's associated with a custom publishing target database. I have the database registered, publishing targets built, content completely ...
Jeff Darchuk's user avatar
5 votes
1 answer
1k views

SXA multisite question

We are using Sitecore 9.0 and are currently investigating SXA multisites posibilities. Our dream scenario would be like this : One tenant severals sites, siteA, siteB etc. each site uses same host ...
Ishak Fajkovic's user avatar
2 votes
2 answers
403 views

How to create multisite solution in SXA 1.6 with different themes

We have created master site using SXA 1.6 in Sitecore 9.0.1. We are aiming to have different sites for different "brands" based on this master site. We want to reuse content from the master site as ...
Peter Procházka's user avatar
3 votes
2 answers
2k views

SC_ANALYTICS_GLOBAL_COOKIE domain name in multisite

I have a multisite configuration running SC8.2u2. All sites have a common domain name xxx.com, however the SC_ANALYTICS_GLOBAL_COOKIE domain name on sub-sites is set to the sub-domain accounts.xxx.com ...
andyp's user avatar
  • 903
1 vote
1 answer
2k views

How/Why would the scheduler website be getting redirected to the 404 page?

Looking at the log file on our CM server, I noticed that there are a lot of warnings getting logged as follows: 6128 00:01:09 WARN Request is redirected to document not found page. Requested url: /...
TomT's user avatar
  • 1,079
1 vote
0 answers
90 views

sitecore strange behavior for only space in url [duplicate]

I have a strange issue, and it seems like related to configuration but I don't know how to fix it. when user add space to url like http://my.local/%20/ I see an error like Configuration Error ...
Arbejdsglæde's user avatar
17 votes
3 answers
3k views

Issue related to %20 in URL

I have two languages on my site: en and de. When I'm trying to open http://{HOSTNAME}/%20/ - I'm recieving error: Question: How can I fix this issue and process this request in correct way?
Andrei Paliakou's user avatar
8 votes
2 answers
508 views

How Sitecore 9 Forms Module is featured for Multi-Site and Multi-Lingual?

Recently while exploring Sitecore 9 Forms Module, came up with some queries hence thought of asking on community. When we select a form, in the bottom right corner we see list of the items where the ...
Amitabh Vyas's user avatar
  • 2,554
0 votes
1 answer
611 views

Sitecore using multiple IIS Websites configured with same physical path

We have a multiple sites Sitecore instance at our client. The architect is attempting to reconfigure that each sub-site has a dedicated IIS Website pointing to one physical path where the instance is ...
Roman's user avatar
  • 257
0 votes
1 answer
1k views

Site definition for multi-site in Sitecore habitat

Currently we have a one Sitecore instance on Sitecore 8.1 with 9 sites hosted using habitat framework. The site definitions are mentioned as follows: site name="Site1" loginPage="/home" requireLogin=...
PVM's user avatar
  • 963
1 vote
1 answer
1k views

Language Fallback not taking effect on my sites

Language fallback not working in Sitecore 9.0 with SXA 1.5. I have done the below changes to enable language fallback(en) for all added languages. On the System Languages in Sitecore Select the ...
Amitabh's user avatar
  • 1,066
5 votes
1 answer
4k views

Sitecore client user login failed: You don't have access permission error

I installed sitecore 8.2 and after installation I logged in with admin account. Then i followed below procedure to create user and roles. 1) In the User manager I created one user - tom (not selected ...
nss monitoring's user avatar
5 votes
1 answer
1k views

Dynamic Site Provider Experience Editor Resolves to Website

The current site I am working with has a custom site provider that does not resolve the context site correctly when trying to open a page in experience editor mode. The parameter sc_site is set to ...
Teeknow's user avatar
  • 2,477