Questions tagged [nuget]

Questions about NuGet, regarding Sitecore's nuget feed or other nuget questions related to Sitecore development

7 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3
votes
1answer
179 views

Sitecore namespace not found when referencing v8.0 packages via NuGet

I have a clean VS 2019 project targeting .NET Framework 4.5 referencing Sitecore.Kernel and Sitecore.ContentSearch packages (specifically v8.0.150812) via NuGet using PackageReference. However, I get ...
1
vote
0answers
42 views

Nuget package to publish Helix config files

OK, I'm probably getting my methodologies mixed up here! We have a central library solution of code which is shared across Sitecore sites ... Inside of this, we have a Foundation project containing ...
1
vote
0answers
56 views

Cannot upgrade nuget package due to Microsoft.Extensions.Configuration

We are trying to install the following NuGet package: Microsoft.IdentityModel.Protocols.OpenIdConnect However, we are being blocked by this error message: Error Unable to find a version of '...
1
vote
0answers
94 views

TDS Package Bundling does not work with NuGet Package Generation

I am attempting to separate and version the Helix Foundation Layer modules into its own solution. I am using TDS/VS2017/Sitecore_8.1U2. Based on documentation, I would like to generate an Update ...
0
votes
1answer
34 views

How to identify configured tasks in visual studio

I would like to understand an existing VS project build/publish scripts. this project was built using sitecore helix architecture. Currently i dont see any tasks configured for the project. In the ...
0
votes
0answers
82 views

Sharing Sitecore content as a NuGet package

Background In our Sitecore 9 solution, we follow Helix principles, when structuring our code and we wish to create NuGet packages that can be re-used across multiple projects. The NuGet packages ...
0
votes
1answer
42 views

Cannot add Sitecore.Commerce.Plugin.Orders

When attempting to add a NuGet reference to Sitecore.Commerce.Engine.Orders, version 2.1.5, I get the following error: NU1603: Sitecore.Commerce.Plugin.Availability 2.1.3 depends on Sitecore.Commerce....