Questions tagged [paas]

Questions relating to using the Platform-as-a-Service deployment model for Sitecore.

Filter by
Sorted by
Tagged with
2
votes
1answer
64 views

Sitecore PaaS best pratice for App_Data

We are currently using Azure DevOps to deploy our Sitecore 9.1.1 and 9.2 solutions to Azure. In Azure DevOps you have the option of "leaving the App_Data" folder alone during deployment, i.e. not ...
2
votes
1answer
26 views

Sitecore Azure SQL DB Advisor recommendation - Drop unused indexes

As part of Sitecore 9.1 Azure hosting setup, I'm seeing few SQL DB Advisor recommendations in Azure to drop unused indexes on certain Sitecore tables that were created by Web deploy packages. Since ...
2
votes
1answer
62 views

Azure database refdata high intermittent load

We've been running a SC9.1 solution on PAAS for a while now, but have recently noticed intermittent slow response times, both on the CD and the CM. We've correlated it to high load on the refdata-db: ...
2
votes
1answer
48 views

Installing Packages in Sitecore PaaS/WebApp

Sitecore Support has stated that I can’t install packages like PowerShell Extensions and SXA if my PaaS environment is already deployed. They stated I need to redeploy and add these to the ARM ...
1
vote
1answer
26 views

Programmatically uploaded media files are not showing in CD Server

Sitecore Version : 9.0.2 Environment: Azure PaaS CD If upload any media file manually in Content editor, it uploads the media and the filepath field is empty. In program, I need to upload the media ...
3
votes
1answer
44 views

Checklist for Sitecore Security Hardening using Azure PaaS

I am Using Sitecore version 9 on Azure PaaS, Is there any official Sitecore security hardening guide for Azure PaaS ?, I can see some documentation as below link - https://doc.sitecore.com/...
3
votes
1answer
61 views

Does Sitecore PaaS support the usage of Azure deployment slots?

Background We are trying to make use of azure deployment slots when we deploy our Sitecore 9.1 PaaS solution to Azure. However, it seems that after a slot swap, the site is not warmed up, which ...
1
vote
1answer
40 views

Date field not showing in Azure Search results

I have a regular date field defined like this: <field type="System.DateTime" fieldName="entry_date" cloudFieldName="entry_date" searchable="NO" retrievable="YES" facetable="YES" filterable="YES" ...
0
votes
0answers
38 views

NullReferenceException while setting up ApplicationInsights with Sitecore 9.1 PaaS

We are following post below for the steps to configure ApplicationInsights and also have applied the patch as specified in the article. After setting things we are getting a NullReferenceException (...
2
votes
1answer
37 views

No SXA 1.7 ARM Template for Sitecore 9.0.1

I have an existing Sitecore 9.0.1 installation on Azure PaaS. I am looking to install SXA 1.7 on this specific version of Sitecore as Sitecore has outlined this version to be compatible in the SXA 1.7 ...
0
votes
0answers
46 views

Unicorn error on Azure Paas

We have been deploying our Sitecore 9.0.1 to Azure Paas, deploying each time to a clean slot. On the last deploy Unicorn synch stopped working, we are even unable to open the Unicorn.aspx page. ...
-1
votes
1answer
41 views

Cache cleared message every second in Azure Logs

We are trying to figure our an issue where our LIVE sites are getting down for 10 minutes everyday. While going through the Azure logs I am getting the following Warning: WARN web[standardValues] ...
2
votes
1answer
68 views

Is it possible to add Custom 403 Error page in Azure Web Apps

We have built our Sitecore 9.1 solution in Azure Web Apps. We have added custom 403 and 400 error pages by making use of the Error Manager module from Sitecore https://marketplace.sitecore.net/en/...
1
vote
2answers
47 views

Where do the UpdateInstallationWizard.aspx logs get saved in Azure PaaS?

Sitecore 9.0.2. In my experience, the logs should be saved into the temp folder. Our environment is configured like so: <sc.variable name="tempFolder" value="d:\local\temp"/> I've looked ...
0
votes
0answers
15 views

Sitecore Azure Paas Media files not appearing

I have installed fresh new Sitecore Azure Paas (Sitecore 9 update 2). Created a Sitecore packages from my local to the new instance to migrate all the content, media, system and templates. Everything ...
1
vote
1answer
47 views

Error when installing WDP in on-premises Sitecore 9.1 XP setup

I followed the steps described in this SSE question/answer to create my WDP. Everything works like a charm when deploying this WDP into a Sitecore Azure Paas instance. However, when I try to install ...
5
votes
1answer
40 views

Error while creating a WDP package using AzureToolkit

I'm trying to create a WDP from an existing Sitecore package but I'm facing the following error even after installing DacFX: Microsoft.Web.Deployment.DeploymentDetailedFatalException: The SQL ...
9
votes
2answers
163 views

How to convert a Sitecore package into a WDP package?

How can I convert a given Sitecore Package previously created using the Package Designer into a WDP package, so that I can create a script to deploy it on my Azure instances?
2
votes
0answers
133 views

Sitecore Identity Server failing to access CM

I have an environment running in Azure PaaS using Sitecore 9.1 (initial release), and after a while I couldn't sign in to the CM anymore. I decide to restart the App Service, and once SI back up, the ...
2
votes
1answer
85 views

Error when Installing Sitecore 9.1 on Azure PaaS

When trying to install Sitecore 9.1 on Azure PaaS, I face the following error: Add-AzureRMAccount : The term 'Add-AzureRMAccount' is not recognized as the name of a cmdlet, function, script file, or ...
1
vote
1answer
82 views

Patching Azure Search config files and deploy on Sitecore Azure PaaS

Our application (Sitecore 9.0.2 SXA 1.8) is currently running on Azure PaaS with Azure Search as Search service Recently we ran into this problem of master index exceeding 1000 field Limit we ...
3
votes
0answers
88 views

Installation issue on migration 9.1.1

I am trying to migrate a Sitecore 9.0.2 to 9.1.1. Following the upgrade guide https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/91/Sitecore_Experience_Platform_91_Update1.aspx, I have to ...
-3
votes
1answer
80 views

How to disable Sitecore login only (Sitecore Client - https://<domain>/sitecore/login)

Is there a way to disable Sitecore Client for public but need to be available inside company network? I am having a domain 'mydomain'. I need https://mydomain/home (website) need to be accessible to ...
2
votes
1answer
143 views

How to deploy Sitecore to a new deployment slot on an existing environment?

I have DTAP environments up and running for this client I'm working for and want to improve the deployment of releases by reducing the downtime / first loadtime. I have read up on blue/green ...
1
vote
1answer
49 views

Is WeBlog compatible with Azure PaaS?

As we know when we run a Sitecore instance on Azure PaaS we have to use Azure Search instead of Solr or Lucene. Since WeBlog does have custom configs for Content Search, I'm wondering if they are ...
1
vote
2answers
222 views

Sitecore PAAS Redis Exception [duplicate]

We are using Sitecore 9.0.2 deployed in PAAS and CD app service is showing below error and logs are full of this kind of exceptions: ERROR ProcessExpiredItems => System.TimeoutException: Timeout ...
1
vote
2answers
118 views

Security Hardening in PaaS

We are using Sitecore 9.0.2 deployed in PaaS as a general recommendation from Sitecore Security Hardening Guide perspective we are supposed to do the below items: 1)Prevent Anonymous Users access to ...
0
votes
1answer
141 views

SXA server error page not working in Azure PaaS

We are using Sitecore 9.0.2 and SXA 1.7.1 We have configured a server error page in the field called "Server Error Page Link" in the "Settings" item. We generated the static error page (navigate to ...
4
votes
1answer
77 views

Image Editor actions throws “Parameter not valid.”

Image editor doesn't function after deploying to the azure environments. This seems to be the case for our Dev, Test and Acceptance environments. When using Crop or Rotate or Flip: Server Error in '/...
5
votes
3answers
544 views

Azure Application Insights not working on Sitecore 9.1 PaaS

I've provisioned a Sitecore 9.1 PaaS, and for some odd reason the Application Insights is not loading graphics except in Live Metrics Stream for Process CPU data I went through the existing post ...
0
votes
1answer
86 views

Sitecore Azure 9.1 Marketing Operations service error

I'm receiving this error in my Sitecore 9.1 Azure Marketing Operations service. FYI my xCollect service is pointing to MongoDB instance so I have enabled sc.Xdb.Collection.Data.MongoDb.xml in ...
0
votes
0answers
73 views

Sitecore.Shell.Applications.Analytics.TrackingField.TrackingFieldDetailsPage throws exception

We are using Sitecore 9.0.2 in PAAS and in specific environment we are getting error on OOB tracking field on all the pages We don't have Sitecore XDb in scope and XDb is not enabled. [...
4
votes
0answers
56 views

Log Sitecore errors as exceptions instead of trace in application insights

By default, Sitecore application insights config logs Sitecore errors as traces instead of exceptions this means application insights dashboard and alerts are unaware of the exception occurring in a ...
0
votes
2answers
254 views

xConnect The HTTP response was not successful: Unauthorized on Azure PaaS

Very similar to this question: xConnect The HTTP response was not successful: Unauthorized But in this case, it's in Azure PaaS so a lot of the answers are not applicable. How can I make sure the ...
0
votes
1answer
353 views

Redis timeout errors in Azure PaaS [duplicate]

We are using Sitecore 9 Update 2 and SXA 1.7.1 in azure PaaS. We are facing issues with Redis cache. The website suddenly throws below error when we looked at Redis cache usage in Azure it's showing ...
1
vote
0answers
99 views

How to fix 500 error in Sitecore ribbon on first Experience Editor / Preview mode load

Every time I deploy to the Azure App Service, the first load of preview or edit mode takes extremely long to load and when the page does become visible, a 500 error becomes visible where the Sitecore ...
3
votes
1answer
247 views

All search indexes missing

Recently created a Sitecore PaaS instance associating with Solr IaaS, The Index Manager Console looks to be empty. What is wrong here !
0
votes
1answer
155 views

How to fix System.Reflection.ReflectionTypeLoadException when loading types from Sitecore.EmailCampaign.Activities

Whenever we restart or deploy to our server, I get the following error message for as long as I can remember. 2019-02-06T17:56:51 PID[9040] Warning 9428 17:56:51 WARN Counter ...
3
votes
1answer
159 views

My index on Content Delivery does not match with CM and is not updating anymore on Azure PAAS - Sitecore 9.0.2

We noticed that our CD environment gave different results from the index compared to the CM environment. We did some more checks and found that the index on CD was also not updating anymore. It did ...
0
votes
1answer
162 views

Auto index rebuild not happening in CD server (Sitecore 9.0 and Azure PaaS)

We have CM and CD servers in Azure PaaS, and Azure search service for indexing the items. After publishing the items from CM to CD auto index rebuild not happening. Content Management index file ...
3
votes
0answers
37 views

Azure Geo-Redundant for CM, CD, and Analytics

Is anyone aware of documentation or support for running Sitecore 9.0.2 in Azure PaaS in a Geo-Redundant way for all services. I know I could put CD in two Regions with publishing targets but not sure ...
2
votes
1answer
129 views

Does Sitecore support Azure Web App for Containers?

Windows Server Containers in Web App are now available in public preview, and I wonder if Sitecore provides any sort of support to run an environment in containers, specifically to Web App for ...
1
vote
1answer
53 views

need Url to download MsDeploy packages

we need below MsDeploy packages to execute ARM template. disablePrefetchCachingMsDeployPackageUrl dataExchangeFrameworkMsDeployPackageUrl dataExchangeFrameworkSitecoreProviderMsDeployPackageUrl ...
1
vote
1answer
149 views

How to manage domains in Multi-site environment with Sitecore PaaS

We are working on Sitecore 9.0.2 in PaaS with multi-site environment. The domain for first site was created when we provisioned the environment using ARM templates. Now question here is for second ...
0
votes
1answer
70 views

Maintenance.lock file persist intermittently during Azure PaaS Deployment

While deploying the CI/CD process with Sitecore 9 ARM Template, Maintenace.lock file came up when the Sitecore instance is started. Talked to Microsoft Azure Dev Ops team and they pointed to us the ...
2
votes
2answers
728 views

Application recycle problems

We upgraded from Sitecore 8.1 to 9.0 some weeks ago, and we moved to Azure PaaS. Since then we are suffering from application recycles in some of our instances. Looking at event viewer, we saw tens ...
2
votes
1answer
195 views

Sitecore Client login Timeout error - Azure PaaS

In the Content Management (CM) environment, /Sitecore is loading correctly with login screen, but when we input credentials and hit on Login button, it just keeps loading and finally gives 500 timeout ...
2
votes
1answer
118 views

Securing Sitecore 9.0.2 PAAS xDB & xConnect Server Role Services

We are using Sitecore 9.0.2 PAAS on Azure and we found that below server roles are not on https instead they are on http xDB Role Services Processing (prc) Reporting (rep) xConnect Server Role ...
4
votes
1answer
396 views

Sitecore 9 in Azure PaaS : Add Application Insights SDK

For Sitecore 9 on Azure PaaS and newer versions, what is the best practice to Add and configure the Application Insights SDK in Visual Studio to generate some telemetry in Visual Studio. As we are ...
5
votes
4answers
284 views

Using Publishing Service on Azure PaaS

Has anyone here used Publishing Service on Azure as PaaS? The client has two databases(two web databases), First, it publishes on the main base then on the "backup" base. I'm thinking of using the ...