Questions tagged [paas]

Questions relating to using the Platform-as-a-Service deployment model for Sitecore.

Filter by
Sorted by
Tagged with
0
votes
0answers
13 views

Sitecore 9.3 installation on Azure PAAS gives error [closed]

During sitecore 9.3 installation on azure cloud at certain steps it gives error and stopped. It seems the contained database authentication procedure is not present in azure cloud sql server 2020. ...
1
vote
1answer
34 views

Most cost effective way to add custom SQL server tables/database to Sitecore 9.1.1 PaaS installation

I'm looking for some guidance please, we have a small (~500Mb) custom SQL server database that we need to run alongside the standard Sitecore 9.1.1 databases. I'm also new to Azure so I apologies if ...
0
votes
0answers
24 views

What is the best option to choose SOLR VM size for Sitecore 9.2 [closed]

I was trying to create a SOLR VM in Azure for using in my Sitecore 9.2 Azure PaaS (XP+XC) (SKU: Small). Can you please suggest which size should I set for the SOLR VM? I was choosing Standard DS3_v2 (...
0
votes
0answers
27 views

Sitecore LaunchPad is distorted after deploying Web Application on Azure PaaS

I have deployed our application on Azure Pass. I am able to login in to the Sitecore CMS and redirected on the LaunchPad. LaunchPad CSS is distorted and click is not working. Also there are lot of ...
1
vote
1answer
40 views

Publishing Service error message: Could not persist PublisherOperations in the service

In my CM logs, I'm seeing the following warning repeatedly. WARN Could not persist PublisherOperations in the service Exception: Polly.CircuitBreaker.BrokenCircuitException Message: The circuit is ...
1
vote
0answers
30 views

Azure search Synonyms implementation using SXA 1.9 and Sitecore 9.2 using postman API

I have requirement to work with the synonyms for the similar group of words in search. I did load the synonyms using Postman API to SXA web index and able to see them on the index. For example: home,...
0
votes
2answers
53 views

Identity Server not redirecting to Azure Frontdoor URL

We are implementing URL hardening in Azure PaaS. We have added Azure front door urls to CM app. We have updated Sitecore.Owin.Authentication.IdentityServer.config on CM server with new url for ...
0
votes
0answers
20 views

Using Seq with Sitecore PaaS

We are running 9.3 in an app service in Azure. We have found a number of articles stating different things about logging in SC. Some say it's log4net, others say Serilog... Since we cannot get to ...
1
vote
1answer
150 views

Sitecore redirects for login page using hostname

We have a sitecore instance (xp0 for now) with an identity server. They are deployed to azure and belong to a private vnet. Access to nodes is done through the application gateway. But because of ...
0
votes
0answers
17 views

Sitecore Azure PaaS ARM templates doesnt support template idempotence

We are using ARM templates to install Sitecore 9.2.0 XP Scaled topology for our infrastructure. While using these templates, we observed that these templates are not idempotent in nature. We needed to ...
0
votes
0answers
24 views

Sitecore Azure PaaS webapp becomes unresponsive when Unicorn files copied

We are using Unicorn to sync Sitecore items between different Sitecore instances. We have created a separate Azure DevOps release pipeline dedicated only for copying Unicorn files and running the sync ...
1
vote
0answers
57 views

Sitecore Paas installation failure - AppGallery Deploy Failed: The declared parameter 'Application Path' is not recognized

We are trying to create Sitecore 9.2 instance in azure PaaS using ARM templates. The ARM templates worked fine. Now we have modified the ARM templates to install the JSS module with Sitecore while ...
1
vote
1answer
68 views

Logs are flooded with requests to reporting server for POST /~/v75/reporting/remotedatasourceproxy/

We installed a new 9.2 solution on PAAS (including SXA 1.9 - although that does not seem to be relevant). This is a clean solution that will be filled with content -and code- from an upgraded version. ...
1
vote
0answers
59 views

SolrCloud on Azure PaaS

I am setting up a Sitecore 9.2 Production instance and ideally would like to Setup SolrCloud in Azure PaaS Web Apps. In test environments i have setup Solr on a single PaaS App Service and it is ...
0
votes
1answer
51 views

Sitecore xConnect client certificates renewal

In our Sitecore 9.2 PaaS solution, we are using self-signed client certificates and have added the AppSetting AllowInvalidClientCertificates=true to all xConnect roles as well as the PRC, CD and CM ...
1
vote
0answers
95 views

Clean install on Azure SQL Managed instance

I am trying to install Sitecore 9.2 vanilla on Azure with SQL Managed Instance but I am getting the following error { "status": "failed", "error": { "code": "ResourceDeploymentFailure", "...
4
votes
1answer
167 views

Provisioning to Azure failure on deploying CM

I am trying to setup a new Sitecore 9.2 instance on PAAS using ARM templates. I used these templates a few months ago on the same subscription to setup our development environment and that worked fine....
1
vote
1answer
37 views

Maintenance Page in Sitecore Azure PaaS

I have a Sitecore 9.0.2 environment in Azure PaaS. It is connecting to different third party services to get and data. Whenever third party update their system or make any new release our portal goes ...
1
vote
0answers
53 views

How can I add a new QA environment to existing Sitecore Azure Paas setup?

We have an existing Sitecore 9 setup in Azure Paas. It includes one CD and one CM server with no xDB. Now we're looking to add a new QA environment which will effectively be a copy of CM with its own ...
1
vote
2answers
218 views

Azure WebApp XDB apps cannot find service 'KeyStoreProviders'

I'm upgrading from 9.0.2 (XM) to 9.2 (XP), so I got a fresh install of the XDB enviroments (Azure WebApps), but my xcollect, ma-ops, xc-search (Solr), and maybe other webapps give me the You do not ...
1
vote
1answer
90 views

Sitecore.XConnect.XdbSearchUnavailableException

Hi I was installing Sitecore in Azure Web App. It has been installed without SOLR cores in SOLR server (in this case I have a separate SORL VM along with Web apps for Sitecore PaaS). Once I have ...
2
votes
2answers
110 views

How to host custom Sitecore solution in Azure PaaS

I am using Azure PaaS as an environment of Sitecore 9.2.0 (XP + XC) with one custom solution. Can anyone please tell me how to deploy that custom solution into Azure Paas, as there are 17 web apps. ...
4
votes
1answer
133 views

DTU shooting up after application start in Azure PAAS Sitecore 9.0.2

We are observing that DTUs are shooting up while the application startsup in Azure PAAS environment, however the frequency is not consistent- sometime we restart the webapp explicitly and sometime it'...
6
votes
1answer
117 views

Azure Traffic Manager and Sitecore 9.2.0 PaaS

Background We are trying to create a "lightweight" failover setup, consisting of a failover CD instance with the core + web database being replicated (Azure SQL failovergroup). Additionally, that ...
4
votes
0answers
43 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
0
votes
1answer
88 views

Sitecore Azure PaaS Client Certificate on ASE

I deployed Sitecore 9.2 on Azure PaaS and facing the issue with Client Certificate Authentication. The Azure hosting is on ASE with Isolated App Service Plan. It seems like CM server is not able to ...
1
vote
2answers
45 views

Azure Deploy of CM + Reporting

I'd like to build a deployment of CM and Reporting in a single App Service. Is the best approach to take the XP0 files and try to remove what isn't needed ? Or try and combine The CM and Reporting ...
1
vote
1answer
103 views

Location of Redis cache connection String in XC 9.2.0 PaaS Scaled

I have installed Sitecore 9.2.0 XC Scaled in Azure PasS. Hence there are two Redis cache has been created in azure portal, one for XC and one for XP. I was able to find out where the Redis cache ...
6
votes
1answer
115 views

Log stream on Azure Paas

I have an environment running Sitecore 9.2 on Azure PAAS. It's an upgraded codebase (from 9.0.2) but on a clean setup. I had an issue with logging. Application Insights is working fine - I can see my ...
0
votes
1answer
62 views

Error: Code=InvalidServiceName | 9.2 PAAS set-up

I am trying to install Sitecore 9.2 Standalone on Azure PAAS using Sitecore Azure Toolkit 2.3.0 rev. 190410. I am following the steps provided at https://doc.sitecore.com/developers/92/sitecore-...
3
votes
2answers
282 views

Error: Code=InvalidContentLink when deploying to Azure

I am trying to set-up Sitecore XP 9.2 standalone in Azure PAAS using Sitecore Azure Toolkit 2.3.0 rev. 190410 following the link at https://doc.sitecore.com/developers/92/sitecore-experience-manager/...
2
votes
2answers
162 views

CORS Error while downloading the fonts from the Azure CDN using Sitecore PaaS

We have configured the Azure CDN for Sitecore Web Apps website, everything is working fine except the Fonts rendering from CDN, and we are getting below error: Any suggestion?
0
votes
1answer
137 views

Sitecore 9.2 multi instance( not multi-site ) set up on Azure PaaS

We're planning Sitecore upgrade from 8.2 to 9.2 Azure PaaS using Sitecore Experience Cloud( XPScaled ) marketplace module. We'll be having 3 sites and due to business constraint, we can't proceed with ...
0
votes
1answer
231 views

Multi-Site Domain is not resolving Using Azure WAF

I am facing domain resolving issue in Sitecore Multi-Site Solution using Azure PaaS with Azure WAF setup, however, it's working fine if I add the custom domain on Content delivery(Web Apps) level. ...
1
vote
0answers
57 views

Publishing Service in Azure Web App Won't Update Schema

I am using Sitecore 8.2 Update 7 Web Apps and created an empty Web App. Following these instructions to deploy the Publishing Service, everything has worked except for the schema upgrade: http://www....
0
votes
1answer
42 views

Warning message: 'GUID' field of 'GUID' item is skipped: field name is missed

In all of our environments, any time there is an index update to our Azure Search indexes, we see the following WARN message logged repeatedly (many thousands of times): 06:11:06 WARN [Index=...
1
vote
2answers
84 views

Azure searches on one Azure CD server are sent as “&search=This_Is_Equal_ConstNode_Return_Nothing”

On one of three CD servers every search we execute is sent to Azure Search like the following: 19660 02:11:05 INFO AzureSearch Query [sitecore_web_index]: &search=...
2
votes
1answer
171 views

Sitecore PaaS best pratice for App_Data

We are currently using Azure DevOps to deploy our Sitecore 9.1.1 and 9.2 solutions to Azure. In Azure DevOps you have the option of "leaving the App_Data" folder alone during deployment, i.e. not ...
2
votes
1answer
67 views

Sitecore Azure SQL DB Advisor recommendation - Drop unused indexes

As part of Sitecore 9.1 Azure hosting setup, I'm seeing few SQL DB Advisor recommendations in Azure to drop unused indexes on certain Sitecore tables that were created by Web deploy packages. Since ...
2
votes
2answers
208 views

Azure database refdata high intermittent load

We've been running a SC9.1 solution on PAAS for a while now, but have recently noticed intermittent slow response times, both on the CD and the CM. We've correlated it to high load on the refdata-db: ...
2
votes
1answer
125 views

Installing Packages in Sitecore PaaS/WebApp

Sitecore Support has stated that I can’t install packages like PowerShell Extensions and SXA if my PaaS environment is already deployed. They stated I need to redeploy and add these to the ARM ...
1
vote
1answer
61 views

Programmatically uploaded media files are not showing in CD Server

Sitecore Version : 9.0.2 Environment: Azure PaaS CD If upload any media file manually in Content editor, it uploads the media and the filepath field is empty. In program, I need to upload the media ...
3
votes
1answer
197 views

Checklist for Sitecore Security Hardening using Azure PaaS

I am Using Sitecore version 9 on Azure PaaS, Is there any official Sitecore security hardening guide for Azure PaaS ?, I can see some documentation as below link - https://doc.sitecore.com/...
3
votes
1answer
142 views

Does Sitecore PaaS support the usage of Azure deployment slots?

Background We are trying to make use of azure deployment slots when we deploy our Sitecore 9.1 PaaS solution to Azure. However, it seems that after a slot swap, the site is not warmed up, which ...
1
vote
1answer
74 views

Date field not showing in Azure Search results

I have a regular date field defined like this: <field type="System.DateTime" fieldName="entry_date" cloudFieldName="entry_date" searchable="NO" retrievable="YES" facetable="YES" filterable="YES" ...
0
votes
0answers
117 views

NullReferenceException while setting up ApplicationInsights with Sitecore 9.1 PaaS

We are following post below for the steps to configure ApplicationInsights and also have applied the patch as specified in the article. After setting things we are getting a NullReferenceException (...
2
votes
1answer
46 views

No SXA 1.7 ARM Template for Sitecore 9.0.1

I have an existing Sitecore 9.0.1 installation on Azure PaaS. I am looking to install SXA 1.7 on this specific version of Sitecore as Sitecore has outlined this version to be compatible in the SXA 1.7 ...
0
votes
0answers
104 views

Unicorn error on Azure Paas

We have been deploying our Sitecore 9.0.1 to Azure Paas, deploying each time to a clean slot. On the last deploy Unicorn synch stopped working, we are even unable to open the Unicorn.aspx page. ...
-1
votes
1answer
160 views

Cache cleared message every second in Azure Logs

We are trying to figure our an issue where our LIVE sites are getting down for 10 minutes everyday. While going through the Azure logs I am getting the following Warning: WARN web[standardValues] ...
2
votes
1answer
696 views

Is it possible to add Custom 403 Error page in Azure Web Apps

We have built our Sitecore 9.1 solution in Azure Web Apps. We have added custom 403 and 400 error pages by making use of the Error Manager module from Sitecore https://marketplace.sitecore.net/en/...