Questions tagged [paas]

Questions relating to using the Platform-as-a-Service deployment model for Sitecore.

Filter by
Sorted by
Tagged with
12
votes
2answers
1k views

How to handle multiple Core Databases in a multi-datacenter setup on Azure PaaS

I'm wondering how to handle multiple datacenters for CD servers in Azure PaaS. According to this ( https://kb.sitecore.net/articles/610106 ) you can use transactional replication for your Web ...
11
votes
3answers
901 views

How to add custom language to Sitecore on Azure PaaS Web Apps?

I want to create custom new languages. On-premise or IaaS I can use https://marketplace.sitecore.net/en/Modules/Custom_Language_Registration.aspx to register a new language. Does anyone have some ...
10
votes
1answer
2k views

Sitecore PaaS Log files missing

Currently, We are on Sitecore PaaS. There are some issues and we are not able to find out the root cause of those issues. We tried to find out some clues in Sitecore log file but We noticed that there ...
10
votes
3answers
655 views

SQL user creation is setting password of 12345, fails deployment

Using the updated Sitecore Azure Toolkit 2.0.1 rev. 171218, which has resources for 9.0.1, I'm hitting an error on the xc-collect\MSDeploy stage where it's attempting to apply the default sql user ...
10
votes
3answers
2k views

Azure Web App Redis timeout exceptions when under load

We are performance testing our Sitecore hosted in azure web apps (2 CD S3) which uses Premium Redis. There are no error during normal UAT and SIT. However, on performance testing there are quiet a ...
10
votes
1answer
796 views

Sitecore Debug Mode [closed]

What are the differences of code/pipeline execution in Sitecore side, when we run on debug mode compared to normal page request? Facing a strange issue where normal page request takes long time to ...
9
votes
2answers
316 views

How to convert a Sitecore package into a WDP package?

How can I convert a given Sitecore Package previously created using the Package Designer into a WDP package, so that I can create a script to deploy it on my Azure instances?
9
votes
1answer
269 views

Is it possible to run Dianoga in an Azure Web App?

A very simple question I'm looking to get confirmed. Can you run Dianoga module in Sitecore within an Azure Web App context? My main concern is that it requires .exe files for compression as ...
9
votes
1answer
781 views

How to Create Web Deploy Package for Sitecore Modules

We are currently using Sitecore PaaS implementation for Sitecore 9 Update 1 and would like to know if it is possible to create a Web Deploy Package for other Sitecore Modules like Data Exchange ...
8
votes
3answers
1k views

Azure Application Insights not working on Sitecore 9.1 PaaS

I've provisioned a Sitecore 9.1 PaaS, and for some odd reason the Application Insights is not loading graphics except in Live Metrics Stream for Process CPU data I went through the existing post ...
7
votes
1answer
479 views

Using TDS sync with Azure PaaS and Sitecore 9

We're setting up a QA environment in Azure PaaS and we're working to figure out the best way to publish things. The code seems to be easy with VS 2017, but we're trying to figure out how to get TDS ...
6
votes
1answer
2k views

Azure Redis Cache, is it necessary for Sitecore?

Currenty we are running Sitecore 9.0 on Azure Paas. I would like to know which is the purpose of the Azure Redis Cache? Reading some documentation it seems that it´s to store session properties of ...
6
votes
3answers
803 views

Sitecore Email Cloud compared to the custom SMTP

While doing email action for workflow on Sitecore 9 PaaS. I came around terms like Custom SMTP and Sitecore email cloud. I need some inputs around Custom SMTP . I understand it is same what we do ...
6
votes
1answer
130 views

Azure Traffic Manager and Sitecore 9.2.0 PaaS

Background We are trying to create a "lightweight" failover setup, consisting of a failover CD instance with the core + web database being replicated (Azure SQL failovergroup). Additionally, that ...
6
votes
2answers
728 views

Using ASE (App Service Environment) to Secure Endpoints in Azure PaaS

I have found Azure Sitecore PaaS has security limitations where you cannot secure the internet facing endpoints of the PaaS Apps. The only way to totally secure App endpoints in Azure is to put them ...
6
votes
1answer
892 views

How can I improve startup times content management in Azure PaaS?

On our Sitecore 9.0.1 in Azure PaaS, we notice that the first load of pages in the sitecore backend (login, desktop, experience editor, content editor) takes a lot of time. For now we implemented some ...
6
votes
1answer
142 views

Log stream on Azure Paas

I have an environment running Sitecore 9.2 on Azure PAAS. It's an upgraded codebase (from 9.0.2) but on a clean setup. I had an issue with logging. Application Insights is working fine - I can see my ...
6
votes
1answer
861 views

Switch Azure Search to Solr Sitecore PaaS [duplicate]

I am working with the Upgrade to Sitecore 9 in Azure PaaS, however, I also need to switch the Azure Search to Solr that is compatible with the Sirecore 9 PaaS. I have tried looking for any ...
5
votes
3answers
580 views

PaaS compatibility for WFFM and EXM?

Are the current versions of WFFM and/or EXM supported on Azure PaaS?
5
votes
4answers
450 views

Using Publishing Service on Azure PaaS

Has anyone here used Publishing Service on Azure as PaaS? The client has two databases(two web databases), First, it publishes on the main base then on the "backup" base. I'm thinking of using the ...
5
votes
2answers
2k views

Azure PaaS reports certificate not found

I have deployed Sitecore 9.0.2 XP Single in an Azure App Service Environment (ASE). After deployment I keep seeing the following error being reported in the log files: Exception: System....
5
votes
1answer
3k views

Azure PaaS webapp app_offline.htm Maintenance page

What is the best practice to enable maintenance page in Sitecore Azure PaaS webapp? Also is there a way we can switch on maintenance page such as app_offline in application settings. I m looking at ...
5
votes
1answer
104 views

Error while creating a WDP package using AzureToolkit

I'm trying to create a WDP from an existing Sitecore package but I'm facing the following error even after installing DacFX: Microsoft.Web.Deployment.DeploymentDetailedFatalException: The SQL ...
5
votes
1answer
472 views

How to share Sitecore caches (item, data, prefetch,etc NOT session state) on Azure PaaS between Web Apps

I can't find any docs on this so I assume it's not possible, but... If you run Sitecore in Azure PaaS and have scale-out enabled (e.g. you're running 2x S3 instances) then can you have a shared/...
4
votes
1answer
187 views

Provisioning to Azure failure on deploying CM

I am trying to setup a new Sitecore 9.2 instance on PAAS using ARM templates. I used these templates a few months ago on the same subscription to setup our development environment and that worked fine....
4
votes
1answer
277 views

My index on Content Delivery does not match with CM and is not updating anymore on Azure PAAS - Sitecore 9.0.2

We noticed that our CD environment gave different results from the index compared to the CM environment. We did some more checks and found that the index on CD was also not updating anymore. It did ...
4
votes
2answers
312 views

Application Insights Telemetry Metrics

Sitecore 9 on Azure PaaS comes with App Insights as a default. Out of the box, there are a bunch of metrics captured. This counts for a lot of data that comes at a cost. Even a clean install with no ...
4
votes
1answer
566 views

Sitecore 9 in Azure PaaS : Add Application Insights SDK

For Sitecore 9 on Azure PaaS and newer versions, what is the best practice to Add and configure the Application Insights SDK in Visual Studio to generate some telemetry in Visual Studio. As we are ...
4
votes
1answer
152 views

DTU shooting up after application start in Azure PAAS Sitecore 9.0.2

We are observing that DTUs are shooting up while the application startsup in Azure PAAS environment, however the frequency is not consistent- sometime we restart the webapp explicitly and sometime it'...
4
votes
1answer
173 views

Image Editor actions throws “Parameter not valid.”

Image editor doesn't function after deploying to the azure environments. This seems to be the case for our Dev, Test and Acceptance environments. When using Crop or Rotate or Flip: Server Error in '/...
4
votes
2answers
423 views

Sitecore Azure PaaS Deployment - ResourceDeploymentFailure | DeploymentFailed | BadRequest

Anyone got the same issue upon the provisioning of Sitecore Web Experience Manager (XM) using Azure PaaS offering. I've just followed the steps provided in Azure with $50 remaining credits in my ...
4
votes
1answer
223 views

Response time and resource usage increase during 4 hours

In the last days we are experiencing some performance problems in our Sitecore. Currently we are using Sitecore 9.0 as PaaS in Azure, in the last weeks we have added new sites on it. Right now we ...
4
votes
0answers
46 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
4
votes
0answers
113 views

Log Sitecore errors as exceptions instead of trace in application insights

By default, Sitecore application insights config logs Sitecore errors as traces instead of exceptions this means application insights dashboard and alerts are unaware of the exception occurring in a ...
3
votes
1answer
1k views

Accessing log files in application insights for Sitecore 9 in Azure app service

I've been reading several blog posts about application insights and Sitecore logs, and I've not been able to get the proper configuration working. This is using Sitecore 9 ARM templates on Azure app ...
3
votes
1answer
351 views

Sitecore Client login Timeout error - Azure PaaS

In the Content Management (CM) environment, /Sitecore is loading correctly with login screen, but when we input credentials and hit on Login button, it just keeps loading and finally gives 500 timeout ...
3
votes
1answer
1k views

Sitecore instance is very slow after deployment in Azure Paas

Sitecore version - 9.0.1 (rev. 171219) After every deployment, to load the home page it is taking at least 20 mins thereafter every new page takes 2 mins on the first instance there after its pretty ...
3
votes
2answers
300 views

Is there possibility to use Solr in Sitecore PaaS?

Clients wants to go full PaaS with Sitecore 9 and Sitecore Experience Commerce 9. We have existing solution which was built with Sitecore 8.2 and Sitecore Commerce 8.2.1 with Solrand it's deployed as ...
3
votes
1answer
158 views

Does Sitecore PaaS support the usage of Azure deployment slots?

Background We are trying to make use of azure deployment slots when we deploy our Sitecore 9.1 PaaS solution to Azure. However, it seems that after a slot swap, the site is not warmed up, which ...
3
votes
2answers
812 views

All search indexes missing

Recently created a Sitecore PaaS instance associating with Solr IaaS, The Index Manager Console looks to be empty. What is wrong here !
3
votes
1answer
3k views

When attempting to deploy, I get “Restricted from provisioning in this region”

When trying to deploy a basic Sitecore 9 XM (Single) Instance via the Azure Portal, I am getting a deployment failure. After looking at the logs, it seems it is related to the West US region I'm ...
3
votes
2answers
223 views

Azure database refdata high intermittent load

We've been running a SC9.1 solution on PAAS for a while now, but have recently noticed intermittent slow response times, both on the CD and the CM. We've correlated it to high load on the refdata-db: ...
3
votes
1answer
88 views

CM server Sitecore 9 Update 1 is hosted on the Azure with XP Scaled didn't see the owin.initialize pipeline

I have used the pipeline profile and found the owin.initialize pipeline isn't available on the CM server which is hosted on the Azure App service. I have used the Sitecore 9 Update 1 - XP Scaled. ...
3
votes
1answer
840 views

Experience Editor Ribbon 'siteName' error

I have deployed a simple Sitecore 9 website in Azure PaaS. There's nothing so special about the code as it is only a newsletter sign up with Personalization. It works well, I can personalized my ...
3
votes
2answers
411 views

Error: Code=InvalidContentLink when deploying to Azure

I am trying to set-up Sitecore XP 9.2 standalone in Azure PAAS using Sitecore Azure Toolkit 2.3.0 rev. 190410 following the link at https://doc.sitecore.com/developers/92/sitecore-experience-manager/...
3
votes
1answer
241 views

Checklist for Sitecore Security Hardening using Azure PaaS

I am Using Sitecore version 9 on Azure PaaS, Is there any official Sitecore security hardening guide for Azure PaaS ?, I can see some documentation as below link - https://doc.sitecore.com/...
3
votes
3answers
2k views

Application recycle problems

We upgraded from Sitecore 8.1 to 9.0 some weeks ago, and we moved to Azure PaaS. Since then we are suffering from application recycles in some of our instances. Looking at event viewer, we saw tens ...
3
votes
1answer
1k views

Certificate not found error while using xConnect on Azure from Visual Studio Application

I have created a Sitecore 9.0 PaaS in Azure. I am trying to work with xConnect by following this article - https://doc.sitecore.net/developers/xp/getting-started/, tutorial 1. The certificate I used ...
3
votes
2answers
180 views

Install EXM on Azure

I am trying to install Sitecore on Azure using marketplace XP1 template also I need to install EXM, in installation wizard I select Sitecore 8.2 update 5 and EXM module, when I try to open content ...
3
votes
0answers
137 views

Installation issue on migration 9.1.1

I am trying to migrate a Sitecore 9.0.2 to 9.1.1. Following the upgrade guide https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/91/Sitecore_Experience_Platform_91_Update1.aspx, I have to ...