Questions tagged [paas]

Questions relating to using the Platform-as-a-Service deployment model for Sitecore.

Filter by
Sorted by
Tagged with
1
vote
0answers
50 views

Files not found on Azure Paas

We have a solution installed on Azure Paas. In the logs we have next errors: Exception: System.IO.FileNotFoundException Message: Could not find file 'D:\home\site\wwwroot\sitecore\shell\client\...
0
votes
1answer
30 views

How can I show static page during a deployment to Sitecore Manage Cloud?

We are using Sitecore Managed Cloud and we have just one CD web app. Obviously when we deploy the website goes down and we would like to show a static page to the users during this time. Is there an ...
1
vote
1answer
419 views

SolrCloud on Azure PaaS

I am setting up a Sitecore 9.2 Production instance and ideally would like to Setup SolrCloud in Azure PaaS Web Apps. In test environments i have setup Solr on a single PaaS App Service and it is ...
5
votes
2answers
78 views

Where to place Custom XConnect Model file in Azure

I had a custom Model JSON file in on Premise environment under the XConnect Project/App_Data/Models folder. Now we are moving to Azure. I see there are more roles in the Azure environment like xc-...
0
votes
2answers
188 views

Invalid identity provider: sitecoreidentityserver when attempting to login

Attempted to simply login to two different sitecore CM ( test and prod ) Azure PaaS servers and go the following error : Invalid identity provider: sitecoreidentityserver I suspect it has to do with ...
0
votes
1answer
52 views

Sitecore PaaS Web DB spikes

We’ve just migrated from Sitecore 8.2.5 on-prem to 9.3 Azure PaaS. Performance seems ok most of the time, but we’re seeing regular spikes to 100% DTU on the web db. The db is standard S2 50 DTU and we’...
4
votes
1answer
96 views

SQL Replication doesn't clear CD caches on remote target

We have a multi-cd publishing situation I can use some help with. We are in an Azure PAAS situation, with the CM and 1 CD server located in the US. We also have a CD Server and SQL database in China (...
1
vote
1answer
554 views

Sitecore.XConnect.XdbSearchUnavailableException [closed]

Hi I was installing Sitecore in Azure Web App. It has been installed without SOLR cores in SOLR server (in this case I have a separate SORL VM along with Web apps for Sitecore PaaS). Once I have ...
0
votes
1answer
703 views

Identity Server not redirecting to Azure Frontdoor URL

We are implementing URL hardening in Azure PaaS. We have added Azure front door urls to CM app. We have updated Sitecore.Owin.Authentication.IdentityServer.config on CM server with new url for ...
0
votes
1answer
21 views

Trim down unused XP roles in a sitecore 9.0.1 XP scaled setup hosted in Azure PaaS [duplicate]

What is the recommended way to trim down the XP roles in a XP Scaled setup (Sitecore 9.0.1) that are not being used by the business. Currently we are using only XM features, so we thought of cutting ...
1
vote
2answers
63 views

Azure Deploy of CM + Reporting

I'd like to build a deployment of CM and Reporting in a single App Service. Is the best approach to take the XP0 files and try to remove what isn't needed ? Or try and combine The CM and Reporting ...
2
votes
3answers
1k views

Login failed for user 'masteruser'

I was moving my Sitecore 9.2 QA database in UAT in Azure PaaS. I have moved the web & master database and renamed the databases to UAT's database name. In connectionString.config we have changed ...
1
vote
0answers
92 views

Sitecore login redirects to website and not Launchpad

We are using azure alias URL "https://abc.com/sitecore/login" to access our prod CM site "https://abc-1001-cm.azurewebsites.net/sitecore/login". Earlier we had Sitecore 9.0.1 ...
10
votes
4answers
4k views

Azure Web App Redis timeout exceptions when under load

We are performance testing our Sitecore hosted in azure web apps (2 CD S3) which uses Premium Redis. There are no error during normal UAT and SIT. However, on performance testing there are quiet a ...
1
vote
1answer
154 views

How to setup Application Insights for a Solr service hosted on Azure PaaS

We have an Azure PaaS environment for Sitecore 9.3 and Solr App services created. Is there any way to connect Application Insights for the Solr App service? For CM and CD services we have setup the ...
1
vote
0answers
37 views

Sitecore List Manager default Email related rules not working

Sitecore version: 9.1 Update 1 on Azure PAAS We are trying to create a segmented list based on OOTB rule where the contact clicked any email but after selecting this rule in rule editor window while ...
0
votes
2answers
50 views

Using Seq with Sitecore PaaS

We are running 9.3 in an app service in Azure. We have found a number of articles stating different things about logging in SC. Some say it's log4net, others say Serilog... Since we cannot get to ...
9
votes
2answers
1k views

How to Create Web Deploy Package for Sitecore Modules

We are currently using Sitecore PaaS implementation for Sitecore 9 Update 1 and would like to know if it is possible to create a Web Deploy Package for other Sitecore Modules like Data Exchange ...
0
votes
2answers
127 views

Sitecore Item URL with Custom Domain in Azure PaaS

I have Sitecore 8.2 update 5 site deployed in Azure PaaS as an App Service. I have created a custom domain (e.g. abc.com) in the App Service. This custom domain is kept behind F5 firewall. I am facing ...
2
votes
2answers
548 views

Incorrect URLs when behind proxy

I have a Sitecore 9.3 xp1 scaled application hosted in Azure PaaS. The CD App Service sits behind an F5 and Azure Gateway, with DNS of https://mysite.com routing through these 2 proxies (F5 -> ...
0
votes
2answers
256 views

Sitecore TDS Webdeploy in Azure PAAS

I am facing issues in Deploying TDS Webdeploy Package to Azure PAAS. I'm using Sitecore 9.3, TDS.6.0.0.14 We are getting an error on TDS service Msg From Kudu --> "WARN Request is ...
1
vote
1answer
225 views

Storing custom data in Redis

Our Sitecore 9.2 PaaS website uses federated authentication for logging in our end users, and we are looking for a secure place to store refresh- and access-tokens (pref. serverside). We would prefer ...
2
votes
1answer
142 views

Load balancing with Azure PaaS on CD

We have a Sitecore 9.2 setup using the S3 profile for the CD with 3 instances scaled out manually. I'm pretty new to managing the PaaS environment, and I'm trying to figure out if the traffic is load-...
1
vote
1answer
47 views

unicorn deployment failure - can't sync when deployed to real environments

I am sure I am missing something simple about using Unicorn in environments above the local dev environments the source folder is correct out of Azure Paas, out on my App Service I am in Sitecore 9.3....
0
votes
0answers
29 views

Sitecore 9 Analytics - added user agent in the <excludedUserAgents> not working

We have Sitecore 9.0.2 based UAT and Live website in Azure PaaS environment. Before some time we have configured Sitecore analytics tracking in UAT and Live both. Now what happened is in both ...
0
votes
1answer
79 views

Does Sitecore Azure paas support sticky session?

I want to enable Sticky session on Azure Pass Sitecore CD instances(multiple app services). Is this possible? If not, what are other options that I have?
0
votes
1answer
42 views

Opening HTML microsite from Sitecore Media Library v9.1.1

looking for settings to open microsite uploaded to media library in browser. In the past we would take an Adobe Captivate html export load it into a folder in the media library and run the .html from ...
0
votes
0answers
50 views

How to setup one common CMS and two CD server in different region in Azure Pass Architecture?

Currently we have scaled environment setup on Azure Pass i:e one CM and one CD server in common region. Now we have created one more site but its for another region and due to compliance policy we can'...
2
votes
1answer
71 views

Scale Out Content Management AppService

I'm looking at options to scale out a content management app service as we have some custom APIs running on CM that will generate load. The docs state that we need to specify a distinct InstanceName ...
3
votes
1answer
507 views

Sitecore Client login Timeout error - Azure PaaS

In the Content Management (CM) environment, /Sitecore is loading correctly with login screen, but when we input credentials and hit on Login button, it just keeps loading and finally gives 500 timeout ...
1
vote
0answers
88 views

Invalid template when adding modules to azuredeploy.parameters.json file

I am using the provided ARM Templates to deploy a Sitecore 9.3 XP Scaled topology to Azure PaaS, and then planning to add some adjustments. It all went mostly fine, but I'm stuck now when I tried to ...
4
votes
1answer
502 views

Multi-Site Domain is not resolving Using Azure WAF

I am facing domain resolving issue in Sitecore Multi-Site Solution using Azure PaaS with Azure WAF setup, however, it's working fine if I add the custom domain on Content delivery(Web Apps) level. ...
1
vote
1answer
128 views

Sitecore xConnect client certificates renewal

In our Sitecore 9.2 PaaS solution, we are using self-signed client certificates and have added the AppSetting AllowInvalidClientCertificates=true to all xConnect roles as well as the PRC, CD and CM ...
2
votes
1answer
267 views

Error when installing WDP in on-premises Sitecore 9.1 XP setup

I followed the steps described in this SSE question/answer to create my WDP. Everything works like a charm when deploying this WDP into a Sitecore Azure Paas instance. However, when I try to install ...
4
votes
1answer
247 views

Enabling Local Cache on Sitecore Azure App Services

I've read the following article https://blog.baslijten.com/increase-your-sitecore-performance-by-enabling-the-local-cache-on-azure-app-services/ that says how to enable Local Cache option in the Azure ...
1
vote
1answer
137 views

Sitecore Azure PaaS Client Certificate on ASE

I deployed Sitecore 9.2 on Azure PaaS and facing the issue with Client Certificate Authentication. The Azure hosting is on ASE with Isolated App Service Plan. It seems like CM server is not able to ...
2
votes
0answers
72 views

Sitecore shared fields getting cleared after deployment to other environments

Sitecore 9.0 shared fields data was getting cleared after deployment in few environments including Production. In Pre production, the content is not cleared but can find this issue happening in lower ...
2
votes
1answer
89 views

Most cost effective way to add custom SQL server tables/database to Sitecore 9.1.1 PaaS installation

I'm looking for some guidance please, we have a small (~500Mb) custom SQL server database that we need to run alongside the standard Sitecore 9.1.1 databases. I'm also new to Azure so I apologies if ...
2
votes
1answer
356 views

Publishing Service error message: Could not persist PublisherOperations in the service

In my CM logs, I'm seeing the following warning repeatedly. WARN Could not persist PublisherOperations in the service Exception: Polly.CircuitBreaker.BrokenCircuitException Message: The circuit is ...
0
votes
0answers
76 views

Sitecore LaunchPad is distorted after deploying Web Application on Azure PaaS

I have deployed our application on Azure Pass. I am able to login in to the Sitecore CMS and redirected on the LaunchPad. LaunchPad CSS is distorted and click is not working. Also there are lot of ...
1
vote
0answers
122 views

Azure search Synonyms implementation using SXA 1.9 and Sitecore 9.2 using postman API

I have requirement to work with the synonyms for the similar group of words in search. I did load the synonyms using Postman API to SXA web index and able to see them on the index. For example: home,...
4
votes
2answers
398 views

Azure database refdata high intermittent load

We've been running a SC9.1 solution on PAAS for a while now, but have recently noticed intermittent slow response times, both on the CD and the CM. We've correlated it to high load on the refdata-db: ...
2
votes
1answer
726 views

Sitecore redirects for login page using hostname

We have a sitecore instance (xp0 for now) with an identity server. They are deployed to azure and belong to a private vnet. Access to nodes is done through the application gateway. But because of ...
0
votes
0answers
59 views

Sitecore Azure PaaS webapp becomes unresponsive when Unicorn files copied

We are using Unicorn to sync Sitecore items between different Sitecore instances. We have created a separate Azure DevOps release pipeline dedicated only for copying Unicorn files and running the sync ...
0
votes
0answers
44 views

Sitecore Azure PaaS ARM templates doesnt support template idempotence

We are using ARM templates to install Sitecore 9.2.0 XP Scaled topology for our infrastructure. While using these templates, we observed that these templates are not idempotent in nature. We needed to ...
0
votes
1answer
176 views

Sitecore Azure 9.1 Marketing Operations service error [closed]

I'm receiving this error in my Sitecore 9.1 Azure Marketing Operations service. FYI my xCollect service is pointing to MongoDB instance so I have enabled sc.Xdb.Collection.Data.MongoDb.xml in ...
1
vote
0answers
113 views

Sitecore Paas installation failure - AppGallery Deploy Failed: The declared parameter 'Application Path' is not recognized

We are trying to create Sitecore 9.2 instance in azure PaaS using ARM templates. The ARM templates worked fine. Now we have modified the ARM templates to install the JSS module with Sitecore while ...
4
votes
1answer
380 views

Logs are flooded with requests to reporting server for POST /~/v75/reporting/remotedatasourceproxy/

We installed a new 9.2 solution on PAAS (including SXA 1.9 - although that does not seem to be relevant). This is a clean solution that will be filled with content -and code- from an upgraded version. ...
0
votes
1answer
497 views

SXA server error page not working in Azure PaaS

We are using Sitecore 9.0.2 and SXA 1.7.1 We have configured a server error page in the field called "Server Error Page Link" in the "Settings" item. We generated the static error page (navigate to ...
1
vote
0answers
309 views

Clean install on Azure SQL Managed instance

I am trying to install Sitecore 9.2 vanilla on Azure with SQL Managed Instance but I am getting the following error { "status": "failed", "error": { "code": "ResourceDeploymentFailure", "...