Questions tagged [paas]

Questions relating to using the Platform-as-a-Service deployment model for Sitecore.

Filter by
Sorted by
Tagged with
1
vote
1answer
27 views

Maintenance Page in Sitecore Azure PaaS

I have a Sitecore 9.0.2 environment in Azure PaaS. It is connecting to different third party services to get and data. Whenever third party update their system or make any new release our portal goes ...
1
vote
2answers
60 views

Azure WebApp XDB apps cannot find service 'KeyStoreProviders'

I'm upgrading from 9.0.2 (XM) to 9.2 (XP), so I got a fresh install of the XDB enviroments (Azure WebApps), but my xcollect, ma-ops, xc-search (Solr), and maybe other webapps give me the You do not ...
1
vote
1answer
26 views

Sitecore.XConnect.XdbSearchUnavailableException

Hi I was installing Sitecore in Azure Web App. It has been installed without SOLR cores in SOLR server (in this case I have a separate SORL VM along with Web apps for Sitecore PaaS). Once I have ...
1
vote
1answer
70 views

How to host custom Sitecore solution in Azure PaaS

I am using Azure PaaS as an environment of Sitecore 9.2.0 (XP + XC) with one custom solution. Can anyone please tell me how to deploy that custom solution into Azure Paas, as there are 17 web apps. ...
4
votes
1answer
71 views

DTU shooting up after application start in Azure PAAS Sitecore 9.0.2

We are observing that DTUs are shooting up while the application startsup in Azure PAAS environment, however the frequency is not consistent- sometime we restart the webapp explicitly and sometime it'...
6
votes
1answer
78 views

Azure Traffic Manager and Sitecore 9.2.0 PaaS

Background We are trying to create a "lightweight" failover setup, consisting of a failover CD instance with the core + web database being replicated (Azure SQL failovergroup). Additionally, that ...
3
votes
0answers
35 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
0
votes
1answer
59 views

Sitecore Azure PaaS Client Certificate on ASE

I deployed Sitecore 9.2 on Azure PaaS and facing the issue with Client Certificate Authentication. The Azure hosting is on ASE with Isolated App Service Plan. It seems like CM server is not able to ...
1
vote
2answers
40 views

Azure Deploy of CM + Reporting

I'd like to build a deployment of CM and Reporting in a single App Service. Is the best approach to take the XP0 files and try to remove what isn't needed ? Or try and combine The CM and Reporting ...
1
vote
1answer
54 views

Location of Redis cache connection String in XC 9.2.0 PaaS Scaled

I have installed Sitecore 9.2.0 XC Scaled in Azure PasS. Hence there are two Redis cache has been created in azure portal, one for XC and one for XP. I was able to find out where the Redis cache ...
6
votes
1answer
74 views

Log stream on Azure Paas

I have an environment running Sitecore 9.2 on Azure PAAS. It's an upgraded codebase (from 9.0.2) but on a clean setup. I had an issue with logging. Application Insights is working fine - I can see my ...
0
votes
1answer
45 views

Error: Code=InvalidServiceName | 9.2 PAAS set-up

I am trying to install Sitecore 9.2 Standalone on Azure PAAS using Sitecore Azure Toolkit 2.3.0 rev. 190410. I am following the steps provided at https://doc.sitecore.com/developers/92/sitecore-...
3
votes
2answers
69 views

Error: Code=InvalidContentLink when deploying to Azure

I am trying to set-up Sitecore XP 9.2 standalone in Azure PAAS using Sitecore Azure Toolkit 2.3.0 rev. 190410 following the link at https://doc.sitecore.com/developers/92/sitecore-experience-manager/...
2
votes
2answers
76 views

CORS Error while downloading the fonts from the Azure CDN using Sitecore PaaS

We have configured the Azure CDN for Sitecore Web Apps website, everything is working fine except the Fonts rendering from CDN, and we are getting below error: Any suggestion?
0
votes
1answer
97 views

Sitecore 9.2 multi instance( not multi-site ) set up on Azure PaaS

We're planning Sitecore upgrade from 8.2 to 9.2 Azure PaaS using Sitecore Experience Cloud( XPScaled ) marketplace module. We'll be having 3 sites and due to business constraint, we can't proceed with ...
0
votes
1answer
106 views

Multi-Site Domain is not resolving Using Azure WAF

I am facing domain resolving issue in Sitecore Multi-Site Solution using Azure PaaS with Azure WAF setup, however, it's working fine if I add the custom domain on Content delivery(Web Apps) level. ...
1
vote
0answers
35 views

Publishing Service in Azure Web App Won't Update Schema

I am using Sitecore 8.2 Update 7 Web Apps and created an empty Web App. Following these instructions to deploy the Publishing Service, everything has worked except for the schema upgrade: http://www....
0
votes
1answer
22 views

Warning message: 'GUID' field of 'GUID' item is skipped: field name is missed

In all of our environments, any time there is an index update to our Azure Search indexes, we see the following WARN message logged repeatedly (many thousands of times): 06:11:06 WARN [Index=...
1
vote
2answers
45 views

Azure searches on one Azure CD server are sent as “&search=This_Is_Equal_ConstNode_Return_Nothing”

On one of three CD servers every search we execute is sent to Azure Search like the following: 19660 02:11:05 INFO AzureSearch Query [sitecore_web_index]: &search=...
2
votes
1answer
117 views

Sitecore PaaS best pratice for App_Data

We are currently using Azure DevOps to deploy our Sitecore 9.1.1 and 9.2 solutions to Azure. In Azure DevOps you have the option of "leaving the App_Data" folder alone during deployment, i.e. not ...
2
votes
1answer
40 views

Sitecore Azure SQL DB Advisor recommendation - Drop unused indexes

As part of Sitecore 9.1 Azure hosting setup, I'm seeing few SQL DB Advisor recommendations in Azure to drop unused indexes on certain Sitecore tables that were created by Web deploy packages. Since ...
2
votes
1answer
110 views

Azure database refdata high intermittent load

We've been running a SC9.1 solution on PAAS for a while now, but have recently noticed intermittent slow response times, both on the CD and the CM. We've correlated it to high load on the refdata-db: ...
2
votes
1answer
85 views

Installing Packages in Sitecore PaaS/WebApp

Sitecore Support has stated that I can’t install packages like PowerShell Extensions and SXA if my PaaS environment is already deployed. They stated I need to redeploy and add these to the ARM ...
1
vote
1answer
38 views

Programmatically uploaded media files are not showing in CD Server

Sitecore Version : 9.0.2 Environment: Azure PaaS CD If upload any media file manually in Content editor, it uploads the media and the filepath field is empty. In program, I need to upload the media ...
3
votes
1answer
139 views

Checklist for Sitecore Security Hardening using Azure PaaS

I am Using Sitecore version 9 on Azure PaaS, Is there any official Sitecore security hardening guide for Azure PaaS ?, I can see some documentation as below link - https://doc.sitecore.com/...
3
votes
1answer
96 views

Does Sitecore PaaS support the usage of Azure deployment slots?

Background We are trying to make use of azure deployment slots when we deploy our Sitecore 9.1 PaaS solution to Azure. However, it seems that after a slot swap, the site is not warmed up, which ...
1
vote
1answer
58 views

Date field not showing in Azure Search results

I have a regular date field defined like this: <field type="System.DateTime" fieldName="entry_date" cloudFieldName="entry_date" searchable="NO" retrievable="YES" facetable="YES" filterable="YES" ...
0
votes
0answers
67 views

NullReferenceException while setting up ApplicationInsights with Sitecore 9.1 PaaS

We are following post below for the steps to configure ApplicationInsights and also have applied the patch as specified in the article. After setting things we are getting a NullReferenceException (...
2
votes
1answer
43 views

No SXA 1.7 ARM Template for Sitecore 9.0.1

I have an existing Sitecore 9.0.1 installation on Azure PaaS. I am looking to install SXA 1.7 on this specific version of Sitecore as Sitecore has outlined this version to be compatible in the SXA 1.7 ...
0
votes
0answers
72 views

Unicorn error on Azure Paas

We have been deploying our Sitecore 9.0.1 to Azure Paas, deploying each time to a clean slot. On the last deploy Unicorn synch stopped working, we are even unable to open the Unicorn.aspx page. ...
-1
votes
1answer
94 views

Cache cleared message every second in Azure Logs

We are trying to figure our an issue where our LIVE sites are getting down for 10 minutes everyday. While going through the Azure logs I am getting the following Warning: WARN web[standardValues] ...
2
votes
1answer
291 views

Is it possible to add Custom 403 Error page in Azure Web Apps

We have built our Sitecore 9.1 solution in Azure Web Apps. We have added custom 403 and 400 error pages by making use of the Error Manager module from Sitecore https://marketplace.sitecore.net/en/...
1
vote
2answers
62 views

Where do the UpdateInstallationWizard.aspx logs get saved in Azure PaaS?

Sitecore 9.0.2. In my experience, the logs should be saved into the temp folder. Our environment is configured like so: <sc.variable name="tempFolder" value="d:\local\temp"/> I've looked ...
0
votes
0answers
16 views

Sitecore Azure Paas Media files not appearing

I have installed fresh new Sitecore Azure Paas (Sitecore 9 update 2). Created a Sitecore packages from my local to the new instance to migrate all the content, media, system and templates. Everything ...
1
vote
1answer
75 views

Error when installing WDP in on-premises Sitecore 9.1 XP setup

I followed the steps described in this SSE question/answer to create my WDP. Everything works like a charm when deploying this WDP into a Sitecore Azure Paas instance. However, when I try to install ...
5
votes
1answer
67 views

Error while creating a WDP package using AzureToolkit

I'm trying to create a WDP from an existing Sitecore package but I'm facing the following error even after installing DacFX: Microsoft.Web.Deployment.DeploymentDetailedFatalException: The SQL ...
9
votes
2answers
211 views

How to convert a Sitecore package into a WDP package?

How can I convert a given Sitecore Package previously created using the Package Designer into a WDP package, so that I can create a script to deploy it on my Azure instances?
2
votes
0answers
235 views

Sitecore Identity Server failing to access CM

I have an environment running in Azure PaaS using Sitecore 9.1 (initial release), and after a while I couldn't sign in to the CM anymore. I decide to restart the App Service, and once SI back up, the ...
2
votes
1answer
109 views

Error when Installing Sitecore 9.1 on Azure PaaS

When trying to install Sitecore 9.1 on Azure PaaS, I face the following error: Add-AzureRMAccount : The term 'Add-AzureRMAccount' is not recognized as the name of a cmdlet, function, script file, or ...
1
vote
1answer
115 views

Patching Azure Search config files and deploy on Sitecore Azure PaaS

Our application (Sitecore 9.0.2 SXA 1.8) is currently running on Azure PaaS with Azure Search as Search service Recently we ran into this problem of master index exceeding 1000 field Limit we ...
3
votes
0answers
118 views

Installation issue on migration 9.1.1

I am trying to migrate a Sitecore 9.0.2 to 9.1.1. Following the upgrade guide https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/91/Sitecore_Experience_Platform_91_Update1.aspx, I have to ...
-3
votes
2answers
108 views

How to disable Sitecore login only (Sitecore Client - https://<domain>/sitecore/login)

Is there a way to disable Sitecore Client for public but need to be available inside company network? I am having a domain 'mydomain'. I need https://mydomain/home (website) need to be accessible to ...
2
votes
1answer
279 views

How to deploy Sitecore to a new deployment slot on an existing environment?

I have DTAP environments up and running for this client I'm working for and want to improve the deployment of releases by reducing the downtime / first loadtime. I have read up on blue/green ...
1
vote
1answer
54 views

Is WeBlog compatible with Azure PaaS?

As we know when we run a Sitecore instance on Azure PaaS we have to use Azure Search instead of Solr or Lucene. Since WeBlog does have custom configs for Content Search, I'm wondering if they are ...
1
vote
2answers
382 views

Sitecore PAAS Redis Exception [duplicate]

We are using Sitecore 9.0.2 deployed in PAAS and CD app service is showing below error and logs are full of this kind of exceptions: ERROR ProcessExpiredItems => System.TimeoutException: Timeout ...
1
vote
2answers
175 views

Security Hardening in PaaS

We are using Sitecore 9.0.2 deployed in PaaS as a general recommendation from Sitecore Security Hardening Guide perspective we are supposed to do the below items: 1)Prevent Anonymous Users access to ...
0
votes
1answer
177 views

SXA server error page not working in Azure PaaS

We are using Sitecore 9.0.2 and SXA 1.7.1 We have configured a server error page in the field called "Server Error Page Link" in the "Settings" item. We generated the static error page (navigate to ...
4
votes
1answer
110 views

Image Editor actions throws “Parameter not valid.”

Image editor doesn't function after deploying to the azure environments. This seems to be the case for our Dev, Test and Acceptance environments. When using Crop or Rotate or Flip: Server Error in '/...
6
votes
3answers
910 views

Azure Application Insights not working on Sitecore 9.1 PaaS

I've provisioned a Sitecore 9.1 PaaS, and for some odd reason the Application Insights is not loading graphics except in Live Metrics Stream for Process CPU data I went through the existing post ...
0
votes
1answer
122 views

Sitecore Azure 9.1 Marketing Operations service error

I'm receiving this error in my Sitecore 9.1 Azure Marketing Operations service. FYI my xCollect service is pointing to MongoDB instance so I have enabled sc.Xdb.Collection.Data.MongoDb.xml in ...