Questions tagged [paas]

Questions relating to using the Platform-as-a-Service deployment model for Sitecore.

32 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
4
votes
0answers
53 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
4
votes
0answers
139 views

Log Sitecore errors as exceptions instead of trace in application insights

By default, Sitecore application insights config logs Sitecore errors as traces instead of exceptions this means application insights dashboard and alerts are unaware of the exception occurring in a ...
3
votes
0answers
145 views

Installation issue on migration 9.1.1

I am trying to migrate a Sitecore 9.0.2 to 9.1.1. Following the upgrade guide https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/91/Sitecore_Experience_Platform_91_Update1.aspx, I have to ...
3
votes
0answers
41 views

Azure Geo-Redundant for CM, CD, and Analytics

Is anyone aware of documentation or support for running Sitecore 9.0.2 in Azure PaaS in a Geo-Redundant way for all services. I know I could put CD in two Regions with publishing targets but not sure ...
2
votes
1answer
44 views

Load balancing with Azure PaaS on CD

We have a Sitecore 9.2 setup using the S3 profile for the CD with 3 instances scaled out manually. I'm pretty new to managing the PaaS environment, and I'm trying to figure out if the traffic is load-...
2
votes
0answers
415 views

Sitecore Identity Server failing to access CM

I have an environment running in Azure PaaS using Sitecore 9.1 (initial release), and after a while I couldn't sign in to the CM anymore. I decide to restart the App Service, and once SI back up, the ...
2
votes
0answers
252 views

How to fix 500 error in Sitecore ribbon on first Experience Editor / Preview mode load

Every time I deploy to the Azure App Service, the first load of preview or edit mode takes extremely long to load and when the page does become visible, a 500 error becomes visible where the Sitecore ...
2
votes
0answers
324 views

Sitecore-Core-Index rebuild at Azure Search for Sitecore 9.0.1 PaaS fails

I have deployed Sitecore 9.0.1 XP Scaled in Azure PaaS (default, no customization). It is used self-signed certificate and configured with allowInvalidClientCertificates="true" in azuredeploy....
1
vote
0answers
40 views

Sitecore shared fields getting cleared after deployment to other environments

Sitecore 9.0 shared fields data was getting cleared after deployment in few environments including Production. In Pre production, the content is not cleared but can find this issue happening in lower ...
1
vote
0answers
72 views

Azure search Synonyms implementation using SXA 1.9 and Sitecore 9.2 using postman API

I have requirement to work with the synonyms for the similar group of words in search. I did load the synonyms using Postman API to SXA web index and able to see them on the index. For example: home,...
1
vote
0answers
87 views

Sitecore Paas installation failure - AppGallery Deploy Failed: The declared parameter 'Application Path' is not recognized

We are trying to create Sitecore 9.2 instance in azure PaaS using ARM templates. The ARM templates worked fine. Now we have modified the ARM templates to install the JSS module with Sitecore while ...
1
vote
0answers
112 views

SolrCloud on Azure PaaS

I am setting up a Sitecore 9.2 Production instance and ideally would like to Setup SolrCloud in Azure PaaS Web Apps. In test environments i have setup Solr on a single PaaS App Service and it is ...
1
vote
0answers
162 views

Clean install on Azure SQL Managed instance

I am trying to install Sitecore 9.2 vanilla on Azure with SQL Managed Instance but I am getting the following error { "status": "failed", "error": { "code": "ResourceDeploymentFailure", "...
1
vote
0answers
55 views

How can I add a new QA environment to existing Sitecore Azure Paas setup?

We have an existing Sitecore 9 setup in Azure Paas. It includes one CD and one CM server with no xDB. Now we're looking to add a new QA environment which will effectively be a copy of CM with its own ...
1
vote
2answers
51 views

Azure Deploy of CM + Reporting

I'd like to build a deployment of CM and Reporting in a single App Service. Is the best approach to take the XP0 files and try to remove what isn't needed ? Or try and combine The CM and Reporting ...
1
vote
0answers
67 views

Publishing Service in Azure Web App Won't Update Schema

I am using Sitecore 8.2 Update 7 Web Apps and created an empty Web App. Following these instructions to deploy the Publishing Service, everything has worked except for the schema upgrade: http://www....
1
vote
0answers
153 views

NullReferenceException while setting up ApplicationInsights with Sitecore 9.1 PaaS

We are following post below for the steps to configure ApplicationInsights and also have applied the patch as specified in the article. After setting things we are getting a NullReferenceException (...
1
vote
0answers
130 views

Sitecore.Shell.Applications.Analytics.TrackingField.TrackingFieldDetailsPage throws exception

We are using Sitecore 9.0.2 in PAAS and in specific environment we are getting error on OOB tracking field on all the pages We don't have Sitecore XDb in scope and XDb is not enabled. [...
0
votes
0answers
28 views

How to setup one common CMS and two CD server in different region in Azure Pass Architecture?

Currently we have scaled environment setup on Azure Pass i:e one CM and one CD server in common region. Now we have created one more site but its for another region and due to compliance policy we can'...
0
votes
0answers
23 views

Sitecore SaaS Migration to Sitecore PaaS on Azure

I would like to move my current Sitecore SaaS to Sitecore PaaS on Azure. If anyone can provide guidelines or documents on the steps process that will be really helpful.
0
votes
0answers
21 views

Invalid template when adding modules to azuredeploy.parameters.json file

I am using the provided ARM Templates to deploy a Sitecore 9.3 XP Scaled topology to Azure PaaS, and then planning to add some adjustments. It all went mostly fine, but I'm stuck now when I tried to ...
0
votes
0answers
45 views

Sitecore TDS Webdeploy in Azure PAAS

I am facing issues in Deploying TDS Webdeploy Package to Azure PAAS. I'm using Sitecore 9.3, TDS.6.0.0.14 We are getting an error on TDS service Msg From Kudu --> "WARN Request is ...
0
votes
1answer
30 views

Sitecore Item URL with Custom Domain in Azure PaaS

I have Sitecore 8.2 update 5 site deployed in Azure PaaS as an App Service. I have created a custom domain (e.g. abc.com) in the App Service. This custom domain is kept behind F5 firewall. I am facing ...
0
votes
0answers
38 views

Sitecore LaunchPad is distorted after deploying Web Application on Azure PaaS

I have deployed our application on Azure Pass. I am able to login in to the Sitecore CMS and redirected on the LaunchPad. LaunchPad CSS is distorted and click is not working. Also there are lot of ...
0
votes
0answers
26 views

Using Seq with Sitecore PaaS

We are running 9.3 in an app service in Azure. We have found a number of articles stating different things about logging in SC. Some say it's log4net, others say Serilog... Since we cannot get to ...
0
votes
0answers
28 views

Sitecore Azure PaaS ARM templates doesnt support template idempotence

We are using ARM templates to install Sitecore 9.2.0 XP Scaled topology for our infrastructure. While using these templates, we observed that these templates are not idempotent in nature. We needed to ...
0
votes
0answers
40 views

Sitecore Azure PaaS webapp becomes unresponsive when Unicorn files copied

We are using Unicorn to sync Sitecore items between different Sitecore instances. We have created a separate Azure DevOps release pipeline dedicated only for copying Unicorn files and running the sync ...
0
votes
0answers
126 views

Unicorn error on Azure Paas

We have been deploying our Sitecore 9.0.1 to Azure Paas, deploying each time to a clean slot. On the last deploy Unicorn synch stopped working, we are even unable to open the Unicorn.aspx page. ...
0
votes
0answers
20 views

Sitecore Azure Paas Media files not appearing

I have installed fresh new Sitecore Azure Paas (Sitecore 9 update 2). Created a Sitecore packages from my local to the new instance to migrate all the content, media, system and templates. Everything ...
0
votes
0answers
174 views

Sitecore PAAS Installation failure

We are trying to install Sitecore 9.0.2 XP rev. 180604 on Azure and we are getting error: ERROR_SQL_EXECUTION_FAILURE. Any inputs would be helpful. New-AzureRmResourceGroupDeployment : 12:31:16 PM -...
0
votes
2answers
250 views

Identity Server not redirecting to Azure Frontdoor URL

We are implementing URL hardening in Azure PaaS. We have added Azure front door urls to CM app. We have updated Sitecore.Owin.Authentication.IdentityServer.config on CM server with new url for ...
-1
votes
1answer
221 views

Cache cleared message every second in Azure Logs

We are trying to figure our an issue where our LIVE sites are getting down for 10 minutes everyday. While going through the Azure logs I am getting the following Warning: WARN web[standardValues] ...