Questions tagged [paas]

Questions relating to using the Platform-as-a-Service deployment model for Sitecore.

31 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
5
votes
0answers
300 views

Log Sitecore errors as exceptions instead of trace in application insights

By default, Sitecore application insights config logs Sitecore errors as traces instead of exceptions this means application insights dashboard and alerts are unaware of the exception occurring in a ...
4
votes
1answer
125 views

SQL Replication doesn't clear CD caches on remote target

We have a multi-cd publishing situation I can use some help with. We are in an Azure PAAS situation, with the CM and 1 CD server located in the US. We also have a CD Server and SQL database in China (...
4
votes
0answers
90 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
3
votes
0answers
167 views

Installation issue on migration 9.1.1

I am trying to migrate a Sitecore 9.0.2 to 9.1.1. Following the upgrade guide https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/91/Sitecore_Experience_Platform_91_Update1.aspx, I have to ...
3
votes
0answers
43 views

Azure Geo-Redundant for CM, CD, and Analytics

Is anyone aware of documentation or support for running Sitecore 9.0.2 in Azure PaaS in a Geo-Redundant way for all services. I know I could put CD in two Regions with publishing targets but not sure ...
2
votes
0answers
81 views

Sitecore shared fields getting cleared after deployment to other environments

Sitecore 9.0 shared fields data was getting cleared after deployment in few environments including Production. In Pre production, the content is not cleared but can find this issue happening in lower ...
2
votes
0answers
678 views

Sitecore Identity Server failing to access CM

I have an environment running in Azure PaaS using Sitecore 9.1 (initial release), and after a while I couldn't sign in to the CM anymore. I decide to restart the App Service, and once SI back up, the ...
2
votes
0answers
490 views

How to fix 500 error in Sitecore ribbon on first Experience Editor / Preview mode load

Every time I deploy to the Azure App Service, the first load of preview or edit mode takes extremely long to load and when the page does become visible, a 500 error becomes visible where the Sitecore ...
2
votes
0answers
346 views

Sitecore-Core-Index rebuild at Azure Search for Sitecore 9.0.1 PaaS fails

I have deployed Sitecore 9.0.1 XP Scaled in Azure PaaS (default, no customization). It is used self-signed certificate and configured with allowInvalidClientCertificates="true" in azuredeploy....
1
vote
0answers
24 views

Sitecore 9.0.2 and Azure PaaS based live website gives '502' error few times in a day

We have our public website in Sitecore 9.0.2 and it is in Azure PaaS infrastructure, from last few days the website gives '502 following error message' at specific times in a day(8 (am or pm), 9(am or ...
1
vote
0answers
63 views

Files not found on Azure Paas

We have a solution installed on Azure Paas. In the logs we have next errors: Exception: System.IO.FileNotFoundException Message: Could not find file 'D:\home\site\wwwroot\sitecore\shell\client\...
1
vote
0answers
204 views

Sitecore login redirects to website and not Launchpad

We are using azure alias URL "https://abc.com/sitecore/login" to access our prod CM site "https://abc-1001-cm.azurewebsites.net/sitecore/login". Earlier we had Sitecore 9.0.1 ...
1
vote
0answers
99 views

Invalid template when adding modules to azuredeploy.parameters.json file

I am using the provided ARM Templates to deploy a Sitecore 9.3 XP Scaled topology to Azure PaaS, and then planning to add some adjustments. It all went mostly fine, but I'm stuck now when I tried to ...
1
vote
0answers
134 views

Azure search Synonyms implementation using SXA 1.9 and Sitecore 9.2 using postman API

I have requirement to work with the synonyms for the similar group of words in search. I did load the synonyms using Postman API to SXA web index and able to see them on the index. For example: home,...
1
vote
0answers
124 views

Sitecore Paas installation failure - AppGallery Deploy Failed: The declared parameter 'Application Path' is not recognized

We are trying to create Sitecore 9.2 instance in azure PaaS using ARM templates. The ARM templates worked fine. Now we have modified the ARM templates to install the JSS module with Sitecore while ...
1
vote
1answer
496 views

SolrCloud on Azure PaaS

I am setting up a Sitecore 9.2 Production instance and ideally would like to Setup SolrCloud in Azure PaaS Web Apps. In test environments i have setup Solr on a single PaaS App Service and it is ...
1
vote
0answers
360 views

Clean install on Azure SQL Managed instance

I am trying to install Sitecore 9.2 vanilla on Azure with SQL Managed Instance but I am getting the following error { "status": "failed", "error": { "code": "ResourceDeploymentFailure", "...
1
vote
0answers
70 views

How can I add a new QA environment to existing Sitecore Azure Paas setup?

We have an existing Sitecore 9 setup in Azure Paas. It includes one CD and one CM server with no xDB. Now we're looking to add a new QA environment which will effectively be a copy of CM with its own ...
1
vote
0answers
128 views

Publishing Service in Azure Web App Won't Update Schema

I am using Sitecore 8.2 Update 7 Web Apps and created an empty Web App. Following these instructions to deploy the Publishing Service, everything has worked except for the schema upgrade: http://www....
1
vote
0answers
324 views

NullReferenceException while setting up ApplicationInsights with Sitecore 9.1 PaaS

We are following post below for the steps to configure ApplicationInsights and also have applied the patch as specified in the article. After setting things we are getting a NullReferenceException (...
1
vote
0answers
263 views

Sitecore.Shell.Applications.Analytics.TrackingField.TrackingFieldDetailsPage throws exception

We are using Sitecore 9.0.2 in PAAS and in specific environment we are getting error on OOB tracking field on all the pages We don't have Sitecore XDb in scope and XDb is not enabled. [...
0
votes
1answer
71 views

Sitecore PaaS Web DB spikes

We’ve just migrated from Sitecore 8.2.5 on-prem to 9.3 Azure PaaS. Performance seems ok most of the time, but we’re seeing regular spikes to 100% DTU on the web db. The db is standard S2 50 DTU and we’...
0
votes
0answers
61 views

How to setup one common CMS and two CD server in different region in Azure Pass Architecture?

Currently we have scaled environment setup on Azure Pass i:e one CM and one CD server in common region. Now we have created one more site but its for another region and due to compliance policy we can'...
0
votes
0answers
103 views

Sitecore LaunchPad is distorted after deploying Web Application on Azure PaaS

I have deployed our application on Azure Pass. I am able to login into the Sitecore CMS and be redirected to the LaunchPad. LaunchPad CSS is distorted and the click is not working. Also, there are a ...
0
votes
1answer
842 views

Identity Server not redirecting to Azure Frontdoor URL

We are implementing URL hardening in Azure PaaS. We have added Azure front door urls to CM app. We have updated Sitecore.Owin.Authentication.IdentityServer.config on CM server with new url for ...
0
votes
0answers
48 views

Sitecore Azure PaaS ARM templates doesnt support template idempotence

We are using ARM templates to install Sitecore 9.2.0 XP Scaled topology for our infrastructure. While using these templates, we observed that these templates are not idempotent in nature. We needed to ...
0
votes
0answers
70 views

Sitecore Azure PaaS webapp becomes unresponsive when Unicorn files copied

We are using Unicorn to sync Sitecore items between different Sitecore instances. We have created a separate Azure DevOps release pipeline dedicated only for copying Unicorn files and running the sync ...
0
votes
0answers
159 views

Unicorn error on Azure Paas

We have been deploying our Sitecore 9.0.1 to Azure Paas, deploying each time to a clean slot. On the last deploy Unicorn synch stopped working, we are even unable to open the Unicorn.aspx page. ...
0
votes
0answers
31 views

Sitecore Azure Paas Media files not appearing

I have installed fresh new Sitecore Azure Paas (Sitecore 9 update 2). Created a Sitecore packages from my local to the new instance to migrate all the content, media, system and templates. Everything ...
0
votes
0answers
197 views

Sitecore PAAS Installation failure

We are trying to install Sitecore 9.0.2 XP rev. 180604 on Azure and we are getting error: ERROR_SQL_EXECUTION_FAILURE. Any inputs would be helpful. New-AzureRmResourceGroupDeployment : 12:31:16 PM -...
-1
votes
1answer
486 views

Cache cleared message every second in Azure Logs

We are trying to figure our an issue where our LIVE sites are getting down for 10 minutes everyday. While going through the Azure logs I am getting the following Warning: WARN web[standardValues] ...