Questions tagged [presentation]

Questions related to Sitecore presentation components: layouts, sublayouts, renderings, presentation details, etc.

Filter by
Sorted by
Tagged with
0
votes
0answers
9 views

Unable to retrieve rendering parameter in controller

I have a legacy MVC action I'm trying to enhance for some limited number of cases. The solution I'm working on uses rendering parameters to impact the behavior of the control. To demonstrate the ...
0
votes
0answers
15 views

Template id not getting set using glassmapper _sitecoreContext.GetCurrentItem

I have an item item1 in sitecore with redering rendering1 in its presentation details. The rendering rendering1 has its datasource and is a controller rendering. The datasource of the rendering one ...
1
vote
2answers
56 views

Component re-render or ad hoc personalization rule verification

We have a personalization rule that depends on two values that are changeable by end-users on a page, using two dropdowns. The personalization rule works fine on a page load (we know which values are ...
1
vote
0answers
40 views

Rendering Variants for non SXA Sitecore site?

I'm creating some new standard Sitecore components and really like how the rendering variants are used in SXA to differentiate between different component variations. Has anyone implemented anything ...
2
votes
2answers
54 views

Does Sitecore SXA supports personalization between rendering variants?

I have come across the situation where we want to implement personalization between the rendering variants for a given rendering. I know we can do the personalization between the renderings but I'm ...
1
vote
2answers
47 views

Put Sitecore component on page based on QueryString

We have a Sitecore component that displays a list of blog posts. Part of this component is a placeholder where a "Featured Blog Post" component may be placed by editors manually. The "Featured Blog ...
2
votes
1answer
41 views

@Html.Sitecore().Rendering does not rendering view even after executing without any errors

I am trying to use @Html.Sitecore().Rendering("--id--", Model.Property) to call render a staic view. It is not rendering on page. Layout: @Html.Sitecore().Rendering("--Myviewid--", Model) Myview: @...
1
vote
0answers
27 views

What would cause a rendering to not show in preview mode for non-admins?

I have a rendering that shows fine for admin users but doesn't display for non-admins in preview mode. This happens on our production server but on our development server the rendering displays fine ...
2
votes
0answers
42 views

Personalization Rules are not working as intended

i've a Sitecore 9.1.1 website on a Windows server2016 with IIS 10. I've enabled the xDb features but the "Personalize" button in the rendering details section is not available. I've seen that the ...
0
votes
1answer
33 views

Is it possible to get page content dynamically (Not HTML but field values which are displayed on the page)?

Is it possible to get the few renderings' (present on the page) contents dynamically, but the catch is like I don't want HTML instead I want the field values which are used to be displayed on the page....
0
votes
1answer
25 views

Retrieving items from a multiselect Rendering Parameter

I'm trying to retrieve items via a multiselect rendering parameter. It parses the rendering parameter correctly but even though it doesn't throw an error when adding a new item to the model, when it ...
-1
votes
1answer
21 views

How to give few rendering's data in custom API response

Hi please see the picture below, so that I can tell you the requirement. Now, I have a requirement as, if I see page-1 there is content on this page which is coming from following renderings: Header, ...
0
votes
1answer
40 views

Need to display multiple renderings in a Tab view

I am using Sitecore 9 and I need to display 5 controller renderings in a Tabbed view. I looked at the article: How to show three different Tabs rendering by using Sitecore in ASP.NET MVC But could ...
0
votes
1answer
31 views

Layout/presentation details and language fallback

I'm working on a multilingual Sitecore site. We currently have everything set up in English (/en); but are adding other cultures and languages (en-CA, es-MX, fr-CA, etc.). I've setup the languages to ...
1
vote
1answer
34 views

SXA placeholder settings not limiting renderings

I've added a placeholder to a rendering variant. When I use that variant on a page, I click on the add item button, and I get the default window with all renderings available. I have then added a ...
1
vote
2answers
32 views

Blank Page is displaying while running particular content item

One specific content item is not rendering, showing blank page. When we check log found below exception: Exception: System.InvalidOperationException Message: The Sitecore.Client.ContentDatabase ...
2
votes
0answers
51 views

Page Cannot Be deleted because of specific renderings

A very specific scenario where the components on a page are causing exception while trying to delete the page. To reproduce : Two components are needed A simple component which uses a datasource (...
0
votes
0answers
24 views

Sitecore making adaptive design as mobile friendly

I have a scenario where i need to make my site mobile friendly compliance . When i tested this with URL https://search.google.com/test/mobile-friendly , it always go to desktop layout so reports as ...
1
vote
1answer
57 views

How can I copy personalization rules to a rendering in Sitecore Powershell?

I'm copying a rendering from one item to another using Sitecore Powershell Extensions. All is working well, except that the personalization rules for the rendering aren't copied over. I can get/set ...
1
vote
1answer
73 views

What are differences between server side rendering and client side rendering in JSS?

Please illuminate main differences between server side rendering and client side rendering for JSS app? Is server side rendering only required for things which are tightly couple with Sitecore like ...
0
votes
1answer
44 views

Update Sitecore rendered links for a specific page

We are using Sitecore 9.0.2 & SXA 1.7.1 and we need to update all links to be absolute only in a specific page as by default all the links are relative for example this is default link <a ...
0
votes
1answer
97 views

Read URL from Rendering Parameter General Link in Sitecore 9

I have used general Link as rendering parameter . How I can extract URL in c#. For Single line text I am using below piece of code. var renderingModel = Sitecore.Mvc.Presentation.RenderingContext....
0
votes
1answer
22 views

Does anybody encounter a data discrepancy between Final Layout in Presentation Details and Final Renderings in Layout section?

Here's the scenario: Component ID is in use as a Datasource in both in Final and Shared Layouts in the Presentation Details but upon checking the raw values, it can only be found in the Renderings [...
1
vote
0answers
66 views

Programmatically add a placeholder including its rendering hierarchy

I am creating a custom placeholder, that always renders the contents of a placeholder on a specific Sitecore item, no matter what page the custom placeholder is added to. I have been using this blot ...
1
vote
2answers
66 views

How to get Rendering from RenderingReference

We are using Sitecore 9.1 MVC. It is possible to get all rendering references for a given item by using: item.Visualization.GetRenderings(Sitecore.Context.Device, true) However, this will give me ...
0
votes
1answer
137 views

How to read Data source field value in view rendering

There is a Controller rendering and in its Data source field, I gave the path of the datasource item. [ The datasource item's path is set in the rendering itself and not in the presentation details. ...
0
votes
1answer
52 views

How can I limit a rendering variant to a partial design?

I'd like to limit a rendering variant so that it is only accessible on a certain partial design, is this possible? For some context, I'd like to add a variant of the promo component into my footer ...
7
votes
1answer
112 views

Knowing which rendering has a broken link

When looking at the broken links report or broken links in the bumper, sometimes it will reference a broken link in the Final Renderings. But no info is available to know which rendering is doing it. ...
2
votes
1answer
32 views

While viewing rendering attached to an item in Core DB, Sitecore is throwing server error

I am trying to access the details of a rendering attached to an item in the Core database, but Sitecore is throwing server error. Please refer to the attached screenshot.
3
votes
1answer
89 views

Pattern for multiple renderings calling same service

Scenario A page contains several separate renderings. Each rendering displays some data which is returned from a remote service. Several of these data items come from the same remote service. This ...
2
votes
1answer
43 views

Renderings on Page Design not visible

Environment: Sitecore 9.0.2 + SXA 1.8.0 What I have done: I have a 'partial design' P1. I applied this P1 to a 'page design' PD1. On this 'page design' PD1, I applied a few renderings. This 'page ...
0
votes
2answers
134 views

Dynamically change the rendering datasource without updating the item

I am trying to set a data source during runtime without updating the item in rendering, but am not able to achieve it. I tried the below approach, but that is updating the rendering data source, I ...
0
votes
0answers
45 views

Creating custom composite rendering from Content Editor with minimal visual studio

SITECORE 9.0.2 + SXA 1.7.1 What i am trying to build: I am trying to create an index/table of contents like this. I can have the links pointing to the pages from 'Page List' rendering and a rich ...
2
votes
2answers
46 views

How do I assign the same Conditional Rendering Rules to Multiple Components?

How could a Content Author copy a Conditional Rendering Rule from one component, to many others? I think the best solution would be to set the Conditional Rendering Rule on the Data Template of the ...
3
votes
4answers
381 views

Detect if page is on experience editor Sitecore 9 via Javascript?

Ok, i see many examples of this online but none seems to work, maybe those examples are for older Sitecore. I simply want to detect if the user is on regular site view or if they are on experience ...
2
votes
1answer
49 views

SXA feature specific style option is missing for cloned rendering

Environment: Sitecore 9.0.2 + SXA 1.7.1 What i have done: I cloned the default 'Navigation rendering' as 'Global Header'. I have added it to under 'Navigation' under available renderings. Under '...
0
votes
0answers
40 views

DisplayName set to “__Standard Value” on Renderings

I have a very strange issue in this Solution I'm working on 8.* that all Renderings suddenly have "__Standard Values" as Displayname and I can't get rid of it. And some of them also have EN & DK ...
0
votes
0answers
54 views

SXA Browser Title not working in Chinese

We have an SXA site in the Chinese Language, however we are unable to render the Browser Title in any of the pages. This is working for other language sites except Chinese. Following investigations ...
0
votes
2answers
197 views

Get inner value of the rendering parameter

For the rendering parameters, I have a droplist which consists of the friendly name of the CSS-class which further consists of a value field for the actual CSS-class. In my view when I try to ...
0
votes
0answers
32 views

Presentation changes due to base partial design

Environment: Sitecore 9.0.2 + SXA 1.7.1 Steps to reproduce: I create a partial design 'MasterPartial' and applied a column splitter on it. I used the 'MasterPartial' as base partial design for ...
0
votes
1answer
40 views

Duplicate icons on column splitter in partial rendering

Environemnt details: Sitecore 9.0.2 + SXA 1.7.1 What is happening: The options to modify the presentation are coming twice, as can be seen in the image below. On hovering over the icons, message is ...
0
votes
0answers
32 views

SXA style option for custom rendering [duplicate]

What I have done: I have a new rendering by cloning. I created a component on the basis of a new template created by cloning. On a new partial rendering, I added the newly created rendering and ...
0
votes
1answer
65 views

SXA Issue displaying fields with new rendering

Environment details: Sitecore 9.0.2 + SXA 1.7.1 What I have done till now: I followed the steps provided at https://doc.sitecore.com/developers/sxa/17/sitecore-experience-accelerator/en/copy-and-...
1
vote
1answer
29 views

Equals sign (=) added after valueless query string parameters

When rendering an external link from a General Link field using the Glass Mapper BeginRenderLink helper, any query string parameters without values are getting an equals sign (=) added after them. An ...
1
vote
1answer
75 views

Dynamically Generated Rendering not displaying in experience editor in SXA Multi Tenant Solution [closed]

When working with with SXA inside of a multi-tenant solution, we are building a component to generate an HTML sitemap. We have implemented a recursive function to generate the html sitemap ...
1
vote
1answer
138 views

Placeholder setting for partial designs

I was creating a page similar to the image below with SXA 1.7.1 in Sitecore 9.0.2 In my situation, I have the 'translation section', 'Videos' and 'The Weeknd' to be reusable. Search results can be ...
1
vote
1answer
553 views

Sitecore broken links reports - how to find wrong component

I have a message about a broken link at final layout at some page item on my Sitecore 8.2 instance. I ran a Scan for broken link report and find a record about this page item. The report shows an ...
0
votes
2answers
176 views

Checking for a checkbox rendering parameter value in view

I have a view that works fine to display rendering parameters for a title and body of a widget, however, I've added a checkbox field to the rendering items for that template and when I try to use it ...
0
votes
1answer
51 views

Missing Files When Duplicating Rendering

I'm able to create modules and duplicate renderings without any problems when on my local Sitecore 9.1 / SXA 1.8 build, but whenever I am facing issues when trying to do the same process when using ...
2
votes
0answers
34 views

Few of the URLs working by placing (.) dot in the end of URL in Sitecore based website

A few of our website URLs are displaying blank pages. However when we append . at the end of the URL, it renders the page correctly. We're not sure how/why a majority of pages are working fine but a ...