Skip to main content

Questions tagged [processing]

For questions related to Sitecore's Processing which refers to the analysis of collected data, and is performed by Processing servers. This activities include interaction aggregation, contact processing, processing agents, batch aggregation. Questions are also related to including the process, functionality, architecture, server-role, etc.

Filter by
Sorted by
Tagged with
0 votes
1 answer
50 views

No Condition definition item could be found for Id

We are seeing a odd issue in our prod environment after a 10.3 upgrade. The processing website keeps throwing A LOT of these errors. ERROR [Experience Analytics]: RulesValidator failed to process ...
ToddB's user avatar
  • 619
1 vote
1 answer
99 views

Failed to start the Processing Engine service - Sitecore 9.3 - [closed]

The Processing Engine Service is failing to start either manually or through the service task. I am getting the below error message in the log file: 023-11-08 14:11:41.489 -06:00 [Error] Failed to ...
Joel Gil's user avatar
0 votes
2 answers
145 views

Sitecore Processing Server log shows "Could not find configuration node: contentSearch/configuration"

In Sitecore (9.1) processing server's logs, I could see the following error: Exception: System.Reflection.TargetInvocationException Message: Exception has been thrown by the target of an invocation. ...
GVK's user avatar
  • 101
1 vote
1 answer
51 views

xdbprocessing role not starting. throwing error for requested document not found

We set up xdbprocessing role on Sitecore 10.2 using SIF install on a new server. It's a scaled environment. We used Sitecore-XP1-prc.json to setup Sitecore 10.2.0 rev. 006766 (OnPrem)_prc.scwdp.zip. ...
NetizenHarry's user avatar
1 vote
1 answer
119 views

Sitecore 10 Solr Indexing only on processing server

Our Sitecore CM has a huge amount of content data and whenever running the index from the control panel it's become a huge load on our Sitecore instance and took a couple of hours. So, we want to ...
D S's user avatar
  • 264
-2 votes
2 answers
264 views

how do we configure processing server in sitecore 9.3 [closed]

I know below link but if any link for sitecore 9.3 version? https://doc.sitecore.com/developers/82/sitecore-experience-platform/en/configure-a-processing-server.html
user7749's user avatar
1 vote
1 answer
453 views

What are the expected behaviors for the xConnect Pools Databases?

I am looking at the xdb pools database on a 9.0.1 instance. I see 3 tables with data in them: GenericProcessingPools GenericProcessingPoolDefinitions InteractionLiveProcessingPool The ...
Bic's user avatar
  • 560
1 vote
0 answers
48 views

sitecore 9.1 Xp1 Scaled (on premise ) Processing server throws error

I have installed xp1 scaled topology on-premise successfully and I see cm analytics default data displayed all 0. I have a dedicated Reporting and Processing server, whenever I browse prc app I see ...
Avinash J's user avatar
  • 313
0 votes
0 answers
122 views

Custom Processing Engine Service Not Working

I'm trying to implement a test Processing Engine service to get started with Sitecore Cortex and ML.NET -> https://www.brimit.com/blog/dive-sitecore-cortex-machine-learning-introduction. Issue: I've ...
LinkedListT's user avatar
1 vote
2 answers
1k views

MediaCreator.CreateFromStream creates an item with the template "File"

I'm using Sitecore.Resources.Media.MediaCreatorOptions and Sitecore.Resources.Media.MediaCreator to programmatically create media items. I've set the MediaCreatorOptions.FileBased property to false ...
Iceape's user avatar
  • 617
0 votes
1 answer
1k views

Why my Sitecore 9.1 instance started to complain about missing xdb.processing.pools and xdb.processing.tasks connection strings?

My Sitecore 9.1 XP1 Scaled dev instance started to spam the following exceptions in its log, related to the xdb.processing.pools and xdb.processing.tasks connection strings: 23372 12:47:01 ERROR ...
Emanuele Ciriachi's user avatar
4 votes
2 answers
882 views

What is the proper troubleshooting technique for a "No known predicate type could be determined" error message?

As the question title suggests, I am looking for proper troubleshooting techniques in order to solve an error currently being experienced in a Sitecore 9.0.2 XP1 Topology Processing Role Server. The ...
Pete Navarra's user avatar
  • 14.7k
1 vote
2 answers
151 views

Configuration Processing server Sitecore 8.2 update 5

I am trying to configure the Processing server according this architecture. 2 server for CD, Reporting server and CM in the one single server and Processing in another server. I am configuring ...
MarielaP's user avatar
1 vote
3 answers
3k views

Sitecore 9 Processing Server - Exception when executing agent pathAnalyzer/mapRebuildStatusCheckerAgent

I am getting below error in Processing role. Our version is sitecore 9.0.2. Anyone faced similar issues? Exception: System.AggregateException Message: One or more errors occurred. Source: mscorlib ...
Ayyappan Krishnamoorthy's user avatar
10 votes
2 answers
3k views

XP Scaled (XP1) how to validate installed application in each server are correct?

I am trying to install Sitecore 9.1 in distributed (on premises) architecture, I have 4 servers: 1-cd 1-cm 1-solr 1-sql,reporting and processing I tweaked the script to install each separately ...
Avinash J's user avatar
  • 313
3 votes
1 answer
254 views

Sitecore 9 Reporting Database records are updating very slow

Problem: Sitecore analytics dashboard is updating very slow around (12 days delay) and old records are updating very slow (around 50 records per hours), on the dashboard Analysis So Far: Records are ...
Ashish Bansal's user avatar
0 votes
1 answer
112 views

Where can I put my custom pipeline to be executed right before Sitecore 8.2 Data Provider?

I have some external data to be populated before my External data provider is executed. Let say I have 2 functions call external data: GetAllItems() GetItem(string itemId) Those functions will ...
purnadika's user avatar
  • 367
0 votes
2 answers
664 views

Admin UI for PRC and REP roles not working on Azure PaaS on vanilla Sitecore 9

I have problem accessing admin UI on Processing and Reporting role on Sitecore 9. We use XP fully scaled environment deployed on Azure via 'Sitecore® Experience Cloud' from Azure Market place. After ...
Petr Havlak's user avatar
8 votes
2 answers
618 views

How to configure multiple processing servers

I followed two below documentation articles to create multiple dedicated processing servers for interaction aggregation: https://doc.sitecore.net/developers/server-role-configuration-reference/core-...
Duan Le's user avatar
  • 191
6 votes
1 answer
334 views

How to scale Processing/Aggregation server

We have managed to setup xDb in our production environment. Currently, we only setup a single instance of Processing/Aggregation server. We are planning to add another server as a processing/...
arseny's user avatar
  • 181
7 votes
1 answer
434 views

Processing server not populating segments table

We have an 8.1 update-2 processing instance configured as per documentation For some reason the segments tables are empty and even if I run the RedeployMarketingData admin page, nothing will be ...
Mark Lowe's user avatar
  • 1,056
1 vote
1 answer
245 views

Failed to create the agent 'processing/taskAgent'

We have a CM - CD setup. On the CD server an error is getting logged: Message: Failed to create the agent 'processing/taskAgent' Source: Sitecore.Kernel at Sitecore.Diagnostics.Assert.IsNotNull(...
Anil Kumar Mall's user avatar
4 votes
1 answer
506 views

xdb Aggregation / Processing background services

Where does sitecore xdb Aggregation / Processing background services run, will this run in worker process when sitecore app pool starts or as a windows services?
Siva Sankar Gurram's user avatar