Questions tagged [site-configuration]

For questions related to the configuration of sites, including site-definitions, SXA site configuration in the Content Editor, etc.

Filter by
Sorted by
Tagged with
0 votes
0 answers
239 views

Object reference not set to an instance of an object - Speak Layout

I recently made some changes inside the bin file, basically I needed to manually upload some dll files. Well, this made my environment get this error that I will show you. I also had to change the web....
  • 349
0 votes
0 answers
40 views

Is there a way to exclude certain placeholders from placeholder wrapper in Content Editor?

I know how to exclude placeholders in Sitecore.XA.Foundation.Grid.config file. but I also know that when I push my changes to another site (from dev to staging) that I also have to change that config ...
  • 349
0 votes
1 answer
59 views

Supress MediaRequestProtection errors at site level

I have a multisite setup in sitecore 9.1 and getting the below error on ERROR MediaRequestProtection: An invalid/missing hash value was encountered. The expected hash value I know the reason for ...
0 votes
1 answer
28 views

Trying to add publishing database for Unicorn Sync when building

So I have two CD servers setup and seems like our Unicorn syncing is not completely setup because in the config it currently just has "web". So I need to add our "web_uk" CD to ...
0 votes
1 answer
558 views

Where to see item cache or data cache is stored?

I have just enabled the below caches in web config file, now how to see the cache is storing in particular location or not ? If so which file or database table i have to check ? <setting name="...
0 votes
2 answers
185 views

IIS home page is getting loaded instead of sitecore 9.3 Home page

I am a newbie to Sitecore 9.3. I have integrated sitecore 9.3 and VS 2017 but i am not able to load the sitecore 9.3 home page, instead IIS Home page gets loaded up. Thanks in advance.
  • 311
0 votes
0 answers
69 views

Compilation Error after integrating VS2017 and Sitecore 9.3

I am newbie to 9.3, Installed and browsed the sitecore project. Tried to integrate with Visual project by adding reference file sitecore.kernel.dll, sitecore.client.dll, system.web.mvc and deleted ...
  • 1
2 votes
0 answers
92 views

Sitecore website as a subsite of an existing non-Sitecore website

We have two websites: the first one is non-Sitecore website (e.g. 'www.non-sitecore-site.com') the second one is Sitecore website (e.g. 'www.sitecore-site.com') My task is to make the second one (...
2 votes
1 answer
2k views

Should targetHostName and hostName be the same?

In our Sitecore 9 setup we are using a CD and CM server. Currently, we have these config transformations: <sites env:require="TestCM" xdt:Transform="Insert"> <site name="website"> ...
  • 884
0 votes
0 answers
161 views

Need to know the configuration files to be modified in CD server

I have installed Sitecore 9.1 XP scaled(XP1) topology using PowerShell script shared in installation guide. I have sitecore.cm, sitecore.cd and other app process installed (REP,PRC,etc). When i ...
  • 313
2 votes
1 answer
974 views

Logged user is always sitecore\Anonymous during processor in SC 9.1

I'm using Sitecore 9.1, thus an identity provider. I have a custom domain named aba and I'm logged in Sitecore Administration Console using an aba\hsantos user. Then I have this processor which is ...
  • 2,261
-1 votes
2 answers
2k views

Error: The type or namespace name 'MVC' does not exist in the namespace 'Sitecore' [closed]

I'm facing this issue in one of my testing instances: Sitecore 9.1.0 Inner Exception: c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\84f876eb\34615233\App_Web_events....
  • 2,261
3 votes
1 answer
2k views

How can I access the Sitecore 9 configuration values programmatically?

I'm trying to get this given node value from the Sitecore configuration (Sitecore 9 instance). My first approach was to read the configuration file on which this value is defined. Pretty standard... ...
  • 2,261
1 vote
1 answer
307 views

How to Update Sitedefinition.config Dynamically?

I am working on building a tool for multi-site implementation, right now when ever i am adding a new site i need to go and change the site definition file manually but i want to make it dynamically as ...
1 vote
0 answers
138 views

Why there is no OOTB LanguageDefinition for a Language which name is "en"?

I'm using a vanilla Sitecore 82u6. When checking the .showconfig.aspx page I realized that the default language name is: <setting name="ClientLanguage" value="en" patch:source="Sitecore....
  • 2,261
2 votes
2 answers
2k views

CD server throws "Unknown connection string. Name: 'master'"

I think I'm completely missing some step in my CD server deployment as I'm setting up my first XP Scaled environment in Azure and I'm facing the following issue with my CD server: Unknown ...
  • 159
1 vote
0 answers
407 views

404s and Sitecore login redirect to a different site in the Sitecore instance

Having an odd problem with a production instance. When I enter a page that doesn't exist, such as www.mysite.com/asdijdsiajdi, the typical Sitecore "Document Not Found" page appears, however the ...
  • 535
5 votes
1 answer
780 views

Sitecore Experience Accelerator (SXA) site won't render as a sub route where JSS app is the root app

We have a JSS app as our site root (e.g., mydomain.com/ renders my JSS app) and want a Sitecore Experience Accelerator (SXA) website as a sub-route of the same domain (e.g., mydomain.com/sxa-site). ...
  • 201
3 votes
1 answer
72 views

CacheSizes node vs cache settings in site definition

I'm setting up a bunch of site definitions for my project. I know I need to add them all to the publish:end and publish:end:remote events to clear caching. But when it comes to the entries in <...
  • 5,062
1 vote
2 answers
151 views

With regard to site definitions what is the default value of the enableTracking attribute?

This may seem like a really obvious question, but I just wanted to make sure as I couldn't find any documentation on this particular attribute. Within the site definitions <site> there is an ...
  • 1,079
3 votes
1 answer
2k views

Preview an unpublishable item

8.2 U5 If I move the go live date, in publish settings, out to the future for my item. And in preview mode move the date out also. I see the content fine. I consider it the poor mans unpublished item....
1 vote
1 answer
98 views

Is it possible/advisable to make the Sitecore CP accessible via sub-domain?

I want to know whether I can/should make /sitecore redirect to sitecore.mysite.com, and if so, how would I go about doing this? I've figured out how to set up sitecore.mysite.com, and even have the ...
  • 145
2 votes
3 answers
326 views

Sitecore Multidomain Similar Language possible?

We have implemented multisite & multilingual Sitecore implementation and now we are going to implement new website which will support 4 languages. Sitecore8.1 in use. Code base( VS solution) &...
  • 53
4 votes
1 answer
535 views

Sitecore IFrame rendering HTTP instead of HTTPS

My application is using HTTPS. The Sitecore sites configurations scheme are all set to HTTPS. When I'm on Sitecore Management some internal sitecore iframes (Insert Link, Template Editor, Package ...
0 votes
0 answers
451 views

Virtual folder setting is not working for multi lingual site

On Sitecore 7.2 (MVC) we are in process of introducing en-CA and fr-CA in our multi-site with multi-lingual project. Where we want to leverage the Virtual Folder concept. Like we want https://abcd.com/...
  • 361
2 votes
1 answer
3k views

SSL certificate requirements for Sitecore 9 Update 1

We have followed installation guide for Sitecore 9.0.1 and installed it on our dev machines. We have used the same approach also on TEST machine. This TEST machine is also standalone installation ...
1 vote
2 answers
2k views

Sitecore context returns Master instead of Web database

My Site configuration looks like this: <site name="sitename" patch:after="site[@name='web_module'] targetHostName="HostName" database="web" virtualFolder="/" ...
1 vote
1 answer
295 views

Minimum hard disk required for Sitecore Installation

Is there any minimum requirement of hard disk for Sitecore installation. I understand the database size will depend on the content but if the database is a separate server, for the CMS and CD part is ...
1 vote
2 answers
449 views

Is there a reason that I am not able to run my Sitecore 7.2 locally?

I have published to my File system: c:/Sites/intranet-local/Website I have created a website under Sites in IIS: pointing to the above. I received the following error: Cannot read configuration ...
4 votes
3 answers
1k views

Solr 6.6 / Sitecore 8.2 Content editor - Value cannot be null

I have read every post on here and every post I can find on this subject on google and I've tried all the tips / suggestions, but no joy. I'm attempting to setup a SOLR 6.6.0 with multiple cores / ...
  • 159
0 votes
1 answer
65 views

Few Queries to set up the separate Processing server on AWS

I have set up a separate processing/aggregation server following instruction - https://doc.sitecore.net/sitecore_experience_platform/82/setting_up_and_maintaining/xdb/configuring_servers/...
  • 235
2 votes
1 answer
282 views

Mystery domain being returned from Resolve Site Context

I get this kind of error in my logs. I have changed the domain changed for company privacy, but... The server's URL should be dev.example.com. But somehow Sitecore is returning www.exampledev....
3 votes
1 answer
157 views

Sitecore 7.2 Analytics DB records grown in size to 200 GB+

Sitecore 7.2 Analytics DB records has grown in size to 200 GB+. Does anyone know of any recommendation for purging old data and this is a production setup so the impact of this data being removed ...
  • 159
3 votes
2 answers
1k views

Could not find variants for component

I have created custom variant render called “Success Story”, I create custom variant to display the “description” only, however the view display “ Description field” with no value, when I look at ...
3 votes
1 answer
1k views

Dash ("-") in Media URLs

I've noticed that there are URL's that contain dashes, for example: https://www.bob.com.au/insurance/ski-quote/-/media/carol/Images/Logo/bob-logo-master.svg Specifically (if it isn't obvious), the ...
4 votes
2 answers
869 views

Patching custom pipeline parameters in project level config file

I have created a custom pipeline in a Foundation level Helix module. At the moment it has a single processor which can have multiple parameter configuration elements. In my project layer, I want to ...
0 votes
2 answers
2k views

Sitecore picking wrong site context

when I try to load my sitecore website homepage it shows me following error, where i see the default site context being picked is "scheduler" not "Website" which should be the default. <sites> ...
  • 397
3 votes
2 answers
1k views

Blank/Empty Page in sitecore 8.1 application

Using Sitecore 8.1 update 3 for our multilingual web application. Here all the items (using the same template, ex : Product template) are rendered as empty/blank page with no error message and don't ...
  • 582
1 vote
1 answer
2k views

Tracker.Current is not initialized + sitecore error [duplicate]

I have fresh installation of sitecore and have just added only one content into sitecore content tree. Whenever I click on presentation tab and try to preview "mypage" content "Tracker.Current is not ...
  • 159
10 votes
2 answers
576 views

Can v7 and v8 coexist on the same server

Can I (and if so how) setup SC 7 and SC 8 on the same server? I do all my dev work in a VM and I need access to both at various times of the day. It would really make my life easier on my laptop if I ...
  • 215
2 votes
0 answers
138 views

Getting Invalid object name 'diagnostics482413' error on deletion of any node in content tree

I am using Sitecore 8.1, while i am trying to delete any node in content tree then getting Invalid object name 'diagnostics482413' error. This error is getting on prod cms server, while the dev and qa ...
  • 521
7 votes
1 answer
3k views

Is there any way to add the custom Link manager provider just for a particular site

I am working with a multi-lingual multi site solution and I come across a case where I need to set a different link manager provider settings for only one of the sites in my solution. Is there a way ...
3 votes
1 answer
477 views

How do i configure CD Servers by removing unwanted config entries?

Once we are ready with CM server when deploying the files to CD server,what are all the config changes i should make? For example shell site(CM related) is not required in CD. Is there a list?
  • 1,059
1 vote
2 answers
2k views

Client caching and gzip settings not working

I am trying to optimize image, js, and css delivery by enabling gzip compression and setting the client cache policy. The issue is, it doesn't seem like any of the settings are being used. Here is the ...
  • 11
4 votes
1 answer
3k views

How to get correct site context in micro-site implementation in Sitecore 8.1

I have implement micro-site solution in Sitecore 8.1 as described in below post Set up microsites in Sitecore 8.1 but we are not getting correct site context for each individual micro-sites. ...
1 vote
1 answer
255 views

Sitecore 7.2 - Maintenance Mode setting

We will be doing some site updates and testing in relation to an update to our AMS system, and would like to put our live SC site in Maintenance Mode, a setting we see under the site settings, while ...
8 votes
2 answers
1k views

How to inhibit reaching other site content using domain of first site

I have 2 sites named Jack and Jill. Below is the site definition for each: name="Jack" hostName="jack.com|www.jack.com" enableTracking="true" virtualFolder="/" physicalFolder="/" rootPath="/...
2 votes
1 answer
617 views

Hostname not being retrieved for the website definition

I'm having a strange issue on Sitecore 8.2. I'm building an IEnuberable<SiteInfo> like this: sites = SiteManager.GetSites().Select(s => new SiteInfo(s.Properties)).ToList(); What's ...
  • 5,648
1 vote
0 answers
105 views

SSO between Sitecore and Custom MVC Application [closed]

We got a requirement of enabling Single sign on between a Sitecore Instance and another MVC Application. It would be helpful if someone can help me in getting a way to implement this? (Both of the ...
  • 143
0 votes
2 answers
3k views

Sitecore Upgrade from 8.0 to 8.1 issue: Required license is missing: Runtime

While upgrading sitecore 8.0 to 8.1. I have follow all the steps of upgrade guide. then i got the error "Required license is missing: Runtime". License file is the same as i have used in sitecore 8....