Questions tagged [site-configuration]

For questions related to the configuration of sites, including site-definitions, SXA site configuration in the Content Editor, etc.

Filter by
Sorted by
Tagged with
11
votes
3answers
6k views

Viewing the compiled Sitecore config on Content Delivery?

On Content Authoring servers, you can go to the control panel and view this page to see the compiled Sitecore config: /sitecore/admin/ShowConfig.aspx. It's also possible to do this via Sitecore Rocks....
10
votes
2answers
493 views

Can v7 and v8 coexist on the same server

Can I (and if so how) setup SC 7 and SC 8 on the same server? I do all my dev work in a VM and I need access to both at various times of the day. It would really make my life easier on my laptop if I ...
9
votes
3answers
2k views

How should I remove the default Home item?

I would like to delete the Home from master database. I can delete without any problem but I saw for example references in site configurations. Is there any other places where should I remove the ...
8
votes
2answers
962 views

How to inhibit reaching other site content using domain of first site

I have 2 sites named Jack and Jill. Below is the site definition for each: name="Jack" hostName="jack.com|www.jack.com" enableTracking="true" virtualFolder="/" physicalFolder="/" rootPath="/...
7
votes
1answer
2k views

Is there any way to add the custom Link manager provider just for a particular site

I am working with a multi-lingual multi site solution and I come across a case where I need to set a different link manager provider settings for only one of the sites in my solution. Is there a way ...
7
votes
1answer
160 views

Country selection page implementation

I want to design a page where a user is taken to once they land on the site for the first time and they can select their country/language there, which gets stored as a cookie. After, the user is ...
6
votes
2answers
298 views

What's the use of the publisher site?

does anyone know what's the use of the publisher site? I imagine it has to do with the publishing but I'm not really sure: <site name="publisher" domain="sitecore" enableAnalytics="false" ...
5
votes
1answer
347 views

Sitecore Experience Accelerator (SXA) site won't render as a sub route where JSS app is the root app

We have a JSS app as our site root (e.g., mydomain.com/ renders my JSS app) and want a Sitecore Experience Accelerator (SXA) website as a sub-route of the same domain (e.g., mydomain.com/sxa-site). ...
5
votes
1answer
747 views

Sitecore site configuration requireLogin not working

If I wanted to force users to go through a login for the entire site. I would previously add requireLogin and loginPage attributes to my site configuration. In 8.2 I am unable to do this. However in ...
5
votes
1answer
320 views

Sitecore IFrame rendering HTTP instead of HTTPS

My application is using HTTPS. The Sitecore sites configurations scheme are all set to HTTPS. When I'm on Sitecore Management some internal sitecore iframes (Insert Link, Template Editor, Package ...
4
votes
2answers
661 views

Patching custom pipeline parameters in project level config file

I have created a custom pipeline in a Foundation level Helix module. At the moment it has a single processor which can have multiple parameter configuration elements. In my project layer, I want to ...
4
votes
2answers
2k views

Obtaining a site url with correct binding port dynamically

I have a situation where I need to obtain a link to the item at my site to use it in an e-mail notification. I currently do it like this: var baseUrl = new Uri(Sitecore.Globals.ServerUrl);. This ...
4
votes
3answers
364 views

Language-specific sub-domain support

One of our clients is requiring that we use language-specific sub-domains instead of sub-folders on their multi-lingual site. They know all of the reasons why this shouldn't be done from an SEO ...
4
votes
1answer
2k views

How to get correct site context in micro-site implementation in Sitecore 8.1

I have implement micro-site solution in Sitecore 8.1 as described in below post Set up microsites in Sitecore 8.1 but we are not getting correct site context for each individual micro-sites. ...
4
votes
1answer
876 views

What is the optimum value (or range) for MaxWorkerThreads sitecore setting?

I believe that the default value for the MaxWorkerThreads is 20. In order to increase the number of concurrent user requests that can be processed, this needs to be increased from its default value. ...
4
votes
2answers
634 views

Solr 6.6 / Sitecore 8.2 Content editor - Value cannot be null

I have read every post on here and every post I can find on this subject on google and I've tried all the tips / suggestions, but no joy. I'm attempting to setup a SOLR 6.6.0 with multiple cores / ...
3
votes
1answer
1k views

Dash (“-”) in Media URLs

I've noticed that there are URL's that contain dashes, for example: https://www.bob.com.au/insurance/ski-quote/-/media/carol/Images/Logo/bob-logo-master.svg Specifically (if it isn't obvious), the ...
3
votes
1answer
410 views

How do i configure CD Servers by removing unwanted config entries?

Once we are ready with CM server when deploying the files to CD server,what are all the config changes i should make? For example shell site(CM related) is not required in CD. Is there a list?
3
votes
1answer
162 views

Item '/sitecore/media library' does not contain IntegrationConfigData field

I am getting several exceptions on the CMS Master server, such as the one shown below. ManagedPoolThread #17 2016:10:25 08:23:54 ERROR Synchronization context can not be created for "media library" ...
3
votes
1answer
110 views

Sitecore 7.2 Analytics DB records grown in size to 200 GB+

Sitecore 7.2 Analytics DB records has grown in size to 200 GB+. Does anyone know of any recommendation for purging old data and this is a production setup so the impact of this data being removed ...
3
votes
2answers
524 views

Blank/Empty Page in sitecore 8.1 application

Using Sitecore 8.1 update 3 for our multilingual web application. Here all the items (using the same template, ex : Product template) are rendered as empty/blank page with no error message and don't ...
3
votes
2answers
673 views

Could not find variants for component

I have created custom variant render called “Success Story”, I create custom variant to display the “description” only, however the view display “ Description field” with no value, when I look at ...
2
votes
1answer
464 views

Hostname not being retrieved for the website definition

I'm having a strange issue on Sitecore 8.2. I'm building an IEnuberable<SiteInfo> like this: sites = SiteManager.GetSites().Select(s => new SiteInfo(s.Properties)).ToList(); What's ...
2
votes
1answer
830 views

Preview an unpublishable item

8.2 U5 If I move the go live date, in publish settings, out to the future for my item. And in preview mode move the date out also. I see the content fine. I consider it the poor mans unpublished item....
2
votes
1answer
2k views

SSL certificate requirements for Sitecore 9 Update 1

We have followed installation guide for Sitecore 9.0.1 and installed it on our dev machines. We have used the same approach also on TEST machine. This TEST machine is also standalone installation ...
2
votes
2answers
776 views

Accessing Sitecore Login from each site in a multi-site setup fails (404 page not found) for only one site [closed]

We have a multi-site instance of Sitecore 8.2 and we have patched the <sites> section to include each site. This all seems fine and every site can be accessed by its unique domain/subdomain. ...
2
votes
3answers
221 views

Sitecore Multidomain Similar Language possible?

We have implemented multisite & multilingual Sitecore implementation and now we are going to implement new website which will support 4 languages. Sitecore8.1 in use. Code base( VS solution) &...
2
votes
2answers
627 views

Experience Editor stopped working after removing default Home node

I had removed the default home node, and created new home item. After this change, Experience Editor navigation stopped working(it is throwing "The layout for the requested document was not found" ...
2
votes
3answers
497 views

Site Definition XML Attributes for Database and Content

There are two attributes in the site definition config XML file that I would like to understand better. If your server (Production) has the content management web site set up separately from the ...
2
votes
1answer
157 views

Logged user is always sitecore\Anonymous during processor in SC 9.1

I'm using Sitecore 9.1, thus an identity provider. I have a custom domain named aba and I'm logged in Sitecore Administration Console using an aba\hsantos user. Then I have this processor which is ...
2
votes
1answer
43 views

CacheSizes node vs cache settings in site definition

I'm setting up a bunch of site definitions for my project. I know I need to add them all to the publish:end and publish:end:remote events to clear caching. But when it comes to the entries in <...
2
votes
1answer
183 views

Mystery domain being returned from Resolve Site Context

I get this kind of error in my logs. I have changed the domain changed for company privacy, but... The server's URL should be dev.example.com. But somehow Sitecore is returning www.exampledev....
2
votes
1answer
1k views

Sitecore Anti Csrf Cookie

We are using Web forms and would like to know if we could reuse/enable Sitecore's built in Anti CSRF token mechanism for the website instead of limiting it's scope to Sitecore itself.. I couldn't ...
2
votes
0answers
126 views

Getting Invalid object name 'diagnostics482413' error on deletion of any node in content tree

I am using Sitecore 8.1, while i am trying to delete any node in content tree then getting Invalid object name 'diagnostics482413' error. This error is getting on prod cms server, while the dev and qa ...
1
vote
2answers
399 views

Is there a reason that I am not able to run my Sitecore 7.2 locally?

I have published to my File system: c:/Sites/intranet-local/Website I have created a website under Sites in IIS: pointing to the above. I received the following error: Cannot read configuration ...
1
vote
2answers
1k views

Sitecore context returns Master instead of Web database

My Site configuration looks like this: <site name="sitename" patch:after="site[@name='web_module'] targetHostName="HostName" database="web" virtualFolder="/" ...
1
vote
1answer
206 views

Minimum hard disk required for Sitecore Installation

Is there any minimum requirement of hard disk for Sitecore installation. I understand the database size will depend on the content but if the database is a separate server, for the CMS and CD part is ...
1
vote
1answer
336 views

How can I access the Sitecore 9 configuration values programmatically?

I'm trying to get this given node value from the Sitecore configuration (Sitecore 9 instance). My first approach was to read the configuration file on which this value is defined. Pretty standard... ...
1
vote
2answers
945 views

CD server throws “Unknown connection string. Name: 'master'”

I think I'm completely missing some step in my CD server deployment as I'm setting up my first XP Scaled environment in Azure and I'm facing the following issue with my CD server: Unknown ...
1
vote
1answer
131 views

How to Update Sitedefinition.config Dynamically?

I am working on building a tool for multi-site implementation, right now when ever i am adding a new site i need to go and change the site definition file manually but i want to make it dynamically as ...
1
vote
2answers
73 views

With regard to site definitions what is the default value of the enableTracking attribute?

This may seem like a really obvious question, but I just wanted to make sure as I couldn't find any documentation on this particular attribute. Within the site definitions <site> there is an ...
1
vote
1answer
2k views

Tracker.Current is not initialized + sitecore error [duplicate]

I have fresh installation of sitecore and have just added only one content into sitecore content tree. Whenever I click on presentation tab and try to preview "mypage" content "Tracker.Current is not ...
1
vote
2answers
1k views

Client caching and gzip settings not working

I am trying to optimize image, js, and css delivery by enabling gzip compression and setting the client cache policy. The issue is, it doesn't seem like any of the settings are being used. Here is the ...
1
vote
1answer
3k views

Unable to get the correct `rootPath` from Sitecore.Context.Site

In my code, I'm trying to access the root path for the current site. Let's say I'm accessing my website http://mywebsite. Here is the site definition: <site patch:before="site[@name='website']"...
1
vote
1answer
203 views

Sitecore 7.2 - Maintenance Mode setting

We will be doing some site updates and testing in relation to an update to our AMS system, and would like to put our live SC site in Maintenance Mode, a setting we see under the site settings, while ...
1
vote
0answers
50 views

Why there is no OOTB LanguageDefinition for a Language which name is “en”?

I'm using a vanilla Sitecore 82u6. When checking the .showconfig.aspx page I realized that the default language name is: <setting name="ClientLanguage" value="en" patch:source="Sitecore....
1
vote
0answers
159 views

404s and Sitecore login redirect to a different site in the Sitecore instance

Having an odd problem with a production instance. When I enter a page that doesn't exist, such as www.mysite.com/asdijdsiajdi, the typical Sitecore "Document Not Found" page appears, however the ...
1
vote
1answer
70 views

Is it possible/advisable to make the Sitecore CP accessible via sub-domain?

I want to know whether I can/should make /sitecore redirect to sitecore.mysite.com, and if so, how would I go about doing this? I've figured out how to set up sitecore.mysite.com, and even have the ...
1
vote
0answers
97 views

SSO between Sitecore and Custom MVC Application [closed]

We got a requirement of enabling Single sign on between a Sitecore Instance and another MVC Application. It would be helpful if someone can help me in getting a way to implement this? (Both of the ...
0
votes
1answer
112 views

SiteDefinition Config Events - Site Changed to MyCompanyName

I noticed a strange difference between our Production and QA Sitecore websites that was deliberately done by our Sitecore vendor. In the SiteDefinition.config file, the site block is changed to ...