Questions tagged [sitecore-client]

For questions related to the Sitecore administrative interface - commonly referred to as Shell or Client - where authors and developers log in to create and manage content, analytics, permissions, etc.

Filter by
Sorted by
Tagged with
0
votes
1answer
31 views

Creating a Sitecore User with read only access to all the Sitecore items

How can I create a Sitecore user with read only access to all the sitecore items. I came across below sitecore link, but this required to assign the permissions by item wise. which takes time. so want ...
0
votes
1answer
17 views

Solr version compatibility with Sitecore 9.0.1

My team is planning to install Sitecore 9.0.1. We are using Solr 6.6.2 version at the moment. Due to some solr search issues we are planning to use solr 6.6.3. Is this Solr version compatible with ...
0
votes
0answers
34 views

How to show the subpages of a page using navigation rendering in Sitecore 9.0.1?

I am using Sitecore 9.0.1 with SXA 1.7 . I have created a partial design page in that i have added a Navigation component to my page and in the Page it is showing all the pages which are to be ...
0
votes
1answer
33 views

Sitecore 9 SXA Redirect for existing page

Is there any way to implement URL Redirect from one sitecore page to another page? Like Home/PageA ===> Home/PageB both pages exists in Sitecore. I tried with Redirect Map with Permanent Redirect(...
1
vote
1answer
33 views

How to create a field editor for Promo Image Field in sitecore 9.0.1

I am using Sitecore 9.0.1 with SXA 1.7. By default the SXA Image component comes with a field editor button to add link to an image. Can anyone please explain how this can be achieved. The default ...
0
votes
2answers
48 views

Could not find configuration node: databases/database[@id='VersionManager']

On serializing part of the tree in Sitecore I get the following error: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System....
0
votes
0answers
21 views

Issues with Relink of Item when Archiving an item

When I try to relink an Item on archive to another item I get the following error Job started: Relink|System.ArgumentNullException: Value cannot be null. Parameter name: path at Sitecore....
2
votes
2answers
206 views

Best way to update .xml file

What is the best way to update .xml file under webroot\sitecore\shell\Applications folder. As we can update it from the folder but when we migrate it to new Sitecore version then it will be overriding....
2
votes
1answer
32 views

Sitecore Security section creating 2 spaces via tds(yml) deployment

Deploying TDS(yml serialization) via Azure Devops, sitecore is creating 2 spaces (denoted in red) in the security section. This is breaking the permissions on Workflow. Any thoughts on this?
1
vote
2answers
54 views

General Link (Insert media item) add custom property when click from Experience Editor

We would like to add custom property when we click on General link from Experience Editor. Would like to add custom property below "Alternate Text" and append custom property values in URL.
0
votes
0answers
11 views

Is it possible to add a custom field for a sxa cloned rendering component in sitecore 9.0.1

I am using sxa 1.7 and sitecore 9.0.1 ,have cloned a event listing rendering and i want to add a custom field for it without touching the code. Is it possible to do that. If yes please explain how? ...
1
vote
0answers
28 views

Can Sitecore 9.1 be configured to have LB from application perspective?

Does Sitecore 9.1 have any option to have internal Load balance ? As we have two CD, can sitecore internally manage the Load balancing rather than server/LB doing the Load balance. Thanks for you kind ...
0
votes
0answers
25 views

How to retrieve a rendering varient field values in sitecore 9.0.1 using sxa 1.7

I am creating a custom search result component, but at the end i m able to retrieve rendering varient fields name not the values .How to retrieve rendering varient field values which is linked to a ...
1
vote
1answer
18 views

when adding @context“: ”http://www.schema.org" in Js files context error is thrown

There is review for SEO to include Schema.org for google search but when added the Json-LD tags as below <script type='application/ld+json'> { "@context": "http://www.schema....
0
votes
0answers
69 views

404 issue for link.aspx?id= type of links

I am facing one issue for multisite. We have 2 sites in sitecore. The requirement is that if the node is present in one site and we are searching from another site with the url: https://www.site2.ca/~/...
-1
votes
2answers
32 views

error CS0119: 'Sitecore.Mvc.HtmlHelperExtensions.Sitecore(System.Web.Mvc.HtmlHelper)' is a 'method', which is not valid in the given context

[![I currently receiving these warnings. Do they have anything to do with it. Furthermore, the warnings say it can’t find Navigation.js and Sitecore.Foundation.Theming.min.js even though they are ...
0
votes
0answers
33 views

Sitecore media field and icon is broken after unpublishing sitecore media item. How to handle this?

Sitecore media field and icon is broken after unpublishing sitecore media item. How to handle this? We are using Sitecore 9.3 Below is the stacktrace error. [ArgumentOutOfRangeException: Specified ...
0
votes
0answers
39 views

Identifier, GUID or “*” expected at position 126. Error when clicked on sitecore items under “Home”

I am using sitecore 9.0.1 .For customizing search functionality i have created a VS solution where it was asked for a patch file configuration so i have added the below lines of code under "...
0
votes
0answers
48 views

Sitecore session timeout

I want to increase my Sitecore session timeout for CMS. I have changed the below three changes but still it is not working. <setting name="Authentication.ClientSessionTimeout" value="...
0
votes
2answers
62 views

Connection to your rendering host failed , Not Found error In Experience Editor

I am working on setup a local XP0 Sitecore 10 development env for training, and one of the learning curves is to host the headless MVP site without containers, I had installed all pre-perquisites, ...
2
votes
1answer
77 views

How to hide specific photos to be viewed in browse image

I'm trying to hide specific photos from browse image dialog. For example "Assets" is my source folder, I want to get all first level photos only which is "Image1" and to hide &...
2
votes
1answer
49 views

TDS Package generation failed error

I am trying to set up already existing TDS in my local Visual studio. Whenever I build the solution I am getting the below error repeatedly. The package builder failed. Please set the build logging ...
0
votes
1answer
40 views

Copied item not getting selected in Sitecore content tree after doing copy

Recently I customized Copy item pipeline to run it as a job processor. Everything works fine but one issue is that after copy item is completed, source item still keeps selected instead of target ...
0
votes
1answer
23 views

Navigate=> Links showing none still item is linked to multiple items

The media library item showing none in Items that refer to slected item however item is linked at multiple items. Also statistics like usage is not showing for every media item on clicking of main ...
0
votes
3answers
51 views

Can we take Sitecore package from 9.2 and install in 9.3

Will there be any issues if we take the Sitecore package from version 9.2 and install it in 9.3 Thanks
0
votes
0answers
16 views

Sitecore Indexing Manager CORS exception

Im seeing a CORS exception when trying to open the Indexing manager on the Sitecore Control Panel Uncaught DOMException: Blocked a frame with origin "https://cm.jssapp.dev.local" from ...
0
votes
0answers
16 views

ItemAuthorizationHelper class implementation in Sitecore 9.3

We have recently upgraded our project from sitecore version 8.2 to 9.3. In one place we have implementation for ItemAuthorizationHelper class. ItemAuthorizationHelper class having different ...
0
votes
0answers
33 views

System.ArgumentNullException: Value cannot be null. Parameter name: rolesInRolesManager

Recently upgraded project from Sitecore version 8.2 to 9.3. But on accessing application getting below error. Value cannot be null. Parameter name: rolesInRolesManager Description: An unhandled ...
0
votes
0answers
30 views

Sitecore 10 update 1 using SIA Installation issue CX509PrivateKey::Create: Access is denied. 0x80070005 (WIN32: 5 ERROR_ACCESS_DENIED)

While installing with Sitecore 10 update 1 using SIA facing an issue as below [ IdentityServerCertificates_CreateR... : NewRootCertificate ------------------] CertEnroll::CX509PrivateKey::Create: ...
1
vote
1answer
39 views

Get IP address for any Content Author who uses Content Editor [closed]

I want to know how can I get IP address for any content Author who uses Content Editor, so that I can write this IP address in the log file. I have created an event handler to handle Save action and I ...
1
vote
0answers
33 views

SXA Media Link Component - Value cannot be null. Parameter name: name in Experience Editor

I am working with SXA Sitecore 10 where I used Media Link Component to attach a file. Everything is working fine except attaching a file in Experience Editor. I always get Value cannot be null. ...
0
votes
0answers
24 views

Blank texts after switching language

After switching my region and language settings in the Control Panel from English to Germany, I'm getting a blank control panel after refresh: We have German version of these texts in our Core DB ...
0
votes
0answers
25 views

CM content tree is not refreshed

we run to an issue where updates to an existing data templates are not showing from Sitecore content tree and when a user try t publish an item inherited from these templates these updates are not ...
0
votes
0answers
44 views

When I click the Workbox, I am getting “Could not parse the language 'en-BG'. Note that a custom language name must be on the form.” error

When I click Workbox, I am getting the below error: "Could not parse the language 'en-BG'(not only for this there are many languages). Note that a custom language name must be on the form." ...
1
vote
1answer
50 views

Solution for “Error: An error occurred” while logging into local Sitecore through default credentials

When ever i tried to login to Sitecore local with admin/b credentials I was landing on a error page stating that "Error: An error occurred". When I analysed in the log file I found that the ...
1
vote
1answer
65 views

clean up draft items in workbox

I have a requirement where I have to clean up the draft items in sitecore workbox which are there for more than two years in workbox. Can anybody tell me from where/how to start and how to access ...
2
votes
2answers
65 views

Is there support for multiple domains on the CM?

Does Sitecore support the scenario where we might bind in IIS / Azure Web Apps multiple domain names for the CM role for logging into Sitecore? Is there any risks with this? For example: cm.domain1....
1
vote
1answer
54 views

How to refresh Content Editor item after calling OnOk method in custom DialogForm?

We have a custom FormDialog (standard combination of xml and cs file that inherits DialogForm) that appears when a custom button in the Content Editor ribbon is clicked. Using some user input, the ...
0
votes
2answers
61 views

Error while browsing Heartbeat.aspx

I am getting below exception when running Heartbeat.aspx in Sitecore 10 41264 21:20:57 FATAL SINGLE MSG: Sitecore heartbeat: Exception: System.Exception Message: Cannot access database defined by &...
3
votes
1answer
125 views

Customize 'Select a Rendering' window

How can I add custom button on Select a Rendering dialog which comes up after clicking on Add here in Experience Editor, as shown below? When click on this newly added button, below screen should ...
0
votes
1answer
29 views

Does anyone know about Cordova or Ionic mobile app compatibility with Sitecore?

Hello my Sitecore Heroes! Does anyone know about Cordova or Ionic mobile app framework? I found that Cordova/Ionic are frameworks to create Mobile App which eventually uses webpages and loads webpages ...
1
vote
0answers
22 views

Multihomed General link with Search

When we try to add an internal link to the "General Link with Search" field, a dialog box opens up which shows the tree structure based on the startSearchLocation parameter. In my scenario, ...
2
votes
1answer
32 views

How to customize field's title in “Navigate to section and fields”

How to customize the field's title present in the "Navigate to sections and Fields" (see image below). Let's say - if I have field called "Summary" in the template. How to change ...
0
votes
0answers
26 views

Looking for sitecore WF comment pipeline

I am looking to see if there a way to pre-fill the fields in the comment template, just wondering if there is a pipeline to do this?
1
vote
1answer
49 views

Where are the Sitecore workflow comments stored?

I am looking for the Sitecore path where the WorkFlow comments are stored.
0
votes
1answer
47 views

Field Name Change based on language switching

I have a situation where Field name need to be changed based on language switching, calling Field name and its value into the website. Suppose, the field name is Color in English and I want to change ...
0
votes
1answer
29 views

RTE “Show Editor” edit adds one extra <a> to HTML <a>

We wrote below code in RTE "HTML editor". Saved it. published it. <div class="content-center"> <a href="https://google.com"> <div class="...
2
votes
2answers
74 views

Outage on your sitecore website during an azure platform upgrade

Our website becomes unresponsive and we get Pingdom alerts whenever there is either an azure platform or infrastructure upgrade on our website. This happens once a month. We have an app gateway and ...
0
votes
0answers
54 views

Sitecore 9.3 with sxa installation is displaying placeholder having empty data binding

My installation has Sitecore 9.3 with SXA. Master page on page have a placeholder and that placeholder is bind to view rendering. View rendering(*.cshtml) contains @Html.Raw with binding to an empty ...
0
votes
0answers
95 views

401 unauthorized on POST to /identity/externallogin

I am trying to enable federated authentication in my Sitecore 9.3 solution to login using Google Authentication. I have configued Sitecore more or less like this: https://blog.nikkipunjabi.com/2018/02/...

1
2 3 4 5
10