Questions tagged [sitecore-client]

For questions related to the Sitecore administrative interface - commonly referred to as Shell or Client - where authors and developers log in to create and manage content, analytics, permissions, etc.

Filter by
Sorted by
Tagged with
0
votes
0answers
14 views

Field of “CustomType” Not working properly in Experience Editor

I have a date field which is of "CustomType". It has a validation in the 'Validation' field with this Regex ^(?!\s*$).+ I need to edit this field in Item through Experience Editor. I have created a ...
0
votes
3answers
49 views

Not able to login to back office if one or more publishing targets are down

Other than the web, I have multiple publishing targets configured which running in different SQL servers and working properly, but if any of the additional publishing targets are not reachable, the ...
0
votes
1answer
35 views

Wildcard Certificate VS MultiDomain Certificate In Sitecore 9.2

I am a Sitecore Developer. Currently I am working through Sitecore upgrade process.Upgrading applications to S9.2 from S8.2. I am helping my team to make TEST and PROD servers ready for Sitecore ...
0
votes
0answers
36 views

Is there a way to load multiple renderings in homepage/dashboard parallel in Sitecore 9.1?

Home page has about 15 renderings with each controller rendering calling different API for analytical data (external systems for graph,charts ,summarized data) hosted on Sitecore 9.1 Average max time ...
0
votes
0answers
14 views

Ezimporter, Hi-URLRewrite and xblog support in Sitecore 9.3

With my sitecore 8.1 solution, i am using EZimporter, Xblog and HI-UrlRewrite modules from sitecore market place. I would like know that, does sitecore 9.3 provide any of the features like EZimporter, ...
0
votes
0answers
15 views

External Component Error. Exception Details: System.Runtime.InteropServices.SEHException: External component has thrown an exception

Does anyone have faced this issue. I am getting this every time when I build my code. Issue gone when I do the IIS reset. Just to let me know guys, when I build my code it directly copy the dll to ...
1
vote
1answer
39 views

PowerShell script to get data from Solr and Edit in Sitecore

Is there a way that i can Query Solr to get data based on a template. Then foreach of that data do a Sitecore Getitem and Update a field's value.
0
votes
1answer
18 views

Edit DropList Field value through Code

I have a droplist field in Item. Its source is of a folder where 2 items present named Yes and No. When the droplist field is clicked 2 options comes up. I want to edit the field through Code i am ...
1
vote
0answers
23 views

Different logo image for different viewports in SXA

I want to have different logo image for mobile and desktop. I created partial design for header and added image component for logo. Now if I can select logo image in that which will be common for all ...
0
votes
0answers
11 views

Sitecore 9.2 Dynamic Package issue

I am trying to create a dynamic package in sitecore. while creating i applied simple search, put 15 days for within the past field both for "creation date filter" and "modification date filter", ...
0
votes
1answer
51 views

How to reset the session at 3AM daily , sitecore has different configs?

Is there an option in sitecore where we can specific the time when all session/logged in user should expire ? Thank you
0
votes
0answers
6 views

class SolrContentSearchManager in namespace Sitecore.ContentSearch.SolrProvider si deprecated

Recently i upgraded sitecore instance from 8.1 to 9.3. SOlr5.4.1 set up was working fine with sc8.1, I was using NINJECT as DI. now after upgrading , SOlr is causing at DI level, complaining that ...
0
votes
0answers
10 views

Assets like css js are not working with sitecore 9.3 as expected

with sitecore 8.1, @styles.Render("virtual path") and @scripts.Render("Virtual Path") are working fine. But with Sc9.3, it is stopped working, i am getting 404 error for these in network tab. Can ...
0
votes
1answer
31 views

Editable checkbox in Page

I have a Sitecore field of checkbox type. I am showing it in Experience Editor as below and is Editable : My code of Cshtml is: IsNavigable: @Html.Glass().Editable(Model,x=>x.IsNavigable) How ...
0
votes
1answer
42 views

SItecore Identity Server on Prem throws“ Error: An error occured”

I am seeing an issue in logging to sitecore 9.3 instance.. When i hit the url like https://{domainname}/sitecore. It gets redirected to Sitecore identity server login page. I enter user name password ...
0
votes
0answers
33 views

Sitecore Error : System.Net.WebException - The operation has timed out

After doing a deployment to the live server, I am getting this error in the logs multiple times due to which the website is not showing. This is the only error that is generated: 12136 23:10:30 ...
0
votes
0answers
10 views

How can i Customize Version adding Functionality on Edit and Lock?

When a Content Author does Edit and Lock to edit an item a new Version is Added. I want to update the workflow state Only when version is added on clicking the Lock and Edit. How can i Achieve the ...
0
votes
2answers
21 views

How to set Droplist Standard Fields to Read-Only for Non-Admin user

I have restricted the "Context Menu" field to Read-Only for non-admin users. However, it is still editable for non-admin. The text was grayed but can still click the droplist. Any idea how to ...
1
vote
2answers
46 views

How can I create SSL certificate on my local machine for Sitecore websites?

How can I create SSL certificate on my local machine for Sitecore websites so that if I bind it to that Sitecore website in IIS, browser should show it as a secure site? Right now I created my SSL ...
0
votes
0answers
38 views

Make Sitecore Workflow comments mandatory

In Sitecore 9 Workflow, i wish to make the comments mandatory for some actions. While surfing i came across the below solution https://stackoverflow.com/questions/16895043/sitecore-workbox-make-...
0
votes
1answer
55 views

Customize WorkFlow Message Dialog box in Experience editor

In Experience Editor Mode when we click on the work flow command,the below dialog box comes up, How can I show a customized dialog instead of default:
0
votes
2answers
33 views

Need to remove Experience Editor mode , when going directly to a WCM URL

In Content Editor, I select an Item and from the publishing tab, I select experience editor. Then the page opens in Experience Editor and the URL like this: wcm-example.com/?sc_mode=edit&sc_itemid=...
0
votes
2answers
68 views

How to display Droplist Field Value in Page and Edit in Experience Editor?

I Have a Field of Droplist type. The source of the field is of a Folder under which two items are present. In the droplist field we can select the name of the two Item present in the source folder. I ...
0
votes
0answers
29 views

Lock and edit feature for all user including Admin

An Item if 'Lock and Edit' then creates a new version if not an admin. As a admin When I select lock from Experience Editor Ribbon and edit the Item which is published once and save then new version ...
0
votes
2answers
336 views

Subpage of website cannot be edited in Experience Editor

I seem to have a weird problem with my dummy website. I am learning about Sitecore via their e-learning tutorials, and currently have a front page with sub page. The problem is with the sub page, ...
0
votes
0answers
28 views

Creating rich text element for Sitecore Forms

I have created a new component for the Sitecore Forms called "Rich Text", with the aim to have "Rich Text" capabilities while working with forms. Everything works as expected. Apart from one thing, ...
0
votes
2answers
61 views

Login failed for user 'masteruser'

I was moving my Sitecore 9.2 QA database in UAT in Azure PaaS. I have moved the web & master database and renamed the databases to UAT's database name. In connectionString.config we have changed ...
8
votes
1answer
2k views

How can I create an app and add a shortcut to the desktop?

I want to create an app that an author can access from the Desktop. How can I make one and insert it in there? I don't seem to find any documentation on that.
2
votes
1answer
264 views

Experience Analytics dashboard gives errors

My Logs shows this error 2428 23:47:09 ERROR [Sitecore Services]: HTTP GET URL http://ffg.local/sitecore/api/ao/aggregates/all/786FBA3A4573445EA74504E3CA5E48C1/all?&dateGrouping=by-week&&dateFrom=23-...
1
vote
1answer
24 views

Error in accessing sitecore in browser via SIM

I was trying to access sitecore website instance which I just installed via SIM (Sitecore instance Manager). It seems some settings must have gone wrong while installing sitecore instance. PFA the ...
0
votes
0answers
22 views

How to set default col 6 on Tablet on SXA Grid Settings

Now when a column splitter is created, the default grid of 6 is applied on Compact Phones. As per our requirement we wanted to set default col 6 on Tablet. I tried below, Updated default component ...
0
votes
1answer
97 views

Sitecore Azure PaaS Client Certificate on ASE

I deployed Sitecore 9.2 on Azure PaaS and facing the issue with Client Certificate Authentication. The Azure hosting is on ASE with Isolated App Service Plan. It seems like CM server is not able to ...
0
votes
1answer
101 views

OpenIdConnectProtocolValidationContext.Nonce was null For Azure AD Auth

I followed the steps here https://sitecore.derekc.net/setting-up-azure-active-directory-integration-with-sitecore-identity-server-sitecore-9-1/ to get this set up and it is all great. However, even ...
0
votes
1answer
53 views

Different datasource for adding and changing rendering component content

We have multiple sites. And for each site has content folder called "data". Our client wants that if he is going to add a rendering component to the page, the datasource would be coming from the data ...
0
votes
1answer
87 views

Index has not been initialized on content management server

We are getting an issue "index has not been initialized" if clicks any of the Sitecore content tree items in the content editor, Does anyone know how to solve this. Thanks, Suresh
3
votes
0answers
71 views

4 Image Controls in a Composite Control, Not showing action buttons

I have created a composite control in Sitecore 9 and I can use that in template editor when adding new fields. This control is supposed to show an Image control where I can browse and select images ...
0
votes
0answers
20 views

Permissions to use preview and Experience editor

I am trying to set up a user profile to only allow someone to add items to one page on our site. I seem to have almost everything configured correctly, but for some reason the below error happens ...
0
votes
0answers
28 views

Unit test for sitecore

I actually have a trouble with unitest using sitecore.fake.DB. I configed step by step flow document. But, when I run it and I have error. Please help me for this. Tks so much!
2
votes
2answers
57 views

How to get a contact with custom facet?

I am trying to get a sitecore contact with the custom facet. The custom facet is working fine I have verified it. The following code is running fine on Standalone and CM environment, but is throwing ...
2
votes
1answer
64 views

Restrict a page from direct access in Sitecore

Is there any way to restrict the end-user from directly accessing a page? I'm having a scenario, where there are 3 pages (say A, B, C). A is like a validation page, then on successful validation ...
4
votes
3answers
1k views

rel=“noopener noreferrer” get automatically added on other content when we add new link with target equals to blank in RTE

Sitecore 8.2 update 4 We've been editing some pages, and noticing that rel="noopener noreferrer" get's added into text. I understand that, it's good to have it added to _blank links. But it's being ...
0
votes
0answers
21 views

Sitecore smart publish with related items publishes items or not? [duplicate]

I have been reading about media items publishing where in my scenario I am using Smart publish. I needed to check if this accounts for the Related media items or not as One article says it's included: ...
2
votes
0answers
59 views

Federated authentication user is getting logged in as interface user not as normal virtual user

This is my config file for the federated authentication. <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www.sitecore.net/xmlconfig/set/"> <sitecore> <...
0
votes
2answers
49 views

This site cant be reached error while I am loading sitecore 8.2 client

It is working fine few days back. But, suddenly my local environment ends up with below error. I have tried installing new instances of sitecore as well but no luck. +Adding Windows Network ...
0
votes
1answer
40 views

The selected link Target value is not displayed after customising the Hyperlink Manager

Following on from a previous question on how to make customisations of the RTE upgrade safe, we have: 1) Customised the LinkManager.ascx to add a new property for the 'rel' attribute on the link. ...
0
votes
0answers
21 views

Extending ContactsController and ContactDataModel for List Manager Fields

Version: Sitecore 9.2 I have added a column Title in core sitecore/client/applications/list manager/lists/contact list and added DataField as Personal_Title (built-in facet). But data does not show ...
0
votes
0answers
27 views

Media Icons Not Showing

In Sitecore 9.2 i am not seeing any icons. Path of every icon are like src="/-/temp//iconcache/apps/48x48/pencil.png.aspx". when i remove "/-" and ".aspx" from DOM then icon appears. i clean up ...
0
votes
0answers
36 views

How can I solve Server Error in '/' Application Index has not been initialized? [duplicate]

If I access my home page, show error like this : Server Error in '/' Application. Index has not been initialized. Description: An unhandled exception occurred. Exception Details: System....
0
votes
1answer
49 views

Sitecore 8.2 update 6 display a not found item [duplicate]

Today, I found a weird issue in Sitecore 8.2 update 6, I have setup the Sitecore in local using Sitecore Installer and give the sc82u6 as host name; Then, the Sitecore default page up and run, and I ...
1
vote
1answer
455 views

HTML content in Multi-Line Text Field misbehaving in Experience Editor

We have a requirement to add HTML in multi-line text field. For example, content author can add a Bold text in the field- "test <b>sample text<b>" now we are having an issue in ...

1
2 3 4 5
10