Questions tagged [sitecore-client]

For questions related to the Sitecore administrative interface - commonly referred to as Shell or Client - where authors and developers log in to create and manage content, analytics, permissions, etc.

132 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
10
votes
1answer
909 views

Can the Identity Server be used for multiple sites/clients?

For Sitecore 9.1, can the Identity Server be used for multiple sites/clients? For example, on a local developer machine I have several 9.1 installs for separate clients. Could I use that Identity ...
4
votes
1answer
262 views

Adding help Text to Section of a template

I want to add help text to section of the template. I have added content to all 3 short description, long description and help link. Templates fields do get all the help text but Template Section is ...
4
votes
0answers
79 views

4 Image Controls in a Composite Control, Not showing action buttons

I have created a composite control in Sitecore 9 and I can use that in template editor when adding new fields. This control is supposed to show an Image control where I can browse and select images ...
4
votes
0answers
985 views

Populate Solr Managed Schema Error

I am getting the 404 error while trying to populate the schema from "Populate Solr Managed Schema". Job started: Index_Update_Collection=sitecore_core_index|#Exception: System.Reflection....
4
votes
0answers
750 views

Sitecore 8.2 unlock item / unlock all items error

We're facing an issue on the Unlock all functionality. PS: The unlock only works after Saving the item (Once we have activated the unlock after saving property). If we click on the unlock button, ...
3
votes
0answers
33 views

Restoring marketing taxonomies with Sitecore powershell extenstion

I am trying to automate Sitecore upgrade from 8.1 to 9.0.1. In Upgrade steps, There is one step restoring deleted marketing taxonomies, which can easily be done with Url navigation and click button on ...
3
votes
0answers
122 views

How to get Current Site Country flag using Sitecore SXA?

Is it possible to get flag and country name associated with each site using Sitecore SXA. I need to dispaly country flag as well as country name side by side on top of the page for each SXA Site. ...
3
votes
0answers
638 views

What Sitecore Client Languages are available?

I was now wondering what the definitive list of Sitecore Client Languages actually is. By default, my own answer would be English, Danish, German and Japanese. However I found this: https://dev....
2
votes
1answer
70 views

Reading values from Password field type

I am trying to use the password field type on some settings items to store data instead of using configs, however when reading its values in code (for example item["passwordfield"]) we are ...
2
votes
0answers
41 views

class SolrContentSearchManager in namespace Sitecore.ContentSearch.SolrProvider si deprecated

Recently i upgraded sitecore instance from 8.1 to 9.3. SOlr5.4.1 set up was working fine with sc8.1, I was using NINJECT as DI. now after upgrading , SOlr is causing at DI level, complaining that ...
2
votes
3answers
137 views

Not able to login to Sitecore if one or more publishing targets are down

Other than the web, I have multiple publishing targets configured which running in different SQL servers and working properly, but if any of the additional publishing targets are not reachable, the ...
2
votes
0answers
103 views

Sitecore Contact Duplication Issue - Dynamics CRM Connector

There is a strange issue that I encountered today. If I submit a Contact using Sitecore Forms and Sync the same contact through dynamics CRM connector, I get duplicated contacts as the identifier of ...
2
votes
0answers
307 views

Not able to load SXA Site after configuring its domain

We have many SXA Sites and we are trying to launch a new site with our domain https://domainA.info. We updated Host Name and Target Host Name fields on site definition item and published as well. The ...
2
votes
0answers
134 views

Add querystring value to preview URL

I thought I had an approach for this but it does not work. My new process is never called. I just need to add an additional querystring to any preview URL that is generated in CM (publish preview, ...
2
votes
0answers
210 views

Icon section not loading? Sitecore 8.2U7

The Icon window for changing icon is not loading. It has some script issue.
2
votes
0answers
79 views

Encrypt zip file while uploading to media library folder sitecore 8.2

i have followed the sitecore link and create my custom processor for (Sitecore.Pipelines.Upload.Save). i have faced issues while saving all media items. it gives error on file.SaveAs(filename); ...
2
votes
0answers
242 views

Computed fields facets are not working in Content Editor

I am on Sitecore 9 using SOLR. We have added some facet configurations under /sitecore/system/Settings/Buckets/Facets to show them while searching for items in buckets. While the facets for fields ...
2
votes
0answers
295 views

Video Media item is not loading as per language query string parameter?

I have created media item and uploaded two different video in "English" and "Spanish" version. When accessing this media item, it is not loading the video as per the query string parameter, please ...
2
votes
0answers
216 views

Sitecore experience editor throws error when saving datasource number field

I've created a config item with a number field (without validation rules), I've added a rendering to my page with this config as datasource. When I edit the item in the Content Editor, everything is ...
2
votes
0answers
158 views

Application access denied - Custom Editor for Sitecore Client

I am building an editor for the Sitecore client. However when I load this editor in the content editor, it shows the error Application access denied. I am currently logged in as an administrator. ...
2
votes
0answers
456 views

Sitecore Admin Page login issue

I'm having problem with the Sitecore Admin Pages. Once I login to visit a page (e.g., sitecore/admin/dbbrowser.aspx) then I'm currently in the page and I tried to load the page I'm being redirected on ...
2
votes
0answers
264 views

How to clear all submission data from a single wffm form

I have a task to remove all current submission data from a particular form. We're running Sitecore at 8.1. I can't seem to find an interface that Sitecore provides to do this. I remember at 7.2 you ...
2
votes
0answers
169 views

Sitecore 8.2 update 1 Social media connector in Azure Webapp

I'm working on Social connector functionality to share item content from Sitecore to targeted social networks (facebook, twitter, Google Plus, Linked In). Based on reference, my understanding is ...
1
vote
1answer
63 views

Find Pages That Match Template Id and add a Value

Using Sitecore PowerShell Extension (SPE). New to SPE and I am trying to do this: If the template id matches && the item is expired && the content type of "video" is missing =...
1
vote
0answers
81 views

Random Sitecore Logout Issues

Running Sitecore version 8.1 Hello, I've been trying to figure out this issue for a while now and was curious to see if anyone has experienced something similar. Issue: Content publishers get kicked ...
1
vote
0answers
37 views

Set General Link Internal Path Globally

Has anyone set the start path of the General Link field globally when choosing internal? I can do it per item/template, but looks like it requires custom code to have it applied globally. I thought ...
1
vote
0answers
33 views

Can Sitecore 9.1 be configured to have LB from application perspective?

Does Sitecore 9.1 have any option to have internal Load balance ? As we have two CD, can sitecore internally manage the Load balancing rather than server/LB doing the Load balance. Thanks for you kind ...
1
vote
0answers
85 views

Sitecore 10 update 1 using SIA Installation issue CX509PrivateKey::Create: Access is denied. 0x80070005 (WIN32: 5 ERROR_ACCESS_DENIED)

While installing with Sitecore 10 update 1 using SIA facing an issue as below [ IdentityServerCertificates_CreateR... : NewRootCertificate ------------------] CertEnroll::CX509PrivateKey::Create: ...
1
vote
0answers
53 views

SXA Media Link Component - Value cannot be null. Parameter name: name in Experience Editor

I am working with SXA Sitecore 10 where I used Media Link Component to attach a file. Everything is working fine except attaching a file in Experience Editor. I always get Value cannot be null. ...
1
vote
1answer
97 views

Solution for "Error: An error occurred" while logging into local Sitecore through default credentials

When ever i tried to login to Sitecore local with admin/b credentials I was landing on a error page stating that "Error: An error occurred". When I analysed in the log file I found that the ...
1
vote
0answers
28 views

Multihomed General link with Search

When we try to add an internal link to the "General Link with Search" field, a dialog box opens up which shows the tree structure based on the startSearchLocation parameter. In my scenario, ...
1
vote
0answers
267 views

Firefox Only :Multiple controls with the same ID 'FContent<GUID>' were found. FindControl requires that controls have unique IDs

After migrating to Sitecore 9.3 from 8.2, we are getting "Multiple controls with the same ID 'FContent' were found. FindControl requires that controls have unique IDs" popup on clicking any ...
1
vote
0answers
36 views

New role not working in Sitecore 9

I have created a new role and its of Sitecore Domain.I have given the required access and added a user as member. But I am not able to login with the user. I have tried assigning Member role Sitecore ...
1
vote
0answers
28 views

Field Compatibility in Experience Editor

I have a Custom Time field that inherits the the IContentField of namespace Sitecore.Shell.Applications.ContentEditor. I am trying to edit this field in Experience Editor using Edit Frame. But the ...
1
vote
0answers
65 views

Is there a way to load multiple renderings in homepage/dashboard parallel in Sitecore 9.1?

Home page has about 15 renderings with each controller rendering calling different API for analytical data (external systems for graph,charts ,summarized data) hosted on Sitecore 9.1 Average max time ...
1
vote
0answers
43 views

Ezimporter, Hi-URLRewrite and xblog support in Sitecore 9.3

With my sitecore 8.1 solution, i am using EZimporter, Xblog and HI-UrlRewrite modules from sitecore market place. I would like know that, does sitecore 9.3 provide any of the features like EZimporter, ...
1
vote
0answers
33 views

Field of "CustomType" Not working properly in Experience Editor

I have a date field which is "CustomType". It has validation in the 'Validation' field with this Regex ^(?!\s*$).+ I need to edit this field in Item through Experience Editor. I have ...
1
vote
0answers
261 views

External Component Error. Exception Details: System.Runtime.InteropServices.SEHException: External component has thrown an exception

Does anyone have faced this issue? I am getting this every time when I build my code. The issue has gone when I do the IIS reset. Just to let me know guys when I build my code it directly copy the dll ...
1
vote
0answers
113 views

Assets like css js are not working with sitecore 9.3 as expected

with sitecore 8.1, @styles.Render("virtual path") and @scripts.Render("Virtual Path") are working fine. But with Sc9.3, it is stopped working, i am getting 404 error for these in network tab. Can ...
1
vote
0answers
201 views

Sitecore Error : System.Net.WebException - The operation has timed out

After doing a deployment to the live server, I am getting this error in the logs multiple times due to which the website is not showing. This is the only error that is generated: 12136 23:10:30 ...
1
vote
0answers
128 views

Creating rich text element for Sitecore Forms

I have created a new component for the Sitecore Forms called "Rich Text", with the aim to have "Rich Text" capabilities while working with forms. Everything works as expected. Apart from one thing, ...
1
vote
0answers
46 views

How to set default col 6 on Tablet on SXA Grid Settings

Now when a column splitter is created, the default grid of 6 is applied on Compact Phones. As per our requirement we wanted to set default col 6 on Tablet. I tried below, Updated default component ...
1
vote
0answers
39 views

Permissions to use preview and Experience editor

I am trying to set up a user profile to only allow someone to add items to one page on our site. I seem to have almost everything configured correctly, but for some reason the below error happens ...
1
vote
0answers
38 views

Unit test for sitecore

I actually have a trouble with unitest using sitecore.fake.DB. I configed step by step flow document. But, when I run it and I have error. Please help me for this. Tks so much!
1
vote
0answers
194 views

Media Icons Not Showing

In Sitecore 9.2, I am not seeing any icons. Path of every icon are like src="/-/temp//iconcache/apps/48x48/pencil.png.aspx". when i remove "/-" and ".aspx" from DOM then ...
1
vote
0answers
131 views

Azure search Synonyms implementation using SXA 1.9 and Sitecore 9.2 using postman API

I have requirement to work with the synonyms for the similar group of words in search. I did load the synonyms using Postman API to SXA web index and able to see them on the index. For example: home,...
1
vote
0answers
233 views

Sitecore Rich Text Editor/ HTML Editor throwing parsing error

I have a requirement to show the tool tip to user for allowed special character on registration page, so i have created a template and adding the following content "<li>Allowed special character ...
1
vote
0answers
369 views

Sitecore error "Server cannot modify cookies after HTTP headers have been sent."

I am trying to Insert a new form. When I am trying to select a placeholder for the form, following error is showing : when I had installed the WFFM, I went to "Restrict placeholder" and added my ...
1
vote
0answers
99 views

Adding hashtag to the internal link that leads to blog search page with tag filter search Sitecore SXA 1.9

The blog index page has all articles are listed and the filter based on tag that works with solr search. The search results based on sxatags filter will get added on the blog index page when apply ...
1
vote
0answers
105 views

Personalization not working (Pattern Card & profile Card)

Using Sitecore .NET 8.1 (rev. 151003). Created ABC pattern card & assign specific placeholder of page. Used rule: where the current contact matches the ABC pattern card in the ABCD profile. ...