Questions tagged [sitecore-client]

For questions related to the Sitecore administrative interface - commonly referred to as Shell or Client - where authors and developers log in to create and manage content, analytics, permissions, etc.

Filter by
Sorted by
Tagged with
1 vote
0 answers
218 views

Random Sitecore Logout Issues

Running Sitecore version 8.1 Hello, I've been trying to figure out this issue for a while now and was curious to see if anyone has experienced something similar. Issue: Content publishers get kicked ...
  • 11
0 votes
1 answer
59 views

Content editor view of tree versus Add link view in Rich Text editor

Using Sitecore 9 - We are trying to set a limited view within the content editor of the content tree and allow users to see the full content tree in the rich text editor for cross-linking across the ...
0 votes
2 answers
269 views

Partial search in Sitecore Multilist with Search type of field

I am using the multi-list with search field in my project. I have many items to render within (approx 400), so it's not possible for the users to scroll through and choose a specific one. There is one ...
0 votes
1 answer
41 views

Shared datasource identification

I have a requirement like when a user copies an existing page by doing this data sources also copied and the user may not realize when they change content on this item they are changing on the ...
  • 97
0 votes
0 answers
91 views

Rich Text Editor removes HTML formatting

I have a role which is a member of "Sitecore/Designer", "Sitecore/Author" and "Sitecore Client Publishing". When I unlock a page it creates a new version and all the Html ...
0 votes
1 answer
760 views

Sitecore Login page redirecting to the login page again and again

We are using client developer license where only one user can login into Sitecore. We are using Sitecore 9.3. We are getting an issue while logging. On login page, we are giving the correct username ...
  • 928
0 votes
1 answer
246 views

Upgrading jQuery for sitecore xp 9.3

I notice sitecore 9.3 does have a pretty low version of jQuery at several places in the content editor in sitecore/shell/lib/jquery, ScriptResource.axd, Telerik.Web.UI.axd are all using jQuery 1.12.4 ...
0 votes
0 answers
71 views

Connect Sitecore to External source for data authoring

We have an external data source (SQL or via API). That data needs to be managed by our content authors. i am looking at something this can be done by tool or minimal customization. I tried to create ...
1 vote
0 answers
41 views

Set General Link Internal Path Globally

Has anyone set the start path of the General Link field globally when choosing internal? I can do it per item/template, but looks like it requires custom code to have it applied globally. I thought ...
  • 715
0 votes
1 answer
292 views

Creating a Sitecore User with read only access to all the Sitecore items

How can I create a Sitecore user with read only access to all the sitecore items. I came across below sitecore link, but this required to assign the permissions by item wise. which takes time. so want ...
  • 163
0 votes
1 answer
109 views

Solr version compatibility with Sitecore 9.0.1

My team is planning to install Sitecore 9.0.1. We are using Solr 6.6.2 version at the moment. Due to some solr search issues we are planning to use solr 6.6.3. Is this Solr version compatible with ...
  • 191
0 votes
0 answers
87 views

How to show the subpages of a page using navigation rendering in Sitecore 9.0.1?

I am using Sitecore 9.0.1 with SXA 1.7 . I have created a partial design page in that i have added a Navigation component to my page and in the Page it is showing all the pages which are to be ...
  • 191
0 votes
1 answer
392 views

Sitecore 9 SXA Redirect for existing page

Is there any way to implement URL Redirect from one sitecore page to another page? Like Home/PageA ===> Home/PageB both pages exists in Sitecore. I tried with Redirect Map with Permanent Redirect(...
1 vote
1 answer
131 views

How to create a field editor for Promo Image Field in sitecore 9.0.1

I am using Sitecore 9.0.1 with SXA 1.7. By default the SXA Image component comes with a field editor button to add link to an image. Can anyone please explain how this can be achieved. The default ...
  • 191
0 votes
2 answers
122 views

Could not find configuration node: databases/database[@id='VersionManager']

On serializing part of the tree in Sitecore I get the following error: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System....
0 votes
0 answers
66 views

Issues with Relink of Item when Archiving an item

When I try to relink an Item on archive to another item I get the following error Job started: Relink|System.ArgumentNullException: Value cannot be null. Parameter name: path at Sitecore....
3 votes
2 answers
279 views

Best way to update .xml file

What is the best way to update .xml file under webroot\sitecore\shell\Applications folder. As we can update it from the folder but when we migrate it to new Sitecore version then it will be overriding....
  • 199
3 votes
1 answer
77 views

Sitecore Security section creating 2 spaces via tds(yml) deployment

Deploying TDS(yml serialization) via Azure Devops, sitecore is creating 2 spaces (denoted in red) in the security section. This is breaking the permissions on Workflow. Any thoughts on this?
  • 327
1 vote
2 answers
378 views

General Link (Insert media item) add custom property when click from Experience Editor

We would like to add custom property when we click on General link from Experience Editor. Would like to add custom property below "Alternate Text" and append custom property values in URL.
  • 199
1 vote
0 answers
37 views

Can Sitecore 9.1 be configured to have LB from application perspective?

Does Sitecore 9.1 have any option to have internal Load balance ? As we have two CD, can sitecore internally manage the Load balancing rather than server/LB doing the Load balance. Thanks for you kind ...
  • 313
1 vote
1 answer
119 views

when adding @context": "http://www.schema.org" in Js files context error is thrown

There is review for SEO to include Schema.org for google search but when added the Json-LD tags as below <script type='application/ld+json'> { "@context": "http://www.schema....
  • 313
-1 votes
2 answers
81 views

error CS0119: 'Sitecore.Mvc.HtmlHelperExtensions.Sitecore(System.Web.Mvc.HtmlHelper)' is a 'method', which is not valid in the given context

[![I currently receiving these warnings. Do they have anything to do with it. Furthermore, the warnings say it can’t find Navigation.js and Sitecore.Foundation.Theming.min.js even though they are ...
1 vote
0 answers
144 views

Sitecore media field and icon is broken after unpublishing sitecore media item. How to handle this?

Sitecore media field and icon is broken after unpublishing sitecore media item. How to handle this? We are using Sitecore 9.3 Below is the stacktrace error. [ArgumentOutOfRangeException: Specified ...
  • 13
0 votes
0 answers
302 views

Identifier, GUID or "*" expected at position 126. Error when clicked on sitecore items under "Home"

I am using sitecore 9.0.1 .For customizing search functionality i have created a VS solution where it was asked for a patch file configuration so i have added the below lines of code under "...
  • 191
0 votes
0 answers
213 views

Sitecore session timeout

I want to increase my Sitecore session timeout for CMS. I have changed the below three changes but still it is not working. <setting name="Authentication.ClientSessionTimeout" value="...
  • 1
1 vote
2 answers
870 views

Connection to your rendering host failed , Not Found error In Experience Editor

I am working on setup a local XP0 Sitecore 10 development env for training, and one of the learning curves is to host the headless MVP site without containers, I had installed all pre-perquisites, ...
2 votes
1 answer
101 views

How to hide specific photos to be viewed in browse image

I'm trying to hide specific photos from browse image dialog. For example "Assets" is my source folder, I want to get all first level photos only which is "Image1" and to hide &...
2 votes
1 answer
454 views

TDS Package generation failed error

I am trying to set up already existing TDS in my local Visual studio. Whenever I build the solution I am getting the below error repeatedly. The package builder failed. Please set the build logging ...
  • 97
0 votes
1 answer
91 views

Copied item not getting selected in Sitecore content tree after doing copy

Recently I customized Copy item pipeline to run it as a job processor. Everything works fine but one issue is that after copy item is completed, source item still keeps selected instead of target ...
0 votes
3 answers
82 views

Can we take Sitecore package from 9.2 and install in 9.3

Will there be any issues if we take the Sitecore package from version 9.2 and install it in 9.3 Thanks
  • 327
1 vote
0 answers
163 views

Sitecore 10 update 1 using SIA Installation issue CX509PrivateKey::Create: Access is denied. 0x80070005 (WIN32: 5 ERROR_ACCESS_DENIED)

While installing with Sitecore 10 update 1 using SIA facing an issue as below [ IdentityServerCertificates_CreateR... : NewRootCertificate ------------------] CertEnroll::CX509PrivateKey::Create: ...
1 vote
0 answers
108 views

SXA Media Link Component - Value cannot be null. Parameter name: name in Experience Editor

I am working with SXA Sitecore 10 where I used Media Link Component to attach a file. Everything is working fine except attaching a file in Experience Editor. I always get Value cannot be null. ...
  • 430
1 vote
1 answer
242 views

Solution for "Error: An error occurred" while logging into local Sitecore through default credentials

When ever i tried to login to Sitecore local with admin/b credentials I was landing on a error page stating that "Error: An error occurred". When I analysed in the log file I found that the ...
  • 45
2 votes
1 answer
242 views

clean up draft items in workbox

I have a requirement where I have to clean up the draft items in sitecore workbox which are there for more than two years in workbox. Can anybody tell me from where/how to start and how to access ...
  • 97
2 votes
2 answers
269 views

Is there support for multiple domains on the CM?

Does Sitecore support the scenario where we might bind in IIS / Azure Web Apps multiple domain names for the CM role for logging into Sitecore? Is there any risks with this? For example: cm.domain1....
  • 4,981
2 votes
1 answer
228 views

How to refresh Content Editor item after calling OnOk method in custom DialogForm?

We have a custom FormDialog (standard combination of xml and cs file that inherits DialogForm) that appears when a custom button in the Content Editor ribbon is clicked. Using some user input, the ...
0 votes
2 answers
154 views

Error while browsing Heartbeat.aspx

I am getting below exception when running Heartbeat.aspx in Sitecore 10 41264 21:20:57 FATAL SINGLE MSG: Sitecore heartbeat: Exception: System.Exception Message: Cannot access database defined by &...
  • 21
3 votes
1 answer
431 views

Customize 'Select a Rendering' window

How can I add custom button on Select a Rendering dialog which comes up after clicking on Add here in Experience Editor, as shown below? When click on this newly added button, below screen should ...
  • 485
0 votes
1 answer
49 views

Does anyone know about Cordova or Ionic mobile app compatibility with Sitecore?

Hello my Sitecore Heroes! Does anyone know about Cordova or Ionic mobile app framework? I found that Cordova/Ionic are frameworks to create Mobile App which eventually uses webpages and loads webpages ...
1 vote
0 answers
43 views

Multihomed General link with Search

When we try to add an internal link to the "General Link with Search" field, a dialog box opens up which shows the tree structure based on the startSearchLocation parameter. In my scenario, ...
2 votes
1 answer
47 views

How to customize field's title in "Navigate to section and fields"

How to customize the field's title present in the "Navigate to sections and Fields" (see image below). Let's say - if I have field called "Summary" in the template. How to change ...
0 votes
0 answers
29 views

Looking for sitecore WF comment pipeline

I am looking to see if there a way to pre-fill the fields in the comment template, just wondering if there is a pipeline to do this?
  • 327
1 vote
1 answer
119 views

Where are the Sitecore workflow comments stored?

I am looking for the Sitecore path where the WorkFlow comments are stored.
  • 327
-2 votes
1 answer
144 views

Field Name Change based on language switching

I have a situation where Field name need to be changed based on language switching, calling Field name and its value into the website. Suppose, the field name is Color in English and I want to change ...
0 votes
1 answer
44 views

RTE "Show Editor" edit adds one extra <a> to HTML <a>

We wrote below code in RTE "HTML editor". Saved it. published it. <div class="content-center"> <a href="https://google.com"> <div class="...
  • 13
2 votes
2 answers
133 views

Outage on your sitecore website during an azure platform upgrade

Our website becomes unresponsive and we get Pingdom alerts whenever there is either an azure platform or infrastructure upgrade on our website. This happens once a month. We have an app gateway and ...
  • 187
0 votes
0 answers
263 views

401 unauthorized on POST to /identity/externallogin

I am trying to enable federated authentication in my Sitecore 9.3 solution to login using Google Authentication. I have configued Sitecore more or less like this: https://blog.nikkipunjabi.com/2018/02/...
0 votes
0 answers
611 views

"XdbContextLoggingPlugin" XdbContext Batch Execution Exception

I am getting an SQL exception in the XConnect application. Error: ["XdbContextLoggingPlugin"] XdbContext Batch Execution Exception XdbContextLoggingPlugin MessageTemplate: [{0}] XdbContext ...
  • 439
1 vote
0 answers
425 views

Firefox Only :Multiple controls with the same ID 'FContent<GUID>' were found. FindControl requires that controls have unique IDs

After migrating to Sitecore 9.3 from 8.2, we are getting "Multiple controls with the same ID 'FContent' were found. FindControl requires that controls have unique IDs" popup on clicking any ...
0 votes
0 answers
60 views

Trying to upload an update package to SC 9.3 and getting "The requested document was not found"

When I try to upload a package to install items I am getting a window that reports "The requested document was not found". This started as a vanilla installation of 9.3 onto which I have ...
  • 500

1 2
3
4 5
12