Questions tagged [sitecore-client]

For questions related to the Sitecore administrative interface - commonly referred to as Shell or Client - where authors and developers log in to create and manage content, analytics, permissions, etc.

Filter by
Sorted by
Tagged with
0
votes
1answer
1k views

A routed “MS_attributerouteWebApi” is already in the route collection. Route names must be unique (Sitecore 9.0.1) [duplicate]

i have a similar question to [A route named x is already in the route collection][1] [1]: A route named x is already in the route collection. Route names must be unique. But the solution mentioned ...
4
votes
2answers
327 views

Granting a role access to a field

I have a component in my sitecore instance called an Article Download component. One of the fields for this component is called Download Item and it is the type link (not General Link). My authors are ...
3
votes
2answers
720 views

Provide permission to one user to unlock items which are locked by other user in CE

We're using Sitecore 8. We have a scenario to provide permission to one user to unlock items which are locked by other user in CE. Could you please advise on it.
1
vote
1answer
381 views

Unable to locate element on the Frame (selenium c#)

I am trying to automate Sitecore using Selenium (C#). More details about the automations steps: Scenario to automate: Login to Sitecore with admin privileges. After logging in, select Content ...
2
votes
0answers
175 views

Computed fields facets are not working in Content Editor

I am on Sitecore 9 using SOLR. We have added some facet configurations under /sitecore/system/Settings/Buckets/Facets to show them while searching for items in buckets. While the facets for fields ...
5
votes
0answers
751 views

Sitecore 9 Separate CD server - ERROR Cannot start analytics Tracker

I Installed Sitecore 9 XP1 with Separate CD and CM servers. I am getting the below error in CD: Unexpected character encountered while parsing value: <. Path '', line 0, position 0 31260 12:55:...
0
votes
1answer
472 views

Sitecore Media File upload above 2GB throws Bad Request 400

we are on Sitecore 8.1 U3 , content editors generally upload large files to the media library using the File upload (advanced) option with Upload as files checked , these files are uploaded to a blob ...
0
votes
3answers
372 views

ComponentArt Grid Unlicensed control. Click here for more information

I'm using Sitecore 8.2 Update 5. I do have ComponentArt Grid license file under bin folder. What else may be the reason of this error? It's working fine locally. I see suggestions to add ComponentArt ...
4
votes
0answers
581 views

Populate Solr Managed Schema Error

I am getting the 404 error while trying to populate the schema from "Populate Solr Managed Schema". Job started: Index_Update_Collection=sitecore_core_index|#Exception: System.Reflection....
4
votes
2answers
267 views

Sitecore 9.0.1 Datepicker displaying wrong format

I'm facing DateTime format issue on the SPEAK DateTime Picker. Basically, when the user is in the Content Editor, the format displays ok (mm/dd/yyyy). But when the user opens the Experience Editor, ...
0
votes
1answer
251 views

Latest Angular basic sample Error

I'm trying to go through all the Angular tutorial from the JSS.Sitecore side but I came across multiple issue. The examples don't match the code that is getting generated Getting missing modules ...
1
vote
0answers
114 views

Sitecore MultiLanguage Content changes the URL. Results 404, Not found error

I'm having an issue in my site.I'm using VirtualFolder property to change the site language content. I've a link 'Environment' and my default site language is Chinese. So,the URL looks like www.xyz....
1
vote
2answers
360 views

Read access to role is not working

I have created new Sitecore item in start menu and created new role to give access to item for one of our user. But item is not displaying at all in start menu when I login as that user(after new role ...
0
votes
1answer
415 views

Redirecting any CM page URL to Experience Editor mode

I am on Sitecore 9 update 1 , XP1 topology-Azure PaaS environment. I am looking for an option of redirecting any Content Management URL to Experience Editor mode. It will redirect login if not logged ...
1
vote
2answers
339 views

Chrome icon coming for pdf's in media library instead of PDF icon

When I tried to upload a pdf file in Media library I am getting chrome symbol as icon instead of pdf icon. I tried in vanilla instance where everything works fine. I checked the template's icon and it ...
4
votes
1answer
402 views

How to refresh prefetch cache?

How prefetch cache update its cached item, If I change the content of Sitecore item? And also other ways of prefetch cache refreshing?
1
vote
3answers
4k views

How to differentiate between CD and CM?

What are the steps to easily identify which environment is configured for CD and CM? Suppose you are given with number Sitecore servers and you want to find out which one is being configured as. For ...
2
votes
2answers
101 views

Are there any differences between Sitecore update version vs patching?

Does anyone know whether the terms patching and update version mean the same thing? Also is there a resource somewhere I would get notified when there is a patch available? In other words, how could I ...
0
votes
1answer
55 views

CD site setup for one country / subset of languages

Planning to setup 2 new CD servers which contain only French and English language pages. All other language versions should not exist in new web db. I took the existing web db backup and setup site ...
1
vote
0answers
240 views

Search filter for Year on a date field in template

I am using Sitecore 9.0.1 with SXA components. I have checked the SXA out of the box components for search functionality. For date fields, we have date range by which we can filter items in a specific ...
1
vote
1answer
310 views

Save popup message is frequently shown in Sitecore [closed]

I have added values in few fields across 400+ items in the Sitecore programmatically. After creating all the items in the Sitecore master database, I am getting this message when I click on each one ...
3
votes
1answer
239 views

How to provide custom info messages in Sitecore Preview Mode

I am trying to add a custom notification message to display in the preview mode in Sitecore 8 for a particular item. I have done some digging and found you can create custom notification message ...
2
votes
0answers
257 views

Video Media item is not loading as per language query string parameter?

I have created media item and uploaded two different video in "English" and "Spanish" version. When accessing this media item, it is not loading the video as per the query string parameter, please ...
0
votes
2answers
277 views

Subpage of website cannot be edited in Experience Editor

I seem to have a weird problem with my dummy website. I am learning about Sitecore via their e-learning tutorials, and currently have a front page with sub page. The problem is with the sub page, ...
6
votes
1answer
577 views

Content Editor showing “failed to load resource: Request timeout” in Safari only

My Sitecore instance is showing an error "failed to load resource: Request timeout" for some items in safari browser only. Same items perfectly opens in other browsers. Is there any external setting I'...
2
votes
1answer
683 views

What is the allowed Max Length for a Rich Text Field on Sitecore 7.2?

I was asked to implement a new page, Privacy Policy page, I decided to use Sitecore rather than create a whole new outside application. Thus, I picked a similar page that content editors were using ...
1
vote
2answers
336 views

Modifying the default text displayed in a field when it's empty [Experience editor]

In the experience editor, there is a default text displayed when one clears the text : [no text in field]. Is there a possibility to customize this text and eventually have one different for each ...
2
votes
1answer
725 views

Could not resolve type name error while performing search in Sitecore in Content tree

After logging to the Sitecore content tree, getting the below error while performing the search. An error occured while searching. Rephrase the query. Could not resolve type name: Sitecore....
1
vote
1answer
382 views

Media Library search functionality shows only on blank image fields

We are using Sitecore 8.2 Initial Release for one of customer. We have one simple question about the media library search. Whenever we click on browse button to select an image (when image field is ...
3
votes
1answer
738 views

Experience Editor Ribbon 'siteName' error

I have deployed a simple Sitecore 9 website in Azure PaaS. There's nothing so special about the code as it is only a newsletter sign up with Personalization. It works well, I can personalized my ...
5
votes
1answer
488 views

Which content security policy header settings are compatible with Sitecore?

Reading up on Content Security Policy (CSP) headers, there are a few that look like they might break the Sitecore Content Editor and Experience Editor, if implemented on the Content Management server. ...
2
votes
2answers
108 views

removing historical data from workflow history

When viewing the workbox for a client install i can see a lot of workflow activity stretching back years. This is not needed now and was wondering whether there is a way to delete all workflow ...
6
votes
1answer
422 views

How to ensure two scheduled tasks won't run in parallel

It looks like out of the box Sitecore is able to prevent the same scheduled task from running simultaneously if a previous run hasn't finished yet (time interval between runs is less than time ...
1
vote
1answer
188 views

Edit tab selected by default

When I click on an item in the Sitecore tree, the right hand pane has an Edit tab displayed by default, rather than the Content tab. In the past when we didn't have this problem, we'd be able to ...
3
votes
1answer
215 views

Is it possible to revoke access of item from all roles at once without looping?

Consider below case for this example. Content Tree: Home A1 A1B1 A1B1C1 A1B1C2 A1B2 A2 Roles: RoleA1 - Having access of item A1 and ...
1
vote
2answers
421 views

updated standard value not being published

I have a item created against a template with some standard values. I have updated one of the standard value fields in the template with some data and can see the change in the item and other items ...
6
votes
1answer
332 views

Buggy UI when choosing icons in CE on Chrome/Firefox with Sitecore9u1

Is it just in my installation or overall that ribbon Configure and button Icon are behaving incorrectly on Chrome and Firefox in Sitecore 9 Update 1? Dialog box is hidden behind content tree: I need ...
2
votes
2answers
1k views

rel=“noopener noreferrer” get automatically added on other content when we add new link with target equals to blank in RTE

Sitecore 8.2 update 4 We've been editing some pages, and noticing that rel="noopener noreferrer" get's added into text. I understand that, it's good to have it added to _blank links. But it's being ...
4
votes
1answer
462 views

Change sort order of Duplicate sitecore item

My requirement is to place newly created item on top. So I changed Sort order of newly created item programmatically using item:added event. It works fine for when I create new item but not work when ...
0
votes
2answers
380 views

Store media item in Sitecore somewhere else instead of Media Library

Is this possible to store Media items in some other Content tree node in place of Media Library?
2
votes
2answers
3k views

How to get MultiList selected items in SOLR search

In a project, I have implemented SOLR search. I am able to get Items from search, based on template name. In a scenario,I have to get items using Search from a MultiList field which are selected. ...
2
votes
2answers
635 views

Experience analytics and Profile icon missing on launch pad

I have Sitecore Version 8.2 .After the plain installation Experience Analytics,FEM , Experience Profile are seen initially at the launch pad of the Sitecore. But after installing the Projects into ...
0
votes
1answer
451 views

Non-admin user facing issue while accessing Sitecore items

We are getting below error while login as non-admin user and accessing the Sitecore items "The security settings for the current language prevent you from seeing this item. To continue, select ...
3
votes
1answer
1k views

Tracker.Current is not initialized in Sitecore [duplicate]

I have created a Sitecore instance and Synced the code from TFS server using TDS. While accessing the Items from Sitecore Content Editor ,the following error occurs. [InvalidOperationException: ...
2
votes
0answers
180 views

Sitecore experience editor throws error when saving datasource number field

I've created a config item with a number field (without validation rules), I've added a rendering to my page with this config as datasource. When I edit the item in the Content Editor, everything is ...
4
votes
2answers
1k views

Sitecore 8.2 Rich Text Editor drop down items

In the RTE in Sitecore 8.2 Update 6, I can see one of the definitions for a drop down in the Core database is for "FormatBlock" which displays a set of css classes in a drop down box. Can anyone ...
4
votes
0answers
592 views

Sitecore 8.2 unlock item / unlock all items error

We're facing an issue on the Unlock all functionality. PS: The unlock only works after Saving the item (Once we have activated the unlock after saving property). If we click on the unlock button, ...
3
votes
0answers
326 views

What Sitecore Client Languages are available?

I was now wondering what the definitive list of Sitecore Client Languages actually is. By default, my own answer would be English, Danish, German and Japanese. However I found this: https://dev....
1
vote
1answer
791 views

Unable to load CMS. Request timeout error

My local instance suddenly stopped working today. The CMS or the live site just doesn't load. When I tried to open it using SIM, it has this log. No changes done to web.config or connection strings. ...
6
votes
1answer
208 views

How to remove [unknown page] in Sitecore analytics

I would like to know how to remove the [unknown page] part in the Sitecore analytics dashboard? I am pretty much sure that they are internal api calls and google tracking etc, it´s displaying unwanted ...