Questions tagged [sitecore-install-framework]

For questions relating to the Sitecore Install Framework introduced in Sitecore 9.

Filter by
Sorted by
Tagged with
0
votes
1answer
40 views

Install Sitecore 10.1 via SIF Skip

I'm trying to install a fresh installation of Sitecore Experience Platform 10.1 Update-1, as part of my setup I wish to Skip a task or maybe more. According to the documentation at https://dev....
0
votes
1answer
54 views

A parameter cannot be found that matches parameter name 'CertificateName'

I am trying to install Sitecore 9.0.2 in the local but when I try to install it using PS script I get below error (in screenshot) in the starting itself while running the command Install-...
1
vote
2answers
63 views

Sitecore commerce 10.1 installation error 503 service is unavailable

While installing Sitecore 10.1 commerce. I am getting attached error “HTTP 503” The Service is unavailable The above error came while the script attempts to call BootStrapping Commerce Services: https:...
0
votes
0answers
38 views

Installing Sitecore 10.1 using SIF: getting error_SQL_execution_failure for XP scaled

Trying to install sitecore 10.1 xp on scaled environment. Installed fine for single XP install. Install runs fine until it creates marketing database and gets this error: Info: Update complete. Info: ...
0
votes
1answer
40 views

Sitecore 9.0.1 installation is failing with Solr 6.6.3

I already have 2 instances running on my machine with Solr version 6.6.2 for POC purpose I am installing Sitecore 9.0.1 instance with Solr version 6.6.3.Solr is installed using the powershell script ...
0
votes
1answer
36 views

Configuration options for xConnect when installing Sitecore 10 XP1 using Sitecore Installation Framework (SIF)

My question is related to the configuration of SIF installation scripts for the xConnect component. There are some options within the example XP1 topology scripts for which I need some additional ...
0
votes
1answer
56 views

Sitecore 9.3.0 and Sitecore 10.0.0 installation fails - XConnect errors

I'm trying to install Sitecore 9.3.0 & Sitecore 10.0.0 in my local machine and both the installations fail with the same error. Tried with both the set.exe & the SIM tool. Did not change any ...
0
votes
1answer
164 views

“validation script for the argument with value ”.\createcert.json“ did not return a result of True.” error while installing Sitecore 10.1

I am trying to install Sitecore 10.1 through SIF but I am getting the below exception.. Cannot retrieve the dynamic parameters for the cmdlet. Cannot validate argument on parameter 'Source'. The &...
0
votes
1answer
55 views

Sitecore 9.3 - Can we allow unsigned Certificate during Installation and still run the Marketing automation service

I am trying to install Sitecore 9.3 using the PowerShell scripts "XP0-SingleDeveloper.ps1". The script stops the installation and throws error on starting the Marketing Automation service. ...
1
vote
2answers
210 views

Sitecore 9.3 Identity Server Redirects to 404

I configured a content management server with Identity server. Accessing the CM server takes me to the Identity server correctly, but after logging it redirects me to https://cm-sitecore93.test.com/...
0
votes
0answers
20 views

Sitecore 9.3 XP0 installation error - XConnectXP0_CleanShards [duplicate]

I have already installed prerequisites but getting below error. Some details: SQL Server version - 2017 Sitecore version - 9.3 Onprem Error: [---------------------------------------------------------...
1
vote
2answers
264 views

Sitecore 9.3 installation security error

Has anyone faces this error while installing sitecore using the GUI interface? Security error. Security error. Security error. Security error. ************************************...
0
votes
0answers
257 views

ERROR: Exception when executing agent aggregation/aggregator( Execution Timeout Expired)

I'm getting Execution Timeout Expired I tried below with no chance : increase the time out on the connection string. Set ping enabled to false. Set the Ping Maximum Response Time (seconds) to a large ...
1
vote
0answers
55 views

USE statement is not supported to switch between databases. Use a new connection to connect to a different database

I'm attempting to install xConnect OnPrem with Azure SQL. I've updated the create user scripts with the following - GO CREATE USER [PlaceHolderForUser] WITH PASSWORD = 'PlaceHolderForPassword'; GO ...
2
votes
2answers
577 views

Sitecore 9.3 Installation issues - SSL/TLS - Solr 8.1.1

I am trying to install Sitecore 9.3 using Solr 8.1.1, I am facing issues with Transport Layer Security [TLS 1.2] Error Message - The request was aborted: Could not create SSL/TLS secure channel. When ...
0
votes
1answer
37 views

Are there any JSS deploy events to which I can tap my custom code?

Just looking if there are any events that are triggered while doing jss deploy?Similar to the other events item:copied packageinstall:ended ...etc
1
vote
1answer
219 views

SIF cannot be installed or updated because the authenticode signature of the file is not valid

I'm trying to install SIF module using PS command. But unfortunately I could not succeed in doing so. PS Version: 5.1 Please refer below snap shot for error details -
0
votes
1answer
85 views

Get-Module SitecoreInstallFramework empty

After putting files of Sitecore Framework in C:\Users\<user>\Documents\WindowsPowerShell\Modules, running Get-Module SitecoreInstallFramework –ListAvailable, returns empty.
2
votes
2answers
185 views

Sitecore 9.2 installation Certificate issue fail (importing PFX file) [closed]

While I'm installing Sitecore 9.2.0 rev. 002893. I've reached step 29 where an error occurs: [------------------------------------------------------------------------------------------ ImportRootCert ...
0
votes
2answers
82 views

SOLR connection issue while installing Sitecore 9.1.1 [closed]

While installing sitecore 9.1.1, getting solr connection issue even Solr is Connecting porperly.
0
votes
1answer
149 views

Failed to start Marketing Automation service

I've an issue in installing Sitecore 9.2 in a machine where Sitecore is getting installed for the first time. On the middle of the installation, I'm getting Failed to start Marketing Automation ...
3
votes
1answer
182 views

Issue while installing horizon “Exception calling Set Access Rule with 1 argument” [closed]

I am installing Horozon. While installing at step "SetPermission : FilePermission" I am getting following exception [------------------------------------------ SetPermissions : FilePermissions -------...
1
vote
1answer
123 views

Sitecore certificates validity expired

My Sitecore certificates are expired due to this all my instances content editor are down and showing below error As suggested in the blog, I have created a new certificate for ...
2
votes
0answers
269 views

SIA installer missing SIF Configuration

SIA is not able to validate my install do to not having SIF configuration checked off on validation page, everything else installs with not issues and the log files are empty after letting SIA install ...
1
vote
2answers
423 views

Method not found: 'Void Sitecore.Mvc.Pipelines.Response.GetPageItem.GetPageItemProcessor..ctor(Sitecore.Abstractions.BaseClient)'

In Sitecore Experience Accelerator 1.9.0 rev. 190528 for Sitecore 9.2 getting below error: [MissingMethodException: Method not found: 'Void Sitecore.Mvc.Pipelines.Response.GetPageItem....
2
votes
2answers
620 views

How to link Sitecore 9.2 and SOLR running on Azure App service

I have installed SOLR 7.5 on Azure App service and this SOLR instance is running fine. Now I have installed Sitecore 9.2 through Azure Sitecore marketplace and mentioned this SOLR url as a search ...
3
votes
1answer
4k views

Solr Error - Error opening new searcher

Please let me know if you need any more information from my side. Attached Screenshots. I am new to Solr and Solr Indexing. Getting error on the master index after opening the Solr URL. I have ...
0
votes
1answer
486 views

SIF exception - Cannot validate argument on parameter 'Path' [duplicate]

while installing Sitecore 91 (solr 7.2.1 running as windows service), SIF is throwing below exception. [ XConnectXP0_CreateShardApplicationDatabaseServerLoginS... : Command ---------------------------...
2
votes
1answer
826 views

Failed to start service 'Sitecore XConnect Search Indexer - local.xconnect-IndexWorker

Hi I am trying to install Sitecore 9 using SIF and a PowerShell script provided with the ELearning Sitecore 9 developer foundations. I've had quite a few issue during this including getting Solr 6.6.2 ...
1
vote
1answer
530 views

Login failed for user 'sa'. Reason: Failed to open the explicitly specified database 'demo_Processing.Pools'. [CLIENT: <local machine>]

I'm trying to install Sitecore 9.2 initial- XP single on my local machine using Sitecore Install Assistant. I installed all the prerequisites through SIA without any error but when I try to install ...
1
vote
0answers
54 views

Error - ScriptHalted while installing Sitecore XC 9.1.0

I'm running into the following error when I try to install Sitecore Experience Commerce 9.1.0. Previously, I had an error stating that "Services are not available at this time". Restarting my ...
1
vote
1answer
110 views

9.1.1 CM Install stops when import key fails

Ok so for our 9.1.1 XP1 installation, so far we have the following roles installed: For xConnect/xDB server: XConnectCollection XConnectCollectionSearch XConnectReferenceData QA....
0
votes
1answer
380 views

Certificate Issues during Sitecore 9.2 install with SIF 2.1.0: missing “SitecoreIdentityCert” from script config?

I have already read this question, that describes a problem similar to mine but not the same none the less. I have the following Powershell output when I try to run IdentityServer.json script using ...
2
votes
3answers
749 views

msdeploy.exe : Error: .Net SqlClient Data Provider: Invalid object name 'Blobs'

I'm trying to install Sitecore Commerce v9.2. I had a few issues that I solved earlier. However, right now I'm getting a database error. When I check the database I can see two new Commerce ...
2
votes
1answer
331 views

Failed to start service Sitecore XConnect Search Indexer [closed]

I'm facing this issue when trying to install my first XP 9.2 instance using Sitecore Install Assistant: [XConnectXP0_StartServices ]:[Updating] jss-sc920xconnect.dev.local-IndexWorker Waiting for ...
3
votes
2answers
1k views

Certificate error installing Sitecore Experience Commerce 9.0 u3 using SIF 2.0.0

I'm trying to install Sitecore Experience Commerce 9.0 u3 (already installed Sitecore 9.0 u2) using SIF 2.0.0. I keep getting the following certificate errors: Creation and startup of the ...
1
vote
2answers
466 views

Sitecore installation error - Dacpac file path: Instance failure. System.InvalidOperationException:

I'm trying to install Sitecore v9.1 update 1 with Sitecore SIF. I did install all the prerequisites. Everything looks fine. Also the script does install 7 databases (like MarketingAutomation, ...
0
votes
2answers
710 views

Installation Sqlcmd: Error - The client cannot connect to the server because the requested instance was not available [duplicate]

I'm trying to install Sitecore 9.1 Update 1 on my local machine. The script actually installs 7 databases like (MarketingAutomation, Messaging, Reporting), however when it comes to Sitecore databases ...
1
vote
2answers
124 views

How can I update a Sitecore XML patch file using SIF?

I want to leverage SIF with the Set-Xml task to update the value in the datafolder.config patch file. But so far it seems I am not succeeding in finding the correct XPath due to the XML NS in the file....
0
votes
1answer
135 views

NotFound exception creating Solr cores on installation

I've installed Solr 7.5 successfully. I am using SIA (Sitecore Install Assistant) for my installing Sitecore 9.2.0. I am getting exception "NotFound - https://solr75:8750/solr//admin/cores?action=...
5
votes
3answers
598 views

Install Sitecore 9.2 errors on Waiting for service 'Sitecore Marketing Automation Engine to start

Whilst trying to install Sitecore 9.2 using either SIF or SIA we are seeing both approaches error with: Waiting for service 'Sitecore Marketing Automation Engine - ###-MarketingAutomationService (###-...
0
votes
1answer
291 views

Installation Issue with Sitecore 9 Update 1 XP0 [duplicate]

I am getting below Error in my last Step of SC9.0 Update 1 Installation- What I have already checked:- I have verfied Database server names, credentials etc are all fine/ I have also ensured its as ...
1
vote
1answer
503 views

Why does Sitecore 9.1.1 Prerequisites EnableWindowsOptionalFeature fail?

I am trying to run the prerequisites.json file for a SC 9.1.1 install and I am getting the following error: [----------------------------------------------------------------------------------- ...
0
votes
2answers
84 views

SXC 9.1.1 Installation Error - GenerateCatalogTemplates

I am getting error while installting SXC 9.1.1. It is throwing error at GenerateCatalogTemplates script Generating Catalog Templates ... GET http://sxa.storefront.com/SiteUtilityPages/...
1
vote
2answers
787 views

Sitecore 9, WebDeploy Failure [closed]

EDIT: SEE MY ANSWER BELOW FOR THE FIX. While trying to install Sitecore 9 via the install PowerShell script provided in the "Sitecore® Developer Foundation 9.0" Course, I've ran into the following ...
1
vote
2answers
1k views

Sitecore 9.1 Install Install-SitecoreConfiguration : Cannot retrieve the dynamic parameters for the cmdlet. Unrecognized escape sequence

Trying to install Sitecore 9.1 XP0 version, single Dev. Have Solr service running TLS, able to browse to https://localhost:8984/solr. Certificate for Solr cert in Trusted Root Certificate Store of my ...
1
vote
0answers
263 views

Access is Denied Error in Sitecore 9.1 Update 1 installing

All I am Getting following error when I am trying to Install Sitecore 9.1 update 1. > This command cannot be run due to the error: Access is denied at > \WindowsPowerShell\Modules\...
0
votes
1answer
751 views

“Could not deploy package” error while installing Sitecore 9 update 2 setup on my local enviromment [duplicate]

I am a beginner in sitecore and I am facing the below error while setting up sitecore on my local environment [----------------------------------------------------------------------------------------...
-3
votes
1answer
150 views

Sitecore 9.1.1 upgrade

I have a Sitecore 8.2 project that I'm upgrading to 9.1.1. I installed a fresh insistence of Sitecore 9.1.1 and moved my old project into it. I have it pointing at the old Core, Master, Web databases ...
1
vote
3answers
632 views

Sitecore 9.1 update 1 installation error with Azure SQL database

I'm trying to install Sitecore 9.1 update 1 with `Azure SQL database as a service, I'm getting below error. Please help. > [---------------------------------- XConnectXP0_InstallWDP : WebDeploy > ----...

1
2 3 4 5