Questions tagged [sitecore-install-framework]

For questions relating to the Sitecore Install Framework introduced in Sitecore 9.

21 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3
votes
0answers
28 views

Restoring marketing taxonomies with Sitecore powershell extenstion

I am trying to automate Sitecore upgrade from 8.1 to 9.0.1. In Upgrade steps, There is one step restoring deleted marketing taxonomies, which can easily be done with Url navigation and click button on ...
2
votes
0answers
151 views

SIA installer missing SIF Configuration

SIA is not able to validate my install do to not having SIF configuration checked off on validation page, everything else installs with not issues and the log files are empty after letting SIA install ...
2
votes
2answers
949 views

ERROR_SMO_NEEDED_FOR_SQL_PROVIDER while installing Sitecore 9.1 manually with no internet

Have a question about Sitecore 9.1 installation. I have to create the installation manually without an outgoing internet connection. This means that I have to install also all prerequisites for ...
1
vote
0answers
29 views

USE statement is not supported to switch between databases. Use a new connection to connect to a different database

I'm attempting to install xConnect OnPrem with Azure SQL. I've updated the create user scripts with the following - GO CREATE USER [PlaceHolderForUser] WITH PASSWORD = 'PlaceHolderForPassword'; GO ...
1
vote
0answers
40 views

Error - ScriptHalted while installing Sitecore XC 9.1.0

I'm running into the following error when I try to install Sitecore Experience Commerce 9.1.0. Previously, I had an error stating that "Services are not available at this time". Restarting my ...
1
vote
1answer
69 views

9.1.1 CM Install stops when import key fails

Ok so for our 9.1.1 XP1 installation, so far we have the following roles installed: For xConnect/xDB server: XConnectCollection XConnectCollectionSearch XConnectReferenceData QA....
1
vote
0answers
186 views

Access is Denied Error in Sitecore 9.1 Update 1 installing

All I am Getting following error when I am trying to Install Sitecore 9.1 update 1. > This command cannot be run due to the error: Access is denied at > \WindowsPowerShell\Modules\...
1
vote
1answer
3k views

Error - msdeploy.exe returned a non-zero exit code - (-1)

I'm trying to install Sitecore 9 Update 1 but getting the following error: [---------------------------------------------- InstallWDP : WebDeploy -----------------------------------------------] [...
1
vote
0answers
276 views

XP Scaled (XP1) Sitecore 9.1 distributed (on premises) architecture certificate issues

I have 4 on premises servers. I ran PowerShell XP1 scaled script for distributed installation, I am getting a certificate issue as certificates are getting generated with computer name (system name). ...
1
vote
0answers
350 views

While clicking on an item in Content Editor throws Invalid Certificate exception

Configuring Sitecore 9.0.2 on scaled environment. On the CM environment when we click any of the items related to our website, we see the exception below. Whereas all the Sitecore ootb items in ...
1
vote
1answer
184 views

Shards DB is not created during the installation of xconnect-xp1-collection

During the xconnect-xp1-collection for sitecore 9.1.0, it fails to create the shards db, although the rest are created successfully. I get the following error during the installation: Could not load ...
1
vote
2answers
111 views

Is it possible to edit items via SIF

Installing Sitecore Commerce 9.0.3 with adjusted URLs (changing everything localhost), I made adjustments to the installation process with SIF. For example, I fix the localhost URLs in the Sitecore....
1
vote
0answers
208 views

Can I automate the PowerShell Extension package installation?

Is it possible to automate the installation of the package that everybody is using to automate the other packages installation? My goal would be having a script which I can use to install SPE on a ...
1
vote
0answers
126 views

Powershell script fails on trying to start website when installing the Sitecore 9.0.1

My powershell script fails when I try to run it on the Azure VM. The local installation passes successfully. Any help is appreciated :) > [-------------------------------------------- ...
1
vote
0answers
320 views

Problems installation Sitecore 9 Commerce XC

I am currently trying to install Sitecore Commerce 9 XC On-Premise locally, and seem to have some problems with the installation script. I am getting this error message during the installation ...
1
vote
0answers
243 views

Cannot read property 'context' of undefined - Sitecore 9

I am trying to build a baisc application on Sitecore 9.0 Update -1 - JSS. This is a vanilla installation. I installed Sample JSS file and ran the following command. jss deploy package --...
0
votes
1answer
141 views

SIF cannot be installed or updated because the authenticode signature of the file is not valid

I'm trying to install SIF module using PS command. But unfortunately I could not succeed in doing so. PS Version: 5.1 Please refer below snap shot for error details -
0
votes
1answer
58 views

Get-Module SitecoreInstallFramework empty

After putting files of Sitecore Framework in C:\Users\<user>\Documents\WindowsPowerShell\Modules, running Get-Module SitecoreInstallFramework –ListAvailable, returns empty.
0
votes
0answers
164 views

Sitecore 9.3.0 rev. 003498 (Setup XP0 Developer Workstation rev. 1.1.1-r4) SIF installation fails

SIF installation fails using the installer Sitecore 9.3.0 rev. 003498 (Setup XP0 Developer Workstation rev. 1.1.1-r4) setup.exe. Below error in log Unable to download the list of available ...
0
votes
1answer
583 views

Install-SitecoreConfiguration : CertEnroll::CSignerCertificate::Initialize: Cannot find object or property. 0x80092004 (-2146885628 CRYPT_E_NOT_FOUND)

I'm trying to install Sitecore Experience Commerce 9.0 u3 (already installed Sitecore 9.0 u2) using SIF 2.0.0. I keep getting the following certificate errors: Creation and startup of the ...
0
votes
0answers
72 views

Sitecore 9.0.1 installation stalls during step 10

I'm getting blocked during step 10 when trying to install a Sitecore 9.0.1 instance locally. I'm using the so famous PowerShell script, by the way. The last few messages I see on the PowerShell ...