Questions tagged [sitecore-install-framework]

For questions relating to the Sitecore Install Framework introduced in Sitecore 9.

Filter by
Sorted by
Tagged with
6
votes
2answers
550 views

How to use SIF to install Sitecore 9.1 instance connected to existing database

I have used SIF to install Sitecore 9.1 and it worked (database is created and everything is working). Now I want to install a new instance of Sitecore 9.1 on another server - without creating a ...
1
vote
1answer
202 views

Package install via the Sitecore Installation Framework

Is it possible to install Sitecore packages (including both items and files) via the Sitecore Installation Framework (SIF) 2.0.0? If this functionality is not available out-of-the-box in SIF, I ...
0
votes
1answer
459 views

Sitecore 9 update 1 Install-SitecoreConfiguration non-zero exit code - (-1) error

Trying to install sitecore 9 update 1 but ended up with the following error. Install-SitecoreConfiguration : Command C:\Program Files\iis\Microsoft Web Deploy V3\msdeploy.exe returned a non-zero exit ...
1
vote
1answer
289 views

Sitecore commerce 9 certificate expired [closed]

I have an instance of sitecore commerce 9.0.1 installed on my local machine. Two days back I found that all the certificates are expired. I created new Self-Signed Certificates and deleted the old ...
1
vote
0answers
276 views

XP Scaled (XP1) Sitecore 9.1 distributed (on premises) architecture certificate issues

I have 4 on premises servers. I ran PowerShell XP1 scaled script for distributed installation, I am getting a certificate issue as certificates are getting generated with computer name (system name). ...
1
vote
1answer
165 views

Sitecore 9.1 Distributed Install Fails on Database Deploy

I am executing a Sitecore 9.1 Distributed Installation but it is failing when xConnectCollection attempts to web deploy databases. I created a SQL Server account with sysadm rights and the SQL Server ...
0
votes
1answer
156 views

Error installation Sitecore 9.1

I tried to install sitecore 9.1 but I got this error so unable to install, please help me
1
vote
2answers
1k views

Sitecore 9.1 xConnect site not working

Background: I am trying to install Sitecore 9.1 XP0 developer topology on my local machine, however, the SIF install fails at task 65 out of 88 with the error message Installation error: Failed to ...
10
votes
2answers
1k views

XP Scaled (XP1) how to validate installed application in each server are correct?

I am trying to install Sitecore 9.1 in distributed (on premises) architecture, I have 4 servers: 1-cd 1-cm 1-solr 1-sql,reporting and processing I tweaked the script to install each separately ...
3
votes
2answers
488 views

Sitecore 9.1 Installation - Skip to particular step

Hi I was installing sitecore 9.1 with SIF. It completed before updatesolrschema. When it was try to access to the below URL, because of proxy issue SIF script failed. I know this was the last step in ...
1
vote
0answers
352 views

While clicking on an item in Content Editor throws Invalid Certificate exception

Configuring Sitecore 9.0.2 on scaled environment. On the CM environment when we click any of the items related to our website, we see the exception below. Whereas all the Sitecore ootb items in ...
1
vote
0answers
191 views

How to run multiple Sitecore 9.x Instances locally? [closed]

I've installed several Sitecore 9.0.2 (XP0) instances locally and went into some issues regarding certificates. I was wondering if anyone had the same issue and how it was solved?
1
vote
1answer
73 views

While installing Sitecore commerce 9 update 3 getting IIS location not found

Install-SitecoreConfiguration : Cannot find path 'IIS:\Sites\xxxx.mysite.name' because it does not exist.
1
vote
1answer
372 views

My sitecore licence got expired. Can I use other sitecore licence in the same sitecore instance

My sitecore(9.1) 60-day trial licence has got expired but i want to use some other active licence with the same instance of the sitecore. Is it possible? if yes, then what are the changes required to ...
0
votes
2answers
2k views

Enable-WindowsOptionalFeature failed when running Prerequisites.ps1

While installing Sitecore 9.1, I'm getting an error when I run Install-SitecoreConfiguration -Path C:\resourceFiles\Prerequisites.json I ran Update-Module SitecoreInstallFramework before installing ...
3
votes
3answers
237 views

What if the xConnect instances are down?

Can someone please suggest that in a scaled Sitecore 9 environment for some reason if the Roles other than CM and CD are down, how the Websites will be impacted? If the xConnect, Marketing ...
0
votes
1answer
39 views

xConnect Instances need to be Anonymous or Windows authentication?

We installed xConnect, Marketing Automation and Reference Data instances in a scaled Sitecore 9.0.1 environment. While accessing the URLs it is asking for the credentials cause the corresponding IIS ...
0
votes
1answer
409 views

Error while running Uninstall-SitecoreConfiguration SIF method

I'm trying to use SIF 2.0 to uninstall a no longer used Sitecore 9.1 instance. This method used to work perfectly with previous versions and I know that for sure since I'm quite a hard user. I don'...
0
votes
1answer
688 views

Certificate error when initializing the XConnect website

The website is loading fine but I can see a lot of exception messages on the log files. Those are all realted to XConnect and certificates as you can see on the below example: Exception: System....
0
votes
1answer
156 views

'Sitecore.SecurityModel.Cryptography.IHashEncryption' from assembly 'Sitecore.Kernel

I have this problem with the instance of the Sitecore. A made a publish from VS project with the same Sitecore.Kernel.dll and Sitecore.Mvc.Dll of the instance. After that I cann't reach anymore the ...
1
vote
1answer
191 views

SIF parameter that determines Solr core prefix

I am having some trouble with correctly configuring the Solr core prefix using SIF. How is the to use Solr core prefix determined in the SIF installation for Sitecore 9? For example, will; Install-...
3
votes
2answers
1k views

What is the default password in Sitecore 9?

Recently I installed Sitecore 9.0 version in my system and after successful installation I tried with Sitecore default credentials (admin/b) but it was not working. But I remember that during ...
1
vote
1answer
184 views

Shards DB is not created during the installation of xconnect-xp1-collection

During the xconnect-xp1-collection for sitecore 9.1.0, it fails to create the shards db, although the rest are created successfully. I get the following error during the installation: Could not load ...
1
vote
1answer
169 views

Sitecore 9.1 Installation blocked at step 87/88 - [UpdateSolrSchema]

The Sitecore 9.1 installation simply stalls at step 87. It doesn't really fail, it just stays there for a long period of time (like 30 minutes last time it happened). All of the sudden, it works and ...
3
votes
3answers
83 views

What is the best approach to spawn a fresh new Sitecore 8x instance automatically?

We are currently developing a Sitecore package and we have a few automated functional/integration tests as part of this project. Ideally, every time a developer pushes its code to the trunk our CI/CD ...
1
vote
2answers
111 views

Is it possible to edit items via SIF

Installing Sitecore Commerce 9.0.3 with adjusted URLs (changing everything localhost), I made adjustments to the installation process with SIF. For example, I fix the localhost URLs in the Sitecore....
1
vote
0answers
208 views

Can I automate the PowerShell Extension package installation?

Is it possible to automate the installation of the package that everybody is using to automate the other packages installation? My goal would be having a script which I can use to install SPE on a ...
3
votes
3answers
956 views

Solr Start Service not working

I am was trying to install Solr. I have followed all the steps specified. But I am getting an error in power shell like this below.Could you please let me know what must have went wrong. Thanks in ...
0
votes
0answers
72 views

Sitecore 9.0.1 installation stalls during step 10

I'm getting blocked during step 10 when trying to install a Sitecore 9.0.1 instance locally. I'm using the so famous PowerShell script, by the way. The last few messages I see on the PowerShell ...
2
votes
3answers
832 views

Sitecore 9.1 installation error : “Notfound issue solr creating core ”

I am installing Sitecore 9.1 with SIF and I am using Solr 7.2.1 version. installation fails due to the below error. Below my error in Powershell: [-------------------------------------------------...
3
votes
1answer
516 views

Error while installing Sitecore 9 update 2 on the same computer that has a 9.1.0 installation

Sitecore 9.1 is already installed on the computer. SitecoreInstallFramework 1.2.1 and 2.0.0 are also installed. I am trying to use SIF 1.2.1 version in order to install Sitecore 9 update 2. I am ...
3
votes
3answers
2k views

9.1 Powershell Install Solr Connection Issue

I am running the XP1-SingleDevloper.ps1 and it is choking when trying to connect to the solr url. If I hit https://solr:8983/solr in a browser it comes up just fine. Thoughts on why it isn't able to ...
1
vote
2answers
499 views

xConnect Installation - Updating Solr Schema for xdb is failing

We have upgraded our Sitecore solution from 8.2.4 to 9.0.2 using the guidelines from the Upgrade Guide. Now we are in progress with preparing the xDB data migration. Using the following script to ...
4
votes
1answer
509 views

Installing Sitecore 9 With Solr on Linux

I am having a hard time getting Sitecore 9 (SIF 2.0) installed where Solr is on a remote Linux box. Basically I have removed the steps in the install powershell script that creates the solr cores ...
2
votes
2answers
634 views

MarketingAutomationService times out during Sitecore 9.1 install with SIF

Background Info: I am trying to install Sitecore 9.1 initial release with SIF. I want to install it on my development machine with the XP0 topology. I have been trying to use the XP0-SingleDeveloper....
4
votes
1answer
3k views

Sitecore 9.1 and Identity Server

I install Sitecore XP 9.1 using SIF but identity server doesn't work. If I delete the IIS site for it I can still log into Sitecore. Nothing in log for Sitecore or identity server. Anyone help?
4
votes
3answers
838 views

Sitecore 9.1 Installation Error

The installation for Sitecore 9.1.0 is stuck at step number 50. This is what I get in the System Event Logs as 3 separate errors. Errors were encountered in the procedure 'dbo....
4
votes
1answer
148 views

What if we don't want to use the EXM Module on Sitecore 9?

We are configuring Sitecore 9.0.2 in a scaled environment and we don't have plans to use the EXM Module. We know how to disable the EXM module but in that case which all roles can be ignored on ...
0
votes
1answer
534 views

Installing CM and CD - binding [closed]

I am new to sitecore so my understanding of the solution is very limited. Anyway i am currently trying to install the following Sitecore XP1 topology : CD1 and CD2 (content delivery servers) CM1 (...
2
votes
2answers
2k views

Sitecore 9.1 Prerequisites check: No registration found for extension 'if' of type 'ConfigFunction' exception

I have successfully installed Sitecore 9.1 (XM topology) locally (Windows 10). But when I tried to install the same instance on Test environment (Windows Server 2016) I have encountered the following ...
3
votes
0answers
28 views

Restoring marketing taxonomies with Sitecore powershell extenstion

I am trying to automate Sitecore upgrade from 8.1 to 9.0.1. In Upgrade steps, There is one step restoring deleted marketing taxonomies, which can easily be done with Url navigation and click button on ...
8
votes
2answers
4k views

Installation with SIF error. “You must remove all users with password before setting the containment property to NONE”

I am getting the following error when I attempt to install Sitecore 9.1 (initial release) with SIF (v2.0.0). (Note this IS after some failed installs, but I believe I have removed everything to do ...
20
votes
3answers
5k views

Installing 9.1 XP0 - Sorry, there was an error : unauthorized_client

After installing 9.1 I see the following error on the login screen: Steps I followed: Updated XP0-SingleDeveloper with ".dev.sc.local" to the site names Ran the installation using XP0-...
1
vote
1answer
445 views

Get-CimInstance : Invalid namespace while installing Sitecore 9.1

While running .\XP0-SingleDeveloper.ps1 at task 39 I am getting the error below: [-------------------------- XConnectXP0_RemoveServices [1] : RemoveService ----------------------------------------...
0
votes
1answer
431 views

Sitecore 9 XP1 Installation with xDB on separate SQL Server

We are in process of setting up the Sitecore 9.0.2 scaled environment for our upgrade from 7.2. On current production setup on 7.2 we have Analytics DB on a separate SQL Server than Core, Master, Web ...
2
votes
1answer
126 views

Installing SC 9.0.2 with SIF and Remote Solr Server with Self-Signed Certificate

I am Installing SC 9.0.2 with SIF and a Remote Solr Server with Self-Signed Certificate. i have split the script up as found here: https://tothecore.sk/2018/04/19/installing-sitecore-9-xp0-with-solr-...
2
votes
2answers
955 views

ERROR_SMO_NEEDED_FOR_SQL_PROVIDER while installing Sitecore 9.1 manually with no internet

Have a question about Sitecore 9.1 installation. I have to create the installation manually without an outgoing internet connection. This means that I have to install also all prerequisites for ...
11
votes
1answer
3k views

SIF 2.0.0 on SC 9.0.2 - “The operation is on user root store and UI is not allowed”

After the release of SIF 2.0.0, an automated SC 9.0.x script began failing with the error: The operation is on user root store and UI is not allowed. This error occurs during the execution of ...
4
votes
3answers
3k views

Unable to uninstall Sitecore 9.1 and getting “No registration found for extension 'RemoveSQLDatabase' of type 'Task'”

I was following Quick Installation Guide available here to uninstall my fresh Sitecore 9.1 instance. It says in chapter 4.2. Uninstall the XP Single topology this: To uninstall any of the Sitecore ...
0
votes
1answer
634 views

Install Sitecore 9.1 Cannot validate argument on parameter 'DnsName' - parameter doesn't exist in the json config

I run in this error by run Install-SitecoreConfiguration -Path createcert.json. The json file is from the xp0 package and it contains no parameter DnsName. I just found a variable like this: "...