Skip to main content

Questions tagged [sitecore-install-framework]

For questions relating to the Sitecore Install Framework introduced in Sitecore 9.

Filter by
Sorted by
Tagged with
0 votes
1 answer
70 views

xConnect Instances need to be Anonymous or Windows authentication?

We installed xConnect, Marketing Automation and Reference Data instances in a scaled Sitecore 9.0.1 environment. While accessing the URLs it is asking for the credentials cause the corresponding IIS ...
Rathan M's user avatar
  • 361
0 votes
1 answer
675 views

Error while running Uninstall-SitecoreConfiguration SIF method

I'm trying to use SIF 2.0 to uninstall a no longer used Sitecore 9.1 instance. This method used to work perfectly with previous versions and I know that for sure since I'm quite a hard user. I don'...
Hugo Santos's user avatar
  • 2,311
0 votes
1 answer
1k views

Certificate error when initializing the XConnect website

The website is loading fine but I can see a lot of exception messages on the log files. Those are all realted to XConnect and certificates as you can see on the below example: Exception: System....
Hugo Santos's user avatar
  • 2,311
0 votes
1 answer
241 views

'Sitecore.SecurityModel.Cryptography.IHashEncryption' from assembly 'Sitecore.Kernel

I have this problem with the instance of the Sitecore. A made a publish from VS project with the same Sitecore.Kernel.dll and Sitecore.Mvc.Dll of the instance. After that I cann't reach anymore the ...
Po Po's user avatar
  • 111
1 vote
1 answer
311 views

SIF parameter that determines Solr core prefix

I am having some trouble with correctly configuring the Solr core prefix using SIF. How is the to use Solr core prefix determined in the SIF installation for Sitecore 9? For example, will; Install-...
Joost's user avatar
  • 1,907
3 votes
2 answers
3k views

What is the default password in Sitecore 9?

Recently I installed Sitecore 9.0 version in my system and after successful installation I tried with Sitecore default credentials (admin/b) but it was not working. But I remember that during ...
BV Winoya's user avatar
  • 159
1 vote
1 answer
359 views

Shards DB is not created during the installation of xconnect-xp1-collection

During the xconnect-xp1-collection for sitecore 9.1.0, it fails to create the shards db, although the rest are created successfully. I get the following error during the installation: Could not load ...
Mohamed Wali's user avatar
1 vote
1 answer
306 views

Sitecore 9.1 Installation blocked at step 87/88 - [UpdateSolrSchema]

The Sitecore 9.1 installation simply stalls at step 87. It doesn't really fail, it just stays there for a long period of time (like 30 minutes last time it happened). All of the sudden, it works and ...
Hugo Santos's user avatar
  • 2,311
3 votes
3 answers
106 views

What is the best approach to spawn a fresh new Sitecore 8x instance automatically?

We are currently developing a Sitecore package and we have a few automated functional/integration tests as part of this project. Ideally, every time a developer pushes its code to the trunk our CI/CD ...
Hugo Santos's user avatar
  • 2,311
1 vote
2 answers
157 views

Is it possible to edit items via SIF

Installing Sitecore Commerce 9.0.3 with adjusted URLs (changing everything localhost), I made adjustments to the installation process with SIF. For example, I fix the localhost URLs in the Sitecore....
Lars-Pascal Körber's user avatar
1 vote
0 answers
342 views

Can I automate the PowerShell Extension package installation?

Is it possible to automate the installation of the package that everybody is using to automate the other packages installation? My goal would be having a script which I can use to install SPE on a ...
Hugo Santos's user avatar
  • 2,311
3 votes
3 answers
3k views

Solr Start Service not working

I am was trying to install Solr. I have followed all the steps specified. But I am getting an error in power shell like this below.Could you please let me know what must have went wrong. Thanks in ...
Deepti's user avatar
  • 51
0 votes
0 answers
110 views

Sitecore 9.0.1 installation stalls during step 10

I'm getting blocked during step 10 when trying to install a Sitecore 9.0.1 instance locally. I'm using the so famous PowerShell script, by the way. The last few messages I see on the PowerShell ...
Hugo Santos's user avatar
  • 2,311
2 votes
3 answers
2k views

Sitecore 9.1 installation error : "Notfound issue solr creating core "

I am installing Sitecore 9.1 with SIF and I am using Solr 7.2.1 version. installation fails due to the below error. Below my error in Powershell: [-------------------------------------------------...
Andi AR's user avatar
  • 763
3 votes
1 answer
1k views

Error while installing Sitecore 9 update 2 on the same computer that has a 9.1.0 installation

Sitecore 9.1 is already installed on the computer. SitecoreInstallFramework 1.2.1 and 2.0.0 are also installed. I am trying to use SIF 1.2.1 version in order to install Sitecore 9 update 2. I am ...
Dheer Rajpoot's user avatar
3 votes
3 answers
3k views

9.1 Powershell Install Solr Connection Issue

I am running the XP1-SingleDevloper.ps1 and it is choking when trying to connect to the solr url. If I hit https://solr:8983/solr in a browser it comes up just fine. Thoughts on why it isn't able to ...
Colema18's user avatar
  • 321
1 vote
2 answers
1k views

xConnect Installation - Updating Solr Schema for xdb is failing

We have upgraded our Sitecore solution from 8.2.4 to 9.0.2 using the guidelines from the Upgrade Guide. Now we are in progress with preparing the xDB data migration. Using the following script to ...
Aura Petric's user avatar
4 votes
1 answer
845 views

Installing Sitecore 9 With Solr on Linux

I am having a hard time getting Sitecore 9 (SIF 2.0) installed where Solr is on a remote Linux box. Basically I have removed the steps in the install powershell script that creates the solr cores ...
Ethan Schofer's user avatar
2 votes
2 answers
1k views

MarketingAutomationService times out during Sitecore 9.1 install with SIF

Background Info: I am trying to install Sitecore 9.1 initial release with SIF. I want to install it on my development machine with the XP0 topology. I have been trying to use the XP0-SingleDeveloper....
Iceape's user avatar
  • 617
4 votes
1 answer
5k views

Sitecore 9.1 and Identity Server

I install Sitecore XP 9.1 using SIF but identity server doesn't work. If I delete the IIS site for it I can still log into Sitecore. Nothing in log for Sitecore or identity server. Anyone help?
Elton P's user avatar
  • 41
4 votes
3 answers
1k views

Sitecore 9.1 Installation Error

The installation for Sitecore 9.1.0 is stuck at step number 50. This is what I get in the System Event Logs as 3 separate errors. Errors were encountered in the procedure 'dbo....
Naveed Ahmad's user avatar
4 votes
1 answer
231 views

What if we don't want to use the EXM Module on Sitecore 9?

We are configuring Sitecore 9.0.2 in a scaled environment and we don't have plans to use the EXM Module. We know how to disable the EXM module but in that case which all roles can be ignored on ...
Rathan M's user avatar
  • 361
0 votes
1 answer
1k views

Installing CM and CD - binding [closed]

I am new to sitecore so my understanding of the solution is very limited. Anyway i am currently trying to install the following Sitecore XP1 topology : CD1 and CD2 (content delivery servers) CM1 (...
Charly Roch's user avatar
2 votes
2 answers
3k views

Sitecore 9.1 Prerequisites check: No registration found for extension 'if' of type 'ConfigFunction' exception

I have successfully installed Sitecore 9.1 (XM topology) locally (Windows 10). But when I tried to install the same instance on Test environment (Windows Server 2016) I have encountered the following ...
Artem Prashkovich's user avatar
3 votes
0 answers
35 views

Restoring marketing taxonomies with Sitecore powershell extenstion

I am trying to automate Sitecore upgrade from 8.1 to 9.0.1. In Upgrade steps, There is one step restoring deleted marketing taxonomies, which can easily be done with Url navigation and click button on ...
OyeHarish's user avatar
  • 141
10 votes
3 answers
10k views

Installation with SIF error. "You must remove all users with password before setting the containment property to NONE"

I am getting the following error when I attempt to install Sitecore 9.1 (initial release) with SIF (v2.0.0). (Note this IS after some failed installs, but I believe I have removed everything to do ...
Sean Holmesby's user avatar
25 votes
3 answers
8k views

Installing 9.1 XP0 - Sorry, there was an error : unauthorized_client

After installing 9.1 I see the following error on the login screen: Steps I followed: Updated XP0-SingleDeveloper with ".dev.sc.local" to the site names Ran the installation using XP0-...
Michael West's user avatar
  • 18.2k
1 vote
1 answer
2k views

Get-CimInstance : Invalid namespace while installing Sitecore 9.1

While running .\XP0-SingleDeveloper.ps1 at task 39 I am getting the error below: [-------------------------- XConnectXP0_RemoveServices [1] : RemoveService ----------------------------------------...
Dheeraj Palagiri's user avatar
0 votes
1 answer
544 views

Sitecore 9 XP1 Installation with xDB on separate SQL Server

We are in process of setting up the Sitecore 9.0.2 scaled environment for our upgrade from 7.2. On current production setup on 7.2 we have Analytics DB on a separate SQL Server than Core, Master, Web ...
Rathan M's user avatar
  • 361
2 votes
1 answer
288 views

Installing SC 9.0.2 with SIF and Remote Solr Server with Self-Signed Certificate

I am Installing SC 9.0.2 with SIF and a Remote Solr Server with Self-Signed Certificate. i have split the script up as found here: https://tothecore.sk/2018/04/19/installing-sitecore-9-xp0-with-solr-...
Justin Bradley's user avatar
3 votes
3 answers
3k views

ERROR_SMO_NEEDED_FOR_SQL_PROVIDER while installing Sitecore 9.1 manually with no internet

Have a question about Sitecore 9.1 installation. I have to create the installation manually without an outgoing internet connection. This means that I have to install also all prerequisites for ...
aklein's user avatar
  • 211
11 votes
1 answer
4k views

SIF 2.0.0 on SC 9.0.2 - "The operation is on user root store and UI is not allowed"

After the release of SIF 2.0.0, an automated SC 9.0.x script began failing with the error: The operation is on user root store and UI is not allowed. This error occurs during the execution of ...
jrap's user avatar
  • 4,951
5 votes
3 answers
4k views

Unable to uninstall Sitecore 9.1 and getting "No registration found for extension 'RemoveSQLDatabase' of type 'Task'"

I was following Quick Installation Guide available here to uninstall my fresh Sitecore 9.1 instance. It says in chapter 4.2. Uninstall the XP Single topology this: To uninstall any of the Sitecore ...
Peter Procházka's user avatar
0 votes
1 answer
1k views

Install Sitecore 9.1 Cannot validate argument on parameter 'DnsName' - parameter doesn't exist in the json config

I run in this error by run Install-SitecoreConfiguration -Path createcert.json. The json file is from the xp0 package and it contains no parameter DnsName. I just found a variable like this: "...
sklenke's user avatar
2 votes
2 answers
2k views

Getting "Could not load file or assembly 'netstandard'" while installing Sitecore 9.1

I am trying to install Sitecore 9.1 in local environment but i am getting below issues while running the installation script. I have executed the Prerequisite.json too. Has anyone come across below ...
arjunan's user avatar
  • 408
2 votes
1 answer
472 views

Certificate exception while installing another Sitecore 9 instance on same machine

Installing 9.0.0 on a machine already having 9.0.1. Getting below Cert exception: PS>TerminatingError(New-SelfSignedCertificate): "CertEnroll::CSignerCertificate::Initialize: Cannot find object or ...
Amitabh Vyas's user avatar
  • 2,554
2 votes
2 answers
1k views

SIF 2.0 Installation Failed - Invalid Web URI

Recent Sitecore 9.1 Initial Release had launched with SIF 2.0. As per documentation you need to execute following command. Assuming here you are doing first time on your machine. Register-...
Vishu's user avatar
  • 127
13 votes
4 answers
7k views

Install-SitecoreConfiguration : Cannot validate argument on parameter 'Signer'. The "$_.HasPrivateKey -eq $true"

Following this article https://buoctrenmay.com/2018/01/11/playing-with-sitecore-9-0-update-1-installation/comment-page-1/#comment-548 to install Sitecore, got this error on step 13, any idea? [-----...
Naveed's user avatar
  • 131
5 votes
1 answer
639 views

Install XConnect 9 without license file

I would like to install XConnect 9 using SIF without license file. This would, for example, allow me to build a XConnect Docker image and provide the required Sitecore license at runtime. By default ...
Joost's user avatar
  • 1,907
4 votes
3 answers
757 views

Installing Sitecore 9(XP0) on premise with Amazon RDS for SQL Server

I am trying to setup Sitecore 9(XP0) on premise with the SQL Server running on Amazon RDS for SQL Server. Unfortunately it fails when running the scripts to setup the databases: Is there anyone who ...
Nicolas Pottrain's user avatar
2 votes
1 answer
163 views

Installing Sitecore 9.0.2 SIF generates wrong marketingdefinitions_master configuration

After configuring SIF installer for Sitecore 9.0.2 installation as follows # Start Install Import-Module SitecoreInstallFramework $prefix = "foo" ... #install solr cores for sitecore $solrParams = @{...
Ed T.'s user avatar
  • 181
0 votes
3 answers
4k views

While installing Sitecore 9 update 2 got below issue

Windows PowerShell Copyright (C) 2014 Microsoft Corporation. All rights reserved. PS P:\> D: PS D:\> cd sc9_install PS D:\sc9_install> .\sc9_install Install-SitecoreConfiguration : The term '...
user7818776's user avatar
1 vote
1 answer
230 views

Sitecore 9.0 installation Solr exception

I am installing sitecore 9.0 update 2 using SIF. I am getting the follwoing error while accessing SOlr. Transcript stopped, output file is C:\sitecoreinstall\xconnect-xp0.181016 (4).log Invoke-...
Rama Krshna Ila's user avatar
0 votes
1 answer
358 views

Moving whole Sitecore instance to another location using Sitecore 8.2.7

When installing Sitecore instance, I chose a wrong physical path but it was meant to be at a different location. I realized that I get 404 error when I moved whole Sitecore folder (Web and Data, but ...
TestUser's user avatar
  • 375
8 votes
2 answers
5k views

Install-SitecoreConfiguration : The property 'Value' cannot be found on this object

Not really sure where to go from here. Trying to install Sitecore 9 and have gotten to this point and can't seem to get beyond it. It tells me that the property value cannot be found, but I have no ...
JKUNKE's user avatar
  • 81
3 votes
6 answers
2k views

ERROR_SQL_EXECUTION_FAILURE | While installing second instance of Sitecore XP 9.0.2

On my development machine, I had installed Sitecore 9.0.2 months ago and now, for POC purposes, I am trying to install the second instance of Sitecore 9.0.2. While doing that I am facing a strange ...
Niraj Jha's user avatar
4 votes
4 answers
8k views

"Could not deploy package" error while installing Sitecore 9 update 2 setup on Remote server

I am facing below issue while installing Sitecore 9 update 2 on my Azure VM server, which doesn’t have any Visual Studio or SQL Management Studio installed. Error states : Microsoft.Data.Tools.Schema....
Abhishek's user avatar
  • 153
1 vote
1 answer
204 views

Revert "contained database authentication" after Installation XP1

We have installed sitecore XP1 on our Servers and our SQL admin whats to disable the "contained database authentication" after installation because of security issues he was reading in a ...
squadwuschel's user avatar
  • 1,165
0 votes
4 answers
479 views

Sitecore deployment with new modules

We have created out deployment chain from Sitecore and Unicorn with TFS and thats works fine so far. Every time when we deploy a new release we delete the current web folder in the wwwroot from our ...
squadwuschel's user avatar
  • 1,165
1 vote
1 answer
172 views

SC 9.0.2 SIF xConnect Stalls During Web Deploy

Using the following in PS1 script: Import-Module SitecoreInstallFramework $prefix = "bc2018" $PSScriptRoot = "D:\resourcefiles" $XConnectCollectionService = "$prefix.xconnect" $xConnectCertName = "$...
Clay Le Beouf's user avatar