Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

Filter by
Sorted by
Tagged with
0
votes
0answers
4 views

Geofiltering does not work on the Shared site setup using SXA 1.7.0

On the shared site setup,no search results being returned when Geofiltering is applied. On the page load, results are rendered on the page. We noticed the below search query being generated when geo ...
1
vote
1answer
24 views

Install-SitecoreConfiguration : One or more errors returned from Solr request

I have cloned following Habitat project on my local environment: https://github.com/Sitecore/Habitat/ And here is the link stating that solr 7.2.1 is supported https://github.com/Sitecore/Habitat/...
1
vote
0answers
33 views

Error opening new searcher. Solr Core init failures [duplicate]

Our Solr for Sitecore is a master slave setup. Sitecore Solr slave has issues with the Sitecore analytics index and the error message is : Error opening New Searcher. Core is missing. We tried to ...
1
vote
2answers
60 views

Rebuild xDB Index in Solr

I'm attempting to get analytics working on a Sitecore 9.0 install. After various issues with connection strings being wrong, trackers not initialising I've got to a point where I'm fairly sure the xDB ...
0
votes
1answer
21 views

Assigning CA SSL certificate to SOLR

We are trying to install SOLR in a standalone server for a production environment. A client has already installed an SSL server certificate on the Server. I can see it in MMC->Certificates->...
2
votes
0answers
30 views

Non-static method requires a target

Recently migrated from Lucene to Solr search(7.2.1) in Sitecore. When I try to get the search results from Code, I'm getting the exception Non-static method requires a target However, from Solr ...
0
votes
2answers
30 views

Solr Move Cores to another server

While doing a sitecore 9.1 install we installed solr as a part of the CM server. We now want to move SOLR to its own separate server. This is what i did I did a clean install of solr in the new ...
0
votes
1answer
33 views

Method not found: 'Boolean Sitecore.ContentSearch.SolrProvider.SolrContentSearchManager.get_EnableHttpCache()'

After upgrading from Sitecore 8.2 to Sitecore 9.1, which updated the Sitecore.ContentSearch.SolrProvider to v4.0.0.0, the code compiles fine but we get the following when trying to access the site: ...
1
vote
1answer
38 views

Limit search result hits to a specific number with facets to match limited result set

I have a requirement to limit search results to an arbitrary number in a Site Search implementation. Is there a way to accomplish this in a query and get accurate facets relative to the arbitrary ...
0
votes
0answers
38 views

Indexing in Sitecore 9.1 erroring out [duplicate]

We have upgraded our solution to Sitecore 9.1 and Solr is upgraded to 7.2.1. Now while running indexing from index manager I am getting below error for few items: Sitecore.ContentSearch....
2
votes
2answers
59 views

Computed index fields on Sitecore 9.1.1 CD server

I have a custom computedfield in Sitecore 9.1.1. I am getting the below error on CD server only as my web.config has: <add key="role:define" value="ContentDelivery" /> Current CustomIndex ...
1
vote
1answer
63 views

Error opening New Searcher. Core is missing: `Sitecore_Analytics_Index`

Our Sitecore Solr has issues with the Sitecore analytics index and the error message is : Error opening New Searcher. Core is missing. We tried to look in to the error but could not gather much ...
2
votes
1answer
150 views

Solr suggester not returning full name

I migrated the project from Sitecore 8.2 to Sitecore 9.1.1. There was a suggester component that we were using to provide a suggestion for a search term. As part of the migration, I also created a ...
0
votes
0answers
20 views

Bucket search based on branch template name

I am trying to add a custom bucket search type by branch template name. However due to limited documentation I am not able to find out how to do this. I have added a custom search type but it does not ...
0
votes
0answers
30 views

Duplicate item records in SOLR index (web)

We have a strange issue on our UAT environment where duplicate records are being returned for a single content item in a new web index we have created and both are marked with 'latestversion:true' (...
1
vote
1answer
66 views

Sitecore 9.1.1 Solr suggester not returning any data

I have migration from Sitecore 8.2 to Sitecore 9.1.1. I have an issue with suggester not working after Solr migration from 5.1.0 to Solr 7.2.1. I am not getting any suggest results back from the ...
2
votes
2answers
68 views

Solr search query by Datetime.Year

I configured Solr index to the path where I created some articles using templates, templates have the same fields with data type as in below model <Root>/sitecore/content/Articles</Root> ...
6
votes
1answer
52 views

xConnect in a DR scenario

NOTE: In our environment, SQL is cloud hosted. It has its own fail over strategy which is separate from the server/site DR. NOTE: Our DR and Production environments are in different geo zones. We can'...
0
votes
2answers
91 views

Sitecore upgrade to 9.1 not indexing solr fields

I have upgrade my sitecore instance from Sitecore.NET 8.2 (rev. 161221) to Sitecore 9.1 update-1. while running migration I ran into the issue where I had <indexAllFields> in the following ...
0
votes
1answer
33 views

Does Sitecore 9.X will support solr version 8.X [duplicate]

Does Sitecore 9.X will support solr version 8.X? I have to take some strategic decision on that based on that. So, if any body have insight or tried this then please help me.
0
votes
1answer
49 views

What happens to Sitecore - Solr query handling when a core is corrupted in Solr slave in a Master - slave setup?

Our Sitecore's solr search engine is a master-slave setup. One of the cores of the Slave is corrupted and is not available at all in Slave. It is not being replicated from Master too (Expecting ...
4
votes
3answers
106 views

Sitecore 9.0 works with solr 7.2.1?

I have installed Sitecore 9.1.0 XP on my system with Solr 7.2.1. I want to install Sitecore 9.0.1 XP also on my system. Should I use Solr 7.2.1 for this or do I need Solr 6.6.2? Any help is ...
0
votes
1answer
56 views

Where should I put SOLR Autosuggest configurations

I'm using Sitecore 9.1 and SXA 1.8, there are two cores for the master index now , instance_name_sxa_master_index and instance_name_master_index, which index should I put the SXA autosuggester ...
2
votes
1answer
123 views

Wildly inconsistent index data after rebuilds

SC 9.1 SwitchOnRebuildSolrSearchIndex is enabled SOLR 7.2.1 I have 120k items in Sitecore, so I have a good bit of data to sample. When I rebuild my web index, the total number is consistent. But ...
0
votes
1answer
52 views

PDF items are not getting indexed and not listed in multilist with search [closed]

I have upgraded Sitecore 8.1 to 9.1 and now in 9.1 PDF items are not getting indexed and also they are not getting listed in a multilist with search field.
1
vote
1answer
68 views

Boosting in solr vs lucene

I am changing the search engine from lucene to solr , and i want to make config changes in my custom indexes , i am using the search_keywords field for the predictive search , and the field is also ...
1
vote
1answer
74 views

sitecore solr Problem accessing /solr//admin/cores

I'm seeing failure to connect logs for all solr cores they all have problem accessing /solr//admin/cores. reason not found. Here's the thing the /solr//admin/cores page doesn't exists while the /...
2
votes
2answers
81 views

Searching a substring using solr

I am trying to move my code from Lucene to Solr, but am facing an issue. I have 4 fields indexed, all the field are of text_general type (from the managed schema). The code from Lucene is: ...
0
votes
0answers
34 views

Has any one tested Sitecore 8.2 compatibility with Solr 7.2?

Currently, we are using Solr 6.5. We want to upgrade Solr 6.5 to Solr 7.2 to leverage bidirectional replication. But Sitecore has not tested Sitecore 8.2 - Solr 7.2 compatibility. Also, there is no ...
0
votes
0answers
65 views

copyField dest :'__renderings_t_ko_str' is not an explicit field and doesn't match a dynamicField [duplicate]

Getting below error for custom Solr in Sitecore 9.1 when I am trying to rebuild index. Error : copyField dest :'__renderings_t_ko_str' is not an explicit field and doesn't match a dynamicField I am ...
-1
votes
1answer
55 views

date field in solr not indexing proper date from sitecore

i am changing search from lucene to solr and faced an issue in this , i have DateTime a field in sitecore and an item is using that field and have value of now ( DATE -- 4/4/2019 TIME -- 12:00 AM) ...
1
vote
0answers
68 views

Something missing from Sitecore package, how to find out what it is

I've been trying to hand off some content for our developers to test with. However, when they use the installation wizard to install my package, the installation fails. I checked their logs and am ...
0
votes
1answer
26 views

SOLR 5.1 Java Version

Using Sitecore 8.2 Update 6, when I install SOLR 5.1, it updates the JAVA_HOME environment variable to C:\Program Files\Java\jre1.8.0_171, but I haven't got version installed (and doesn't seem to be ...
0
votes
0answers
47 views

When searching with solr sitecore does not search in the right fields

We know that sitecore uses solr dynamic fields so that we don't need to declare all the fields that we have in sitecore separately in the solr schema to get them indexed. In our case we have a ...
0
votes
0answers
33 views

Recipients in EXM count is always 0 [duplicate]

I tried to use EXM in siteore and I uploaded CSV file I already got message that was "Contacts expected to be imported are 2" but "Recipients" are still 0 like in attached Images so I can't complete ...
2
votes
0answers
64 views

Searching the keywords with spaces in solr

I have a search functionality in my project and the code for exactly matched keywords and search all word, the exactly is working fine but not the search all words: if (!searchRequest.SearchType....
3
votes
1answer
340 views

Custom Solr Fields in Sitecore 9 and Solr 7.2.1

I am converting my custom index fields from Sitecore 8.1. Previously, I would declare them like this: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www....
0
votes
1answer
59 views

Solr Basic Auth xDB / Indexer

Working on setting up basic authentication for our Solr instance to help put some form of security for people internally who might accidentally drop an index in production. We're able to pass the ...
0
votes
1answer
62 views

Master/Slave replication and fault tolerance [closed]

I am using solr-7.6 version with Master/Slave config. Being a novice, I do have few question on the solr functionality: 1. What happens when Master will be down? Do i need to make Slave as Master ...
2
votes
1answer
90 views

Index Update Strategy not Firing on Publish End with Custom Publishing Target and Custom Solr Index [duplicate]

We have a prod set up that has one CM and two CDs. The CD servers serve content from a second web database that we call "live". This database is a clone of web. We use web as a staging environment on ...
0
votes
0answers
86 views

Item not removed from SOLR index after unpublish or delete

When I delete or unpublish an item in Sitecore 9.1, it is removed from the web-database and sitecore_web_index, but not from my custom index (Solr 7.2.1), any other update finds its way into the index....
0
votes
1answer
249 views

Sitecore 9.1 upgrade Error loading hook

We're upgrading from Sitecore 8.1 Update 3 to Sitecore 9.1. We use Solr for xConnect search, Lucene for web site search The CM is working, but the CD is not. Got the following error message: Server ...
1
vote
1answer
334 views

Index are not listing in sitecore 9.1

I have installed fresh sitecore 9.1 instance in local environment. There is no issue with installation but i couldn't see any indexes in Index manager. All the configurations are enabled and i even ...
0
votes
0answers
54 views

Solr query works in the web UI, not when invoked though code

I'm on Solr 4.10.4, Sitecore 8.1 160519. I have a query used internally by my application that returns 0 records. In the Search.log I can see that same query; if I copy the querystring value to the ...
3
votes
0answers
59 views

Sitecore Content Search API returns expected results with Lucene as search provider but not with Solr

I'm currently writing a service that needs to integrate with Eventbrite to store external event information as items in Sitecore. We run a Sitecron job every 4 hours to pull in and update the ...
1
vote
0answers
40 views

Sitecore 8.2 Azure Web App / Solr VMs

We are running Sitecore 8.2 as a WebApp on Azure, with this we using Solr on VMs , using along with Zookeeper [3 nodes]. There is odd behavior we are seeing, if we make any configurations on Solr as ...
2
votes
1answer
292 views

Sitecore 9 and custom solr indexes

I'm working with Sitecore 9 and solr 6.2.2. I am trying to create a custom index and in this index I'm only including a few fields. One of the fields is called OfficeLocation and it's a string. When ...
0
votes
0answers
41 views

Page testing is not working when I use SOLR

When I create a page test in Sitecore Experience Optimization for the pages that are stored in SOLR index and then get the page item (which is under the page test) from the solr in code and display to ...
0
votes
0answers
47 views

Multiple versions of sitecore item under the page testing are retrieved from solr index

After the creation a page test for item, which is recorded to SOLR index, in Experience Optimization and creation some page versions to test against (during the test creation), when I get items from ...
1
vote
1answer
76 views

Sitecore Solr Slop Defaulting

Running into a bit of an issue using Slop with SOLR. Previously on Lucene indexes we were able to use the .Like() method on the IQueryable result from the SearchContext. The code runs roughly like so ...