Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

3
votes
3answers
56 views

Sitecore 9.0 works with solr 7.2.1?

I have installed sitecore 9.1.0 XP on my system with solr 7.2.1. Now I want to Install sitecore 9.0.1 XP on my system. So Can I use Solr 7.2.1 for sitecore 9.0.1 installation or Do I need to install ...
0
votes
1answer
37 views

Where should I put SOLR Autosuggest configurations

I'm using Sitecore 9.1 and SXA 1.8, there are two cores for the master index now , instance_name_sxa_master_index and instance_name_master_index, which index should I put the SXA autosuggester ...
2
votes
0answers
23 views

Wildly inconsistent index data after rebuilds

SC 9.1 SwitchOnRebuildSolrSearchIndex is enabled SOLR 7.2.1 I have 120k items in Sitecore, so I have a good bit of data to sample. When I rebuild my web index, the total number is consistent. But ...
0
votes
1answer
41 views

PDF items are not getting indexed and not listed in multilist with search [on hold]

I have upgraded Sitecore 8.1 to 9.1 and now in 9.1 PDF items are not getting indexed and also they are not getting listed in a multilist with search field.
1
vote
1answer
52 views

Boosting in solr vs lucene

I am changing the search engine from lucene to solr , and i want to make config changes in my custom indexes , i am using the search_keywords field for the predictive search , and the field is also ...
-2
votes
0answers
55 views

Solr Performance issue while calling a method from ajax

I have recently upgraded sitecore 8.1 to 9.1 and initially lucene was there , but i installed solr , and i am facing performance issue in this , the code is same for lucene and solr , then also . I ...
1
vote
1answer
38 views

sitecore solr Problem accessing /solr//admin/cores

I'm seeing failure to connect logs for all solr cores they all have problem accessing /solr//admin/cores. reason not found. Here's the thing the /solr//admin/cores page doesn't exists while the /...
2
votes
2answers
55 views

Searching a substring using solr

I am trying to move my code from Lucene to Solr, but am facing an issue. I have 4 fields indexed, all the field are of text_general type (from the managed schema). The code from Lucene is: ...
0
votes
0answers
29 views

Has any one tested Sitecore 8.2 compatibility with Solr 7.2?

Currently, we are using Solr 6.5. We want to upgrade Solr 6.5 to Solr 7.2 to leverage bidirectional replication. But Sitecore has not tested Sitecore 8.2 - Solr 7.2 compatibility. Also, there is no ...
0
votes
0answers
38 views

copyField dest :'__renderings_t_ko_str' is not an explicit field and doesn't match a dynamicField [duplicate]

Getting below error for custom Solr in Sitecore 9.1 when I am trying to rebuild index. Error : copyField dest :'__renderings_t_ko_str' is not an explicit field and doesn't match a dynamicField I am ...
-1
votes
1answer
38 views

date field in solr not indexing proper date from sitecore

i am changing search from lucene to solr and faced an issue in this , i have DateTime a field in sitecore and an item is using that field and have value of now ( DATE -- 4/4/2019 TIME -- 12:00 AM) ...
0
votes
0answers
56 views

Something missing from Sitecore package, how to find out what it is

I've been trying to hand off some content for our developers to test with. However, when they use the installation wizard to install my package, the installation fails. I checked their logs and am ...
0
votes
1answer
25 views

SOLR 5.1 Java Version

Using Sitecore 8.2 Update 6, when I install SOLR 5.1, it updates the JAVA_HOME environment variable to C:\Program Files\Java\jre1.8.0_171, but I haven't got version installed (and doesn't seem to be ...
0
votes
0answers
35 views

When searching with solr sitecore does not search in the right fields

We know that sitecore uses solr dynamic fields so that we don't need to declare all the fields that we have in sitecore separately in the solr schema to get them indexed. In our case we have a ...
0
votes
0answers
32 views

Recipients in EXM count is always 0 [duplicate]

I tried to use EXM in siteore and I uploaded CSV file I already got message that was "Contacts expected to be imported are 2" but "Recipients" are still 0 like in attached Images so I can't complete ...
2
votes
0answers
54 views

Searching the keywords with spaces in solr

I have a search functionality in my project and the code for exactly matched keywords and search all word, the exactly is working fine but not the search all words: if (!searchRequest.SearchType....
0
votes
0answers
75 views

Exception after upgrade: multiple values encountered for non multiValued field

I am trying to upgrade Sitecore from 8.2 to 9.1. Configured SOLR, added all the required cores and populated managed schema for each index. However, I can't rebuild sitecore_master_index: ERROR: [...
3
votes
1answer
182 views

Custom Solr Fields in Sitecore 9 and Solr 7.2.1

I am converting my custom index fields from Sitecore 8.1. Previously, I would declare them like this: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www....
0
votes
1answer
46 views

Solr Basic Auth xDB / Indexer

Working on setting up basic authentication for our Solr instance to help put some form of security for people internally who might accidentally drop an index in production. We're able to pass the ...
0
votes
1answer
41 views

Master/Slave replication and fault tolerance [closed]

I am using solr-7.6 version with Master/Slave config. Being a novice, I do have few question on the solr functionality: 1. What happens when Master will be down? Do i need to make Slave as Master ...
2
votes
1answer
69 views

Index Update Strategy not Firing on Publish End with Custom Publishing Target and Custom Solr Index [duplicate]

We have a prod set up that has one CM and two CDs. The CD servers serve content from a second web database that we call "live". This database is a clone of web. We use web as a staging environment on ...
0
votes
0answers
57 views

Item not removed from SOLR index after unpublish or delete

When I delete or unpublish an item in Sitecore 9.1, it is removed from the web-database and sitecore_web_index, but not from my custom index (Solr 7.2.1), any other update finds its way into the index....
0
votes
1answer
140 views

Sitecore 9.1 upgrade Error loading hook

We're upgrading from Sitecore 8.1 Update 3 to Sitecore 9.1. We use Solr for xConnect search, Lucene for web site search The CM is working, but the CD is not. Got the following error message: Server ...
0
votes
1answer
200 views

Index are not listing in sitecore 9.1

I have installed fresh sitecore 9.1 instance in local environment. There is no issue with installation but i couldn't see any indexes in Index manager. All the configurations are enabled and i even ...
0
votes
0answers
43 views

Solr query works in the web UI, not when invoked though code

I'm on Solr 4.10.4, Sitecore 8.1 160519. I have a query used internally by my application that returns 0 records. In the Search.log I can see that same query; if I copy the querystring value to the ...
3
votes
0answers
53 views

Sitecore Content Search API returns expected results with Lucene as search provider but not with Solr

I'm currently writing a service that needs to integrate with Eventbrite to store external event information as items in Sitecore. We run a Sitecron job every 4 hours to pull in and update the ...
1
vote
0answers
37 views

Sitecore 8.2 Azure Web App / Solr VMs

We are running Sitecore 8.2 as a WebApp on Azure, with this we using Solr on VMs , using along with Zookeeper [3 nodes]. There is odd behavior we are seeing, if we make any configurations on Solr as ...
2
votes
1answer
216 views

Sitecore 9 and custom solr indexes

I'm working with Sitecore 9 and solr 6.2.2. I am trying to create a custom index and in this index I'm only including a few fields. One of the fields is called OfficeLocation and it's a string. When ...
0
votes
0answers
37 views

Page testing is not working when I use SOLR

When I create a page test in Sitecore Experience Optimization for the pages that are stored in SOLR index and then get the page item (which is under the page test) from the solr in code and display to ...
0
votes
0answers
45 views

Multiple versions of sitecore item under the page testing are retrieved from solr index

After the creation a page test for item, which is recorded to SOLR index, in Experience Optimization and creation some page versions to test against (during the test creation), when I get items from ...
1
vote
1answer
63 views

Sitecore Solr Slop Defaulting

Running into a bit of an issue using Slop with SOLR. Previously on Lucene indexes we were able to use the .Like() method on the IQueryable result from the SearchContext. The code runs roughly like so ...
2
votes
1answer
59 views

Search on custom solr index

I am trying to search on a solr core which contains static data without any Sitecore details. <doc> <str name="_property_text">1</str> <str name="_itemnumber_string">1250000&...
0
votes
1answer
33 views

Datetime fields appear garbled in Solr [duplicate]

I'm on Solr 4.10.4, Sitecore 8.1 160519. I have a custom index defined the following way: <field fieldName="date_of_birth" returnType="datetime" type="MyProject.Search.ComputedFields....
2
votes
2answers
113 views

Solr and Tokenizers: how to tokenize specific indexes using Solr 4.10.4

I'm on Solr 4.10.4, Sitecore 8.1 160519. I finally managed to convert my Lucene custom index configuration to Solr, but some indexes are not tokenized. The custom index "parsed_answers" on Lucene is ...
1
vote
1answer
88 views

Solr log: Multiple values encountered for non multiValued field _basetemplates_s

I'm on Solr 4.10.4, Sitecore 8.1 160519. The configuration of the custom index is <field fieldName="_basetemplates" returnType="string" multiValued="true" storageType="yes" indexType="untokenized"...
1
vote
0answers
25 views

Solr Document Boosting

I'm attempting to item boosting working with Solr and I can't for the life of me get it to work. I'm certain that I've had it working in the past for other projects. The problem looks to be on the ...
0
votes
0answers
86 views

Indexing tool “Populate Solr Managed Schema” missing

I am currently trying to migrate some indexes and was looking at the documentation. It seems like there should be an option "Populate Solr Managed Schema" in the control panel. However, in my ...
0
votes
2answers
112 views

Connection error to search provider [Solr] : Unable to connect to [https://localhost:8983/solr], Core: [sitecore_analytics_index]

Sitecore 8.1, never used Solr before, just switched from Lucene. I downloaded the latest Solr and installed it using nssm. Generated self-signed certificate. Admin runs well at https://localhost:8983/...
0
votes
1answer
93 views

System.NullReferenceException Sitecore.ContentSearch.SolrProvider at Sitecore.ContentSearch.SolrProvider.SolrIndexSummary.get_NumberOfDocuments()

I am trying to setup the solr 6.6.1 with Sitecore 8.2 update 7. I am having the following errors in the logs: Message: Object reference not set to an instance of an object. Source: Sitecore....
2
votes
1answer
152 views

An index with the name “sitecore_analytics_index” have already been added.,

Im currently working on getting a existing Sitecore 8.2 Habitat solution running on my system locally. Anytime I go to routes like /sitecore or /sitecore/admin/showconfig.aspx I get the following ...
0
votes
1answer
64 views

Switched from Lucene to Solr: “Could not find configuration node: contentSearch/indexConfigurations/defaultSolrIndexConfiguration/FieldReaders”

I am upgrading from 8.1 to 9.1, and I'm switching to Solr before the actual upgrade. I have a rather elaborate custom index configuration, and I converted it to Solr at the best of my knowledge. The ...
2
votes
2answers
125 views

Indexes are not appearing in Indexing Manager when using Client Certificate Authentication With Solr [closed]

We have setup Client Certificate Authentication with Solr using below link: https://blogs.perficientdigital.com/2018/08/01/client-certificate-authentication-with-solr/ Solr admin panel is loading ...
3
votes
2answers
202 views

Solr Start Service not working

I am was trying to install Solr. I have followed all the steps specified. But I am getting an error in power shell like this below.Could you please let me know what must have went wrong. Thanks in ...
1
vote
2answers
244 views

Sitecore 9.1 installation error : “Notfound issue solr creating core ”

Hi I am installing sitecore 9.1 with SIF and i am using solr 7.2.1 version. installation fails due to below error. Below my error in powershell: [--------------------------------------------------...
1
vote
1answer
50 views

AuthenticationException on Azure with Solr and self-signed certificates

looking for Azure experts advice! I have about 1M AuthenticationExceptions while connecting to solr in the last few hours for almost non-active Sitecore instance... I checked all the apps, they all ...
0
votes
2answers
113 views

SolrSearchIndex: No matching constructor was found

What I have: Under IIS: I have Sitecore 9.0.2 XP0 with SXA 1.7 and SOLR for indexing working fine. Under Visual Studio: I have Habitat Solution downloaded from https://codeload.github.com/Sitecore/...
2
votes
1answer
112 views

How to configure seperate solr index for multi site in a single instance in sitecore?

I have 2 websites configured in a single instance, where i wanted to configure separate search indexes of solr for each website.
1
vote
2answers
413 views

9.1 Powershell Install Solr Connection Issue

I am running the XP1-SingleDevloper.ps1 and it is choking when trying to connect to the solr url. If I hit https://solr:8983/solr in a browser it comes up just fine. Thoughts on why it isn't able to ...
2
votes
1answer
134 views

Is there any way to check the solr is running in sitecore

We have requirement to redirect to a error page if the solr is stopped programtically in sitecore. Is there any way to check whether the solr is running or not?
4
votes
1answer
151 views

Installing Sitecore 9 With Solr on Linux

I am having a hard time getting Sitecore 9 (SIF 2.0) installed where Solr is on a remote Linux box. Basically I have removed the steps in the install powershell script that creates the solr cores ...