Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

88 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
6
votes
1answer
588 views

Migrating Solr Core indexes to Azure Search indexes

I am midst of migrating a Sitecore project to Azure Paas offering. I've completed the deployment of the files (ie. dlls, configs, css, js, etc) and were able to do a complete unicorn sync. That looks ...
5
votes
0answers
182 views

Atomic update of a SOLR document. Updating fields on document instead of full reindex of document

SOLR has a feature for doing partial updates of a document called Atomic Updates. The SOLR documentation has this example: { "id":"mydoc", "price":{"set":99}, "popularity":{"inc":20}, "...
5
votes
0answers
1k views

XConnect IndexWorker unable to connect

So after a clean install of Sitecore, I've been trying to get an app working with xConnect, but when I'm running that I'm getting the following exception in my code: No connection could be made ...
5
votes
1answer
390 views

CreateAlias: Setting alias 'sitecore_custom_web_index_primary_alias' to collection 'sitecore_custom_web_index' failed

I have configured a High Availability for SOLR solution with 2 x SOLR 3 x Zookeeper While I was building the indexes everything went well, except for the following 7816 05:28:53 ERROR ...
5
votes
0answers
180 views

SolrCloud and the Indexing Manager not showing statistical information

We are looking at deploying SolrCloud with our 8.2.5 install. Everything seems to be running OK so far, however I've noticed that the Indexing manager does not load any of the indexing statistical ...
5
votes
0answers
158 views

Configuring Solr on remote server using SIM

Is it possible to configure Solr using SIM on a remote machine? By default it shows http://localhost:8983/solr .Can we have it something as http://abc.com:8983/solr ?
5
votes
0answers
728 views

Sitecore Solr index FieldNameTranslator is null

I am currently playing around with Sitecore indexes - both Solr and Lucene. I have made my own custom index and it works fine for Lucene, but I cannot get it to work with Solr. My problem is that ...
4
votes
1answer
1k views

Custom Solr Fields in Sitecore 9 and Solr 7.2.1

I am converting my custom index fields from Sitecore 8.1. Previously, I would declare them like this: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www....
4
votes
0answers
98 views

Sitecore Content Search API returns expected results with Lucene as search provider but not with Solr

I'm currently writing a service that needs to integrate with Eventbrite to store external event information as items in Sitecore. We run a Sitecron job every 4 hours to pull in and update the ...
4
votes
0answers
264 views

Sitecore Index_Update Job Performance

We just updated from Sitecore 8.2 Update 4 to Update 7 and we've started seeing some strange behavior when publishing new items. The issue presents itself in that it takes awhile for newly created ...
4
votes
0answers
724 views

Populate Solr Managed Schema Error

I am getting the 404 error while trying to populate the schema from "Populate Solr Managed Schema". Job started: Index_Update_Collection=sitecore_core_index|#Exception: System.Reflection....
3
votes
0answers
70 views

Sitecore indexing a SXA Multisite configuration for more than 500 sites

I am stuck with issue for indexing a SXA Multisite configuration for 600 sites. The case study is as below. Issue: Indexing get failed at certain point of time from CM itself for Solr Master(after 2 ...
3
votes
0answers
160 views

Searching the keywords with spaces in solr

I have a search functionality in my project and the code for exactly matched keywords and search all word, the exactly is working fine but not the search all words: if (!searchRequest.SearchType....
3
votes
0answers
149 views

SOLR CLOUD error on looping through search result on 9.0 Update-1

I'm trying to setup SOLR Cloud to work with my Sitecore 9.0 (Update-1) instance. I'm using 3 different VMs with [1-Zookeeper + 1-SOLR 6.6.2] configured on all machines. I have added the following ...
3
votes
0answers
840 views

Error with indexWorker process in Sitecore 9 xConnect with Solr 6.6.2

I am running Sitecore 9 with Solr 6.6.2 and I am seeing lot of error in the IndexWorker logs in Sitecore xConnect as below: 018-02-21 16:16:13.686 +10:00 [Error] An error occured. System.Net.Http....
3
votes
0answers
559 views

“org.apache.solr.common.SolrException: undefined field 0001-01-01T00” when rebuilding index

When I rebuild one of my indexes in Sitecore, I get the following error in the Solr log: org.apache.solr.common.SolrException: undefined field 0001-01-01T00 I don't have a field called 0001-01-...
3
votes
0answers
103 views

Multi-list with search showing gibberish after switching to SOLR Cloud

I'm running Sitecore 8.1 (Original Release), and last night we switched our SOLR indexes to use a dedicated SOLR Cloud set of servers instead of using a stand-alone SOLR instance on our CM server. ...
2
votes
1answer
89 views

SXA Search Boosting Throws Error

I have configured the search scope for SXA (Sitecore 9.3) and it works as expected. However, when I try to add boost configuration to the search scope it throws the below error. Invalid Method Call ...
2
votes
0answers
44 views

Populate Solr Managed Schema deletes added solr fields

I am adding fields via the Solr admin and can see them in the managed-schema file, however when I go to Sitecore Populate Solr Managed Schema, and run it, those fields get removed Am I missing ...
2
votes
0answers
94 views

Non-static method requires a target

Recently migrated from Lucene to Solr search(7.2.1) in Sitecore. When I try to get the search results from Code, I'm getting the exception Non-static method requires a target However, from Solr ...
2
votes
0answers
200 views

Something missing from Sitecore package, how to find out what it is

I've been trying to hand off some content for our developers to test with. However, when they use the installation wizard to install my package, the installation fails. I checked their logs and am ...
2
votes
1answer
98 views

Search on custom solr index

I am trying to search on a solr core which contains static data without any Sitecore details. <doc> <str name="_property_text">1</str> <str name="_itemnumber_string">1250000&...
2
votes
0answers
90 views

Solr Document Boosting

I'm attempting to item boosting working with Solr and I can't for the life of me get it to work. I'm certain that I've had it working in the past for other projects. The problem looks to be on the ...
2
votes
0answers
846 views

Sitecore.Social: Social messages index could not be determined for master database

We are on Sitecore 8.1 rev. 160519 (Update-3) and using SOLR 6.2.1 Logs on one of our CM server is suddenly overflowing with the following error message: Sitecore.Social: Social messages index ...
1
vote
0answers
44 views

How to get the exact match or sub string of the passed query in solr

I'd like to query a string to Solr and let it answer with all records which are a subset of that string. The string is separated by comma. I wanna make solr to give me all records where a specific ...
1
vote
0answers
36 views

Empty String in Solr

I have a custom field to be Indexed for each Item. If it does not get the value it returns string.Empty. Before when Item's searched in Solr, whose custom fields are string.empty the field was not ...
1
vote
0answers
24 views

Keyword search with field level boosting and spatial search

Sitecore 9.3 I want to boost a result based on a field containing a keyword and it's working absolutely fine with the below query. var keywordQuery = PredicateBuilder.True<SearchResultItem>(); ...
1
vote
2answers
114 views

Working with chinese language with the SXA Search Component

We have an issue, where we have content in multiple languages, and we are doing a basic keyword site search using the SXA Search Component. As far as I can tell (from the search.log), the SXA Search ...
1
vote
0answers
109 views

SolrCloud on Azure PaaS

I am setting up a Sitecore 9.2 Production instance and ideally would like to Setup SolrCloud in Azure PaaS Web Apps. In test environments i have setup Solr on a single PaaS App Service and it is ...
1
vote
0answers
48 views

What permissions does Sitecore need to manage Solr?

Solr 6.1.0 + Zookeeper + Basic Authentication Sitecore 8.0 Update-5 What are the minimum permissions required for Sitecore to manage Solr? The official documentation says nothing about this AFAICT ...
1
vote
0answers
54 views

Sitecore SXA search doesnt work

I have recently installed a fresh Sitecore 8.2 update 5 including Power Shell 4.7.2 SXA 1.5 rev 171010 Sitecore SXA Showcase v1.2 Everything seems working fine except for the search function. When ...
1
vote
0answers
97 views

Not indexing properly on publish

I have a sitecore instance running on Sitecore v8.2 update 1 using SOLR. So I have created 3 new computed fields, this fields are working properly when I rebuild index or re-index tree (both master ...
1
vote
0answers
52 views

Index core names and rebuild core

I've noticed in Sitecore 9 (at least through 9.1.1) that the value of <param desc="core> is based on the prefix you use during installation (IE, if you chose "local" as a prefix, the core is ...
1
vote
0answers
73 views

Sitecore 9.1 Upgrade - Lucene to SOLR

I am updating Lucene to SOLR as part of Sitecore 8.2 to Sitecore 9.1 upgrade. I have updated some search configuration like updated field map to: <fieldMap ref="contentSearch/indexConfigurations/...
1
vote
0answers
39 views

Not able to Perform multi-language search Sitecore with searchstring

Using Solr as Default search provider. Content Search is working when website language is -en example.com/en/sxa/search/results/?l=en&q=query From localhost:8983(solr) Able to query the data ...
1
vote
0answers
50 views

Adding hashtag to the internal link that leads to blog search page with tag filter search Sitecore SXA 1.9

The blog index page has all articles are listed and the filter based on tag that works with solr search. The search results based on sxatags filter will get added on the blog index page when apply ...
1
vote
0answers
22 views

Specific search terms return 500

We are on Sitecore 9.0.1 and Solr version 6.6.2 and have previously had issues with populating our schemas from the Sitecore control panel. After overriding the pipeline like in this blog post (https:/...
1
vote
0answers
116 views

Implementing a solr.DateRangeField type in Sitecore

We need to use DateRangeField query in Solr to perform two dates range filter. Managed schema field sample: <fieldType name="date_range" class="solr.DateRangeField"/> I have written computed ...
1
vote
0answers
45 views

Sitecore 9.2 JSS with Solr 7.5 , JSS route items and its subitems are not indexing

Currently we are developing Sitecore JSS app with React frontend. in this we are using Headless SSR mode to create the content in sitecore and rendering. our application is working fine with React, ...
1
vote
2answers
163 views

Limit search result hits to a specific number with facets to match limited result set

I have a requirement to limit search results to an arbitrary number in a Site Search implementation. Is there a way to accomplish this in a query and get accurate facets relative to the arbitrary ...
1
vote
0answers
57 views

Sitecore 8.2 Azure Web App / Solr VMs

We are running Sitecore 8.2 as a WebApp on Azure, with this we using Solr on VMs , using along with Zookeeper [3 nodes]. There is odd behavior we are seeing, if we make any configurations on Solr as ...
1
vote
0answers
58 views

Items inside composite items are not listed on search

In SXA Search we are not getting the results for items present inside composite components like Tab/Carousel components. Does anyone have any suggestion that might help?
1
vote
0answers
49 views

Virtual Folder defined for a language site not working with Data API URL

We are on multi-lingual websites having en-CA and fr-CA languages as well. We defined virtual folder for fr-CA to share the same domain name with en-CA. Hence the en-CA works on www.mywebsite.ca and ...
1
vote
0answers
63 views

Azure Search doesn't work with query more than five letters

I've implemented simple search by query in my sitecore application. Locally it works perfectly with solr, but when solution is deployed to an Azure environment that is using Azure Search it doesn't ...
1
vote
0answers
323 views

Can I use self-signed certificates for xConnect, Solr, and Sitecore Commerce in a Sitecore 9 XP0 production deployment?

I am planning a small Sitecore 9.0.2 + Sitecore Experience Commerce production deployment for a demo website with very low traffic. I do not have a lot of time to provision multiple servers, so I plan ...
1
vote
0answers
1k views

The remote server returned an error: (400) Bad Request Error while building the custom index in SOLR 5.1

We have created a custom Itembuket_community and rebuliding the index. while Rebuilding the index, getting follwoing error Job started: Index_Update_IndexName=sitecore_Community_index|#Exception: ...
1
vote
0answers
80 views

Solr query on read/deny roles

We have a custom Solr index which includes read and deny roles. Both are added as predicates using the following code: protected virtual IQueryable<TIndexable> ApplyDenyUserRules<TIndexable&...
1
vote
0answers
418 views

Solr indexes don't incrementally update after rebuilding

We are on version 8 update 2. We have one CM and 2 CDs. All indexes are set to manual strategy on CDs. CM does all the indexing. All master db indexes are set to sync master and all web indexes to ...
1
vote
1answer
146 views

How to use Sitecore API to return result which removes Solr stopwords?

In Solr GUI I am seeing that when I am in the analyzer tab, it is removing stop words and returning results. But when I try to retrieve same result using the Sitecore search API it is not removing ...
0
votes
0answers
11 views

AutoSuggest with _content field

Is it possible to use the _content field for auto suggest , or we can only use fields which are on the document? Autosuggest works fine if I set <str name="field">_content</str> ...