Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

129 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
5
votes
0answers
411 views

Atomic update of a SOLR document. Updating fields on document instead of full reindex of document

SOLR has a feature for doing partial updates of a document called Atomic Updates. The SOLR documentation has this example: { "id":"mydoc", "price":{"set":99}, "popularity":{"inc":20}, "...
5
votes
0answers
1k views

XConnect IndexWorker unable to connect

So after a clean install of Sitecore, I've been trying to get an app working with xConnect, but when I'm running that I'm getting the following exception in my code: No connection could be made ...
5
votes
1answer
461 views

CreateAlias: Setting alias 'sitecore_custom_web_index_primary_alias' to collection 'sitecore_custom_web_index' failed

I have configured a High Availability for SOLR solution with 2 x SOLR 3 x Zookeeper While I was building the indexes everything went well, except for the following 7816 05:28:53 ERROR ...
5
votes
0answers
254 views

SolrCloud and the Indexing Manager not showing statistical information

We are looking at deploying SolrCloud with our 8.2.5 install. Everything seems to be running OK so far, however I've noticed that the Indexing manager does not load any of the indexing statistical ...
5
votes
0answers
170 views

Configuring Solr on remote server using SIM

Is it possible to configure Solr using SIM on a remote machine? By default it shows http://localhost:8983/solr .Can we have it something as http://abc.com:8983/solr ?
5
votes
0answers
831 views

Sitecore Solr index FieldNameTranslator is null

I am currently playing around with Sitecore indexes - both Solr and Lucene. I have made my own custom index and it works fine for Lucene, but I cannot get it to work with Solr. My problem is that ...
4
votes
1answer
1k views

Custom Solr Fields in Sitecore 9 and Solr 7.2.1

I am converting my custom index fields from Sitecore 8.1. Previously, I would declare them like this: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www....
4
votes
0answers
191 views

Sitecore Content Search API returns expected results with Lucene as search provider but not with Solr

I'm currently writing a service that needs to integrate with Eventbrite to store external event information as items in Sitecore. We run a Sitecron job every 4 hours to pull in and update the ...
4
votes
0answers
344 views

Sitecore Index_Update Job Performance

We just updated from Sitecore 8.2 Update 4 to Update 7 and we've started seeing some strange behavior when publishing new items. The issue presents itself in that it takes awhile for newly created ...
4
votes
0answers
934 views

Populate Solr Managed Schema Error

I am getting the 404 error while trying to populate the schema from "Populate Solr Managed Schema". Job started: Index_Update_Collection=sitecore_core_index|#Exception: System.Reflection....
3
votes
0answers
86 views

Not able to fetch search result in Content search API with Solr and Azure

I am using content search API in Sitecore 9.1.1. However, it is not fetching result if i am using search with any of the template field. The below code fetching result based on template id but when we ...
3
votes
0answers
96 views

Sitecore indexing a SXA Multisite configuration for more than 500 sites

I am stuck with issue for indexing a SXA Multisite configuration for 600 sites. The case study is as below. Issue: Indexing get failed at certain point of time from CM itself for Solr Master(after 2 ...
3
votes
0answers
378 views

Searching the keywords with spaces in solr

I have a search functionality in my project and the code for exactly matched keywords and search all word, the exactly is working fine but not the search all words: if (!searchRequest.SearchType....
3
votes
0answers
174 views

SOLR CLOUD error on looping through search result on 9.0 Update-1

I'm trying to setup SOLR Cloud to work with my Sitecore 9.0 (Update-1) instance. I'm using 3 different VMs with [1-Zookeeper + 1-SOLR 6.6.2] configured on all machines. I have added the following ...
3
votes
0answers
2k views

The remote server returned an error: (400) Bad Request Error while building the custom index in SOLR 5.1

We have created a custom Itembuket_community and rebuliding the index. while Rebuilding the index, getting follwoing error Job started: Index_Update_IndexName=sitecore_Community_index|#Exception: ...
3
votes
0answers
994 views

Error with indexWorker process in Sitecore 9 xConnect with Solr 6.6.2

I am running Sitecore 9 with Solr 6.6.2 and I am seeing lot of error in the IndexWorker logs in Sitecore xConnect as below: 018-02-21 16:16:13.686 +10:00 [Error] An error occured. System.Net.Http....
3
votes
0answers
626 views

"org.apache.solr.common.SolrException: undefined field 0001-01-01T00" when rebuilding index

When I rebuild one of my indexes in Sitecore, I get the following error in the Solr log: org.apache.solr.common.SolrException: undefined field 0001-01-01T00 I don't have a field called 0001-01-...
3
votes
0answers
107 views

Multi-list with search showing gibberish after switching to SOLR Cloud

I'm running Sitecore 8.1 (Original Release), and last night we switched our SOLR indexes to use a dedicated SOLR Cloud set of servers instead of using a stand-alone SOLR instance on our CM server. ...
2
votes
0answers
141 views

Sort By Grouping NumFound Field

Hello Sitecore Stack Exchange, Environments: Sitecore 9.2, Solr 7.5.0|SolrCloud 7.5.0, Custom search index. In the Search logic I have the next requirement: I should group search response and sort ...
2
votes
0answers
90 views

Filtering Solr search results based on score

I'm trying to figure out a way to apply a filter on result scores. E.g. I want only results with score >50. In pure Solr, that is solved by using a filter query. Adding the following to the query ...
2
votes
2answers
241 views

Boosting Search Results

I was disheartened to see this in the Sitecore docs: Important Search result boosting works in Solr version 6.6 or earlier, but Solr changed the implementation in Solr 7, and later versions. ...
2
votes
0answers
367 views

Empty String in Solr

I have a custom field to be Indexed for each Item. If it does not get the value it returns string.Empty. Before when Item's searched in Solr, whose custom fields are string.empty the field was not ...
2
votes
0answers
56 views

Keyword search with field level boosting and spatial search

Sitecore 9.3 I want to boost a result based on a field containing a keyword and it's working absolutely fine with the below query. var keywordQuery = PredicateBuilder.True<SearchResultItem>(); ...
2
votes
0answers
33 views

class SolrContentSearchManager in namespace Sitecore.ContentSearch.SolrProvider si deprecated

Recently i upgraded sitecore instance from 8.1 to 9.3. SOlr5.4.1 set up was working fine with sc8.1, I was using NINJECT as DI. now after upgrading , SOlr is causing at DI level, complaining that ...
2
votes
0answers
85 views

Sitecore Solr search indexing getting stopped

We are seeing Solr master and web index updates are getting stopped randomly in mid of the day. I tried one approach that is mentioned in this answer. Updated the master index strategy to use ...
2
votes
1answer
294 views

SXA Search Boosting Throws Error

I have configured the search scope for SXA (Sitecore 9.3) and it works as expected. However, when I try to add boost configuration to the search scope it throws the below error. Invalid Method Call ...
2
votes
0answers
75 views

Populate Solr Managed Schema deletes added solr fields

I am adding fields via the Solr admin and can see them in the managed-schema file, however when I go to Sitecore Populate Solr Managed Schema, and run it, those fields get removed Am I missing ...
2
votes
1answer
194 views

Non-static method requires a target

Recently migrated from Lucene to Solr search(7.2.1) in Sitecore. When I try to get the search results from Code, I'm getting the exception Non-static method requires a target However, from Solr ...
2
votes
0answers
303 views

Something missing from Sitecore package, how to find out what it is

I've been trying to hand off some content for our developers to test with. However, when they use the installation wizard to install my package, the installation fails. I checked their logs and am ...
2
votes
0answers
113 views

Solr Document Boosting

I'm attempting to item boosting working with Solr and I can't for the life of me get it to work. I'm certain that I've had it working in the past for other projects. The problem looks to be on the ...
2
votes
0answers
932 views

Sitecore.Social: Social messages index could not be determined for master database

We are on Sitecore 8.1 rev. 160519 (Update-3) and using SOLR 6.2.1 Logs on one of our CM server is suddenly overflowing with the following error message: Sitecore.Social: Social messages index ...
1
vote
0answers
49 views

solr connection issue with Sitecore on CD servers

We have an issue happening every once and while related to the connection between the CD servers and the solr which is causing some pages to go down and show empty results.  We found that the CM is ...
1
vote
1answer
49 views

Installing Sitecore 9.3 Offline

I am trying to Install Sitecore 9.3 in one of our servers (not connected to internet). But in the end it throws this error. I installed Solr separately before installing Sitecore using traditional ...
1
vote
0answers
54 views

Facet for Sitecore SXA search filter

The product item has a field "Property Type" which is a single line text I want to create a facet so that I can use in the SXA search Checklist filter. I have added the field in the solr ...
1
vote
0answers
57 views

Solr index rebuild on CD servers

I am working on a client applciation on sitecore 8.1 we have one CM and multiple CD server , The CM solr instance and CD solr instance are pointing to 2 seperate instances , configured as master and ...
1
vote
1answer
68 views

Rebuild the xDB index in Solr - error mongo

I have problem with rebuilding xDB index in solr. I changed IndexPIISensitiveData to true in job SerachIndexer and after executing the command \XConnectSearchIndexer.exe -rr there is no sensitive data ...
1
vote
1answer
44 views

Link Lists not showing up in search

I am working on the search for my site. It is working as expected for the most part, but I noticed that if I add a link list with multiple links, the text from those links does not show up in the ...
1
vote
1answer
57 views

Is it possible to search the data with field type droplist ,droplink or tag tree list

I m using sitecore 9.0.1 with sxa 1.7,i have default sxa search component and wants to know whether we can search the data with field type droplist ,droplink ,tag tree list etc..Without adding any ...
1
vote
2answers
81 views

No Solr in Sitecore 10 CD

I would like to know if Solr is needed in CD environment? We don't use Solr as our site search but a different search provider. Thanks
1
vote
0answers
70 views

Newly created SXA indexes are not showing up in Sitecore 9.0.1

Followed the below steps to add new sxa cores in the solr 6.6.2 1.Duplicated core directory created for sitecore_master_index (or company_name_master_index) twice and rename to: ...
1
vote
0answers
124 views

Queries for null or empty strings

I tried to apply exactly what is on the following link to query fields with null or empty strings https://doc.sitecore.com/developers/92/sitecore-experience-manager/en/queries-for-null-or-empty-...
1
vote
0answers
356 views

How to get the exact match or sub string of the passed query in solr

I'd like to query a string to Solr and let it answer with all records which are a subset of that string. The string is separated by comma. I wanna make solr to give me all records where a specific ...
1
vote
0answers
140 views

Any insight on how to fix "XConnect Exception Filter OnException" errors?

Our instance has been pretty stable until recently we started receiving the following errors in XConnect. Main log [Error] XConnect Exception Filter OnException(), url - "https://site.com/odata/...
1
vote
0answers
110 views

Moving from Solr to SolrCloud

We are currently working on a Sitecore project where we are using Sitecore XP 9.0.2 and Sitecore XC 9.0.3 with Standalone Solr 6.6.2 As we are growing in terms of user base, we are looking to ...
1
vote
0answers
82 views

Switch on rebuild for Commerce Cores

I am using two Solr Cloud Instance with two Zookeeper and indexed Commerce Indexes (CustomersScope, OrdersScope, CatalogItemsScope) in it. And now I want to apply Switch On Rebuild for that ...
1
vote
0answers
74 views

Sitecore not resolving index properties to corresponding solr field names (with suffix)

I have a single line field in Sitecore, (I see same issue for other field types too). I am trying to do a SOLR search on this field. I created a search result class public class SearchResult : ...
1
vote
0answers
65 views

Sitecore Spell checker neglect search scope

I'm using Sitecore 9.1 and SXA 1.8, I'm using Solr spell checker feature to fetch suggestions for a SXA search box that I use, the source of the suggestions is the field you specify in the ...
1
vote
0answers
148 views

How to exclude the results based on some templates in Solr/Suggest search?

I have a scenario that, I want to exclude some templates(Items that are based on these templates are need to be excluded) from solr Suggestion/autocomplete results. I did set a context field as ...
1
vote
0answers
23 views

How to configure Solr to treat European English language the same as international English

I'm configuring a few sites within my solution to use "European English" (en-150 yes, it's weird, but it is a valid culture!). Does Solr treat all en- languages the same, or will I need to set up ...
1
vote
2answers
288 views

Working with chinese language with the SXA Search Component

We have an issue, where we have content in multiple languages, and we are doing a basic keyword site search using the SXA Search Component. As far as I can tell (from the search.log), the SXA Search ...