Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

Filter by
Sorted by
Tagged with
2 votes
2 answers
1k views

Solr and Tokenizers: how to tokenize specific indexes using Solr 4.10.4

I'm on Solr 4.10.4, Sitecore 8.1 160519. I finally managed to convert my Lucene custom index configuration to Solr, but some indexes are not tokenized. The custom index "parsed_answers" on Lucene is ...
0 votes
1 answer
413 views

Switched from Lucene to Solr: "Could not find configuration node: contentSearch/indexConfigurations/defaultSolrIndexConfiguration/FieldReaders"

I am upgrading from 8.1 to 9.1, and I'm switching to Solr before the actual upgrade. I have a rather elaborate custom index configuration, and I converted it to Solr at the best of my knowledge. The ...
0 votes
2 answers
1k views

Connection error to search provider [Solr] : Unable to connect to [https://localhost:8983/solr], Core: [sitecore_analytics_index]

Sitecore 8.1, never used Solr before, just switched from Lucene. I downloaded the latest Solr and installed it using nssm. Generated self-signed certificate. Admin runs well at https://localhost:8983/...
0 votes
0 answers
27 views

Unknown query node type: 'Constant'

We could see the lot of below exceptions in the Sitecore log file. Could you please provide some suggestions to resolve this issue? Exception: System.NotSupportedException Message: Unknown query node ...
5 votes
1 answer
621 views

SolrCloud and the Indexing Manager not showing statistical information

We are looking at deploying SolrCloud with our 8.2.5 install. Everything seems to be running OK so far, however I've noticed that the Indexing manager does not load any of the indexing statistical ...
5 votes
1 answer
2k views

SwitchOnRebuild with SolrCloud not working

We are running Sitecore 9.0.0 (Initial Release) on Azure with SolrCloud (6.6.2) and getting close to go-live. We are using Sitecore's SwitchOnRebuild functionality for indexing so that the indexes ...
0 votes
1 answer
37 views

Custom Index Strategy Not Updating Indexes

We have a custom database named Preview and are able to publish to this, but the preview index is not getting updated when an item is published. If we manually rebuild via the CMS, the item will then ...
1 vote
1 answer
967 views

Suggestions on Improving Solr Indexing Speed

Please let me know if you need any more information from my side. I am new to Solr and Solr Indexing. I have 2 Million Records to be indexed and adding more soon, it is taking 16 hours to complete ...
1 vote
1 answer
46 views

SOLR Not Working 503 Error Netty dependencies have versions that do not match the versions specified in the azure-core-http-netty pom.xml file

We have an Azure Web App SOLR connected with Sitecore for Indexing. it was working great till Yesterday. Now the Azure Service is Not coming up with Error. HTTP Error 503. The service is unavailable. ...
0 votes
1 answer
102 views

In Solr can we use two diff. fields (min and max) for single range facet?

Currently, I am trying to implement salary range facets like 10000-20000 (2) 20001-30000 (100) 50000-60000 (150) However in Sitecore, we have two different fields (MinSalary & MaxSalary) to ...
0 votes
1 answer
68 views

An error occured during index rebuilding. There will be another attempt to check

Getting the below error message while rebuilding the index SourceContex - Sitecore.Xdb.Collection.Indexing.Rebuild.IIndexRebuildFlow System.Net.Http.HttpRequestException: at System.Net.Http....
1 vote
1 answer
61 views

how to add Analyzer and Tokenizer in our customfieldtype

I'm trying to implement an analyzer and tokenizer on my created custom field type. Any ideas on how to implement it? example:- I have created one custom field type like wtbngramscase in solr schema ...
0 votes
2 answers
61 views

Solr xdb Rebuild not progressing from past 4 days

I am trying to rebuild xdb. However, it is stuck on 20.97% from past 4 days. No Error in log file. The solr is stopped on the 4742794. But keeps on saying lastmodified a minute ago. I have tried out ...
1 vote
0 answers
39 views

Sitecore Multi-Zone Setup: Solr Index not Updating in One Zone during Indexing

Title: Sitecore Multi-Zone Setup: Solr Index not Updating in One Zone during Indexing Sitecore setup with 4 CD servers configured into two zones: zone-a and zone-b zone-a: servers 01a and 02a zone-b:...
0 votes
1 answer
860 views

SolrCore Initialization Failures - error accessing managed-schema config

I ran Sitecore "Getting Started template" and got SolrCore Initialization Failures. sitecore_marketing_asset_index_web_shard1_replica_n1: org.apache.solr.common.SolrException:org.apache....
0 votes
1 answer
54 views

Custom boosting rule for scopes to boost by time passed since last update

I am trying to implement a custom boosting rule (as described here) for the site search scope, where an item should be boosted by the time passed since last updated. For the record - we already ...
2 votes
1 answer
109 views

Facing issues while Enabling Application Insights on a SOLR App Service

I have installed Solr as an App Service in Azure by following the below articles. https://www.iamashishsharma.com/2020/11/install-solr-as-azure-app-service.html Now I am setting Application Insights ...
0 votes
2 answers
29 views

What is the relationship between Sitecore index to Solr index core?

I was able to deploy Sitecore 10.3.1 in Azure and I verified the solrConnectionString is pointed to my Solr installation https://mydomain.com:8983/solr. I understand when we deploy onprem locally, ...
0 votes
0 answers
37 views

Sitecore SolrCloud: Main alias not updating after index rebuild

I'm using Sitecore SolrCloud, and I have encountered an issue with the index rebuild process. Here's what happened: I inadvertently deleted index records from both the main and rebuild aliases in my ...
0 votes
1 answer
29 views

How to supply solrConnectionString when deploying Sitecore 10.3.1 to Azure?

I created a VM and installed the Solr 8.11 and added public IP address and certificate to make Solr accessible from outside the VM as https://mydomain.com:8983/solr - url tested and it is working. I ...
14 votes
4 answers
8k views

Configuring SSL for Solr

So I'm working my way through the Sitecore 9 install instructions, and part of it is to install Solr with SSL. Since the install guide just refers you over to Solr, I've been following the ...
3 votes
2 answers
1k views

Boosting Search Results

I was disheartened to see this in the Sitecore docs: Important Search result boosting works in Solr version 6.6 or earlier, but Solr changed the implementation in Solr 7, and later versions. ...
2 votes
1 answer
164 views

Solr search with contain

If my search keyword is 'test,' then my document is 'testtesttest.' How can I get the result to show that the number of occurrences is 3 in Solr?" Unfortunately, the result I am getting shows a ...
2 votes
1 answer
172 views

Is it possible to search the data with field type droplist ,droplink or tag tree list

I m using sitecore 9.0.1 with sxa 1.7,i have default sxa search component and wants to know whether we can search the data with field type droplist ,droplink ,tag tree list etc..Without adding any ...
0 votes
2 answers
1k views

The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel

I am installing Sitecore 9.0 update 1 using SIF version 1.2.1 , have installed Solr 6.6.2 also by following http://www.flux-digital.com/blog/install-sitecore-9-update-1-4-simple-steps/ blog but i am ...
0 votes
3 answers
37 views

Removing all index data from both main and rebuild aliases when using SwitchOnRebuild

I'm using the SitecoreSwitchOnRebuild feature, which involves two Solr index aliases - the "main" alias for search/update operations and the "rebuild" alias for rebuilding the ...
1 vote
2 answers
243 views

Including the solr field in search result along with item fields in the Search result rendering variant

I am using sxa search result for rendering the service items which contain coordinates(lat-lang). We have got a new requirement where the same services may be available in different locations. Hence ...
1 vote
1 answer
272 views

How to use Sitecore API to return result which removes Solr stopwords?

In Solr GUI I am seeing that when I am in the analyzer tab, it is removing stop words and returning results. But when I try to retrieve same result using the Sitecore search API it is not removing ...
1 vote
3 answers
382 views

Unable to get results from Solr for the Multilist values using Sitecore 9.3 code

I'm upgrading our application from Sitecore 8.2 to 9.3 and we are working on Solr 8.1 where there are lots of multilist fields available as below: "document_languages_sm":["...
1 vote
2 answers
463 views

Working with chinese language with the SXA Search Component

We have an issue, where we have content in multiple languages, and we are doing a basic keyword site search using the SXA Search Component. As far as I can tell (from the search.log), the SXA Search ...
1 vote
0 answers
43 views

How to resolve duplicate Video Items getting created in Sitecore Content Tree on Brightcove pull sync pipeline?

We have recently upgraded to Brightcove 10.1 connector. Right now we are using pull pipeline to fetch videos, player, playlist and label. But the duplicate video items are getting created even though ...
2 votes
1 answer
3k views

Non-static method requires a target

Recently migrated from Lucene to Solr search(7.2.1) in Sitecore. When I try to get the search results from Code, I'm getting the exception Non-static method requires a target However, from Solr ...
0 votes
1 answer
129 views

Accordion item type template items not indexing in Sitecore search as well as Solr search

I am working on SXA search in Sitecore I found something strange, content or data of composite rendering child items like accordion item templates types items are not indexing. I added _searchable ...
3 votes
5 answers
2k views

Solr Cores Locking. v 9.0.2

We have our SOLR server running on an Azure App Service. Occasionally the cores will lock. This can be resolved by a restart but I am hoping that there is some configuration that can help to prevent ...
0 votes
1 answer
455 views

Sitecore 9.0.1 installation is failing with Solr 6.6.3

I already have 2 instances running on my machine with Solr version 6.6.2 for POC purpose I am installing Sitecore 9.0.1 instance with Solr version 6.6.3.Solr is installed using the powershell script ...
0 votes
1 answer
212 views

How to run SOLR service on a single Port in the Azure app service?

We host the SOLR as an app service in the Azure PaaS. It seems that SOLR runs on the different port every time. Is there any way to restrict the SOLR to run on a single port only?
2 votes
1 answer
455 views

solr connection issue with Sitecore on CD servers

We have an issue happening every once and while related to the connection between the CD servers and the solr which is causing some pages to go down and show empty results.  We found that the CM is ...
1 vote
1 answer
71 views

How to reconfigure/restored Xdb Index?

My Local Xdb consists of only 4 Docs, By Using Sitecore.XConnectSearchIndexer.exe -rr command, I already rebuild my xdb index. But I am unable to get all data in Solr.
1 vote
1 answer
55 views

Content Editor search is not working for the template Ids

I have Sitecore 10.3 with SOLR search. In the "Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config" I have mentioned the <indexAllFields>false</indexAllFields> and next ...
0 votes
1 answer
105 views

Restrict Article items getting indexed programmatically in Solr

We have both Solr and Coveo Indexes for different purposes. We apply an optimization technique to indexing that I call Escape Validation. It's designed to prevent indexation from indexing content ...
0 votes
2 answers
4k views

Solr admin portal HTTP ERROR 404 Issue

We are using solr 6.6.2 with Sitecore 9.0.2 and https://localhost:8989/solr/ working fine. Yesterday evening suddenly I was getting HTTP ERROR 404 Problem accessing /solr/. Reason: Not Found ...
0 votes
1 answer
416 views

Finding literal spaces and dashes

I'm working with Sitecore 10.1 and SOLR 8.4.0. I am building a typeahead search that matches items (around 17,000) within a bucket in Sitecore. There are two fields in my template that can be matched, ...
1 vote
5 answers
98 views

How to create Solr Index custom field mapping with schema configuration?

I am newbie to Solr Index and its custom field mapping in sitecore along with its configuration. I have googled so much but I am got completely confused and unable to start from basic. Please give me ...
0 votes
1 answer
91 views

Share Index across multiple site

We are using SXA to build 4 sites under same talent for example site A , B , C and D. We have requirement to show the news articles created under any of these sites to be shown to rest of the sites , ...
3 votes
1 answer
312 views

In solr Master-Slave configuration custom indexes are getting out of sync sometimes in one of the slave servers

In our production environment, we have Master-Slave SOLR server configuration. We have 2 SOLR slave servers and configured SOLR load balancing URLs in prod CM and CD servers. Right now we are facing ...
0 votes
1 answer
222 views

Error While setting up SSL certificate for Solr 6.6.2

I am trying to setup SSL for solr 6.6.2 for Sitecore 9.0.2 but getting the below error: Does anyone have an idea how to fix this? Trusting generated SSL certificate... Import-PfxCertificate : ...
1 vote
1 answer
58 views

Order search results by frequency of the search item in a list of fields in Solr

We have a requirement to order search results based on the number of occurrence of the search term in a list of fields(not all the fields). We tried the below query in sort, but this does not provide ...
0 votes
1 answer
125 views

Sitecore Media Items not showing up in List view of dialogue box

I have recently updated my local Sitecore setup to 10.3 from 10.1 and found out that the media items are not loading in the list view of the Select Media dialogue box while the tree view working fine. ...
1 vote
1 answer
152 views

SwitchOnRebuildSolrSearchIndex is providing wrong results for SOLR master-slave setup

Our custom indexes have primary (search_index) and Secondary (search_index_rebuild) cores which are pointing differently in master and slave servers as we are using SwitchOnRebuildSolrSearchIndex. Due ...
1 vote
1 answer
203 views

SolrCloud Base ConfigSet does not exist: sitecore_content_config

I run Sitecore 10.2 with SXA in containers and I deleted all my SOLR data, SOLR Cloud have 0 collections and only a default configset in ZooKeeper. The solr-init containers give the following error on ...

1
2 3 4 5
14