Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

Filter by
Sorted by
Tagged with
0 votes
1 answer
32 views

Custom Index Strategy Not Updating Indexes

We have a custom database named Preview and are able to publish to this, but the preview index is not getting updated when an item is published. If we manually rebuild via the CMS, the item will then ...
Kode's user avatar
  • 243
1 vote
1 answer
42 views

SOLR Not Working 503 Error Netty dependencies have versions that do not match the versions specified in the azure-core-http-netty pom.xml file

We have an Azure Web App SOLR connected with Sitecore for Indexing. it was working great till Yesterday. Now the Azure Service is Not coming up with Error. HTTP Error 503. The service is unavailable. ...
Sunil Rana's user avatar
1 vote
0 answers
37 views

Sitecore Multi-Zone Setup: Solr Index not Updating in One Zone during Indexing

Title: Sitecore Multi-Zone Setup: Solr Index not Updating in One Zone during Indexing Sitecore setup with 4 CD servers configured into two zones: zone-a and zone-b zone-a: servers 01a and 02a zone-b:...
Harish's user avatar
  • 129
0 votes
1 answer
53 views

Custom boosting rule for scopes to boost by time passed since last update

I am trying to implement a custom boosting rule (as described here) for the site search scope, where an item should be boosted by the time passed since last updated. For the record - we already ...
z00mable's user avatar
  • 621
0 votes
2 answers
29 views

What is the relationship between Sitecore index to Solr index core?

I was able to deploy Sitecore 10.3.1 in Azure and I verified the solrConnectionString is pointed to my Solr installation https://mydomain.com:8983/solr. I understand when we deploy onprem locally, ...
John's user avatar
  • 91
0 votes
1 answer
29 views

How to supply solrConnectionString when deploying Sitecore 10.3.1 to Azure?

I created a VM and installed the Solr 8.11 and added public IP address and certificate to make Solr accessible from outside the VM as https://mydomain.com:8983/solr - url tested and it is working. I ...
John's user avatar
  • 91
0 votes
0 answers
37 views

Sitecore SolrCloud: Main alias not updating after index rebuild

I'm using Sitecore SolrCloud, and I have encountered an issue with the index rebuild process. Here's what happened: I inadvertently deleted index records from both the main and rebuild aliases in my ...
Harish's user avatar
  • 129
0 votes
2 answers
60 views

Solr xdb Rebuild not progressing from past 4 days

I am trying to rebuild xdb. However, it is stuck on 20.97% from past 4 days. No Error in log file. The solr is stopped on the 4742794. But keeps on saying lastmodified a minute ago. I have tried out ...
Sunil Rana's user avatar
0 votes
3 answers
36 views

Removing all index data from both main and rebuild aliases when using SwitchOnRebuild

I'm using the SitecoreSwitchOnRebuild feature, which involves two Solr index aliases - the "main" alias for search/update operations and the "rebuild" alias for rebuilding the ...
Harish's user avatar
  • 129
1 vote
0 answers
43 views

How to resolve duplicate Video Items getting created in Sitecore Content Tree on Brightcove pull sync pipeline?

We have recently upgraded to Brightcove 10.1 connector. Right now we are using pull pipeline to fetch videos, player, playlist and label. But the duplicate video items are getting created even though ...
Aniket Bajpai's user avatar
1 vote
5 answers
94 views

How to create Solr Index custom field mapping with schema configuration?

I am newbie to Solr Index and its custom field mapping in sitecore along with its configuration. I have googled so much but I am got completely confused and unable to start from basic. Please give me ...
Kumari Dimple's user avatar
0 votes
2 answers
70 views

Sitecore Multilist not indexed as multivalue

I'm working on a Solr problem. We're in the process of upgrading a Sitecore 9.2 version instance up to a 10.3. It's a multi-tenant site in Sitecore. Hosting ~10 sites. All the sites share a solr index ...
Anthony's user avatar
  • 133
0 votes
2 answers
63 views

xdb_collection.GetContactsChanges-Sync token is no longer valid for [Contacts] table

After rebuilding the xDB search index in SOLR Cloud, the data is not reflecting in the xdb_internal collection but is being updated in the xdb_rebuild_internal collection. I have checked the ...
Himmat Singh Dulawat's user avatar
1 vote
1 answer
55 views

Content Editor search is not working for the template Ids

I have Sitecore 10.3 with SOLR search. In the "Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config" I have mentioned the <indexAllFields>false</indexAllFields> and next ...
Rameshkumar's user avatar
1 vote
1 answer
52 views

What to check before rebuilding a Sitecore index via scheduled task?

I'm trying to do something that I don't see a lot of descriptions of. For our installation of Sitecore, we have a special index, for managing pictures via a service called "Digizuite". This ...
Ask Sejsbo's user avatar
0 votes
1 answer
32 views

Index rebuild on CM server only updates some CD servers in Sitecore

I have a Sitecore architecture with 1 CM server and 4 CD servers split into an A and B environment (2 servers each). The A and B environments each have their own separate databases (uatadb and uatbdb)....
Harish's user avatar
  • 129
2 votes
1 answer
165 views

My Solr health check during docker compose up is failing in my local xm cloud instance

I am having an issue with starting my XM Cloud Local Docker instance, using the up.ps1 script. It looks to be stopping specifically at this health check: test: ["CMD", "powershell",...
Bridgette Ryan's user avatar
0 votes
1 answer
66 views

SOLR issue - Install Sitecore 10.3

I'm facing the issue while installing the Sitecore 10.3 on my local. In the first step followed prerequisites step and install SOLR at the time SOLR is not installing it stuck on the 3rd out of 20. ...
Rameshkumar's user avatar
0 votes
0 answers
100 views

Sitecore SXA search ordering with Solr

I'm trying to understand how results are ordered when using a SXA Search results component without using a Default sort order option or a Sort result component. I need this for a site search, where ...
z00mable's user avatar
  • 621
1 vote
1 answer
32 views

Item versions to create by date [closed]

We have requirement to show some text content (rich text field) based on revision date updated (date field). Latest updated content (sorted by date in descending) will be shown at the top . So content ...
Akshay D's user avatar
1 vote
1 answer
51 views

Solr not returning the result on new publishing target based CD

We are trying to get the data from one of the custom indexes and the data comes on CM and CD (web DB based) but we have created a new CD based on the new publishing target as a preview and there data ...
Jumping Rabbit's user avatar
2 votes
1 answer
107 views

How to set the JVM Memory for Solr running on an Azure App Service

If you are following one of these blog posts on setting up Solr in an Azure App Service (instead of an VM) such as: https://www.getfishtank.com/blog/installing-solr-app-service-in-sitecore-azure-paas, ...
Adam Seabridge's user avatar
3 votes
1 answer
122 views

xDB index rebuild gets stuck and get Request Entity Too Large exceptions

I encountered an issue during a manual trigger of an xDB index rebuild. The process appears to get stuck at approximately 7%, and despite waiting for hours, there's no further progress. Upon ...
Antoine's user avatar
  • 71
0 votes
0 answers
29 views

Is it possible to install Sitecore in local for free? [duplicate]

Is it possible to install in local for free just for learning purpose? . please help me with it.
Yash Desai's user avatar
3 votes
1 answer
54 views

SwitchOnRebuildSolrCloudSearchIndex not working with manual update strategy

Our Sitecore 9.3 platform has a custom index called "OurProject_crawledcontent" which is used by the search functionality on the main website. This index is rebuilt by a Sitecore task every ...
Peter M.'s user avatar
  • 143
1 vote
1 answer
27 views

SXA search result API is not giving the result for the custom index on newly setup preview CD based on publishing target

We have created the custom indexes on the newly set CD server based on the new publishing target using docker. Please quickly check one of the posted questions to get an idea of how I've set up the ...
Jumping Rabbit's user avatar
0 votes
0 answers
48 views

Order search results by frequency of the search item (Wildcard and substring)

Extending my previous question We have a requirement to order search results based on the number of occurrence of the search term (wildcard and substring) in a list of fields(not all the fields). Ex : ...
D J's user avatar
  • 385
0 votes
1 answer
75 views

New publishing target based CD server is not showing index data

In docker, I created the new publishing target as preview and set the new container by copying the docker-componse instructions of the CM service and removed the master connection string from this, ...
Jumping Rabbit's user avatar
1 vote
1 answer
58 views

Order search results by frequency of the search item in a list of fields in Solr

We have a requirement to order search results based on the number of occurrence of the search term in a list of fields(not all the fields). We tried the below query in sort, but this does not provide ...
D J's user avatar
  • 385
1 vote
1 answer
56 views

Solr fails to restart during Sitecore 9.1 SIF installation

I'm installing Sitecore 9.1.0 locally using SIF and it reaches about step 70 of 85, then fails with the error Could not complete request for https://localhost:8984/solr - Unable to connect to the ...
Matthew Dresser's user avatar
0 votes
1 answer
125 views

Sitecore Media Items not showing up in List view of dialogue box

I have recently updated my local Sitecore setup to 10.3 from 10.1 and found out that the media items are not loading in the list view of the Select Media dialogue box while the tree view working fine. ...
Tabbuu's user avatar
  • 75
0 votes
1 answer
143 views

no indexes in Indexing Manager

I've recently installed a fresh local instance of Sitecore 10.3 XP0, and I've encountered an unusual issue. When I attempt to populate a Solr schema or rebuild indexes, the only indexes that appear ...
Daniel's user avatar
  • 3
0 votes
0 answers
26 views

sitecore XP to XM : Could not create instance of type: Sitecore.ContentSearch.SolrProvider.SolrSearchIndex. No matching constructor was found [duplicate]

I am deploying my XP solution to XM. I disabled xdb, analytics from project. created custom indexes in solr and then deployed the whole solution to sc102xmcm.dev.local. it is giving following error: [...
Jagmeet Kaur's user avatar
0 votes
0 answers
75 views

Rebuilding the xdb index in Solr 8.1.1 does not finish

On Sitecore 9.3 and Solr 8.1.1 I am trying to rebuild the xdb index and have started monitoring it, the progress has been stuck at 55.74 % for more than 10 hours, however, I see xdb index is moving up ...
Joel Gil's user avatar
0 votes
0 answers
31 views

Sitecore SXA All Facet values not reflecting

I am using Sitecore 10.1 SXA with Solr on Azure Kubernetes. On a Multicheck list filter, the facet values coming from sitecore_sxa_web_index exceed 100 values, hence facet.limit increased to 1000. ...
Tabbuu's user avatar
  • 75
0 votes
2 answers
291 views

Installation Failed - Cannot validate argument on parameter 'FilePath' [closed]

I am trying to install Sitecore 9.2 but at the end of the process, I am getting an error: SitecoreSolr_AddSchemaUniqueKeyField [1] : SetXml Install-sitecoreConfiguration: Cannot validate argument on ...
Daniel's user avatar
  • 3
1 vote
1 answer
157 views

Sitecore Redis Timeout Exception on ZADD Shared_ExpirationIndex

We are using Sitecore 9.3 in our multi-site application. And we are using Redis Cache in one of our application. We are suddenly facing the below exception in our Redis server. Please find the below ...
Geetha's user avatar
  • 133
0 votes
1 answer
116 views

Solr connectivity issue in Azure

I have setup Sitecore 10.3 instance in Azure and Solr hosted in Azure VM machine. Solr is not connecting and we are getting the below exception. Job started: Sitecore.ContentSearch.SolrProvider.Agents....
Reddy's user avatar
  • 125
0 votes
1 answer
116 views

Setting update.autoCreateFields=false via API when creating Solr Cores for Sitecore 10.3

I'm trying to Automate some of the Setup of Solr Core's for Sitecore 10.3 and everything works fine - apart from one thing which is that there is a requirement to set update.autoCreateFields=false in ...
Adam Seabridge's user avatar
0 votes
0 answers
24 views

Install Sitecore from EKS Cluster

I followed this link, to install Sitecore 10.3. But in real time, we need to update the secret in aws secret manager. So, I followed this link, All the pods are working as expected. But When I tried ...
biswajit sahu's user avatar
1 vote
1 answer
61 views

how to add Analyzer and Tokenizer in our customfieldtype

I'm trying to implement an analyzer and tokenizer on my created custom field type. Any ideas on how to implement it? example:- I have created one custom field type like wtbngramscase in solr schema ...
Chandan Agrawal's user avatar
0 votes
0 answers
50 views

XdbCollectionUnavailableException : The Http response was not successful Forbidden only for English and Portuguese Brazil Language

We are using Sitecore 9.3 in our application and we have updated our certificate as our certificate is going to expire on Aug 31, 2023. We have updated the thumbprint in all the Sitecore and XConnect ...
Geetha's user avatar
  • 133
2 votes
1 answer
65 views

How can get current index name while adding a custom fields to a Solr schema in using 'IPopulateHelperFactory' Sitecore 10.3

I am adding custom fields in solr schema in Sitecore 10.3. But it will be for specific index. How can i get index name in the class which is inherited from IPopulateHelperFactory refer this link to ...
Kuldeep Tewatia's user avatar
2 votes
1 answer
164 views

Solr search with contain

If my search keyword is 'test,' then my document is 'testtesttest.' How can I get the result to show that the number of occurrences is 3 in Solr?" Unfortunately, the result I am getting shows a ...
Alexng Koklek's user avatar
2 votes
0 answers
121 views

How do you add custom Solr indexes in XM/XP 10.2 with containers?

I am trying to get a custom solr index to work in sitecore 10.2 running in containers. Config <?xml version="1.0" encoding="utf-8" ?> <configuration xmlns:...
Ken Tucker's user avatar
2 votes
1 answer
97 views

Media Items not getting indexed after creation in CMS

I am facing issue with Media file indexing in Sitecore 9.2. When I upload one media file in CMS, then after save the media file is not getting index in Solr. But If I create a package of Media item ...
Koushik Mukherjee's user avatar
2 votes
1 answer
102 views

What is the way to update solr schema using code in sitecore 10.3?

I need to update Solr schema for text highlighting using code. What is the way to update Solr schema using code in Sitecore 10.3? Since 'SolrProvider.GetHelper is obsolete'
Kuldeep Tewatia's user avatar
2 votes
2 answers
807 views

Sort by title asc on Solr not working as expected

When trying sort search results in Solr using title (alphabetical) asc or desc does not work as expected and not sorted.
Sara Elgendy's user avatar
1 vote
0 answers
39 views

sort by Title in solr not working as expected [closed]

the result not sorted alphabetical esc as expected
Sara Elgendy's user avatar
0 votes
1 answer
67 views

An error occured during index rebuilding. There will be another attempt to check

Getting the below error message while rebuilding the index SourceContex - Sitecore.Xdb.Collection.Indexing.Rebuild.IIndexRebuildFlow System.Net.Http.HttpRequestException: at System.Net.Http....
Ankit Pradhan's user avatar

1
2 3 4 5
14