We’re rewarding the question askers & reputations are being recalculated! Read more.

Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

53 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
7
votes
0answers
394 views

Solr Search Model doesn't work without the dynamic field suffix

I have ContentSearch code that works and runs fine using Lucene. When I switch the configs over to Solr, the query fails, and the logs state that the field I'm using in the query doesn't exist. [...
5
votes
0answers
143 views

SolrCloud and the Indexing Manager not showing statistical information

We are looking at deploying SolrCloud with our 8.2.5 install. Everything seems to be running OK so far, however I've noticed that the Indexing manager does not load any of the indexing statistical ...
5
votes
0answers
460 views

Sitecore Azure Paas - Migrating Solr Core indexes to Azure Search indexes

I am midst of migrating a Sitecore project to Azure Paas offering. I've completed the deployment of the files (ie. dlls, configs, css, js, etc) and were able to do a complete unicorn sync. That looks ...
5
votes
0answers
140 views

Configuring Solr on remote server using SIM

Is it possible to configure Solr using SIM on a remote machine? By default it shows http://localhost:8983/solr .Can we have it something as http://abc.com:8983/solr ?
4
votes
1answer
99 views

How to add externally stored PDF documents to my existing custom index

using Sitecore 8.2 update 4 and SOLR 6.6.0. Currently using a custom crawler to index database records. I have a requirement to now index the actual pdf content the database will house a http://path/...
4
votes
0answers
200 views

Sitecore Index_Update Job Performance

We just updated from Sitecore 8.2 Update 4 to Update 7 and we've started seeing some strange behavior when publishing new items. The issue presents itself in that it takes awhile for newly created ...
4
votes
0answers
790 views

XConnect IndexWorker unable to connect

So after a clean install of Sitecore, I've been trying to get an app working with xConnect, but when I'm running that I'm getting the following exception in my code: No connection could be made ...
4
votes
1answer
282 views

CreateAlias: Setting alias 'sitecore_custom_web_index_primary_alias' to collection 'sitecore_custom_web_index' failed

I have configured a High Availability for SOLR solution with 2 x SOLR 3 x Zookeeper While I was building the indexes everything went well, except for the following 7816 05:28:53 ERROR ...
4
votes
0answers
562 views

Populate Solr Managed Schema Error

I am getting the 404 error while trying to populate the schema from "Populate Solr Managed Schema". Job started: Index_Update_Collection=sitecore_core_index|#Exception: System.Reflection....
4
votes
0answers
594 views

Sitecore Solr index FieldNameTranslator is null

I am currently playing around with Sitecore indexes - both Solr and Lucene. I have made my own custom index and it works fine for Lucene, but I cannot get it to work with Solr. My problem is that ...
3
votes
1answer
747 views

Custom Solr Fields in Sitecore 9 and Solr 7.2.1

I am converting my custom index fields from Sitecore 8.1. Previously, I would declare them like this: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www....
3
votes
0answers
65 views

Sitecore Content Search API returns expected results with Lucene as search provider but not with Solr

I'm currently writing a service that needs to integrate with Eventbrite to store external event information as items in Sitecore. We run a Sitecron job every 4 hours to pull in and update the ...
3
votes
1answer
466 views

Querying Solr datetime Collection

I have a Sitecore 9 instance using Solr. I'm trying to query a collection of datetimes such that if any of the datetimes in that collection are within a range that item will be returned. The issue ...
3
votes
0answers
111 views

SOLR CLOUD error on looping through search result on 9.0 Update-1

I'm trying to setup SOLR Cloud to work with my Sitecore 9.0 (Update-1) instance. I'm using 3 different VMs with [1-Zookeeper + 1-SOLR 6.6.2] configured on all machines. I have added the following ...
3
votes
0answers
681 views

Error with indexWorker process in Sitecore 9 xConnect with Solr 6.6.2

I am running Sitecore 9 with Solr 6.6.2 and I am seeing lot of error in the IndexWorker logs in Sitecore xConnect as below: 018-02-21 16:16:13.686 +10:00 [Error] An error occured. System.Net.Http....
3
votes
0answers
100 views

Multi-list with search showing gibberish after switching to SOLR Cloud

I'm running Sitecore 8.1 (Original Release), and last night we switched our SOLR indexes to use a dedicated SOLR Cloud set of servers instead of using a stand-alone SOLR instance on our CM server. ...
2
votes
0answers
50 views

Non-static method requires a target

Recently migrated from Lucene to Solr search(7.2.1) in Sitecore. When I try to get the search results from Code, I'm getting the exception Non-static method requires a target However, from Solr ...
2
votes
0answers
114 views

Something missing from Sitecore package, how to find out what it is

I've been trying to hand off some content for our developers to test with. However, when they use the installation wizard to install my package, the installation fails. I checked their logs and am ...
2
votes
0answers
81 views

Searching the keywords with spaces in solr

I have a search functionality in my project and the code for exactly matched keywords and search all word, the exactly is working fine but not the search all words: if (!searchRequest.SearchType....
2
votes
1answer
76 views

Search on custom solr index

I am trying to search on a solr core which contains static data without any Sitecore details. <doc> <str name="_property_text">1</str> <str name="_itemnumber_string">1250000&...
2
votes
0answers
717 views

Sitecore.Social: Social messages index could not be determined for master database

We are on Sitecore 8.1 rev. 160519 (Update-3) and using SOLR 6.2.1 Logs on one of our CM server is suddenly overflowing with the following error message: Sitecore.Social: Social messages index ...
2
votes
0answers
493 views

“org.apache.solr.common.SolrException: undefined field 0001-01-01T00” when rebuilding index

When I rebuild one of my indexes in Sitecore, I get the following error in the Solr log: org.apache.solr.common.SolrException: undefined field 0001-01-01T00 I don't have a field called 0001-01-...
1
vote
0answers
29 views

Not able to Perform multi-language search Sitecore with searchstring

Using Solr as Default search provider. Content Search is working when website language is -en example.com/en/sxa/search/results/?l=en&q=query From localhost:8983(solr) Able to query the data ...
1
vote
0answers
21 views

Specific search terms return 500

We are on Sitecore 9.0.1 and Solr version 6.6.2 and have previously had issues with populating our schemas from the Sitecore control panel. After overriding the pipeline like in this blog post (https:/...
1
vote
0answers
41 views

Implementing a solr.DateRangeField type in Sitecore

We need to use DateRangeField query in Solr to perform two dates range filter. Managed schema field sample: <fieldType name="date_range" class="solr.DateRangeField"/> I have written computed ...
1
vote
0answers
26 views

Sitecore 9.2 JSS with Solr 7.5 , JSS route items and its subitems are not indexing

Currently we are developing Sitecore JSS app with React frontend. in this we are using Headless SSR mode to create the content in sitecore and rendering. our application is working fine with React, ...
1
vote
1answer
61 views

Limit search result hits to a specific number with facets to match limited result set

I have a requirement to limit search results to an arbitrary number in a Site Search implementation. Is there a way to accomplish this in a query and get accurate facets relative to the arbitrary ...
1
vote
0answers
52 views

Sitecore 8.2 Azure Web App / Solr VMs

We are running Sitecore 8.2 as a WebApp on Azure, with this we using Solr on VMs , using along with Zookeeper [3 nodes]. There is odd behavior we are seeing, if we make any configurations on Solr as ...
1
vote
0answers
44 views

Solr Document Boosting

I'm attempting to item boosting working with Solr and I can't for the life of me get it to work. I'm certain that I've had it working in the past for other projects. The problem looks to be on the ...
1
vote
0answers
52 views

Items inside composite items are not listed on search

In SXA Search we are not getting the results for items present inside composite components like Tab/Carousel components. Does anyone have any suggestion that might help?
1
vote
0answers
45 views

Virtual Folder defined for a language site not working with Data API URL

We are on multi-lingual websites having en-CA and fr-CA languages as well. We defined virtual folder for fr-CA to share the same domain name with en-CA. Hence the en-CA works on www.mywebsite.ca and ...
1
vote
0answers
59 views

Azure Search doesn't work with query more than five letters

I've implemented simple search by query in my sitecore application. Locally it works perfectly with solr, but when solution is deployed to an Azure environment that is using Azure Search it doesn't ...
1
vote
0answers
259 views

Can I use self-signed certificates for xConnect, Solr, and Sitecore Commerce in a Sitecore 9 XP0 production deployment?

I am planning a small Sitecore 9.0.2 + Sitecore Experience Commerce production deployment for a demo website with very low traffic. I do not have a lot of time to provision multiple servers, so I plan ...
1
vote
0answers
954 views

The remote server returned an error: (400) Bad Request Error while building the custom index in SOLR 5.1

We have created a custom Itembuket_community and rebuliding the index. while Rebuilding the index, getting follwoing error Job started: Index_Update_IndexName=sitecore_Community_index|#Exception: ...
1
vote
0answers
75 views

Solr query on read/deny roles

We have a custom Solr index which includes read and deny roles. Both are added as predicates using the following code: protected virtual IQueryable<TIndexable> ApplyDenyUserRules<TIndexable&...
1
vote
0answers
389 views

Solr indexes don't incrementally update after rebuilding

We are on version 8 update 2. We have one CM and 2 CDs. All indexes are set to manual strategy on CDs. CM does all the indexing. All master db indexes are set to sync master and all web indexes to ...
1
vote
1answer
129 views

How to use Sitecore API to return result which removes Solr stopwords?

In Solr GUI I am seeing that when I am in the analyzer tab, it is removing stop words and returning results. But when I try to retrieve same result using the Sitecore search API it is not removing ...
0
votes
0answers
23 views

Adding hashtag to the internal link that leads to blog search page with tag filter search Sitecore SXA 1.9

The blog index page has all articles are listed and the filter based on tag that works with solr search. The search results based on sxatags filter will get added on the blog index page when apply ...
0
votes
0answers
33 views

sort the documents in solr based on the occurence of the searched words

I am building a search component in solr , and want to get the results on the basis of how relevant (most occured ) that word is in the particular field , i am filtering the results on a Content field ...
0
votes
0answers
23 views

Geofiltering does not work on the Shared site setup using SXA 1.7.0

On the shared site setup, no search results being returned when Geofiltering is applied. On the page load, results are rendered on the page. We noticed the below search query being generated when geo ...
0
votes
0answers
21 views

Bucket search based on branch template name

I am trying to add a custom bucket search type by branch template name. However due to limited documentation I am not able to find out how to do this. I have added a custom search type but it does not ...
0
votes
0answers
99 views

Duplicate item records in SOLR index (web)

We have a strange issue on our UAT environment where duplicate records are being returned for a single content item in a new web index we have created and both are marked with 'latestversion:true' (...
0
votes
0answers
36 views

Has any one tested Sitecore 8.2 compatibility with Solr 7.2?

Currently, we are using Solr 6.5. We want to upgrade Solr 6.5 to Solr 7.2 to leverage bidirectional replication. But Sitecore has not tested Sitecore 8.2 - Solr 7.2 compatibility. Also, there is no ...
0
votes
0answers
70 views

When searching with solr sitecore does not search in the right fields

We know that sitecore uses solr dynamic fields so that we don't need to declare all the fields that we have in sitecore separately in the solr schema to get them indexed. In our case we have a ...
0
votes
0answers
119 views

Item not removed from SOLR index after unpublish or delete

When I delete or unpublish an item in Sitecore 9.1, it is removed from the web-database and sitecore_web_index, but not from my custom index (Solr 7.2.1), any other update finds its way into the index....
0
votes
0answers
87 views

Solr query works in the web UI, not when invoked though code

I'm on Solr 4.10.4, Sitecore 8.1 160519. I have a query used internally by my application that returns 0 records. In the Search.log I can see that same query; if I copy the querystring value to the ...
0
votes
0answers
62 views

Page testing is not working when I use SOLR

When I create a page test in Sitecore Experience Optimization for the pages that are stored in SOLR index and then get the page item (which is under the page test) from the solr in code and display to ...
0
votes
0answers
64 views

Multiple versions of sitecore item under the page testing are retrieved from solr index

After the creation a page test for item, which is recorded to SOLR index, in Experience Optimization and creation some page versions to test against (during the test creation), when I get items from ...
0
votes
0answers
140 views

Indexing tool “Populate Solr Managed Schema” missing

I am currently trying to migrate some indexes and was looking at the documentation. It seems like there should be an option "Populate Solr Managed Schema" in the control panel. However, in my ...
0
votes
0answers
268 views

Sitecore SolrNet - The given key was not present in the dictionary error

We are using SolrNet open source client in Sitecore 9.0 update2 and SXA 1.7 version. We have written this code to get SolrConnection: Assert.ArgumentNotNull(searchcontext, "searchcontext"); var ...