Skip to main content

Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

167 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
6 votes
1 answer
2k views

Populate Solr Managed Schema Error

I am getting the 404 error while trying to populate the schema from "Populate Solr Managed Schema". Job started: Index_Update_Collection=sitecore_core_index|#Exception: System.Reflection....
Alok Kumar's user avatar
5 votes
0 answers
654 views

Atomic update of a SOLR document. Updating fields on document instead of full reindex of document

SOLR has a feature for doing partial updates of a document called Atomic Updates. The SOLR documentation has this example: { "id":"mydoc", "price":{"set":99}, "popularity":{"inc":20}, "...
Nikolaj's user avatar
  • 163
5 votes
0 answers
2k views

XConnect IndexWorker unable to connect

So after a clean install of Sitecore, I've been trying to get an app working with xConnect, but when I'm running that I'm getting the following exception in my code: No connection could be made ...
Trayek's user avatar
  • 1,217
5 votes
1 answer
711 views

CreateAlias: Setting alias 'sitecore_custom_web_index_primary_alias' to collection 'sitecore_custom_web_index' failed

I have configured a High Availability for SOLR solution with 2 x SOLR 3 x Zookeeper While I was building the indexes everything went well, except for the following 7816 05:28:53 ERROR ...
Vinicius Deschamps's user avatar
5 votes
1 answer
644 views

SolrCloud and the Indexing Manager not showing statistical information

We are looking at deploying SolrCloud with our 8.2.5 install. Everything seems to be running OK so far, however I've noticed that the Indexing manager does not load any of the indexing statistical ...
j_r's user avatar
  • 143
5 votes
0 answers
191 views

Configuring Solr on remote server using SIM

Is it possible to configure Solr using SIM on a remote machine? By default it shows http://localhost:8983/solr .Can we have it something as http://abc.com:8983/solr ?
tpkphani's user avatar
  • 339
5 votes
0 answers
1k views

Sitecore Solr index FieldNameTranslator is null

I am currently playing around with Sitecore indexes - both Solr and Lucene. I have made my own custom index and it works fine for Lucene, but I cannot get it to work with Solr. My problem is that ...
M.frank's user avatar
  • 101
4 votes
0 answers
271 views

Sitecore Content Search API returns expected results with Lucene as search provider but not with Solr

I'm currently writing a service that needs to integrate with Eventbrite to store external event information as items in Sitecore. We run a Sitecron job every 4 hours to pull in and update the ...
Ryan Shohoney's user avatar
4 votes
0 answers
486 views

Sitecore Index_Update Job Performance

We just updated from Sitecore 8.2 Update 4 to Update 7 and we've started seeing some strange behavior when publishing new items. The issue presents itself in that it takes awhile for newly created ...
Ben Stichter's user avatar
4 votes
0 answers
1k views

Error with indexWorker process in Sitecore 9 xConnect with Solr 6.6.2

I am running Sitecore 9 with Solr 6.6.2 and I am seeing lot of error in the IndexWorker logs in Sitecore xConnect as below: 018-02-21 16:16:13.686 +10:00 [Error] An error occured. System.Net.Http....
Arun Kumar's user avatar
4 votes
0 answers
112 views

Multi-list with search showing gibberish after switching to SOLR Cloud

I'm running Sitecore 8.1 (Original Release), and last night we switched our SOLR indexes to use a dedicated SOLR Cloud set of servers instead of using a stand-alone SOLR instance on our CM server. ...
Keith VanderVeen's user avatar
3 votes
1 answer
333 views

In solr Master-Slave configuration custom indexes are getting out of sync sometimes in one of the slave servers

In our production environment, we have Master-Slave SOLR server configuration. We have 2 SOLR slave servers and configured SOLR load balancing URLs in prod CM and CD servers. Right now we are facing ...
Ruchi Gupta's user avatar
3 votes
1 answer
125 views

Facing issues while Enabling Application Insights on a SOLR App Service

I have installed Solr as an App Service in Azure by following the below articles. https://www.iamashishsharma.com/2020/11/install-solr-as-azure-app-service.html Now I am setting Application Insights ...
Anuj Singh's user avatar
3 votes
2 answers
1k views

Boosting Search Results

I was disheartened to see this in the Sitecore docs: Important Search result boosting works in Solr version 6.6 or earlier, but Solr changed the implementation in Solr 7, and later versions. ...
Ethan Schofer's user avatar
3 votes
0 answers
249 views

Not able to fetch search result in Content search API with Solr and Azure

I am using content search API in Sitecore 9.1.1. However, it is not fetching result if i am using search with any of the template field. The below code fetching result based on template id but when we ...
Ashish's user avatar
  • 912
3 votes
0 answers
142 views

Sitecore indexing a SXA Multisite configuration for more than 500 sites

I am stuck with issue for indexing a SXA Multisite configuration for 600 sites. The case study is as below. Issue: Indexing get failed at certain point of time from CM itself for Solr Master(after 2 ...
Nikhil Kulkarni's user avatar
3 votes
0 answers
824 views

Searching the keywords with spaces in solr

I have a search functionality in my project and the code for exactly matched keywords and search all word, the exactly is working fine but not the search all words: if (!searchRequest.SearchType....
Rohan Bhateja's user avatar
3 votes
0 answers
225 views

SOLR CLOUD error on looping through search result on 9.0 Update-1

I'm trying to setup SOLR Cloud to work with my Sitecore 9.0 (Update-1) instance. I'm using 3 different VMs with [1-Zookeeper + 1-SOLR 6.6.2] configured on all machines. I have added the following ...
Jijo Viswanathan's user avatar
3 votes
0 answers
2k views

The remote server returned an error: (400) Bad Request Error while building the custom index in SOLR 5.1

We have created a custom Itembuket_community and rebuliding the index. while Rebuilding the index, getting follwoing error Job started: Index_Update_IndexName=sitecore_Community_index|#Exception: ...
Pushpendra Vats's user avatar
3 votes
0 answers
733 views

"org.apache.solr.common.SolrException: undefined field 0001-01-01T00" when rebuilding index

When I rebuild one of my indexes in Sitecore, I get the following error in the Solr log: org.apache.solr.common.SolrException: undefined field 0001-01-01T00 I don't have a field called 0001-01-...
Matt Eno's user avatar
  • 373
2 votes
1 answer
228 views

Solr search with contain

If my search keyword is 'test,' then my document is 'testtesttest.' How can I get the result to show that the number of occurrences is 3 in Solr?" Unfortunately, the result I am getting shows a ...
Alexng Koklek's user avatar
2 votes
0 answers
123 views

How do you add custom Solr indexes in XM/XP 10.2 with containers?

I am trying to get a custom solr index to work in sitecore 10.2 running in containers. Config <?xml version="1.0" encoding="utf-8" ?> <configuration xmlns:...
Ken Tucker's user avatar
2 votes
3 answers
107 views

Is it possible to use bucket items on more than one page?

We have an Item bucket of News articles created for one of our client websites. We want to display those items on the News page and Press Release page since the content is somewhat the same. We are ...
Mohit Patil's user avatar
2 votes
1 answer
89 views

Inconsistent behavior when use Solr boosting

I'm using Sitecore 9.3 and Solr 8.1.1, I have this simple query q=itemName_t:(*test*)^80&fl=itemName_t,_templateID,score&fq=_indexname:(custom_index)&wt=xml And these are the results: ...
Mohamed Yaseen's user avatar
2 votes
1 answer
475 views

solr connection issue with Sitecore on CD servers

We have an issue happening every once and while related to the connection between the CD servers and the solr which is causing some pages to go down and show empty results.  We found that the CM is ...
Hamzeh Aledous's user avatar
2 votes
1 answer
264 views

Installing Sitecore 9.3 Offline

I am trying to install Sitecore 9.3 on one of our servers (not connected to the internet). But in the end it throws this error. I installed Solr separately before installing Sitecore using ...
Amin Sayed's user avatar
2 votes
0 answers
703 views

Sort By Grouping NumFound Field

Hello Sitecore Stack Exchange, Environments: Sitecore 9.2, Solr 7.5.0|SolrCloud 7.5.0, Custom search index. In the Search logic I have the next requirement: I should group search response and sort ...
Vadim Birkos's user avatar
2 votes
0 answers
705 views

Filtering Solr search results based on score

I'm trying to figure out a way to apply a filter on result scores. E.g. I want only results with score >50. In pure Solr, that is solved by using a filter query. Adding the following to the query ...
Max Mayorov's user avatar
2 votes
1 answer
174 views

Is it possible to search the data with field type droplist ,droplink or tag tree list

I m using sitecore 9.0.1 with sxa 1.7,i have default sxa search component and wants to know whether we can search the data with field type droplist ,droplink ,tag tree list etc..Without adding any ...
Vinaya's user avatar
  • 321
2 votes
0 answers
1k views

Empty String in Solr

I have a custom field to be Indexed for each Item. If it does not get the value it returns string.Empty. Before when Item's searched in Solr, whose custom fields are string.empty the field was not ...
Debaparna's user avatar
  • 507
2 votes
0 answers
87 views

Keyword search with field level boosting and spatial search

Sitecore 9.3 I want to boost a result based on a field containing a keyword and it's working absolutely fine with the below query. var keywordQuery = PredicateBuilder.True<SearchResultItem>(); ...
Arvind Gehlot's user avatar
2 votes
0 answers
146 views

class SolrContentSearchManager in namespace Sitecore.ContentSearch.SolrProvider si deprecated

Recently i upgraded sitecore instance from 8.1 to 9.3. SOlr5.4.1 set up was working fine with sc8.1, I was using NINJECT as DI. now after upgrading , SOlr is causing at DI level, complaining that ...
Rajesh Kumar's user avatar
2 votes
0 answers
260 views

Sitecore Solr search indexing getting stopped

We are seeing Solr master and web index updates are getting stopped randomly in mid of the day. I tried one approach that is mentioned in this answer. Updated the master index strategy to use ...
Ramakrishna Kudikala's user avatar
2 votes
1 answer
430 views

SXA Search Boosting Throws Error

I have configured the search scope for SXA (Sitecore 9.3) and it works as expected. However, when I try to add boost configuration to the search scope it throws the below error. Invalid Method Call ...
poola's user avatar
  • 21
2 votes
0 answers
280 views

Populate Solr Managed Schema deletes added solr fields

I am adding fields via the Solr admin and can see them in the managed-schema file, however when I go to Sitecore Populate Solr Managed Schema, and run it, those fields get removed Am I missing ...
David Glass's user avatar
2 votes
0 answers
187 views

Index core names and rebuild core

I've noticed in Sitecore 9 (at least through 9.1.1) that the value of <param desc="core> is based on the prefix you use during installation (IE, if you chose "local" as a prefix, the core is ...
Ken McAndrew's user avatar
  • 5,122
2 votes
1 answer
4k views

Non-static method requires a target

Recently migrated from Lucene to Solr search(7.2.1) in Sitecore. When I try to get the search results from Code, I'm getting the exception Non-static method requires a target However, from Solr ...
Thakash Kumar's user avatar
2 votes
0 answers
582 views

Something missing from Sitecore package, how to find out what it is

I've been trying to hand off some content for our developers to test with. However, when they use the installation wizard to install my package, the installation fails. I checked their logs and am ...
Frank Rosario's user avatar
2 votes
0 answers
171 views

Solr Document Boosting

I'm attempting to item boosting working with Solr and I can't for the life of me get it to work. I'm certain that I've had it working in the past for other projects. The problem looks to be on the ...
Matthew FitzGerald-Chamberlain's user avatar
2 votes
0 answers
1k views

Sitecore.Social: Social messages index could not be determined for master database

We are on Sitecore 8.1 rev. 160519 (Update-3) and using SOLR 6.2.1 Logs on one of our CM server is suddenly overflowing with the following error message: Sitecore.Social: Social messages index ...
Arvind Gehlot's user avatar
1 vote
2 answers
39 views

My csv contact list after update to list manager is showing 0 recipient

I am working on EXM, so i have created contact list csv and uploaded it in List manager in my local, but after that it is showing as 0 recipients. How to fix it?? Note: This issue is only occurring ...
smruti satapathy's user avatar
1 vote
1 answer
116 views

SOLR Not Working 503 Error Netty dependencies have versions that do not match the versions specified in the azure-core-http-netty pom.xml file

We have an Azure Web App SOLR connected with Sitecore for Indexing. it was working great till Yesterday. Now the Azure Service is Not coming up with Error. HTTP Error 503. The service is unavailable. ...
Sunil Rana's user avatar
1 vote
0 answers
46 views

Sitecore Multi-Zone Setup: Solr Index not Updating in One Zone during Indexing

Sitecore setup with 4 CD servers configured into two zones: zone-a: servers 01a and 02a zone-b: servers 01b and 02b Each zone has its own Solr Cloud setup: zone-a points to a Solr cluster with ...
Harish's user avatar
  • 129
1 vote
0 answers
45 views

How to resolve duplicate Video Items getting created in Sitecore Content Tree on Brightcove pull sync pipeline?

We have recently upgraded to Brightcove 10.1 connector. Right now we are using pull pipeline to fetch videos, player, playlist and label. But the duplicate video items are getting created even though ...
Aniket Bajpai's user avatar
1 vote
1 answer
58 views

Content Editor search is not working for the template Ids

I have Sitecore 10.3 with SOLR search. In the "Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config" I have mentioned the <indexAllFields>false</indexAllFields> and next ...
Rameshkumar's user avatar
1 vote
1 answer
60 views

Order search results by frequency of the search item in a list of fields in Solr

We have a requirement to order search results based on the number of occurrence of the search term in a list of fields(not all the fields). We tried the below query in sort, but this does not provide ...
D J's user avatar
  • 385
1 vote
1 answer
70 views

how to add Analyzer and Tokenizer in our customfieldtype

I'm trying to implement an analyzer and tokenizer on my created custom field type. Any ideas on how to implement it? example:- I have created one custom field type like wtbngramscase in solr schema ...
Chandan Agrawal's user avatar
1 vote
1 answer
78 views

How to reconfigure/restored Xdb Index?

My Local Xdb consists of only 4 Docs, By Using Sitecore.XConnectSearchIndexer.exe -rr command, I already rebuild my xdb index. But I am unable to get all data in Solr.
Ankit Pradhan's user avatar
1 vote
0 answers
35 views

Sitecore Search Scope Boosting - 400 Bad request

I have created a search scope that works very well. But I would like to make the search box to search the items based on the field value. So I add a new rule in the boosting section and it throws a ...
Jack Noob's user avatar
1 vote
1 answer
162 views

SwitchOnRebuildSolrSearchIndex is providing wrong results for SOLR master-slave setup

Our custom indexes have primary (search_index) and Secondary (search_index_rebuild) cores which are pointing differently in master and slave servers as we are using SwitchOnRebuildSolrSearchIndex. Due ...
Ruchi Gupta's user avatar