Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

Filter by
Sorted by
Tagged with
0 votes
0 answers
59 views

Apply sorting on specific template

I'm using Sitecore 9.3, I have search API that fetches two types of templates, Product and Content Page, the search results are always a combination of these two types. I apply boosting on Product ...
0 votes
0 answers
61 views

SXA indexes are populated with limited document count only

I am facing a weird issue like if I index sitecore_sxa_master_index and sitecore_sxa_web_index then popup shows all items indexed successfully and no error is coming in either siteore logs or SOLR ...
2 votes
1 answer
195 views

How to set uniqueKey field in JSON based Solr Schema

I am using JSON based Solr schema to create custom indexes in Sitecore V10.2 docker. After rebuilding my custom index, I am getting following error : Although, when I checked the fields in the custom ...
  • 83
0 votes
1 answer
110 views

Adding a computed field using the Schema API with SolrCloud

Does anyone have any experience adding computed fields to a managed schema? I'm using Solr in SolrCloud mode with 1 node. My Sitecore 10.2 setup uses docker with a solr-init and solr image. I'm able ...
0 votes
0 answers
24 views

Enabling "Sitecore.ContentSearch.SolrCloud.SwitchOnRebuild" Gives error [duplicate]

I am using Solr Cloud with Sitecore 10.1. When I enable the configuration file Sitecore.ContentSearch.SolrCloud.SwitchOnRebuild it gives me the below error. Here is the text error message Could not ...
  • 2,553
0 votes
0 answers
38 views

SolrContextCommand.DoesIndexExist

I have a problem with crawling after installing Sitecore commerce. SOLR works, mom is set in CommerceMinions application: "$values": [ { "$type": "Sitecore....
  • 301
2 votes
1 answer
347 views

Sorting by date with Solr is returning an incorrect sort order

If I run a normal search query via the content search API, sorted by an indexed date field, it is not sorting the results correctly. I have checked that the sort field on the Solr managed schema is in ...
  • 5,110
1 vote
1 answer
26 views

Select A Rendering Not Recognizing Allowed Controls From Placeholder after App Pool Recycle

I'm experiencing an issue in Sitecore 9.0.2, Lucene index, and 10.2, Solr index, where some, but not all, of our placeholders in Experience Editor are not recognizing the renderings inside the Allowed ...
  • 21
0 votes
0 answers
148 views

Configure remote solr server for Sitecore 10 running on docker container

I have Sitecore 10 instance running on docker. It uses a default solr container, indexing also works fine. But I want to use a remote Solr server (I have configured solr search service in azure). I ...
  • 71
0 votes
0 answers
22 views

In Solr can we use two diff. fields (min and max) for single range facet?

Currently, I am trying to implement salary range facets like 10000-20000 (2) 20001-30000 (100) 50000-60000 (150) However in Sitecore, we have two different fields (MinSalary & MaxSalary) to ...
2 votes
3 answers
252 views

sitecore_web_index index is not getting updated upon publish on remote Solr servers

I am hoping to understand the cause of this and hopefully find a solution - I have looked at every possible solution, but haven't been able to fix it. Sitecore v10.0.2 using Solr 8.4. In my current ...
  • 97
0 votes
1 answer
518 views

SolrCore Initialization Failures - error accessing managed-schema config

I ran Sitecore "Getting Started template" and got SolrCore Initialization Failures. sitecore_marketing_asset_index_web_shard1_replica_n1: org.apache.solr.common.SolrException:org.apache....
  • 31
3 votes
2 answers
696 views

Creating a custom Solr core using solr-init container in docker

I am using docker approach with Sitecore V10.2. I am trying to create a custom index with it's associated schema. I followed following article as the reference point : Add your custom index to Solr in ...
  • 83
1 vote
1 answer
64 views

Modifying Solr Logging Library on Sitecore 8.2

I'm trying to modify the log4j 1 library in Solr which is used with Sitecore 8.2. The plan is to either upgrade the Log4j to Log4j 2, or to use Java Logging instead using SLF4J. Will this kind of ...
0 votes
1 answer
85 views

Solr QueryElevationComponent being ignored

I'm trying to set up "best bets" in a Sitecore 9.3 environment. I set up the Solr Query Elevation Component following the instructions at this URL: https://solr.apache.org/guide/6_6/the-...
  • 21
0 votes
2 answers
233 views

GetFacets / GetResults returns an empty facet list

I was tasked to create a facet component for our solution on top of an already existing search functionality - which is an API controller. The code snippet I added is the use of .FacetOn(x => x[key]...
  • 333
1 vote
2 answers
175 views

Solr index field return types are different

We have upgraded to Sitecore 10.1 from Sitecore 8.2 and Solr 8.4 from Solr 6.6.2 We have a droplist field which is PropertyAddressState and after rebuiliding the index it is propertyaddressstate_s ...
0 votes
0 answers
40 views

Solr 8.4 date issue

We are migrating Sitecore 8.2 to 10.1 and also Solr 6.6.2 to Solr 8.4. The indexes in Solr 8.4 are building fine. But, there is issue with the date. The search result looks like this The publication ...
1 vote
2 answers
511 views

Sitecore indexing manager is empty without showing indexes

Issue: Sitecore Indexing manager not listing any indexes and got the below error in crawling logs. About the application architecture: We are using Sitecore 9.2 which hosted in On Premises as scaled ...
  • 137
0 votes
0 answers
108 views

Solr - sort results based on the distance (lat and long) and search keyword relevance

I am working on the search functionality where I am trying to sort the results based on the distance and search keyword relevance but it is not working as expected. When I try with the search keyword ...
0 votes
1 answer
44 views

Share Index across multiple site

We are using SXA to build 4 sites under same talent for example site A , B , C and D. We have requirement to show the news articles created under any of these sites to be shown to rest of the sites , ...
6 votes
2 answers
766 views

Could not find add method: AddIndex (type: Sitecore.ContentSearch.ContentSearchConfiguration)

We are setting up a new Sitecore 9.3 instance on a server, making the respective connection string changes and getting the below error while loading the Sitecore login page: Error: Could not find add ...
  • 93
1 vote
1 answer
386 views

Creating a custom Solr core in docker using docker

I am trying to create a custom solr index using custom schema with docker container approach. I am able to create a custom index, but I am not able to associate it with the custom schema. I did copy a ...
  • 83
0 votes
2 answers
64 views

Semantic Tag Based Sxa Search not showing result on solr search service

I am using Sitecore 10.1 with Sxa on solr 8.4.1. The sxa scopes based on templates having any semantic tag is showing result in build query, but not on page preview nor published page. Example query : ...
  • 63
0 votes
3 answers
263 views

How to write the query for grouping of articlecategories to fetch the count of article in Solr

I would like to query in Solr, to pass the list of categoryID('cat001','cat002','cat003','cat004'), based on the categoryID, we need to get the count of Article of passed categoryID in the Solr Query, ...
0 votes
1 answer
588 views

Install Solr Search Service failed - Sitecore 10

I am installing Sitecore Experience Platform 10.1 Update-1 using a Graphical setup package for XP Single. After completion of pre-requisites when it install Solr Seach Service its failed and shows me ...
0 votes
0 answers
11 views

Is there any way to decrease the IDF factor in the relevancy score for Solr?

Context: We are seeing users use location names in the keyword search for medical practices and any practice that has the location name in the name of the practice and is only 2-3 words showing up ...
1 vote
1 answer
188 views

How to apply a greater/less than DateTime query in Sitecore using the `IQueryable<ContentSearchResult>` Linq?

How do you apply a DateTime field comparison in Sitecore using the Sitecore.ContentSearch SDK? The ContentSearchResult[string key] function always returns a string which cannot be cast into a DateTime ...
0 votes
0 answers
208 views

Sitecore throw exception when index Date field

We are seeing the error below being thrown in our production environment. In our QA and dev environments we don't see the error. We have tried the following: Deleting the Solr index and rebuilding ...
0 votes
0 answers
75 views

Content search - An error has occurred and the search cannot be completed

When I search something in the Content search and it is not working, and the UI shows 0 results with a message on red background under the search bar "An error has occurred and the search cannot ...
  • 193
1 vote
1 answer
116 views

How to find zookeeper configs path location

I've setup a SOLR server with Zookeeper by followed the below link. SolrCloud-Helpers I have done the Solr and Zookeeper setup by using the powershell script by given the above link and I can see ...
0 votes
1 answer
225 views

Finding literal spaces and dashes

I'm working with Sitecore 10.1 and SOLR 8.4.0. I am building a typeahead search that matches items (around 17,000) within a bucket in Sitecore. There are two fields in my template that can be matched, ...
  • 1
0 votes
1 answer
111 views

Boosting items by its own field values

I'm using Sitecore 9.3 and Solr 8.2.1, I had Solr index-time boosting in my old search implementation, but after I upgraded to a new Solr version, it is deprecated now. Imagine I have an item with ...
3 votes
1 answer
110 views

Sitecore.ContentSearch.Linq is adding backslash to all space characters in search query

Whenever I query using the Like query the Sitecore generated Solr query escapes the space characters. Here is an example: queryable = queryable.Where(result => result["...
1 vote
1 answer
138 views

Solr suspicious behavior

I've Sitecore instance hosted on Azure according to below breakdown : Sitecore 9.1 (each component as standalone App Service) Solr 7.2.1 (standalone App Service) App insights configured and connected ...
  • 43
1 vote
1 answer
292 views

Publish events don't trigger indexing

I was using Sitecore 8.2 then upgraded to Sitecore 9.3, after the upgrade process, when I publish any item, I noticed that the index is not updated, I must trigger a full rebuild for the index to be ...
0 votes
0 answers
140 views

Unexplained SOLR query

I'm using Sitecore instance 9.1, Solr 7.2.1, and SXA 1.8. I was checking "Search" logs and found below ERROR entry. 5012 12:49:26 INFO Solr Query - ?q=((query:(self) AND _path:(...
  • 43
0 votes
2 answers
191 views

Content Search API issue with Droplist and Treelist fields

I am facing a weird(might not be weird for experienced people) issue where ContentSearch API is returning null value for few fields while I can see the correct values in Solr. The fields whose values ...
2 votes
0 answers
218 views

solr connection issue with Sitecore on CD servers

We have an issue happening every once and while related to the connection between the CD servers and the solr which is causing some pages to go down and show empty results.  We found that the CM is ...
1 vote
2 answers
688 views

Solr index field are indexed with ItemFieldName_sm & not as ItemField_s

Recently we have upgraded our project to Sitecore 10 & SOLR 8.4 , after the upgrade we set up the solr & rebuilt indexes for all indexes. But we are seeing a lot of index fields are stored/...
  • 97
0 votes
1 answer
171 views

No such core:xdb

I am getting a no such core:xdb error when trying to rebuild xdb Sitecore.Xdb.Collection.Search.Solr.Failures.SolrResponseException: { "responseHeader":{ "status":400, &...
user avatar
1 vote
2 answers
188 views

Visualization.GetRenderings returns empty string using local: data source

I am trying to index rendered content. I am using the following plugin. It works with a global data source, however, it does not index rendered content if the data source is local (local:/Data/Rich ...
0 votes
3 answers
197 views

Unable to get results from Solr for the Multilist values using Sitecore 9.3 code

I'm upgrading our application from Sitecore 8.2 to 9.3 and we are working on Solr 8.1 where there are lots of multilist fields available as below: "document_languages_sm":["...
  • 93
1 vote
1 answer
325 views

Sitecore 9.3 Solr Computed Field not updated [duplicate]

I have a computed field which is not updated when Sitecore item getting into index (all other field values are indexed) but if I do manual rebuild for the index then my computed field value get ...
0 votes
1 answer
2k views

Solr admin portal HTTP ERROR 404 Issue

We are using solr 6.6.2 with Sitecore 9.0.2 and https://localhost:8989/solr/ working fine. Yesterday evening suddenly I was getting HTTP ERROR 404 Problem accessing /solr/. Reason: Not Found ...
0 votes
1 answer
40 views

Finding root of a current index

Is there a way to get the index root. I am able to find the current index using the following code indexService.GetContentIndexName() How can I get the current Root defined inside the index ?
user avatar
0 votes
1 answer
70 views

Crawl html links in a Rich textfield in SOLR

I have a Rich text field. If the user enters a hyperlink in the richtextbox and I run a query in SOLR, it shows up as text only. The link associated does not show up. What could the issue be? In the ...
1 vote
1 answer
150 views

Including the solr field in search result along with item fields in the Search result rendering variant

I am using sxa search result for rendering the service items which contain coordinates(lat-lang). We have got a new requirement where the same services may be available in different locations. Hence ...
-1 votes
1 answer
106 views

Unable to GetItems() from Multilist Field with Search

I am currently working on upgrading Sitecore 8.2 to 9.3, I came across the multi-list field with Search where we were able to get the items in 8.2 but not in 9.3. Please find the below code used to ...
  • 93
1 vote
1 answer
240 views

Programmatically boost items in an index does not work

I have this code: public class ResolveDemoBoostFactor : BaseResolveItemBoostPipelineProcessor { public override void Process(ResolveItemBoostArgs args) { Assert.ArgumentNotNull(...

1
2
3 4 5
12