We’re rewarding the question askers & reputations are being recalculated! Read more.

Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

Filter by
Sorted by
Tagged with
5
votes
1answer
966 views

“There is no method 'Filter' on type 'Sitecore.ContentSearch.Linq.QueryableExtensions' that matches…”

I'm re-posting because the other thread on with 'GetResults' instead of 'Filter' SOLR error message is in a different context. This thread was when migrating from 8.1 to 8.2, while we are migrating ...
10
votes
3answers
1k views

SOLR and Zookeeper setup

I am trying to setup mit XP1 installation requirements. So I've setup a single SOLR server with Zookeeper on it like descripted here: https://lucene.apache.org/solr/guide/6_6/setting-up-an-external-...
1
vote
1answer
456 views

Sitecore Index Update on Item Delete

Is there a way where i can delete the Item from Sitecore Solr Index when an Item is deleted since item is not there i can not get the handle of item
0
votes
1answer
319 views

Sitecore Content Search is not working in the Content Editor

I'm getting the following error while performing Sitecore content search: ERROR Could not resolve type name: Sitecore.Support.ContentSearch.Client.Pipelines.Search.SearchContentSearchIndex, ...
1
vote
1answer
137 views

Solr cloud collection sitecore_web_index occasionally has multiple versions of an item in the index

We are running Solr 5.5.4 and Sitecore 8.2.3. Our collection for the web index occasionally has multiple versions of an item in it. This is causing problems with some of our older search queries ...
4
votes
1answer
282 views

CreateAlias: Setting alias 'sitecore_custom_web_index_primary_alias' to collection 'sitecore_custom_web_index' failed

I have configured a High Availability for SOLR solution with 2 x SOLR 3 x Zookeeper While I was building the indexes everything went well, except for the following 7816 05:28:53 ERROR ...
0
votes
4answers
2k views

Solr custom field reader and indexing

I have read this article about how to create custom field reader and index I would like to ask that at the very last step, in MySearchResultItem class, is it mandatory to match the index field name "...
3
votes
1answer
457 views

Sitecore Search API not searching List of Guids Unsupported expression node type

I have created an index field called "facetCategory". public class IndexResultModel : SearchResultItem { [IndexField("facetcategory_sm")] public IList<Guid> FacetCategory { ...
3
votes
1answer
310 views

Sitecore datetimecollection computed field issue

We've solr configured for our 8.2 solution. Recently, a new computed field has been added to the schema. This field is a datetimecollection field which has list of datetimes. Here is the code for it....
1
vote
1answer
409 views

Sitecore Date type Solr indexing In UTC - How to perform solr search

I have a date field in the template. It's value is set to 4/8/2018. However, when I see the item's raw value, Sitecore converts it into UTC and stores it like 20180407T183000Z. The same value is ...
1
vote
1answer
466 views

How to ignore case sensitivity for multilist/list types field in the solr

I have created a Computed Field to index a MultiList field type into Solr. By default, Solr defines a Case Sensitive search behavior over Multivalued/List type. Below is the example- Solr indexed ...
3
votes
2answers
250 views

Is there possibility to use Solr in Sitecore PaaS?

Clients wants to go full PaaS with Sitecore 9 and Sitecore Experience Commerce 9. We have existing solution which was built with Sitecore 8.2 and Sitecore Commerce 8.2.1 with Solrand it's deployed as ...
3
votes
0answers
111 views

SOLR CLOUD error on looping through search result on 9.0 Update-1

I'm trying to setup SOLR Cloud to work with my Sitecore 9.0 (Update-1) instance. I'm using 3 different VMs with [1-Zookeeper + 1-SOLR 6.6.2] configured on all machines. I have added the following ...
0
votes
3answers
2k views

Unable to set up SSL for Solr

I am trying to install Sitecore 9 (Update 1) through SIF. I have everything in place, I just need to enable SSL for Solr. I have Solr 6.6.2. I saw the official reference and have no idea how to ...
4
votes
0answers
558 views

Populate Solr Managed Schema Error

I am getting the 404 error while trying to populate the schema from "Populate Solr Managed Schema". Job started: Index_Update_Collection=sitecore_core_index|#Exception: System.Reflection....
1
vote
1answer
249 views

Site Search is not working with Solr Master slave configuration [closed]

We have set up the Master and Slave for Solr configuration. There is one master and two slave servers configured on different ports. Appropriate replication is configured. The load balance is in place ...
4
votes
1answer
176 views

How to use Sitecore SwitchOnRebuildSolrSearchIndex on Solr slave Indexes which are replicated from Master Index

The following is our master/slave configuration by using Solr replication. Here is the image which depicts our configuration: SOLR-master is connected to the CM instance. When the CM rebuilds the ...
1
vote
3answers
2k views

When do indexes get rebuilt automatically in Sitecore?

To my knowledge, indexes get rebuilt automatically when a Content Author performs a Smart Publish and/or a Full Republish in Sitecore. That functionality does not seem to functioning as intended as we ...
5
votes
2answers
3k views

Installing Sitecore 9 in XP0 setup with SOLR instance on Remote Server

I have setup the sitecore 9 on my machine and used setup guide I have installed SQL Server 2017 and SOLR 6.6.2 in Remote Server. [The OS is Windows Server 2012 R2 Standard] I have followed the ...
0
votes
1answer
639 views

Unable to filter solr index contents by template

I have created a custom index (Sitecore 9 Update 1) using the below config, hoping that the index would contain documents only corresponding to the 3 included templates. However my index includes all ...
4
votes
1answer
564 views

Sitecore 9 Installation :: Could not find Solr instance [closed]

I'm following given post for Sitecore 9 Set up on local machine Sitecore 9 set up Got below error on install.ps1 execution even I'm able to browse the Solr URL( https://localhost:8985/solr/ ) ...
1
vote
1answer
122 views

SXA Search Results Grouping

I am using Sitecore 9.0 with SXA 1.6 and Solr search provider. Is there a way to display results grouped in SXA Search results components?
1
vote
1answer
290 views

Content search in Sitecore pointing to custom index instead of Master

we have configured SOLR MASTER/SALVE in our environment on different servers and Configured the required replication. Index is rebuild and web site is search is working. when we try to search with in ...
0
votes
1answer
60 views

Switching Sitecore Indexing to Solr with SXA 1.4

We have switched our Sitecore instance from Lucene to Solr with SXA 1.4. Lucene works fine with the 'yyyyMMdd' date format but Solr needs 'yyyy-MM-DDTHH:mm:ssZ', so querying is not working when we ...
0
votes
1answer
538 views

Error while rebuilding the search index on Sitecore 8.2 and Solr 6.6.1

We are able to successfully build all the indexes for the first time except sitecore_master_index, sitecore_web_index and Sitecore_core_index And when trying to rebuild sitecore_master_index for the ...
1
vote
2answers
1k views

XConnect IndexWorker Certificate issue

On a developer workstation, all of my xConnect instances are having their \App_data\jobs\continuous\IndexWorker\App_data\Logs filled with the following error: 2018-03-26 22:44:01.661 -04:00 [Error]...
1
vote
1answer
350 views

SXA 1.6 SOLR SolrNet.Exceptions.SolrConnectionException unknown field

In Sitecore 8.2.6 the following error occurs: WARN [Index=sitecore_master_index] Crawler : AddRecursive DoItemAdd failed - {93F413F7-09AF-4E67-B0C4-45D501DD042C} Exception: SolrNet.Exceptions....
1
vote
0answers
949 views

The remote server returned an error: (400) Bad Request Error while building the custom index in SOLR 5.1

We have created a custom Itembuket_community and rebuliding the index. while Rebuilding the index, getting follwoing error Job started: Index_Update_IndexName=sitecore_Community_index|#Exception: ...
2
votes
1answer
605 views

No Indexes showing in Index Manager on Azure CM AppService

We have created our Sitecore production environment (Sitrecore 8.2 Update 5, EXM + XDB Cloud) using ARM templates. This means we have CM, CD, Reporting, Processing and DDS (Data Distribution Server) ...
5
votes
1answer
132 views

Setting Up Query Elevations

This is related to Solr QueryElevationComponent component usage, but I'm looking for information on getting elevation setup. I see some other questions involving Solr query elevation. Is there ...
2
votes
1answer
702 views

Could not resolve type name error while performing search in Sitecore in Content tree

After logging to the Sitecore content tree, getting the below error while performing the search. An error occured while searching. Rephrase the query. Could not resolve type name: Sitecore....
0
votes
1answer
621 views

Get parent item and it's all child item from solr searchresultItem

I have a requirement that needs to get particular item along with all child item or some of the child item using template id from solr searchresultitem. Can anyone help how to achieve this?
3
votes
1answer
168 views

What are some methods for indexing and searching content from multiple sites? [closed]

Pretend you have a small client that is on Sitecore 8.2 on-premise (virtual servers). Traffic is pretty light, and they get away with using just 2 servers (1 DB and 1 Web). Needless to say budget is ...
2
votes
1answer
178 views

How to correctly process index dependencies for correct language?

I am updating index dependencies as mentioned in Sitecore Full Content Search where we are using GetDatasourceDependencies. Now, the issue is that this works fine for the English language, but, ...
2
votes
2answers
269 views

Sitecore HTML Indexing

We have custom indexer which indexes all the RTF Data in present in content tree and this indexed RTF Data can have Div's ,breaker Tags and anchor tags. When we get search result out from Solr we ...
3
votes
0answers
680 views

Error with indexWorker process in Sitecore 9 xConnect with Solr 6.6.2

I am running Sitecore 9 with Solr 6.6.2 and I am seeing lot of error in the IndexWorker logs in Sitecore xConnect as below: 018-02-21 16:16:13.686 +10:00 [Error] An error occured. System.Net.Http....
5
votes
1answer
443 views

What is the best way to store a single Sitecore field into two Solr index fields with different types?

I have a Category field in sitecore and it is currently stored as a text_general in Solr. It has this type because I need it to be tokenized and lowercase for searching. On the other hand I need to ...
0
votes
2answers
758 views

How to fix “/site_masterindex/suggest not found” error for SXA Search

I am using Sitecore 9.0.1 rev. 171219 with SXA 1.6 rev 180103 and Solr 6.6.2. In the SXA site, search results text box suggestions giving error as "/site_masterindex/suggest" not found. Solr search ...
0
votes
2answers
2k views

Solr Core Initialization Failures

Trying to configure Solr 7.2.1 with Sitecore 8.2 But after generating schema.xml with Sitecore when i am trying to add core from Solr Admin Page, i am getting below error. Please have a look at ...
1
vote
0answers
163 views

Sitecore 9.0 Update 1 in PaaS: Error in Experience Profile [duplicate]

I have deployed my Sitecore 9.0.1 solution in Azure PaaS with Self Signed Certificate.I can't add contacts in List Manager and when I view the Experience Profile, I always get "An error has occurred." ...
1
vote
2answers
226 views

SqlShardingDeploymentTool causes Sitecore 9.0 update 1 installation to fail during SIF installation

I'm trying to setup a Sitecore 9.0 update 1 installation on my local machine using windows 10 Solr 6.6.2 SQL Server 2016 SP1 Sql Express 2017 SIF-less 0.6.0.0 Despite a couple of annoying hickups I ...
3
votes
2answers
735 views

“Solr start” resets the schema and solrconfig file

As per Sitecore documentation for setting up Solr, I have generated the schema.xml (using managed-schema file) and updated solrconfig.xml. I copied both the files to the conf folder of the all cores ...
2
votes
3answers
3k views

Custom index field returning “Server Error in '/' Application. Could not find add method: AddComputedIndexField”

I am trying to create a commuted index field in sitecore 9 but can't get the configuration to work. I have a local environment which is running Solr and also environment is Azure. I have added the ...
5
votes
1answer
135 views

Exception while switching Lucene to Solr 4.1 on Sitecore 7.2

I am attempting to switch an instance of Sitecore 7.2 from Lucene to Solr on my local machine. I followed a well written guide detailing the steps, but I can't make it work. My environment: ...
1
vote
2answers
337 views

Sitecore Content Search Exception: Entry point was not found

I'm having an issue taking an older version of our site running under Sitecore 7.2 (with some older dll's such as glass mapper) and switching over from Lucene to Solr (6.6.2). I've followed the steps ...
8
votes
5answers
659 views

Error opening new searcher. exceeded limit of maxWarmingSearchers=2

I am relatively new to SOLR. We are using SOLR 6.1.0.1 with Sitecore 8.1 Update 3. There are roughly 50K items (content and files) being indexed. We are being plagued by poor throughput (through ...
2
votes
2answers
597 views

How to install Solr cores for Sitecore 9 on Linux

I need to install the Solr cores required for Sitecore 9 on a Linux machine already running Solr 6.6.2. What is the best way to do this in Linux (since SIF cannot be used)?
2
votes
2answers
3k views

How to get MultiList selected items in SOLR search

In a project, I have implemented SOLR search. I am able to get Items from search, based on template name. In a scenario,I have to get items using Search from a MultiList field which are selected. ...
2
votes
1answer
1k views

SolrNet.Exceptions.SolrConnectionException when trying to configure custom Solr index

I am migrating a project from 8.2 to 9, and moving indexes from Lucene to Solr. The default indexes are fine, but my custom index is throwing an exception: 53416 08:51:21 ERROR Unable to connect to [...
3
votes
2answers
1k views

Switch to Solr - getting Unknown Field

Using Sitecore 8.1 Update and Solr 6.0.1 After switching to Solr, I am having indexing problems. Sometime the index rebuild works, and sometimes it fails with a variety of: ERROR: [doc=sitecore://...