Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

Filter by
Sorted by
Tagged with
4
votes
2answers
969 views

Why is SIF failing to create Solr core?

I am trying to install Sitecore XP9 by following the installation guide as described in Chapter 5 of the Sitecore Experience Platform Installation Guide. After creating a Powershell script as ...
3
votes
3answers
587 views

Solr Issues Using Multilist Property on Search Result

I have a multilist field on article items called Categories. In a module I am trying to filter based on one or more items in that multilist field. I can do this if I directly supply the name of the ...
1
vote
4answers
743 views

Compatability issues between Sitecore 8.2 and Solr 7.1 [closed]

I have been lately trying to configure Solr 7.1 with Sitecore 8.2. Once configuration done, after going to content tree, I am getting error "Data at the root level is invalid. Line 1, position 1." In ...
6
votes
1answer
558 views

Migrating Solr Core indexes to Azure Search indexes

I am midst of migrating a Sitecore project to Azure Paas offering. I've completed the deployment of the files (ie. dlls, configs, css, js, etc) and were able to do a complete unicorn sync. That looks ...
4
votes
2answers
1k views

Object Reference Error in Sitecore.ContentSearch.SolrProvider.SolrIndexSummary.get_NumberOfDocuments()

I am running Solr 5.5.4. When I open the index manager, I see a bunch of errors in the Sitecore log file of the following: 5664 13:40:46 ERROR Object reference not set to an instance of an object. ...
5
votes
1answer
2k views

Issue with http://localhost:8983/solr in Sitecore configuration

I observed an interesting scenerio in my machine. I have the following configuration: <setting name="ContentSearch.Solr.ServiceBaseAddress" value="http://localhost:8983/solr" /> Now, If I go ...
5
votes
0answers
157 views

Configuring Solr on remote server using SIM

Is it possible to configure Solr using SIM on a remote machine? By default it shows http://localhost:8983/solr .Can we have it something as http://abc.com:8983/solr ?
5
votes
1answer
1k views

SOLR Custom Index Causing Error

I am converting a Lucene custom index to a SOLR custom index. I got the Cores working for the default indexes, but having trouble converting my custom indexes. I got through some of the issues, but ...
14
votes
3answers
5k views

Configuring SSL for Solr

So I'm working my way through the Sitecore 9 install instructions, and part of it is to install Solr with SSL. Since the install guide just refers you over to Solr, I've been following the ...
8
votes
2answers
120 views

Compatiblity of Sitecore 7.1 with Solr Search 4.1

We have our site on older version of Sitecore 7.1 (another site on Sitecore 7.2) and we are intending to integrate it with Solr Search 4.1 server. I have question that if this version of Sitecore is ...
7
votes
2answers
419 views

How do you boost fields such as Title or Navigation individually in SXA when using SOLR?

In our example, we have a Careers search feature in which we only want to match on title, job id, or a meta field such as description. One wonderful feature about SXA is that you have an easy-to-use ...
1
vote
1answer
526 views

Sitecore Web Index Rebuild

We are using Solr 5.4 and Sitecore 8.2 we plan to do daily/Weekly Rebuild of Indexes for Web Environment through Sitecore Job or Tasks. Can some body suggest me what is best way to do this Note : ...
3
votes
0answers
545 views

“org.apache.solr.common.SolrException: undefined field 0001-01-01T00” when rebuilding index

When I rebuild one of my indexes in Sitecore, I get the following error in the Solr log: org.apache.solr.common.SolrException: undefined field 0001-01-01T00 I don't have a field called 0001-01-...
6
votes
2answers
698 views

When using SOLR with Sitecore is it mentioned anywhere to always use lowercase index names?

For a recent customer, we moved them to SOLR, which I highly recommend for production environments over Lucene, and we encountered a few issues, as some of the Lucene indexes had some uppercase ...
5
votes
0answers
699 views

Sitecore Solr index FieldNameTranslator is null

I am currently playing around with Sitecore indexes - both Solr and Lucene. I have made my own custom index and it works fine for Lucene, but I cannot get it to work with Solr. My problem is that ...
10
votes
2answers
15k views

Unable to start Solr service on Windows 10 / Windows Server 2016 x64 [closed]

I'm trying to install Solr service as described here. I use NSSM prelease build 2.2.4-101 to 'avoid an issue with services failing to start', but after installation the service cannot start anyway: ...
4
votes
3answers
3k views

Value cannot be null. Parameter name: fieldNameTranslator | Upgrade 8.1 update 4 to 8.2 Update 2

I am getting the following error when opening the content editor or loading my site: Server Error in '/' Application. Value cannot be null. Parameter name: fieldNameTranslator Description: An ...
4
votes
1answer
215 views

Could not find configuration node: marketingDefinitions/funnel/funnelStepTypeResolver

I am trying to upgrade from Sitecore 8.1 update 4 to Sitecore 8.2 update 2. I am on Solr 6.1 and while doing the upgrade we are getting the below error: Could not find configuration node: ...
5
votes
2answers
263 views

Internal search doesn't work after configuring solr

The internal search stopped working. It was working fine until I configured Solr. The changes I made are : Disable all Lucene configs except the DefaultIndexConfiguration.config and enabled all Solr ...
3
votes
2answers
187 views

500 error page for Sitecore Start Up with no Solr or mongo connected

I'm trying to configure a 500 error page.h I have successfully done this for handling exceptions once the application is already up and running. However I'm having an issue where if Solr Or MongoDB ...
4
votes
2answers
713 views

How point SolrCloud in Sitecore configuration?

I'm working on a new project with Sitecore 8.2 update 2 and SolrCloud to provide high availability for Solr. For SolrCloud, I'll have 3 Zookeepers and 2 Solrs but every solution will run on its own ...
6
votes
2answers
338 views

Solr on Windows with Sitecore

I am trying to setup solr to work with Sitecore. Locally, it was easy to set up on my Windows machine. In the other environments I naturally want to use a dedicated Solr server. The question is: can ...
1
vote
1answer
156 views

Installing a SOLR-based instance via SIM fails with 401 Unauthorized error

I'm trying to install an instance with SOLR search provider but it fails with unauthorized error: I suppose the reason is pretty simple, I've never set any SOLR credentials in SIM because I didn't ...
5
votes
1answer
80 views

Is there a way to use asterix in Sitecore SOLR configuration root?

First of all a little context. I'm using Sitecore 8.1 with Solr 5.5.0-1 and my data are stored like this : sitecore ->content -->Assistance --->Products ---->Alarms ----->...
1
vote
1answer
1k views

502 Bad Gateway error when reindexing with Solr to localhost address

I'm using the Bitnami Solr 6.5.1 installer, and I've used it successfully on other servers. On our QA server, which is sharing CM/CD in one site and has Solr installed locally, I'm getting the ...
4
votes
1answer
621 views

How do you stop optimizing sitecore_analytics_index

We have our analytics_index over 150 million documents now (with Solr on a standalone windows server). How can we stop Sitecore from optimizing the index? Solr says optimizing should only be done on ...
-2
votes
1answer
169 views

Solr based Sitecore Blog Module [closed]

Do we have any Solr based blog module available in Sitecore? We have looked for different blog solution but didn't find any blog module based on Solr.
5
votes
1answer
3k views

Solr multivalued fields

We are currently working on migrating from Lucene to Solr and we're having a couple of issues with our index data. There hasn't been any code changes so we're assuming it is stemming from the indexed ...
2
votes
1answer
651 views

Do I really need MediaItemContentExtractor if I'm not indexing media?

I have a site that allows visitors to upload a PDF via a WFFM form. However, each time a visitor does so, the logs fill up with the following errors: ManagedPoolThread #2 17:14:20 WARN Could not ...
2
votes
2answers
4k views

SolrNet.Exceptions.SolrConnectionException: The operation has timed out

After sitecore upgrade from 7.2 to 8.2u3 and solr from 5.4.1 to v6.1, below solr timeout starts to happen in one server, works fine in local machine setup. We have increased from 125500 (on local ...
3
votes
1answer
2k views

SOLR 6.5.1 will not run with Sitecore as a service on Windows machine [closed]

Got SOLR setup and working on my local machine with all my cores installed. Everything is functioning as intended when starting SOLR from Command Prompt via a "bin\solr start" command. However, I ...
1
vote
1answer
960 views

Customizing SXA checklist filter facet component

I would like to do pivoted search using SXA Search filter facet Component. Is there a way to customize SXA Search component and have pivoted kind of search? I see that sxa delivers SearchController ...
2
votes
1answer
97 views

Solr QueryElevationComponent component usage

I am hoping to use the Solr QueryElevationComponent for best bets on my site search. Hooking it up was easy enough, the biggest issue I have is _uniqueid field which is used by the component to ...
3
votes
0answers
103 views

Multi-list with search showing gibberish after switching to SOLR Cloud

I'm running Sitecore 8.1 (Original Release), and last night we switched our SOLR indexes to use a dedicated SOLR Cloud set of servers instead of using a stand-alone SOLR instance on our CM server. ...
6
votes
1answer
238 views

Boost Search Placement for One Page and One Keyword

Our website has a search feature where the user types in a keyword and the results page lists out links to all the pages that the keyword is found on. We want one particular page to come up at the ...
2
votes
1answer
224 views

What is Sitecore.ContentSearch.SearchTypes.Content Property which maps solr _content field?

What is _content in SOLR. While mapping through Sitecore, what are the fields will it map? Is it good practice to use Content property in search query builder? In that case, How will it work in ...
0
votes
1answer
300 views

Solr Stopword not working in multilingual application?

In our application, I am trying to implement stopword for various language. We are having country wise core index. One of my search, I am fetching search item using Content, Headline and SearchKeyword ...
1
vote
2answers
973 views

How to disable solr in the sitecore content delivery environment?

I got a scenario where solr connections are working fine in Sitecore CMS where it is giving some issue in Content Delivery. We have defensive code in place where we check if sitecore content indexing ...
1
vote
1answer
1k views

Search indexing not working as expected

I'm new to search and indexing. We are implementing this for a search feature on the website for the end user (not the internal search) and using Solr 4.10.3 with sc8.0 u5 Solr is setup with all the ...
0
votes
1answer
160 views

How to configure solr 4.1 for Sitecore 8.0

We need to configure Solr 4.1 for our sc8.0 u5 instance. This will be used as a platform for the website search (not the internal search). The official doc I feel is not really helpful or incomplete. ...
0
votes
1answer
778 views

How to initialize Solr end point connection with basic authentication programmatically?

I want to store Solr basic authentication credential in key vault and I want to achieve this by doing something like this.. however I tried using below code in application start but it seems it is not ...
3
votes
1answer
362 views

SOLR search field type of “textCollection” and “Coordinates” are not generated in schema.xml when using SXA

Sitecore 8.2.4 SXA 1.4 I have configured solr with all required installation and configuration outlined by the Sitecore Documentation site. I have enabled the following sxa solr config for SXA search ...
6
votes
1answer
2k views

Solr and multivalue fields

I have a field in Sitecore that contains data such as "2010,2011,2012,2013" or "Europe;Asia;Africa;Artic" etc. These are string fields and don't need to be anymore than strings. These fields come from ...
6
votes
2answers
10k views

Value cannot be null. Parameter name: fieldNameTranslator - Opening Content Editor [closed]

I was trying to setup the Sitecore with Solr. I created the Default Instance and added Solr. I use Castle Windsor as IOC, updated the Global.asax. Since I was not able to download the Solr Support ...
3
votes
1answer
395 views

Searching the date array

I have the following setup: I'm indexing Sitecore items (Employee) in Solr I have the computed field "checkins" of type stringArray set in the index Checkins is list of datetime values I get from ...
0
votes
1answer
92 views

SOLR JVM fluctuating wildly

We are using Sitecore 8.0 Update 2 and Solr 4.10.3. Today we had a website crash because Solr went down and our listing pages and search related components weren't working. The issue turned out to be ...
2
votes
4answers
5k views

Could not find configuration node: contentSearch/indexConfigurations/defaultLuceneIndexConfiguration/fieldMap

I did a setup of sample Sitecore Instance (sc82solr), and followed the configuration from the following link https://doc.sitecore.net/sitecore_experience_platform/81/setting_up_and_maintaining/...
1
vote
0answers
412 views

Solr indexes don't incrementally update after rebuilding

We are on version 8 update 2. We have one CM and 2 CDs. All indexes are set to manual strategy on CDs. CM does all the indexing. All master db indexes are set to sync master and all web indexes to ...
2
votes
1answer
442 views

How to search by a date with ContentSearch and IObjectIndexers

I have a generic search method which should be able to search based on any field. I have something like this: criteria = x => x[FieldName] == fieldValue; This works well for strings but, how can I ...
6
votes
1answer
2k views

SOLR Cloud error “The remote server returned an error: (500)”

I'm trying to setup SOLR Cloud to work with my Sitecore 8.2 (original release) instance. I'm doing this because our analytics index has gotten to the point where our massive SOLR box (90 Gb RAM, 16 ...

1
5 6
7
8 9