Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

Filter by
Sorted by
Tagged with
3
votes
1answer
74 views

Detached solr cores while server restarts [closed]

We are using Bitnami solr 6.2.1 with sitecore 8.1 update 3. Every thing is just working fine in our development and qa environment. The issue is, whenever these environment gets rebooted or restarted ...
3
votes
0answers
101 views

Multi-list with search showing gibberish after switching to SOLR Cloud

I'm running Sitecore 8.1 (Original Release), and last night we switched our SOLR indexes to use a dedicated SOLR Cloud set of servers instead of using a stand-alone SOLR instance on our CM server. ...
3
votes
2answers
66 views

ContentSearch Solr SendPostRequests settings throw exception

When is set setting ContentSearch.Solr.SendPostRequests to true, for searching in solr by post request because query is very big and Get not working, the next exception is thrown. Sitecore version 9.1,...
2
votes
2answers
717 views

Programmatically stopping Solr Indexing

We are programmatically creating items and using Solr indexes so we want to disable solr indexing whenever we create an item. We tried following code to disable during item creation Item.Add() ...
2
votes
2answers
3k views

How to get MultiList selected items in SOLR search

In a project, I have implemented SOLR search. I am able to get Items from search, based on template name. In a scenario,I have to get items using Search from a MultiList field which are selected. ...
2
votes
4answers
4k views

Could not find configuration node: contentSearch/indexConfigurations/defaultLuceneIndexConfiguration/fieldMap

I did a setup of sample Sitecore Instance (sc82solr), and followed the configuration from the following link https://doc.sitecore.net/sitecore_experience_platform/81/setting_up_and_maintaining/...
2
votes
1answer
208 views

How to configure seperate solr index for multi site in a single instance in sitecore?

I have 2 websites configured in a single instance, where i wanted to configure separate search indexes of solr for each website.
2
votes
1answer
208 views

Is there any way to check the solr is running in sitecore

We have requirement to redirect to a error page if the solr is stopped programtically in sitecore. Is there any way to check whether the solr is running or not?
2
votes
3answers
758 views

Media Library searching with SOLR

Sitecore 8.2 U5 SOLR 6.6.2 In the content editor, I can search for any words or phrase. Sitecore will return results for any item where that word or phrase is used, in any field. But in the media ...
2
votes
1answer
67 views

Use the TermFreq() function programatically in Sitecore

I was building query on the basis of the occurence/relevancy of the terms present in a field and got one issue , suppose i searched for a keyword "text" in the content field , and i want to sort the ...
2
votes
2answers
160 views

Solr search query by Datetime.Year

I configured Solr index to the path where I created some articles using templates, templates have the same fields with data type as in below model <Root>/sitecore/content/Articles</Root> ...
2
votes
1answer
331 views

An index with the name “sitecore_analytics_index” have already been added.,

Im currently working on getting a existing Sitecore 8.2 Habitat solution running on my system locally. Anytime I go to routes like /sitecore or /sitecore/admin/showconfig.aspx I get the following ...
2
votes
3answers
3k views

Custom index field returning “Server Error in '/' Application. Could not find add method: AddComputedIndexField”

I am trying to create a commuted index field in sitecore 9 but can't get the configuration to work. I have a local environment which is running Solr and also environment is Azure. I have added the ...
2
votes
1answer
520 views

Do I really need MediaItemContentExtractor if I'm not indexing media?

I have a site that allows visitors to upload a PDF via a WFFM form. However, each time a visitor does so, the logs fill up with the following errors: ManagedPoolThread #2 17:14:20 WARN Could not ...
2
votes
1answer
48 views

Can Sitecore be configured to automatically recover after restarting the Solr service?

We are hosting Sitecore 9 on Azure App Services using Solr as the search provider. Microsoft will occasionally restart the server that is hosting Solr (due to ... updates made by Microsoft to the ...
2
votes
3answers
89 views

Error in custom index after upgrading to Sitecore 9

After upgrading to Sitecore 9 and converting custom index files from using Lucene to Solr, I am getting the following error on an Ajax call: Unable to cast object of type 'System.Collections....
2
votes
1answer
68 views

xDB : System.TimeoutException

Environment: Sitecore 9.0.2 + XP0 All the components are hosted locally. Error in poc1.xconnect\App_data\logs: 2019-08-04 16:02:43.787 +05:30 [Error] Sitecore.XConnect.Operations.XdbSearchOperation`...
2
votes
1answer
622 views

Rebuilding Indexes with SOLR throws Exceptions

I set up a fresh Sitecore 9.1 with SXA on my local machine. When rebuilding the indexes, I get the following messages: (Core) 19676 14:50:03 WARN Could not compute value for ...
2
votes
2answers
611 views

How to install Solr cores for Sitecore 9 on Linux

I need to install the Solr cores required for Sitecore 9 on a Linux machine already running Solr 6.6.2. What is the best way to do this in Linux (since SIF cannot be used)?
2
votes
2answers
3k views

SolrNet.Exceptions.SolrConnectionException: The operation has timed out

After sitecore upgrade from 7.2 to 8.2u3 and solr from 5.4.1 to v6.1, below solr timeout starts to happen in one server, works fine in local machine setup. We have increased from 125500 (on local ...
2
votes
1answer
2k views

Microsoft.Practices.ServiceLocation assembly not loading

I'm upgrading my Sitecore 8.1 Visual Studio project to use Sitecore 8.2, and I've made quite a bit of progress. I've switched to SOLR, updated Glass Mapper, and replaced out my DLL references to use ...
2
votes
1answer
43 views

Some contacts are missing in Experience Profile (IndexWorker error)

We have Sitecore 9.1 with Solr-7.2.1 environment. Some contacts in our solution are missing in Experience Profile. All of these contacts are known and have a lot of webvisits. And everything is OK ...
2
votes
1answer
65 views

Issue with the Like operator on my custom field

My field configuration on Sitecore: <field fieldName="unifiedtitle" storageType="yes" indexType="tokenized" returnType="string">Project.Foundation.Indexing.ComputedFields....
2
votes
2answers
197 views

Computed index fields on Sitecore 9.1.1 CD server

I have a custom computedfield in Sitecore 9.1.1. I am getting the below error on CD server only as my web.config has: <add key="role:define" value="ContentDelivery" /> Current CustomIndex ...
2
votes
1answer
209 views

Solr suggester not returning full name

I migrated the project from Sitecore 8.2 to Sitecore 9.1.1. There was a suggester component that we were using to provide a suggestion for a search term. As part of the migration, I also created a ...
2
votes
1answer
165 views

Index Update Strategy not Firing on Publish End with Custom Publishing Target and Custom Solr Index [duplicate]

We have a prod set up that has one CM and two CDs. The CD servers serve content from a second web database that we call "live". This database is a clone of web. We use web as a staging environment on ...
2
votes
1answer
387 views

Sitecore 9 and custom solr indexes

I'm working with Sitecore 9 and solr 6.2.2. I am trying to create a custom index and in this index I'm only including a few fields. One of the fields is called OfficeLocation and it's a string. When ...
2
votes
1answer
627 views

SwitchOnRebuild with SolrCloud not working

We are running Sitecore 9.0.0 (Initial Release) on Azure with SolrCloud (6.6.2) and getting close to go-live. We are using Sitecore's SwitchOnRebuild functionality for indexing so that the indexes ...
2
votes
1answer
716 views

Could not resolve type name error while performing search in Sitecore in Content tree

After logging to the Sitecore content tree, getting the below error while performing the search. An error occured while searching. Rephrase the query. Could not resolve type name: Sitecore....
2
votes
1answer
191 views

What is Sitecore.ContentSearch.SearchTypes.Content Property which maps solr _content field?

What is _content in SOLR. While mapping through Sitecore, what are the fields will it map? Is it good practice to use Content property in search query builder? In that case, How will it work in ...
2
votes
1answer
77 views

Using Sitecore Rocks for Solr Search Enabled Sitecore instance

I have noticed this strange error in my instance after attempting to connect sitecore rocks with my local sitecore instance which I have recently migrated to solr from Lucene search provider. Actual ...
2
votes
1answer
442 views

Increasing SOLR security (hardening), and how Sitecore will handle with it?

I'm looking to increase the security of my SOLR environment and wonder how Sitecore will handle with it? For example, I saw a possibility to use SSL and I guess it would be simply replace HTTP to ...
2
votes
3answers
37 views

SOLR connection string for ARM template

I am installing Sitecore using the ARM template and using SOLR as a search service. Now I have configured SOLR as master/slave model. While installing Sitecore, which connection string should I ...
2
votes
1answer
16 views

Solr XConnect Search Web Deploy package URL

I am trying to install Sitecore 9.2.0 XP with SOLR in ARM template. For that I need to put the web deploy package of "Solr XConnect Search Web Deploy package URL" in the place of "...
2
votes
1answer
59 views

How to apply stop words at Solr query time?

I'm having some fun with Solr and here is my current issue. I've applied some stop words using the stopwords.txt file and rebuilt my indexes. Everything looks fine here, I can see that those stop ...
2
votes
2answers
381 views

Solr and Tokenizers: how to tokenize specific indexes using Solr 4.10.4

I'm on Solr 4.10.4, Sitecore 8.1 160519. I finally managed to convert my Lucene custom index configuration to Solr, but some indexes are not tokenized. The custom index "parsed_answers" on Lucene is ...
2
votes
1answer
338 views

Solr log: Multiple values encountered for non multiValued field _basetemplates_s

I'm on Solr 4.10.4, Sitecore 8.1 160519. The configuration of the custom index is <field fieldName="_basetemplates" returnType="string" multiValued="true" storageType="yes" indexType="untokenized"...
2
votes
1answer
91 views

Installing SC 9.0.2 with SIF and Remote Solr Server with Self-Signed Certificate

I am Installing SC 9.0.2 with SIF and a Remote Solr Server with Self-Signed Certificate. i have split the script up as found here: https://tothecore.sk/2018/04/19/installing-sitecore-9-xp0-with-solr-...
2
votes
1answer
463 views

Solr Error When Rebuild xDB Search Index

I'm working with Sitecore 9.0.2 and Solr 6.6.2. When i tried to rebuild xDB search index, i saw some error in log of SOLR as below : 9/7/2018, 4:47:39 PM ERROR false RequestHandlerBase org.apache....
2
votes
1answer
179 views

How to correctly process index dependencies for correct language?

I am updating index dependencies as mentioned in Sitecore Full Content Search where we are using GetDatasourceDependencies. Now, the issue is that this works fine for the English language, but, ...
2
votes
1answer
1k views

SolrNet.Exceptions.SolrConnectionException when trying to configure custom Solr index

I am migrating a project from 8.2 to 9, and moving indexes from Lucene to Solr. The default indexes are fine, but my custom index is throwing an exception: 53416 08:51:21 ERROR Unable to connect to [...
2
votes
1answer
389 views

Content Manager returns empty list

I am on v8.2 Using SOLR as search index. I have the items indexed and can see them in the index. I kicked off index rebuild a few times. However, ContentSearchManager.GetIndex("sitecore_web_index")....
2
votes
1answer
416 views

How to search by a date with ContentSearch and IObjectIndexers

I have a generic search method which should be able to search based on any field. I have something like this: criteria = x => x[FieldName] == fieldValue; This works well for strings but, how can I ...
2
votes
1answer
36 views

Filtering Content Editor global search in SOLR

When I use the global search in the Content Editor in my Sitecore 8.1 instance (that uses Lucene), the search.log displays the following output: ExecuteQueryAgainstLucene (sitecore_master_index): ...
2
votes
2answers
121 views

What is the fix for solr error 'undefined field _indexname' after building custom index in sitecore (v9.1.0)?

I created a new custom index named CUSTOM_SERVICES_INDEX using this command: C:\solr\solr-7.2.1\bin>solr.cmd create -c [custom index name] (cmd as administrator) then I created the config file ...
2
votes
2answers
283 views

Searching a substring using solr

I am trying to move my code from Lucene to Solr, but am facing an issue. I have 4 fields indexed, all the field are of text_general type (from the managed schema). The code from Lucene is: ...
2
votes
2answers
333 views

Indexes are not appearing in Indexing Manager when using Client Certificate Authentication With Solr [closed]

We have setup Client Certificate Authentication with Solr using below link: https://blogs.perficientdigital.com/2018/08/01/client-certificate-authentication-with-solr/ Solr admin panel is loading ...
2
votes
1answer
111 views

Installing Sitecore 9.0.2 SIF generates wrong marketingdefinitions_master configuration

After configuring SIF installer for Sitecore 9.0.2 installation as follows # Start Install Import-Module SitecoreInstallFramework $prefix = "foo" ... #install solr cores for sitecore $solrParams = @{...
2
votes
1answer
135 views

Experience profile doesn't display number of contacts fully after rebuild xDB search index

I migrated xDB data from mongo database to xconnect collection databases successfully. After that i tried to rebuild xDB search index. The rebuild process finished successfully. But i noticed that ...
2
votes
2answers
301 views

Solr Installation error : NativeCommandError

I am setting up the Solr 6.6.2 with SSL for Sitecore 9 installation on one of the new development machine. I am following the Kam Figy PS script : https://gist.github.com/kamsar/...