Questions tagged [solr]

Anything related to Solr indexes: querying, configuring, maintaining, ...

Filter by
Sorted by
Tagged with
0
votes
1answer
725 views

solr Sitecore full text indexing ifilter

I'm attempting to index the content of pdf's with Solr 6.6.2 and Sitecore 8.2 Update 6. I've got my solr indexes working correctly, and I'm able to search text from pages (content items) and I'm able ...
0
votes
1answer
848 views

How to initialize Solr end point connection with basic authentication programmatically?

I want to store Solr basic authentication credential in key vault and I want to achieve this by doing something like this.. however I tried using below code in application start but it seems it is not ...
0
votes
1answer
30 views

Crawl html links in a Rich textfield in SOLR

I have a Rich text field. If the user enters a hyperlink in the richtextbox and I run a query in SOLR, it shows up as text only. The link associated does not show up. What could the issue be? In the ...
0
votes
1answer
82 views

Computed field is getting updated in solr index only when we do full rebuild of reindex

I have a Sitecore instance running on Sitecore v9 update 2 using SOLR. So I have created 3 new computed fields, these fields are working properly when I rebuild index or re-index tree (both master and ...
0
votes
1answer
31 views

CreateConnection method doesn't exits in DefaultSolrStartUp - Sitecore 9.3

I am in process of upgrading content serach Solr provider from Sitecore 8.2 to Sitecore 9.3. I am facing some code issue after upgraded the dll(Sitecore.ContentSearch.SolrProvider, Version=6.0.0.0) ...
0
votes
2answers
141 views

Sitecore 9.3 Solr ContentSearch does not get the right language

I have a site with the language english (en -> default language) and portuguese (pt-BR). Now I have the problem that on the portugese website there are shown items of the english language version. ...
0
votes
3answers
320 views

Crawling log - Unable to connect to Solr

Solr is accessible with https but not with http in my local. What could be the reason ? Am i missing some configuration ? ManagedPoolThread #1 11:53:35 WARN Unable to connect to Solr: [http://...
0
votes
1answer
237 views

Why Solr returns 0 results when querying with stopwords only?

Really straightforward question: Why does Solr return 0 results when I query using only for, which is a stop word on my Solr setup? IMO this scenario should behave as a query without any keywords at ...
0
votes
1answer
74 views

FuzzyLookupFactory is not working with Arabic words

I'm using Sitecore 9.1 and SXA 1.8, I'm using FuzzyLookupFactory for my suggester, and this is the configuration: <searchComponent name="suggest" class="solr.SuggestComponent"> <lst ...
0
votes
1answer
111 views

SOLR 5.1 Java Version

Using Sitecore 8.2 Update 6, when I install SOLR 5.1, it updates the JAVA_HOME environment variable to C:\Program Files\Java\jre1.8.0_171, but I haven't got version installed (and doesn't seem to be ...
0
votes
1answer
58 views

Does it matter Sitecore CM connect to Solr Cloud leader vs follower?

We currently have our Solr Cloud with zookeeper and for front with load balance (Solr Prd1 and Prd2). CM is connecting to Solr Prd1 (leader) and CDs are connecting to Solr load balance. Questions: ...
0
votes
1answer
75 views

Switching Sitecore Indexing to Solr with SXA 1.4

We have switched our Sitecore instance from Lucene to Solr with SXA 1.4. Lucene works fine with the 'yyyyMMdd' date format but Solr needs 'yyyy-MM-DDTHH:mm:ssZ', so querying is not working when we ...
0
votes
2answers
1k views

How to fix "/site_masterindex/suggest not found" error for SXA Search

I am using Sitecore 9.0.1 rev. 171219 with SXA 1.6 rev 180103 and Solr 6.6.2. In the SXA site, search results text box suggestions giving error as "/site_masterindex/suggest" not found. Solr search ...
0
votes
1answer
28 views

Boosting items by its own field values

I'm using Sitecore 9.3 and Solr 8.2.1, I had Solr index-time boosting in my old search implementation, but after I upgraded to a new Solr version, it is deprecated now. Imagine I have an item with ...
0
votes
1answer
48 views

Content Search API issue with Droplist and Treelist fields

I am facing a weird(might not be weird for experienced people) issue where ContentSearch API is returning null value for few fields while I can see the correct values in Solr. The fields whose values ...
0
votes
1answer
45 views

No such core:xdb

I am getting a no such core:xdb error when trying to rebuild xdb Sitecore.Xdb.Collection.Search.Solr.Failures.SolrResponseException: { "responseHeader":{ "status":400, &...
0
votes
2answers
99 views

Solr admin portal HTTP ERROR 404 Issue

We are using solr 6.6.2 with Sitecore 9.0.2 and https://localhost:8989/solr/ working fine. Yesterday evening suddenly I was getting HTTP ERROR 404 Problem accessing /solr/. Reason: Not Found ...
0
votes
1answer
51 views

PopulateManagedSchema.aspx The remote server returned an error: (404) Not Found

While installing Sitecore 9.3 I am getting this error Error requesting https://us-int-cms.com/sitecore/admin/PopulateManagedSchema.aspx?indexes=all: The remote server returned an error: (404) Not ...
0
votes
1answer
82 views

Problems with solr docker suggester in context query: blanks are not correctly processed

I am using Solr version 8.8.1 in a docker container. I use an address query system based on a csv file. I want to get a city in relation to the street name. The fields in my managed-schema are looking ...
0
votes
1answer
73 views

How to change solr.jetty.request.header.size in docker

I have created a Solr version 8.1.1 in Azure using a Docker for Sitecore. I get the following error for a large query: ERROR Error during executing a query. Exception: SolrNet.Exceptions....
0
votes
1answer
57 views

GroupBy clause for both search providers (Solr, Azure)

Would like to use groupby clause in Sitecore 9.1.1 for both search provide (Azure, Solr) in content search API. However, Sitecore does not support this clause. Kindly let us know how we can group ...
0
votes
1answer
227 views

Solr computed index field of type stringCollection not stored as expected

I've made a computed index field in my solution. The class returns List<string> from the ComputeFieldValue method and the config patch includes the field within the fieldMap and documentOptions ...
0
votes
1answer
153 views

How do you configure Solr 8.1.1 for TLS / SSL including replication with a PFX (PKCS12) certificate?

I started off following this post to setup TLS with a certificate with the PFX extension. An issue was revealed while trying to setup Solr replication; Wireshark showed Certificate Unknown when the ...
0
votes
1answer
98 views

SXA Boosting by multiple query

I'm using Sitecore 9.1 and SXA 1.8, I'm using SXA boosting rule of where the field contains Search Box query, this rule doesn't work when the Search Box query is multiple words that are not in order. ...
0
votes
1answer
167 views

Boost search results by field value

I'm using Sitecore 9.1 and SXA 1.8, Is it possible to boost the search results by a specific field value? What I see in SXA boosting rules that you adjust boost by adding a value statically, I want ...
0
votes
3answers
472 views

How to filter solr suggestions only from particular path

I recently tried solr autosuggest search in my local, Steps I followed : Added configuration in master in sensoft_master_index\conf\solrconfig.xml Restarted solr8.1 service in services in C# code, ...
0
votes
1answer
74 views

Boost not activating in Sitecore Solr query

I've got some code that's generating a predicate for Solr search as follows: foreach (string query in querySplit) { contentPredicate = contentPredicate.Or(item => item.DocumentTitle.Matches(...
0
votes
1answer
185 views

Error indexing Polish and Czech language version in Sitecore 9.1 Initial Release with Solr 7.2.1

We seem to be getting errors similar to: [Index=sitecore_master_index] Crawler : AddRecursive DoItemAdd failed Remote error message: ERROR: unknown field 'description_t_cs' Remote error message: ...
0
votes
2answers
89 views

SOLR connection issue while installing Sitecore 9.1.1 [closed]

While installing sitecore 9.1.1, getting solr connection issue even Solr is Connecting porperly.
0
votes
1answer
333 views

Sitecore Index - Separate index for each language

I am using Sitecore 9.2 and SOLR. We have huge content and multi-language environment. We would like to create separate SOLR core index for each of the language. Is it possible? If yes, please guide ...
0
votes
1answer
139 views

NotFound exception creating Solr cores on installation

I've installed Solr 7.5 successfully. I am using SIA (Sitecore Install Assistant) for my installing Sitecore 9.2.0. I am getting exception "NotFound - https://solr75:8750/solr//admin/cores?action=...
0
votes
1answer
260 views

PDF items are not getting indexed and not listed in multilist with search [closed]

I have upgraded Sitecore 8.1 to 9.1 and now in 9.1 PDF items are not getting indexed and also they are not getting listed in a multilist with search field.
0
votes
1answer
310 views

Master/Slave replication and fault tolerance [closed]

I am using solr-7.6 version with Master/Slave config. Being a novice, I do have few question on the solr functionality: 1. What happens when Master will be down? Do i need to make Slave as Master ...
0
votes
1answer
43 views

Datetime fields appear garbled in Solr [duplicate]

I'm on Solr 4.10.4, Sitecore 8.1 160519. I have a custom index defined the following way: <field fieldName="date_of_birth" returnType="datetime" type="MyProject.Search.ComputedFields....
0
votes
1answer
253 views

How to add charFilter to Solr Managed Schema from Sitecore 9?

I need to add a charFilter to the Solr managed schema. I'm using Solr Cloud 6.6 and Sitecore 9.0.1. Sitecore uses a SchemaPopulateHelper class that generates xml updates to the managed schema. It ...
0
votes
1answer
491 views

Do I need a SearchCrawler to add and update items in a custom Solr Index?

I have an custom index where I will store data that doesn't exist in Sitecore, it has the following configuration: <?xml version="1.0" encoding="utf-8" ?> <configuration xmlns:patch="http://...
0
votes
1answer
1k views

Unable to filter solr index contents by template

I have created a custom index (Sitecore 9 Update 1) using the below config, hoping that the index would contain documents only corresponding to the 3 included templates. However my index includes all ...
0
votes
1answer
837 views

Get parent item and it's all child item from solr searchresultItem

I have a requirement that needs to get particular item along with all child item or some of the child item using template id from solr searchresultitem. Can anyone help how to achieve this?
0
votes
1answer
324 views

Solr Stopword not working in multilingual application?

In our application, I am trying to implement stopword for various language. We are having country wise core index. One of my search, I am fetching search item using Content, Headline and SearchKeyword ...
0
votes
1answer
165 views

How to configure solr 4.1 for Sitecore 8.0

We need to configure Solr 4.1 for our sc8.0 u5 instance. This will be used as a platform for the website search (not the internal search). The official doc I feel is not really helpful or incomplete. ...
0
votes
1answer
132 views

SOLR JVM fluctuating wildly

We are using Sitecore 8.0 Update 2 and Solr 4.10.3. Today we had a website crash because Solr went down and our listing pages and search related components weren't working. The issue turned out to be ...
0
votes
1answer
130 views

Why does the search in Experience Profile return non-matches?

I am trying a search in Experience Profile in Sitecore 8.1-3 with Solr 4.10 as the search provider. I am noticing that sometimes it returns results that don't seem to match the search query at all. ...
0
votes
0answers
31 views

Sitecore throw exception when index Date field

We are seeing the error below being thrown in our production environment. In our QA and dev environments we don't see the error. We have tried the following: Deleting the Solr index and rebuilding ...
0
votes
0answers
32 views

Content search - An error has occurred and the search cannot be completed

When I search something in the Content search and it is not working, and the UI shows 0 results with a message on red background under the search bar "An error has occurred and the search cannot ...
0
votes
1answer
22 views

How to find zookeeper configs path location

I've setup a SOLR server with Zookeeper by followed the below link. SolrCloud-Helpers I have done the Solr and Zookeeper setup by using the powershell script by given the above link and I can see ...
0
votes
1answer
26 views

Solr ContentSearch - Finding literal spaces and dashes

I'm working with Sitecore 10.1 and SOLR 8.4.0. I am building a typeahead search that matches items (around 17,000) within a bucket in Sitecore. There are two fields in my template that can be matched, ...
0
votes
0answers
27 views

Solr spatial search as part of an OR clause in a content search predicate

When performing content search queries, you can make use of the WithinRadius, OrderByDistance and OrderByDistanceDescending methods of the Sitecore.ContentSearch.Linq.QueryableExtensions class to get ...
0
votes
0answers
19 views

How to setup SSL for SOLR with an existing certificate

I am trying to setup SSL for SOLR Cloud instance, in K8s. Trying to follow these instructions: https://solr.apache.org/guide/8_6/enabling-ssl.html. But, we cannot use self signed certificates due to ...
0
votes
0answers
76 views

Unexplained SOLR query

I'm using Sitecore instance 9.1, Solr 7.2.1, and SXA 1.8. I was checking "Search" logs and found below ERROR entry. 5012 12:49:26 INFO Solr Query - ?q=((query:(self) AND _path:(...
0
votes
0answers
30 views

Tokens are incompatible, they have different set of shards error in Prod

I am getting the Tokens are incompatible error. 2021-07-19 10:59:11.131 +00:00 [Error] Failed indexing next set of changes. There will be an attempt to recover from the failure. Sitecore.Xdb....