Questions tagged [speak]

Questions about Sitecore's SPEAK (Sitecore Process Enablement & Accelerator Kit) framework

Filter by
Sorted by
Tagged with
7
votes
2answers
1k views

Sitecore 8.0 Preview Mode not rendering all the way

The preview mode loads the page, but it has the SPEAK square just spinning over the top of it with an server error in '/' Application at the top where the ribbon is suppose to be. If I inspect the ...
25
votes
2answers
436 views

How do I get my section icons in the Content Editor to show again?

It used to be, that next to the collapsible sections in the Content Editor tab; the section icon would display on the tab. This made it very easy for me to identify the section I was looking for. To ...
11
votes
1answer
444 views

Display custom facets in Sitecore Experience Profile version 9 or later

I am creating custom facet for saving contact information (Like Car Model, Variant, Color, etc) into XDB. I am successfully able to save and retrieve custom facets details with respective Contact. Now ...
3
votes
1answer
274 views

Speak Disable Button In Experience Editor Mode

I have made a custom /sitecore/templates/System/Layout/Renderings/View renderingcalled UpdateButton. I would like to only enable this for certain templates. Currently I am completely hiding it when on ...
6
votes
1answer
536 views

Add custom attributes to the General Link field and have it work in Experience Editor and Content Editor

I would like to add a couple of custom fields for Dataattributes on links and to add in NoFollow for the link in Sitecore 8.2 update 2 and above. So NoFollow would be a check box and Dataattributes ...
4
votes
2answers
266 views

Sitecore 9.0.1 Datepicker displaying wrong format

I'm facing DateTime format issue on the SPEAK DateTime Picker. Basically, when the user is in the Content Editor, the format displays ok (mm/dd/yyyy). But when the user opens the Experience Editor, ...
2
votes
1answer
38 views

While viewing rendering attached to an item in Core DB, Sitecore is throwing server error

I am trying to access the details of a rendering attached to an item in the Core database, but Sitecore is throwing server error. Please refer to the attached screenshot.
2
votes
1answer
463 views

How to open the content editor from SPEAK?

I've created a custom SPEAK 2.0 dashboard that lists sitecore items for a specific template. This dashboard was created for low level content editors which will only manage (create, edit, delete &...
1
vote
1answer
267 views

General Link Dialog “InsertLinkViaTreeDialog” misses InsertLinkRules after Upgrade to 8.2u2

We recently upgraded from Sitecore 8.1u1 to Sitecore 8.2u2 and noticed that the general link field dialog "InsertLinkViaTreeDialog" has a different structure now. We had a custom field that was ...