Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [sxa]

Anything related to the Sitecore Experience Accelerator (SXA)

0
votes
0answers
4 views

How to show price range filter as minimum and maximum dropdown filter using sitecore sxa search?

According to our design requirement, user should be able to select minimum price and maximum price from a dropdown and properties gets filtered based on the selected range. Can this functionality be ...
3
votes
0answers
25 views

How to work around Bootstrap 4 issues in SXA

We are using Sitecore 9.1 version and wanted to create a new website using Sitecore SXA. we have installed SXA 1.8 module but we have been facing an issue like All partial design and components ...
0
votes
0answers
21 views

Sitecore SXA is displaying body-top place holder on all pages

Our solution is currently on Sitecore 9.0.2 with SXA 1.8 , until yesterday all our deployments were working as expected. All of a sudden, I am facing the Mythical Body-top placeholder problem - http://...
0
votes
1answer
62 views

Publish Related Items error - Object reference not set to an instance of an object - Sitecore 9 Update 2

I am getting error only for Publish related items. I have installed sitecore.support.13144.dll also. No luck after that. Job started: Publish to 'web'|#Exception: System.Reflection....
0
votes
1answer
31 views

Append a querystring dynamically using sitecore SXA link component

I want to append a querystring which will have the value of current page's GUID when somebody clicks on a link. URL should look like: https://some redirected url ?sc_itemid=139C9F7D-55A7-4065-9D7A-...
4
votes
1answer
20 views

What Google API keys are needed to make SXA Location Finder work?

I am following below link for location filter and showing it on map. https://michaellwest.blogspot.com/2016/10/build-location-finder-search-using-sxa.html When I start searching in the text box, I ...
3
votes
1answer
48 views

Cache not being cleared when changing partial design

I have a component that is cacheable within a placeholder where another component is placed, which is an SXA component. When I try to remove the SXA component inside the placeholder, the cache doesn't ...
2
votes
1answer
70 views

Sorting inherited template fields

I have a page template inheriting from base templates. But when I go to edit those from Experience Accelerator, Page metadata, Other dialog, they are in a strange order. It seems like its grabbing ...
2
votes
1answer
23 views

Consume RSS and JSON

Does SXA support consuming an RSS feed or JSON, style it and the render it on the website. I see components to generate RSS but not to consume it.
1
vote
2answers
38 views

What enables the SXA style and behavior editing of a component?

I am trying to minimum requirements for enabling styling and behavior editing on a SXA component (using SXA 1.8). At the moment I have a Controller that inherits from Sitecore.XA.Foundation.Mvc....
0
votes
0answers
24 views

Template in variant does not read Arabic version

I used Sitecore 9.1 and SXA 1.8, I created variant and inserted new template when i added Arabic version for template. I see that template does not read Arabic version and read English version only. ...
0
votes
0answers
21 views

Adding a SXA Link List as a Component rendering

I have a page content rendering, and in the rendering variant I wanted to include a link list. I've seen simpler examples where you can tie it to a set datasource but in this instance I'd want the ...
0
votes
1answer
25 views

Pre-populate referrer details in Sitecore Forms

We are using Sitecore 9.0.2 with SXA 1.8 I have a product detail page with a 'Register Interest' link. On click, it should open a form to fill user details which can be pre-populated if logged in. On ...
0
votes
1answer
39 views

Azure search with SXA

Environment: SXA 1.8 in Azure PAAS + Azure search What I have: My client has multiple offices and each office has its individual page managed with SXA. The fields on this page include address and ...
1
vote
1answer
52 views

Using Sitecore SXA Location Search with Azure Search

Our Sitecore Application(9.0.2 with SXA 1.8) is hosted on Azure PaaS and we intend to use Azure Search as the Search provider for our application. One of the Features that we want to implement is ...
1
vote
1answer
34 views

Setup security for the Sitecore SXA site multiple times

When we try to add the Security Setting to the site for the first time we are able to run the Setup Security script with the link under Scripts. When we tried to make changes again in the security, ...
4
votes
1answer
43 views

Azure Search duplicate results for multilingual countries in same site with different language versions

We have a multi-lingual site where the group of countries (say for example Asia Region) is hosted in one Site folder. Thus Home, Pages, Settings have different language versions (zh-HK, en-HK, en-AU)...
1
vote
0answers
15 views

SXA - Partial Designs are not Visible [duplicate]

I added partial designs to my page design and they are showing on my published site but are not visible in my experience editor. Please let me know if you have any workaround for this.
0
votes
1answer
38 views

Accessing SXA Site Grouping Site Settings Properties from Code

I have a SXA site created and under "/settings/Site Grouping" I have defined a Site item. I want to access "Other Properties" fields (ex: "dictionaryPath" which I have added into Other properties) ...
0
votes
1answer
37 views

Not able to edit items after using Sitecore SXA security role

I wanted to create security roles for sitecore users and use the script available in sxa by referring the below links - https://doc.sitecore.com/developers/sxa/17/sitecore-experience-accelerator/en/...
0
votes
1answer
39 views

Google Map zoom not working

SXA Version: 1.8 Component: Maps I am using SXA map component on my page and is connecting to Google Map. I have provided the coordinates. I want to display the map zoomed to the street level. But ...
0
votes
0answers
38 views

SXA Toolbar missing on Customized version of Bootstrap Layout

Due to project base markup particularities, such as a different wrapper ID, different disposition of header, footer , we need to create a customized version of SXA's Bootstrap Layout and implement our ...
0
votes
0answers
45 views

Something missing from Sitecore package, how to find out what it is

I've been trying to hand off some content for our developers to test with. However, when they use the installation wizard to install my package, the installation fails. I checked their logs and am ...
0
votes
1answer
27 views

Default Component Grid Width

Is it possible to set the default grid width for a component out of the box in SXA? Let me explain the thought process behind this to hopefully highlight the problem. I have a component that has four ...
2
votes
1answer
34 views

Renderings on Page Design not visible

Environment: Sitecore 9.0.2 + SXA 1.8.0 What I have done: I have a 'partial design' P1. I applied this P1 to a 'page design' PD1. On this 'page design' PD1, I applied a few renderings. This 'page ...
2
votes
1answer
32 views

Missing custom page templates from “Template to design mapping” in Sitecore SXA

We are using Sitecore SXA 1.8 I have created a Tenant Folder , a Tenant and a Site using SXA. I have created custom page templates for the site. I am trying to map a custom page template to a Page ...
0
votes
0answers
18 views

navigate to particular site home page when click XE button in launch pad [duplicate]

we are using sitecore 9 update 2 and SXA 1.7.1 and we have 2 sites called site1(english) and site2(Korean). both sites created separately in SXA. when click Experience Editor button in launch pad ...
2
votes
2answers
64 views

SXA default redirect rule not working

I am trying the sxa default redirect url but it is not working for my site. Steps followed : /sitecore/content/Tenant/Site/Settings/Redirects/TestRedirect It is not redirecting me to the link i ...
0
votes
1answer
22 views

Create multiple Views under one folder and have the different controller resolve the respective Views

Implementation: I am creating my custom SXA components for Header, Footer and Breadcrumb I have a project "Navigation" Under Navigation I have created three controllers Header, Breadcrumb, Footer I ...
0
votes
1answer
50 views

Renderings in the SXA toolbox show up on the same line

When I add my custom renderings to AvailableRenderings for the site they show up on the same line in the SXA toolbox
1
vote
1answer
47 views

Display list of items with a dynamic query set by content editors

I would like to have a listing module where content editor could select from a list of article types (custom field on a custom template). The list should then query all articles for the selected ...
0
votes
0answers
17 views

FatalError Required validation not working in sitecore 9.1 [duplicate]

i'm using sitecore 9.1 with SXA 1.8, i had the same problem in the this question, i tried to follow the solution mentioned there, i created a new user and gave him some read/write permissions while it'...
0
votes
0answers
27 views

Creating custom composite rendering from Content Editor with minimal visual studio

SITECORE 9.0.2 + SXA 1.7.1 What i am trying to build: I am trying to create an index/table of contents like this. I can have the links pointing to the pages from 'Page List' rendering and a rich ...
0
votes
1answer
47 views

Site Settings- Favicon configuration

I'm using sitecore 9.1 withSXA 1.8, i'm trying to add browser title and favicon to my site. I managed to add the browser title from SXA settings ( ../Settings/Browser) folder and then adding the ...
1
vote
1answer
27 views

Overlays in SXA - Open in Overlay check box not showing

Acccording to the Sitecore documentaion there should be a Open in Overlay check box in the Hyperlink manager. I am running Sitecore 9.1 with SXA 1.8 and I dont see this option (screenshot attached). ...
0
votes
0answers
27 views

Not able to load SXA Site after configuring its domain

We have many SXA Sites and we are trying to launch a new site with our domain https://domainA.info. We updated Host Name and Target Host Name fields on site definition item and published as well. The ...
0
votes
1answer
38 views

How to copy Sitecore Items from one SXA site to another programmatically?

We are using Sitecore SXA with one global website and 6 cloned sites (regional sites). Now, client want to handle all the press releases in global website only (each press release is a separate page) ...
0
votes
1answer
27 views

Automatically adding Renderings to SXA toolbox

I am using Sitecore 9.0 with SXA and have a custom Rendering that I want to add the SXA toolbox for each site that I create. It is of course possible to do this manually (as described here), but I ...
1
vote
0answers
25 views

Custom query in SXA search scope

Using Sitecore, I have defined some tags, related to food or pet type and assigned some of these tags to pages How can I limit search scope to find all pages which have any food tag assigned ?
0
votes
2answers
33 views

Is there any possibility to have LayoutNotFound Url specific to SXA site readily?

We have many SXA sites in our instance and want to configure each site to have its own 'LayoutNotFound' Url. Is there any ready configuration/field available with SXA like 'Page Not Found Url' field ...
1
vote
1answer
28 views

Placeholders generated by partial design are behaving differently

Environment: Sitecore 9.0.2 + SXA 1.7.1 What I have done: I created a partial design, say PartialD1. In the 'main' placeholder of the PartialD1, i added a column splitter generating 2 placeholders '...
0
votes
2answers
44 views

How to use different themes folder for an SXA site?

I have two different sites. SiteA and SiteB (Cloned version of SiteA). I want SiteB to point to themes folder of SiteA instead of its own. I have updated the field 'Themes Folder' of SiteB site item ...
0
votes
1answer
43 views

How can I add a Custom Experience Button for a Link List Item (section)

I have cloned a link list rendering. Whilst I can attach a custom experience button for the experience editing to my cloned rendering - it's actually the item properties that I need to facilitate ...
1
vote
1answer
61 views

How to implement Nofollow/Noindex in Sitecore SXA?

I want to implement NoFollow and NoIndex for every item in Sitecore but I am using SXA. Problem is there is no common template inherited among all of the items. Is there any way I can implement the ...
2
votes
1answer
16 views

Two custom SXA renderings with variants conflict?

I created a first custom rendering for SXA with variant as described in the docs with a repository that inherits from VariantsRepository and it seems to work fine (we created one variant and that ...
0
votes
2answers
73 views

Is there a way to exclude language from URL in SXA Sitemap

We are using Sitecore SXA 1.7.1. The checkbox 'Language Embedding' is set to false for one of our SXA sites and all the site url's are rendering without language code. But, in the sitemap -provided ...
0
votes
0answers
48 views

SXA Custom index not used by Search Results component

Following the SXA documentation Configure SXA indexing, I have created my custom indexes : Then I have created a patch config file for the corresponding index definitions. On a page I use a ...
0
votes
1answer
71 views

SXA server error page not working in Azure PaaS

We are using Sitecore 9.0.2 and SXA 1.7.1 We have configured a server error page in the field called "Server Error Page Link" in the "Settings" item. We generated the static error page (navigate to ...
3
votes
1answer
74 views

How to display page list based on query against a dynamic sxatag value

I want to have a list of articles that could be located anywhere throughout the website with a particular tag associated to it. I don't want to have to have a specific query for each and every tag ...
1
vote
2answers
32 views

The type or namespace name “IocProcessor”could not be found In SXA custom component

I am trying to register service with IoC Processor in SXA custom component But i have face error "the type or namespace name "IocProcessor"could not be found" What should i go for resolved error.