Questions tagged [sxa]

Anything related to the Sitecore Experience Accelerator (SXA)

Filter by
Sorted by
Tagged with
0
votes
1answer
18 views

Where are my SXA items?

Running 10.2, I followed the SXA installation instructions and installed: Powershell Extensions 6.3 Sitecore Experience Accelerator 10.2.0 rev. 04247 If I go into /templates, then SXA stuff is there,...
1
vote
1answer
160 views

How to add social media component in sitecore 9.0.1 using sxa 1.7

I am using sitecore 9.0.1 with sxa 1.7 , wants to add a new WeChat social media component to my sitecore site.I have added a default LinkedIN to the site and i need other medias too .can anyone please ...
0
votes
1answer
61 views

How to trigger or refresh the search results on the basis of a session variable?

I have a page with the SXA search result component. I want to refresh the search result on the click of a button. Please let me know if it is possible. Thanks
1
vote
1answer
77 views

Trying to publish themes but nothing changes when I do

If I ever change anything with my theme, take out a base theme, remove a script, etc., if I publish, it doesn't update on the website. It isn't even reflecting in EE. Then sometimes randomly if I ...
0
votes
1answer
28 views

Editing SXA Searchbox rendering parameters thru powershell

I am trying to update the 'Search results signature' and Suggestion mode of SXA Search box rendering of items thru below powershell script but it is adding new parameter at the bottom instead of ...
1
vote
1answer
65 views

Site clone script running for hours

I have started cloning a SXA site but it's shows "running script..." on UI. I checked few things Checked logs, found this line Job ended: SPE - "Clone Site" - sitecore\Admin (...
0
votes
2answers
103 views

How can I get to my site settings in my content tree from a scheduler class?

I am trying to get to my site settings item in my tree to see what office id I need between my US site and my CA version. I have tried Sitecore.Context.Site but since this is a scheduled task it comes ...
1
vote
1answer
60 views

Is it possible to search the data with field type droplist ,droplink or tag tree list

I m using sitecore 9.0.1 with sxa 1.7,i have default sxa search component and wants to know whether we can search the data with field type droplist ,droplink ,tag tree list etc..Without adding any ...
1
vote
1answer
48 views

Link Lists not showing up in search

I am working on the search for my site. It is working as expected for the most part, but I noticed that if I add a link list with multiple links, the text from those links does not show up in the ...
0
votes
2answers
200 views

How to use different themes folder for an SXA site?

I have two different sites. SiteA and SiteB (Cloned version of SiteA). I want SiteB to point to themes folder of SiteA instead of its own. I have updated the field 'Themes Folder' of SiteB site item ...
2
votes
3answers
205 views

SXA CLI skips uploading pre-optimized-min.css.map, says "Incorrect File Name."

On Sitecore 10.1, we have a pretty standard SXA CLI setup. in gulp\config.js the following settings are set for Css handling. css: { path: ['styles/**/*.css','styles/**/*.css.map'], ...
3
votes
2answers
957 views

SXA site grouping

I'm trying to use the CORS settings under Site Grouping, but they don't seem to do anything. I also can't seem to find any documentation about it. Does anyone know of documentation or know what the ...
0
votes
1answer
45 views

NullReferenceException for placeholders in Experience Editor

I am facing an issue with Experience Editor. Each placeholder is throwing null reference exception. e.g. @Html.Sitecore().Placeholder("body-top") I tried removing this placeholder but it ...
0
votes
1answer
40 views

How to show the checklist filter data when it is clicked on the filter component

Using Sitecore 9.0.1 with SXA 1.7 and I want to display the checklist filter data when it is clicked on the item. Can anyone please explain how can I do that? Below are the things which I have done ...
0
votes
1answer
45 views

Clone of a rendering in SXA not showing Variant

In Sitecore SXA, I've created a clone of a rendering called "Page Content". But when I add this on a page, it doesn't render the data. When I checked its presentation details I found that ...
1
vote
2answers
58 views

How to create a custom Site template in Sitecore SXA?

In Sitecore SXA when I right-click on a tenant, it should have an option to add an eCommerce site. So, when a user clicks on the eCommerce site it should run the same PowerShell script that is run ...
1
vote
1answer
169 views

Redirect home item not working with SxA

We are using SXA 1.9 and I can reproduce the behaviour on a vanilla sitecore instance with SXA 1.9 installed. I've created a tenant called "my-tenant and" a site called "my-site" ...
2
votes
1answer
304 views

SXA Search Boosting Throws Error

I have configured the search scope for SXA (Sitecore 9.3) and it works as expected. However, when I try to add boost configuration to the search scope it throws the below error. Invalid Method Call ...
0
votes
1answer
19 views

VelocityContext in Sitecore 10.1

When migrating from Sitecore 8.2 to 10.1. I have encountered the error in VelocityContext This is the code. public class AddTemplateRenderers : IGetTemplateRenderersPipelineProcessor { public void ...
1
vote
0answers
35 views

Error during creation of SXA Tenant in Sitecore 9.3

Powershell scrips for the creation of Tenant accidentally stopped to work I click the right mouse button on the content item and select "Insert>Tenant" I fill the name of a tenant and ...
0
votes
1answer
11 views

Paging for Site Manager

I have few sites but I can't see all of them on the same page in Site Manager. There are presented in 2 pages but I don't see any option to go to page 2 which make hard to manage sites. Is there any ...
0
votes
1answer
18 views

Information disclosure security issue

There is one security issue reported by Qualys scan. When we hit the url - https://hostnamecd/api/sitecore/image, it shows the page shown in below screenshot. Instead, it should result in custom 404 ...
0
votes
1answer
22 views

Share Index across multiple site

We are using SXA to build 4 sites under same talent for example site A , B , C and D. We have requirement to show the news articles created under any of these sites to be shown to rest of the sites , ...
1
vote
0answers
20 views

"Cannot use import statement outside a module"

When running gulp I get the following error: My node version is 17.1.0 Gulp CLI Version is 2.3.0 Local gulp is 4.0.2
1
vote
1answer
16 views

Nothing happening when running "sxa init"

hoping someone can help. I have successfully installed the SXA CLI as the pre-perquisites to setting up an SXA theme in Sitecore 10.1, I'm following the next steps but hitting a snag I think when ...
0
votes
1answer
65 views

Sitemap is showing Virtual folder name after the language code in Sitecore 9.0.1 with SXA 1.7

I am using Sitecore 9.0.1 with SXA 1.7. We have created one site where the languages used are "zh-CN" and "en" and configured the site to use virtual folder "/cn". When ...
0
votes
1answer
136 views

How to apply styles for partial designs in SXA?

I'm creating the header for an SXA site. I created a new header Partial Design, and then in Experience Editor added some stuff from SXA toolbox. So now, how do I apply (my custom) header CSS classes ...
0
votes
0answers
26 views

How to display the JSON content of a SXA page in a sequential order in Sitecore 9.0.1?

We have a Sitecore SXA website. Sitecore version is 9.0.1, SXA version is 1.7. I am fetching the json data of a page by using default Sitecore resolvers and appending ?sc_device=json. But ...
0
votes
2answers
81 views

Updated field in rendering variant not working

The requirement was to show the last updated date and time of the item in the page. So I tried to create a rendering variant of page content with field as Updated (which is there for every item ...
0
votes
1answer
26 views

Specify default rendering for placeholder in partial design

We have a partial design with an empty placeholder that is being pre-filled with one of its allowed renderings upon page creation. It is not clear where exactly it is being specified for this ...
0
votes
1answer
51 views

Including the solr field in search result along with item fields in the Search result rendering variant

I am using sxa search result for rendering the service items which contain coordinates(lat-lang). We have got a new requirement where the same services may be available in different locations. Hence ...
0
votes
1answer
108 views

Sitecore SxA Composite Layout not adding custom css and js

We have created a custom Accordion Module. Therefore, we also changed the Accordion MVC Layout.cshtml for Accordion Items. But our custom theme doesn't appear in the head nor does the js show up. What ...
1
vote
1answer
85 views

SXA doesn't recognize font files - how do I include them in my theme?

I have a pretty typical font setup: in my creative-exchange theme folder, I placed some custom font files and I reference my fonts like so: @font-face { font-family: "Graphik"; font-...
0
votes
1answer
46 views

How to Evaluate EnableRule field of Sitecore Rendering variant

I have got a scenario that I put some conditions in EnableRule field in rendering variant field. If rule is true then it should render mapped field value and if false it should render some default ...
1
vote
1answer
284 views

'Insert Link' link is not pointing to Site Home item

We are having multiple SXA sites under a tenant. For all the sites, when we click 'Insert link' on General Link field, able to see Home item of current Site. But, for one site (whose language is de-DE)...
0
votes
1answer
29 views

Sitecore SXA Search Results Filter number of fields returned in SOLR response

I am using Sitecore 10.1 with SXA, I have a page that contains search results component and I have noticed that the query that is generated and run on SOLR is retrieving all the fields in the response....
0
votes
1answer
32 views

SXA watch CLI only minify and upload CSS only. JS and Scriban does not work

sxa watch All -d AND gulp, only track css. It says its watching js and scriban but when I save a js or scriban, CLI does not throw a response. Am I missing something ? This is my config: Sass (working)...
0
votes
1answer
27 views

Assign different theme for Header

Is it possible to add different theme for Header and different theme for body / main content..? In SXA, it is allowed to do it but in Header partial view using Experience editor and shows that theme ...
0
votes
1answer
36 views

Can we add or delete data directly into database through Sitecore SXA? [closed]

Can we add or delete data directly into database from programming in Sitecore SXA? Can we add .edmx in Sitecore and perform create/update/delete operation through it ?
1
vote
1answer
69 views

SXA Page Designs versus Standard Values

In the original methods used to set up page layouts (Standard Values and Branches) I was able to predefine a set of renderings without data sources applied, that could be wired up when the page was ...
0
votes
1answer
68 views

SXA Search scope dynamically passing facet information

We have a requirement where we need to display the first two news items (sorted by time) and along with it there will be a link to view the rest of the news as well (this is page 1). If they click on ...
3
votes
1answer
425 views

SXA 1.8 Link field class ignored from rendering variant

I have created a link rendering variant and put in css class of "btn login-button" However in my markup where the link is using that rendering variant this does not appear <div class="component ...
2
votes
1answer
101 views

How do you get value of item tag in scriban template

Sorry this is probably a dumb question but I am a bit stuck in here and I can't find suitable solutions in google. Basically I have an item or a page with a Tagging on it. But I can't seem to get the ...
0
votes
1answer
47 views

Tag Cloud Component doesn't support multilingual tags

I am using Sitecore 9.3 and working on scaled environment. First I have created tags with two versions English and Spanish for every tag like below "Sketch Tag" I needed to tag content Page ...
1
vote
1answer
49 views

Base partial design order

We have two base partial design. First partial design used to set the logo and navigation and the second partial design have log + navigation + breadcrumb, so we use the base partial design feature in ...
0
votes
1answer
127 views

Site Navigation based on selected pages from a list using SXA

I have a requirement where I need to show site navigation in header based on selected pages(From a List) using SXA OOTB functionality. So its like, if a site has 10 pages, I need to show only 5 pages ...
0
votes
3answers
73 views

How to add a sitenames in the dropdown filter of an Experience Analytics in Sitecore 9.0.1

I am using Sitecore 9.0.1 with SXA 1.7. I want to show the list of Sitenames inside the dropdown filter of an Experience Analytics . How can i achieve this? By default it is showing All sites and ...
2
votes
0answers
81 views

Different logo image for different viewports in SXA

I want to have different logo images for mobile and desktop. I created a partial design for the header and added an image component for the logo. Now if I can select logo image in that which will be ...
0
votes
2answers
29 views

Semantic Tag Based Sxa Search not showing result on solr search service

I am using Sitecore 10.1 with Sxa on solr 8.4.1. The sxa scopes based on templates having any semantic tag is showing result in build query, but not on page preview nor published page. Example query : ...
0
votes
1answer
501 views

ERROR An item with the same key has already been added

Working with sitecore 9.1.1 and SXA 1.8.1. The below error suddenly appeared on the CD URL. Server Error in '/' Application. An item with the same key has already been added. Below is the stack ...

1
2 3 4 5
23