Questions tagged [sxa]

Anything related to the Sitecore Experience Accelerator (SXA)

Filter by
Sorted by
Tagged with
1
vote
1answer
30 views

Configure rendering variant parameter in a page content structure component in different sites

I'm using Sitecore 9.1.1 and SXA 1.8.1. I have the following structure: A shared site in which i create the page designs, partial designs and rendering variants. And I have another two sites: Site A ...
2
votes
1answer
25 views

Running SXA Creative Exchange Import on build and release pipelines (CI / CD)

How do I build the front end static assets for a SXA web site in my build pipeline, and then import into Sitecore in the release pipeline ? I would like to run unit tests, code scanning, and produce ...
-1
votes
1answer
25 views

Does Sitecore Horizon v9.3 support SXA?

Sitecore Horizon v9.3 is fairly new, and I could not see any documentation if Horizon v9.3 supports SXA. Does Horizon v9.3 support SXA?
0
votes
1answer
19 views

Add Controls to shared layout

I tried to add Rendering to shared layout from experience editor , but I found it added to final layout not shared
0
votes
0answers
19 views

Rich Text Editor - Sitecore9.2 - Apply Css class around <tr> html tag

I select complete row of the table, Then select a class which changes the background color of the table row. Background color is not applying to the selected table row, because RTE added header class ...
0
votes
0answers
38 views

Custom Field Type - WebEdit Buttons not showing in Experience Editor

I've created a custom Field Type that's very similar to Rich Text (a Duplicate, in fact) and want to use it with a custom HTML Editor Profile that's similar to Rich Text XA (you guessed it, also a ...
1
vote
0answers
25 views

Load more feature with page list in sxa

Does SXA out of box component PageList support load more feature? There is Page size field in PageList but that is use to return number of results as specified. Search Load more component also does ...
0
votes
1answer
163 views

Components added to Page Design are not showing in page

When I add some component to page design and select that page design for a page, the components present in page design are not reflecting in page. On the other hand, if I add components to a partial ...
1
vote
0answers
43 views

Allow rendering variants/styles based on selected Theme SXA

I'm curious if it's possible or someone tried to implement something like: Allow rendering variants/styles based on selected Theme. There is already an Allow in Template filter on rendering variants ...
1
vote
1answer
41 views

Displaying SXA Search Results on the separate page

I'm currently working on SXA OOTB the Search Box and Search Result rendering. SXA sites structure is as below Sites Country Site 1 Country Site 2 Shared Site I have search box in the site header ...
0
votes
1answer
17 views

A public action method 'ReusableIndex' was not found on controller after 9.3 Upgrade

Just upgraded Sitecore 9.1.1 and SXA 1.8.1 to Sitecore 9.3 and SXA 9.3. After the upgrade a few components are throwing the following exception: Error Rendering Controller: Sitecore.XA.Feature....
0
votes
0answers
31 views

How to build Scope Query in SXA sitecore 9.2

I am using Sitecore 9.2 and SXA version 1.9 and i want to utilize predefined search component and when i build the scope query to achieve the search result but i am not be able to configure the Scope ...
0
votes
1answer
49 views

How to implement Print functionality in sitecore 9.1 and SXA 1.8?

I know how to implement print functionality the javascript way and in pure sitecore using controller etc. I wanted some thoughts on implementing print functionality in SXA. I am using sitecore 9.1 ...
1
vote
1answer
36 views

Rebase an SXA website to a new Home node

I have an SXA website with many pages. It has a Home node and quite a lot of items, its children or different SXA settings, refer to it. I would like to let our editors create a new Home node, enter ...
1
vote
1answer
36 views

How can I control Rich Text editor profiles in SXA?

We're about to implement some changes/restrictions on the Rich Text Editor Profile for our SXA solution. We're also exploring the possibility for letting this be controlled in some way, by the user ...
1
vote
0answers
22 views

SXA 1.2 Error 500 & 400 Page configuration

i'm currently using SXA 1.2. I have to create 404 and 500 page. do we have out of the box Feature to configure 404 and 500 Page. In the recent SXA release i can see we can able to configure(see the ...
6
votes
1answer
559 views

Theme not actualizing in Experience Editor but OK after publishing

I'm encountering a little issue : => When I export my theme then edit it and then import it back the CSS modifications do not apply in the Experience Editor (event after opening the editor again, ...
1
vote
1answer
161 views

SXA Responsive Image Variant is not working correctly

I am using the SXA Responsive Image Variant in the SXA's default Image component. Using this configuration: Here whether I enter the values in the Sizes field or not. It is only considering the ...
7
votes
2answers
355 views

How do you boost fields such as Title or Navigation individually in SXA when using SOLR?

In our example, we have a Careers search feature in which we only want to match on title, job id, or a meta field such as description. One wonderful feature about SXA is that you have an easy-to-use ...
0
votes
1answer
50 views

Glass mapper returning null for shared fields with values

I have an SXA site. It has language fallback enabled on the site node. Page and component datasource templates' standard values have had both their item level and field level fallback enabled for non-...
2
votes
0answers
29 views

How to set up map component with SXA search?

I am trying to integrate search result with out of box SXA map component.For that-- I have created "address" template inheriting from IPOI template. Then I have created few address items under site/...
2
votes
1answer
42 views

Sitecore SXA Pass Through Field how to get actual Item?

If I want to render the image url in a data-attribute (lets assume the Image Field is called TeaserImage) I can render the Media URL by $(TeaserImage). So far so good. Now I have a reference field ...
10
votes
1answer
1k views

Create new Grid in Sitecore Experience Accelerator

I am using Sitecore Experience Accelerator 1.4 and I do not want to use Bootstrap, Foundation or Grid960. I have my custom CSS framework. Anyone can provide me a solution that how I can add new Grid?
0
votes
1answer
68 views

_HasValidUrlName not working

I have inherited my items from _HasValidUrlName template, that should create valid item name. for example replace spaces to dash. but item display name would be equal to user input. but at sitecore ...
1
vote
1answer
43 views

Facing the challenge while adding the custom styling related to font in the SXA Site

I am building a SXA site and I have created the custom theme by following the Link I have created my custom stylesheet and added in the theme. But, it is not getting reflected when I preview the ...
2
votes
0answers
50 views

Error in Rendering Sitemap in xml format

There is a Sitecore SXA sitemap enabled in the website, but I am facing the problem when trying to access it (example: sxa18/sitemap.xml), it gives the following error on accessing the url as show in ...
1
vote
1answer
129 views

How to reuse a component in different pages in SXA?

We're building a website using SXA. The website has scope for reusing components. Say we have added a carousel Component (or take any ootb SXA component) in Page A. We want to reuse the same ...
1
vote
0answers
31 views

Sitecore SXA search doesnt work

I have recently installed a fresh Sitecore 8.2 update 5 including Power Shell 4.7.2 SXA 1.5 rev 171010 Sitecore SXA Showcase v1.2 Everything seems working fine except for the search function. When ...
1
vote
1answer
34 views

Search results count not updated when deleting items

I am using Sitecore 9.0.2. and SXA 1.8. I am facing a strange issue when I delete an item. The search results that returns this item is retrieved with the old count (including the deleted item) ...
2
votes
2answers
60 views

How to get item URL using SXA query?

I am using a variant of 'Page Content' to list all the children of the item based on page template. I am able to get the list using the below query. I am also able to fetch the fields of the children ...
2
votes
1answer
197 views

SXA 1.8 Link field class ignored from rendering variant

I have created a link rendering variant and put in css class of "btn login-button" However in my markup where the link is using that rendering variant this does not appear <div class="component ...
3
votes
1answer
81 views

How can I use Sitecore Rules in Scriban templates in SXA 9.3

In SXA 9.3 we have the possibility of using Scriban Templates. I wonder if there is a possibility to use Sitecore rules engine inside of those templates. Let say that I would like to render part of ...
1
vote
1answer
59 views

Installing Sitecore 9.3 + SXA using SIA - not in default physical root

I tried installing Sitecore 9.3 (simple developer machine setup) with the Sitecore Install Assistant. I checked SXA to be installed. In the config file (setup.exe.config) all parameters were set ...
5
votes
1answer
153 views

Using Geospatial Features Implemented in SXA with a Custom Search Index - Run-time Error

After manually implementing support for the Edm.GeographyPoint field type (per Is it possible to get Azure Search to support EDM.GeographyPoint?), I was happy to notice an answer on a related question ...
3
votes
1answer
211 views

Error in Sitecore 9.2 and SXA 1.9 - Could not load type “Sitecore.Jobs.Job” when creating new Tenant

To replicate: Download and install Sitecore 9.2 Initial Release using "Graphical setup package for XP Single" option, which will install Sitecore.NET 9.2.0 (rev. 002893) Download "Sitecore Experience ...
1
vote
1answer
106 views

Sitecore SXA Multisite Robots.txt is returning 404 on one of CD servers

I have an issue on production environment that robots.txt is returning 404 on one CD server while it is working on the other. Any suggestion if there is any missing configuration?
1
vote
1answer
34 views

Exclude specific javascript files or themes from Asset Optimizer

Is there a way to exclude specific JavaScript files from Asset Optimizer. I know you can globally turn off Asset Optimizer or even do it at a site level. Is there a way to do it a file level or even ...
0
votes
1answer
266 views

How can I add a css class for page level using sitecore sxa

How can I add a css class for page level using sitecore sxa
1
vote
0answers
51 views

SXA robots.txt configuration not recognized on bing an yahoo [closed]

on the settings of my site the robots txt does not seem to work for bing and yahoo , but works as expected for google , am i missing anything ?? Robots txt
0
votes
1answer
231 views

Setting site default language in SXA

I'm using Sitecore 9 and SXA 1.7. I can set the default language of the site at Site Grouping: I want to know where to set the language programmatically in SXA. Which dll to use, as I want to ...
2
votes
0answers
52 views

Sitecore indexing a SXA Multisite configuration for more than 500 sites

I am stuck with issue for indexing a SXA Multisite configuration for 600 sites. The case study is as below. Issue: Indexing get failed at certain point of time from CM itself for Solr Master(after 2 ...
1
vote
0answers
14 views

Sitecore.XA.Feature.Composites.EventHandlers.SaveCompositeItems.GetNewLayoutFromRequest throws exception when importing

We have exported our site and then without change anything we tried to upload it back and got the error below. The item id it refers is a Silde Datasource Item from a Carousel Composite and there is ...
1
vote
1answer
54 views

Dropdown Filter - Language English Name

I am using SXA Search component and with that I want to use "Dropdown" filter which will have "Language" facets in the dropdown for the search items. I am able to achieve it by getting "_language" ...
0
votes
1answer
156 views

'Insert Link' link is not pointing to Site Home item

We are having multiple SXA sites under a tenant. For all the sites, when we click 'Insert link' on General Link field, able to see Home item of current Site. But, for one site (whose language is de-DE)...
0
votes
1answer
102 views

Update Sitecore rendered links for a specific page

We are using Sitecore 9.0.2 & SXA 1.7.1 and we need to update all links to be absolute only in a specific page as by default all the links are relative for example this is the default link <a ...
4
votes
3answers
1k views

SXA or not SXA is the Question what are your experiences?

I am not sure if I should use SXA in my project. Currently we want to use only the XP but in the future we would like to use XC too. I think I need to create many components by my self because of the ...
1
vote
1answer
55 views

Duplicate icons on column splitter in partial rendering

Environemnt details: Sitecore 9.0.2 + SXA 1.7.1 What is happening: The options to modify the presentation are coming twice, as can be seen in the image below. On hovering over the icons, message is ...
0
votes
0answers
46 views

Experience Editor is not loading theme style sheets

Application is running Sitecore v9 Update 1 with SXA v1.6. I have cloned a site and I have added a new language to this site. I'm trying to edit a page in Experience Editor in new language version but,...
1
vote
0answers
32 views

Does language fallback work for rendering variant fields?

I have created a rendering variant in 'en' and enabled item fallback. But when I tried to access the rendering variant with other language like fr-fr, all the rendering variant fields are not ...
4
votes
2answers
84 views

Is there any way to check Page mode like edit/preview using Sitecore Rule?

Is there any way to check Page mode like edit/preview/normal using Sitecore Rule? I want to render specific field in rendering variant of SXA component based on page mode (editor/preview).