Questions tagged [sxa]

Anything related to the Sitecore Experience Accelerator (SXA)

Filter by
Sorted by
Tagged with
0 votes
1 answer
329 views

How to apply styles for partial designs in SXA?

I'm creating the header for an SXA site. I created a new header Partial Design, and then in Experience Editor added some stuff from SXA toolbox. So now, how do I apply (my custom) header CSS classes ...
0 votes
1 answer
60 views

Setting up Sitecore sxastarter project in Linux/Ubuntu 22.04

I use Ubuntu for development. What is the best way to set up sxastarter project for Linux development in Connected mode or Sitecore first approach? Are there any resources available that focus on ...
0 votes
2 answers
69 views

How to show custom model parameter in rendering variant

I would like to show the custom model value in the rendering variant. Could someone assist with this? In our scenario, we are getting the URL in the custom model property and would like to show this ...
1 vote
2 answers
177 views

Updated field in rendering variant not working

The requirement was to show the last updated date and time of the item in the page. So I tried to create a rendering variant of page content with field as Updated (which is there for every item ...
1 vote
1 answer
215 views

Sitecore SxA Composite Layout not adding custom css and js

We have created a custom Accordion Module. Therefore, we also changed the Accordion MVC Layout.cshtml for Accordion Items. But our custom theme doesn't appear in the head nor does the js show up. What ...
0 votes
0 answers
48 views

Collection was modified; enumeration operation may not execute(while trying to install SXA for 9.2)

I am trying to install the SXA package for 9.2 in my local. After sometimes of loading it is showing this error. And ended up with package installation failed error. Collection was modified; ...
1 vote
1 answer
527 views

Component's personalization rule applies only once

In our solution we're using custom personalization rule to show/hide components based on some criteria. This rule works fine but only for the first time the user visits the page after it's published ...
0 votes
0 answers
44 views

When attempting to download the package from Scripting with the Sitecore SXA 9.3 version, the following issue is encountered [closed]

When attempting to download the package from Scripting with the Sitecore SXA 9.3 version, the following issue is encountered. Also tried with packaging generation method and facing same Error: ...
1 vote
2 answers
307 views

Accordion Items are not shown up after indexing even in scope query when we provide template name

I am trying to make my accordion items (data source is in Data node) searchable. I tried adding _searchable to the accordion-item, but I guess it is not getting indexed. As I try to add it using ...
3 votes
2 answers
60 views

Error - "SXA: Could not find 'id' attribute for node"

I am seeing an error in my SC 10.2 (headless SXA) logs that I can't find any information about online. When a call is made to this path: /sitecore/api/layout/render/default?item=/some/page&...
1 vote
3 answers
137 views

Redirect map template not working in sitecore 10.2

In Sitecore 10.2 Sxa, I am trying to add redirection rules with redirect map, which is under the settings item. But when I try to add a redirect map , redirection does not work. What could be the ...
0 votes
1 answer
170 views

SXA Search scope dynamically passing facet information

We have a requirement where we need to display the first two news items (sorted by time) and along with it there will be a link to view the rest of the news as well (this is page 1). If they click on ...
0 votes
1 answer
1k views

404 error handle in Sitecore SXA

I am using Sitecore SXA and handling page not found through by default functionality in SXA by going on below path: /sitecore/content/{tenant name}/{sitename}/Settings > Error handling tab > and ...
2 votes
1 answer
212 views

Base partial design order

We have two base partial design. First partial design used to set the logo and navigation and the second partial design have log + navigation + breadcrumb, so we use the base partial design feature in ...
1 vote
2 answers
52 views

General Link Field Reuse with Multisite

I have a Sitecore 10 SXA multisite setup that uses delegated areas. Each delegated page (item) contains several promos with datasources set to the main site. Within these promos we have internal links ...
0 votes
1 answer
54 views

How SXA resolves the Sitecore.Context.Database.Name

I noticed a thing in SXA that on the new publishing target-based CD we have 2 connection strings like <add name="web" ...../> and <add name="preview" ..../>. When the ...
0 votes
1 answer
54 views

Can we add rendering in body-top placeholder in Partial design?

We would like to add one div at the top of #wrapper in Sitecore SXA 1.8. Would like to add extra div through Content Editor. I don't want to add in layout view. I tried to add metadata partial design ...
1 vote
0 answers
26 views

SXA search scope query not updating custom field name

In the scope query field, for the SXA search, I have entered a query like +custom:Divisions|{C24CDE42-XXXX-4225-9F5F-65D6953EF1C7}. Now I check the Solr query log it builds the query like ?q=divisions:...
2 votes
2 answers
47 views

Insert Link SXA Current Site Item is not displaying

We have maintained SXA multisite with the same tenant. In Settings, we have selected the "Linkable Site with a tenant" option in the Link settings. Site A Site B In Site A, from any CTA ...
1 vote
2 answers
491 views

How to make SXA search on particular Data folder?

I'm using SXA 1.7 and Sitecore 9.0.1. I have created a folder under the Site node and when my search should check the field values under the folder. For this I have created a search scope. I'm ...
6 votes
1 answer
201 views

Sitecore item data fetch on the basis of language if wrong language append goes to 404 page

I am getting stuck with an issue, I have a Multilanguage site that is based on SXA. Rather than going to change via language drop-down, I am going to change language via URL. Please see the steps ...
2 votes
1 answer
165 views

Sitecore SXA Dynamic Placeholders

We are trying to render dynamic placeholders with Scriban as follows: {{ sc_placeholder "relatedcontainer*" }} On our UAT instance the placeholder expands the wildcard out properly: ...
2 votes
2 answers
131 views

Sitecore RSS feed generation error in Sitecore 9.1 SXA site

We want to configure the RSS feed for news/events items in the SXA site with two separate RSS links for each type. Feed generation works for news, but throws errors to the events feed. Please suggest ...
3 votes
2 answers
220 views

How to create a custom facet for a Time range for an SXA search filter

I have a search result component showing all the events. The requirement is to add a CheckList filter to filter the events that have their event date before 9AM and after 9AM. How can I create a ...
2 votes
1 answer
2k views

ERROR An item with the same key has already been added

Working with sitecore 9.1.1 and SXA 1.8.1. The below error suddenly appeared on the CD URL. Server Error in '/' Application. An item with the same key has already been added. Below is the stack ...
2 votes
1 answer
152 views

Extending or customizing XM Cloud - Sitecore Pages to support droplink editing

Is there a way to extend or customize Sitecore Pages to allow editing droplink or droptree in the side panel for XM cloud, similar to how we can edit the currently supported fields here https://doc....
0 votes
1 answer
36 views

Sxa search box suggested result not found in multisite scenario

Context: I am using the sxa search box component in site A to search through the items of site B, which is a shared site. The search itself it is working fine: when I click enter, it shows the results ...
0 votes
2 answers
44 views

SXA Component creation: "Access to the path is denied error" [closed]

There is a local Sitecore 10.3 Docker setup with SXA and SPE (6.4). Component creation fails with access denied powershell error trying to create the view .cshtml file: New-Item : Access to the path '...
1 vote
1 answer
189 views

Insert two values in SXA custom search query token (ResolveSearchQueryTokensProcessor)

I am working with a custom SXA search query token. I want to Insert with two different values. foreach (var val in values) { args.Models.Insert(i, this.BuildModel(itemFieldName, val)); } args....
0 votes
1 answer
701 views

Partial design content not appearing in Page design

Using Sitecore 9.2 and SXA 1.9, I've created a Partial design which appears OK in the Experience Editor. I've then added the Partial design to a Page design but when I view that Page design in the ...
1 vote
2 answers
741 views

Sitecore Form default CSS and JS not loading

I have a Sitecore Form that is working fine on one SXA site. However, if try to use the same form on another site then on the click of submit button, it's redirecting to the Formbuilder page. Also, I ...
2 votes
2 answers
159 views

Incorrect Canonical URL in Sitecore SXA Multisite - Domain Name gets appended twice

In our Sitecore 10.2 XM SXA website, the canonical URLs are not being generated properly - the domain name gets appended twice - <link rel="canonical" href="https://prod.*******....
1 vote
1 answer
219 views

SXA Optimized Items Not Created Completely. Core Database error

In 9.3 we are seeing the base themes not always generating the optimized items. The weird thing it will create the item, but never have the code attached. We see the following in the logs. Why is the ...
1 vote
1 answer
146 views

How do you reverse sort and hide the count from the SXA dropdown fiilter?

Can the following two be answered without requiring code changes? How to hide/remove the inside dropdown count number? How to sort the year lastest on top?
3 votes
1 answer
177 views

Was Asset Optimizer's optimized.min having multiple language version intentional?

Last night we encountered a yellow page that reads "Unrecognizable Guid format" and upon investigating, we found out that the web DB has an optimized min that has an English (United States) version ...
2 votes
1 answer
93 views

Federated Authentication with Space in Site Name

I have several SXA sites with spaces in the site name. When enabling federated login for a site containing a space in the name I get the following error on the redirect. "Site from query string ...
1 vote
1 answer
1k views

Bind JSON data in the rendering variants using custom SXA component

Recently I was building a custom SXA component and I have made that by cloning the Default Event List Component given by SXA . I have to get the data in json format from a controller and bind it with ...
2 votes
1 answer
102 views

Does anyone know how to display an image in an NVelocity template?

Unfortunately, I'm stuck on 9.2 until client agrees to upgrade to 10. I have NVelocity templates working nicely as a rendering variant but would like to display an image. If I simply add the $item....
0 votes
1 answer
64 views

How to resolve page datasource of composite rendering in sitecore sxa

On the page item I have added Tabs composite component and on the tab item added Hero component and data source set from page data folder like page:Data/hero I am running logic on publish end event, ...
1 vote
1 answer
62 views

add component in experience editor not working

I am trying to add a component in experience editor in sxa project. On clicking add here button, the below popup is coming I am expecting this list of available rendering is there any configuration ...
2 votes
1 answer
458 views

In SXA, rendering variant - need to generate context item url

I have a list of item and by using reference variant, I'm able to loop the items with the multi-list values. Now each tile which is displayed should wrap with two fields (ie., image and title) with ...
0 votes
1 answer
123 views

Server side rendering engine application URL

Is there anyways I can get the ID for default internal editing host value? If i'm not wrong then when we create a project using the XM Cloud Deploy App, the project is set up with a default internal ...
1 vote
3 answers
240 views

Links on Auth Site are Appending Prod Targethostname URL

I have two Site groupings set up in Sitecore - Test Auth and Test Prod. Test Auth has a site URL of test1-sc10-auth.com, while Test Prod has a site URL of test1-sc10.com. However, whenever I click on ...
1 vote
1 answer
181 views

SXA checklist filter has an issue with facet values that contain spaces

I am trying to create an SXA checklist filter with multiple selections that reads from a list facet. This facet reads from values that may contain spaces (ex: Action Recommended), however the search ...
1 vote
1 answer
443 views

Cannot read properties of null (reading '1')

I am getting this error when I am trying to create a new theme using SXA CLI. ? Enter your login sitecore\admin ? Enter your password [hidden] ? Specify theme path. Root is Themes folder(format <...
1 vote
1 answer
66 views

Is it possible to target a specific page template in sitecore and convert all pages of that template into an SXA pages

Recently we have upgraded to Sitecore 10 XP, some of our pages are still using old templates. Is it possible to target a specific page template in Sitecore and convert all pages of that template into ...
0 votes
1 answer
46 views

Multi tenant and site with Experience Analytics

I have a Question about Experience Analytics. If I create a new tenant and site should it automatically add the newly created site in the Filters dropdown in the Experience Analytics Dashboard? ...
0 votes
2 answers
55 views

System.InvalidOperationException: Could not find method: Process

I am getting an issues while publishing in the content editor. Here is the full error if it will help Job started: Publish to 'web'|Items created: 0|Items deleted: 0|Items updated: 0|Items skipped: 2|#...
2 votes
1 answer
164 views

Is it possible to search the data with field type droplist ,droplink or tag tree list

I m using sitecore 9.0.1 with sxa 1.7,i have default sxa search component and wants to know whether we can search the data with field type droplist ,droplink ,tag tree list etc..Without adding any ...
0 votes
2 answers
702 views

When i publish the item I do not see changes (missing component on certain language)?

I am having this weird bug where I published my changes but I do not see those changes for that specific item on the site, and I also have this weird issue that in certain languages (in this example ...

1
2 3 4 5
27