Questions tagged [sxa]

Anything related to the Sitecore Experience Accelerator (SXA)

Filter by
Sorted by
Tagged with
1
vote
1answer
16 views

Rebase an SXA website to a new Home node

I have an SXA website with many pages. It has a Home node and quite a lot of items, its children or different SXA settings, refer to it. I would like to let our editors create a new Home node, enter ...
0
votes
1answer
17 views

How to implement Print functionality in sitecore 9.1 and SXA 1.8?

I know how to implement print functionality the javascript way and in pure sitecore using controller etc. I wanted some thoughts on implementing print functionality in SXA. I am using sitecore 9.1 ...
1
vote
1answer
12 views

How can I control Rich Text editor profiles in SXA?

We're about to implement some changes/restrictions on the Rich Text Editor Profile for our SXA solution. We're also exploring the possibility for letting this be controlled in some way, by the user ...
1
vote
0answers
10 views

SXA 1.2 Error 500 & 400 Page configuration

i'm currently using SXA 1.2. I have to create 404 and 500 page. do we have out of the box Feature to configure 404 and 500 Page. In the recent SXA release i can see we can able to configure(see the ...
2
votes
0answers
23 views

How to set up map component with SXA search?

I am trying to integrate search result with out of box SXA map component.For that-- I have created "address" template inheriting from IPOI template. Then I have created few address items under site/...
2
votes
1answer
36 views

Sitecore SXA Pass Through Field how to get actual Item?

If I want to render the image url in a data-attribute (lets assume the Image Field is called TeaserImage) I can render the Media URL by $(TeaserImage). So far so good. Now I have a reference field ...
2
votes
0answers
45 views

Error in Rendering Sitemap in xml format

There is a Sitecore SXA sitemap enabled in the website, but I am facing the problem when trying to access it (example: sxa18/sitemap.xml), it gives the following error on accessing the url as show in ...
1
vote
1answer
124 views

How to reuse a component in different pages in SXA?

We're building a website using SXA. The website has scope for reusing components. Say we have added a carousel Component (or take any ootb SXA component) in Page A. We want to reuse the same ...
1
vote
0answers
27 views

Sitecore SXA search doesnt work

I have recently installed a fresh Sitecore 8.2 update 5 including Power Shell 4.7.2 SXA 1.5 rev 171010 Sitecore SXA Showcase v1.2 Everything seems working fine except for the search function. When ...
1
vote
1answer
31 views

Search results count not updated when deleting items

I am using Sitecore 9.0.2. and SXA 1.8. I am facing a strange issue when I delete an item. The search results that returns this item is retrieved with the old count (including the deleted item) ...
2
votes
2answers
57 views

How to get item URL using SXA query?

I am using a variant of 'Page Content' to list all the children of the item based on page template. I am able to get the list using the below query. I am also able to fetch the fields of the children ...
2
votes
1answer
68 views

How can I use Sitecore Rules in Scriban templates in SXA 9.3

In SXA 9.3 we have the possibility of using Scriban Templates. I wonder if there is a possibility to use Sitecore rules engine inside of those templates. Let say that I would like to render part of ...
1
vote
1answer
55 views

Installing Sitecore 9.3 + SXA using SIA - not in default physical root

I tried installing Sitecore 9.3 (simple developer machine setup) with the Sitecore Install Assistant. I checked SXA to be installed. In the config file (setup.exe.config) all parameters were set ...
1
vote
1answer
41 views

Facing the challenge while adding the custom styling related to font in the SXA Site

I am building a SXA site and I have created the custom theme by following the Link I have created my custom stylesheet and added in the theme. But, it is not getting reflected when I preview the ...
1
vote
0answers
48 views

SXA robots.txt configuration not recognized on bing an yahoo [closed]

on the settings of my site the robots txt does not seem to work for bing and yahoo , but works as expected for google , am i missing anything ?? Robots txt
0
votes
1answer
68 views

_HasValidUrlName not working

I have inherited my items from _HasValidUrlName template, that should create valid item name. for example replace spaces to dash. but item display name would be equal to user input. but at sitecore ...
2
votes
0answers
51 views

Sitecore indexing a SXA Multisite configuration for more than 500 sites

I am stuck with issue for indexing a SXA Multisite configuration for 600 sites. The case study is as below. Issue: Indexing get failed at certain point of time from CM itself for Solr Master(after 2 ...
1
vote
0answers
11 views

Sitecore.XA.Feature.Composites.EventHandlers.SaveCompositeItems.GetNewLayoutFromRequest throws exception when importing

We have exported our site and then without change anything we tried to upload it back and got the error below. The item id it refers is a Silde Datasource Item from a Carousel Composite and there is ...
1
vote
1answer
52 views

Dropdown Filter - Language English Name

I am using SXA Search component and with that I want to use "Dropdown" filter which will have "Language" facets in the dropdown for the search items. I am able to achieve it by getting "_language" ...
1
vote
1answer
34 views

Exclude specific javascript files or themes from Asset Optimizer

Is there a way to exclude specific JavaScript files from Asset Optimizer. I know you can globally turn off Asset Optimizer or even do it at a site level. Is there a way to do it a file level or even ...
0
votes
0answers
45 views

Experience Editor is not loading theme style sheets

Application is running Sitecore v9 Update 1 with SXA v1.6. I have cloned a site and I have added a new language to this site. I'm trying to edit a page in Experience Editor in new language version but,...
1
vote
0answers
32 views

Does language fallback work for rendering variant fields?

I have created a rendering variant in 'en' and enabled item fallback. But when I tried to access the rendering variant with other language like fr-fr, all the rendering variant fields are not ...
4
votes
2answers
80 views

Is there any way to check Page mode like edit/preview using Sitecore Rule?

Is there any way to check Page mode like edit/preview/normal using Sitecore Rule? I want to render specific field in rendering variant of SXA component based on page mode (editor/preview).
1
vote
0answers
26 views

SXA search result returns Error 400

I am using Sitecore 9.0.2 and SXA 1.7.1. Search results return Error 400 with response "Exception has been thrown by the target of an invocation." while facets return results as expected. any idea ...
0
votes
1answer
43 views

Glass mapper returning null for shared fields with values

I have an SXA site. It has language fallback enabled on the site node. Page and component datasource templates' standard values have had both their item level and field level fallback enabled for non-...
0
votes
0answers
49 views

Method not found: 'Void Sitecore.Mvc.Pipelines.Response.GetPageItem.GetPageItemProcessor..ctor(Sitecore.Abstractions.BaseClient)'

In Sitecore Experience Accelerator 1.9.0 rev. 190528 for Sitecore 9.2 getting below error: [MissingMethodException: Method not found: 'Void Sitecore.Mvc.Pipelines.Response.GetPageItem....
1
vote
0answers
15 views

Sitecore Form with Salesforce Connect - Custom validations for postcode using external API

The custom validation for the postcode validation using Sitecore forms for a simple contact form which connects to salesforce. I have seen multiple articles for the custom validation and also ...
0
votes
0answers
25 views

Adding hashtag to the internal link that leads to blog search page with tag filter search Sitecore SXA 1.9

The blog index page has all articles are listed and the filter based on tag that works with solr search. The search results based on sxatags filter will get added on the blog index page when apply ...
2
votes
0answers
35 views

Sitecore SXA and Fed Auth - Not picking the right provider

Sitecore Version: 9.1.1 I am trying to integrate SXA with Fed Auth and Azure B2C. I have followed the instructions on this question How can I get SXA login working with my Federated Authentication ...
2
votes
1answer
59 views

Create custom SXA Component

I'm struggling to create my first SXA component for an email form. Even after looking at several tutorials and Sitecore Doc It still doesn't work. I use Sitecore 9.2 and SXA 1.9. For now, as I ...
0
votes
1answer
24 views

Grid -Component Layout is missing in Presentation Details of Standard values

I am using Sitecore 9.1.1 with SXA 1.81. I need to set the Grid- Component Layout in the presentation details for my template standard values, but I am seeing the Component Layout as blank Does ...
0
votes
0answers
51 views

Blog posts with Tag Cloud filter does not work on the search results - Sitecore 9.2 and SXA 1.9

I have created the blog component based on the below link https://alan-null.github.io/2017/12/sxa-blog Somehow, the filter does not work using the SXA tags. What I have done: Created Blog Module ...
2
votes
0answers
45 views

How to implement nested condition in Sitecore search Query Token?

Refereeing this nice post https://ggullentops.blogspot.com/2019/01/extending-sxa-search-query-tokens.html Above approach works well with simple conditions which generate the below SOLR query e.g. ...
2
votes
1answer
34 views

Render Name value list using rendering variant fields

Is there any way to render Name value list field using rendering variant fields?
1
vote
0answers
23 views

Solr Computed Index field in Sitecore SXA Search Result rendering variant [duplicate]

Is there any way to render computed index field of solr using Search Result rendering variant in Sitecore SXA 1.9?
0
votes
0answers
41 views

Adding a new Site under a Tenant fails with message “Something went wrong. See SPE logs for more details.”

I've install Vanilla Sitecore 9.1.1 with Commerce 9.1 and SXA 1.8.1. I tried to create and new Site under a new Tenant. It gives me the following error: I dug into the logs and found this: 5656 16:...
0
votes
0answers
17 views

Adding a custom Button to the sxa-storefront delivery page

I'm trying to add a custom action method to customize the SXA-Storefront. I'm using the CheckoutController of the Sitecore.Commerce.XA.Feature.Cart while I make an ajax call to my custom Controller ...
0
votes
1answer
30 views

SXA search suggest throws error 500

I'm trying to implement the Sitecore SXA auto suggest search functionality, below is the setup <searchComponent name="suggest" class="solr.SuggestComponent"> <lst name="suggester"> &...
2
votes
1answer
69 views

Sitecore Dictionary Labels in SXA Rendering Variants?

How do I make use of Sitecore Dictionary Labels in SXA Rendering Variants? I want the CTA Text to come from Dictionary. It will have two texts namely "View More" and "View Less" in 3 languages.
1
vote
0answers
33 views

Sitecore SXA “ServiceLocator.ServiceProvider.GetService” [closed]

I'm following this guide to build a simple rendering. https://doc.sitecore.com/developers/sxa/17/sitecore-experience-accelerator/en/walkthrough--building-a-simple-rendering.html When I'm trying to ...
2
votes
1answer
36 views

Clone SXA OOB component javascript

I am using Sitecore 9.1 and SXA 1.8, I need to clone "component-search-results-count.js" in base theme to extend some functionality to the OOB "Search Result Count" component. How can I do that?
2
votes
1answer
58 views

Error in RenderingVariantCacheClearer after publishing page with custom Rendering Variants component

My goal is to set up a custom rendering. But I'm running into this error after publishing. I'm not sure where to look for the problem as I'm quite new. Is this a controller error or am I registering ...
0
votes
0answers
32 views

SXA Creative Exchange SASS Compilation Error

Have a blank Sitecore 9 sandbox setup running SXA 1.7 & a new custom theme. Exported and began setting up Creative Exchange. However, I get this error every time and SASS won't compile: Error ...
0
votes
1answer
54 views

SXA drop down filters reset button not working

I'm using in one page 3 SXA drop down filters (category, services, activity), search result and a reset button that clears the filters in the bellow script: function forceReset(){ if ($xa(".clear-...
0
votes
1answer
32 views

FuzzyLookupFactory is not working with Arabic words

I'm using Sitecore 9.1 and SXA 1.8, I'm using FuzzyLookupFactory for my suggester, and this is the configuration: <searchComponent name="suggest" class="solr.SuggestComponent"> <lst ...
6
votes
1answer
55 views

Remove inline style from sxa image tag in sitecore

I created rendering variant and inserted field like that: and the image rendered as : <img src="/master-site/-/media/Project/ADGEs/Master-Site/Register-Icon.svg" alt="" style="margin: 0px 0px;...
0
votes
0answers
36 views

SXA Multiple facets field name is not working

I'm using Sitecore 9.1 and SXA 1.8, I'm using search facet for sorting, I want to sort by three fields, I wrote the names of the fields lower case and comma-separated at the Facet Field Name as ...
0
votes
1answer
97 views

What are the Pros and Cons of using SXA? [duplicate]

The company I work for has purchased Sitecore XP1, and we will be basically starting from scratch to get all of our sites into Sitecore. I have been told that SXA is already included in our package, ...
1
vote
1answer
51 views

SXA Search functionality works only with the whole search query

I'm using Sitecore 9.1 and SXA 1.8, I implemented search functionality using Search box and Search results OOB SXA components, When I search with a sentence, it only returns the exact match for the ...
2
votes
1answer
60 views

SxaTags not rendering in Rendering Variants

I'm trying to render SxaTags through Reference in Rendering Variants but it won't render in the front end. I'm trying this in a component that is cloned from the existing Promo component. Sitecore ...