Questions tagged [sxa]

Anything related to the Sitecore Experience Accelerator (SXA)

299 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
6 votes
1 answer
371 views

Good workflow for SXA PowerShell scripts

I am trying to find a good way to work with PowerShell scripts that we use for SXA such as for scaffolding. I have tried the PowerShell ISE client that was built into Sitecore but sometimes the UI was ...
6 votes
0 answers
549 views

SXA & Item Language Fallback

This is for Sitecore 8.2 update-5 version and SXA 1.5 . I have configured item fallback language in the settings of my site : Now, we have implemented a partial design with json content that ...
5 votes
1 answer
128 views

Sitecore item data fetch on the basis of language if wrong language append goes to 404 page

I am getting stuck with an issue, I have a Multilanguage site that is based on SXA. Rather than going to change via language drop-down, I am going to change language via URL. Please see the steps ...
5 votes
0 answers
481 views

Sitecore SXA Preview Item error

I am using sitecore 9.3 with SXA and i faced an issue while trying to preview an item but i am not sure what can be the root cause of this it happens appears several times, any one has faced this ...
  • 797
5 votes
0 answers
256 views

Dynamic Date Comparison in Search filter

Using Sitecore 9.01 and SXA 1.6 , we are trying to create search scope that filter News item based on their dates , so each News item has start and End date and we need to display only not expired ...
4 votes
0 answers
2k views

SXA Video, Youtube doesn't show thumbnail on mobile?

I am using a Video component and I've created a couple examples, 1 video uses a YouTube source, the other uses a video in the media library. On mobile devices, the Youtube video doesn't show the ...
4 votes
0 answers
327 views

How to search all the articles that have the same (or at least one) tag with the current page?

I found TaggedTheSameAsCurrentPage|SxaTags and TaggedWithAtLeastOneTagFromCurrentPage|SxaTags that is similar to what I need. However it doesn't return any results. I couldn't find much ...
4 votes
0 answers
234 views

Insert Search component inside of another component

I am trying to create a heading element on a page which contains of a background image, title and search box component. Our UI developer advised us to put searchbox into the same div element as image. ...
  • 41
3 votes
1 answer
182 views

Serialized version contained a blank language value!

I am trying to serialize some Sitecore items from the Sitecore instance running in my docker container. So I try this: dotnet sitecore ser pull This works most of the time. But occasionally I get an ...
  • 53
3 votes
0 answers
158 views

Sitecore SXA override Search Controller

I am using Sitecore 9.3 with SXA search components (search box, search results, filters and paging) and needs to extend this to read data from custom API. What I have thought of is to clone the search ...
  • 797
3 votes
1 answer
129 views

Was Asset Optimizer's optimized.min having multiple language version intentional?

Last night we encountered a yellow page that reads "Unrecognizable Guid format" and upon investigating, we found out that the web DB has an optimized min that has an English (United States) version ...
  • 333
3 votes
0 answers
124 views

Sitecore indexing a SXA Multisite configuration for more than 500 sites

I am stuck with issue for indexing a SXA Multisite configuration for 600 sites. The case study is as below. Issue: Indexing get failed at certain point of time from CM itself for Solr Master(after 2 ...
3 votes
0 answers
153 views

Sitecore SXA and Fed Auth - Not picking the right provider

Sitecore Version: 9.1.1 I am trying to integrate SXA with Fed Auth and Azure B2C. I have followed the instructions on this question How can I get SXA login working with my Federated Authentication ...
3 votes
0 answers
392 views

Sitecore SXA Multisite Robots.txt is returning 404 on one of CD servers

I have an issue on production environment that robots.txt is returning 404 on one CD server while it is working on the other. Any suggestion if there is any missing configuration?
  • 797
3 votes
0 answers
135 views

How to get Current Site Country flag using Sitecore SXA?

Is it possible to get flag and country name associated with each site using Sitecore SXA. I need to dispaly country flag as well as country name side by side on top of the page for each SXA Site. ...
3 votes
0 answers
116 views

Translating SXA Date Filter

I'm using SXA 1.7 and i use a date range filter on a page.When i create an arabic version for this filter, i'm only allowed to translate the (Title, from label and to label)but for example the month ...
  • 649
3 votes
0 answers
165 views

SXA 1.6 - Dynamic search scope

Using SXA 1.6 we have the requirement to allow the content editor to select articles with specific tags; these tags are editable by the content editor, is there a user friendly way to do so without ...
2 votes
0 answers
19 views

SXA theme without using node-sass

I created a new SXA theme in Sitecore 10.2.0 and it is bringing in "@sxa/celt": "^10.2.2" which in turn brings in node-sass. This package is deprecated and I want to use dart-sass ...
  • 5,110
2 votes
1 answer
58 views

Unable to map sxatags_sm field to model

I have indexed my content in the SOLR 8.8.2 and the tags available on those items are being pushed in the SOLR as below: { "description_t_en":"Lorem Ipsum is simply dum", &...
2 votes
1 answer
121 views

Base partial design order

We have two base partial design. First partial design used to set the logo and navigation and the second partial design have log + navigation + breadcrumb, so we use the base partial design feature in ...
2 votes
1 answer
156 views

How to create a custom facet for a Time range for an SXA search filter

I have a search result component showing all the events. The requirement is to add a CheckList filter to filter the events that have their event date before 9AM and after 9AM. How can I create a ...
2 votes
0 answers
175 views

Sxa custom search token query for date range is not working in azure search service

I have Sitecore 9.3 SXA with Azure search in our application. We are trying to create a custom SXA search token to filter upcoming events starting from the current date. In the code am trying to pass ...
2 votes
0 answers
95 views

Exact search in Azure search in Sitecore SXA

Using azure search in Sitecore SXA 1.7 and it is not fetching exact result likewise if we are using "Test data" in search box then it is showing result based which match "Test data ...
  • 1
2 votes
2 answers
85 views

Sitecore RSS feed generation error in Sitecore 9.1 SXA site

We want to configure the RSS feed for news/events items in the SXA site with two separate RSS links for each type. Feed generation works for news, but throws errors to the events feed. Please suggest ...
2 votes
0 answers
63 views

SXA Unrecognized Guid format on certain URL path

Our site has language embedding enabled, so our site URL is https://{siteUrl}/en But when I mistakenly omitted en and typed a path (which is a two-letter word, e.g. https://{siteUrl}/gg it throws the ...
  • 333
2 votes
0 answers
332 views

Sitecore SXA export failing with error - startIndex cannot be larger than length of string

I don't think this is self signed certificate issue I have alreacy set name="XA.Feature.CreativeExchange.SkipServerCertificateValidation" value="true" Here is the stack trace of error from logs ...
2 votes
0 answers
112 views

Different logo image for different viewports in SXA

I want to have different logo images for mobile and desktop. I created a partial design for the header and added an image component for the logo. Now if I can select logo image in that which will be ...
2 votes
0 answers
61 views

SXA search filters don't intersect itself

I'm using Sitecore 9.1 and SXA 1.8, I have checklist filter with data as seen: Individual has items : News3, News4, News7 Vacation has items : News3, News5, News6 When I choose these two options, ...
2 votes
1 answer
280 views

Unable to upload files with larger than 100kb using Creative Exchange/CLI

I have created a new theme using the CLI and have it connected to my local instance of Sitecore. This all mostly works without any issues. I have my settings to upload source files (SASS, CSS and JS). ...
  • 13.7k
2 votes
0 answers
75 views

SxaTags is not working with SearchResults signature

I am using Sitecore 9.3 and SXA, when I used the tag cloud with a searchresults component without having signature it worked fine but when I added a searchresults signature it stopped filtering in the ...
2 votes
0 answers
72 views

Return Partial view inside search results rendering variant

I'm using Sitecore 9.1.1 with SXA 1.8.1. I have a search results component, I need to render a partial view inside a section in its rendering variant. I tried to add a Variant component for a custom ...
  • 649
2 votes
1 answer
386 views

SXA Search Boosting Throws Error

I have configured the search scope for SXA (Sitecore 9.3) and it works as expected. However, when I try to add boost configuration to the search scope it throws the below error. Invalid Method Call ...
  • 21
2 votes
0 answers
213 views

How to set up map component with SXA search?

I am trying to integrate search result with out of box SXA map component.For that-- I have created "address" template inheriting from IPOI template. Then I have created few address items under site/...
2 votes
0 answers
243 views

Error in Rendering Sitemap in xml format

There is a Sitecore SXA sitemap enabled in the website, but I am facing the problem when trying to access it (example: sxa18/sitemap.xml), it gives the following error on accessing the url as show in ...
2 votes
0 answers
139 views

Does language fallback work for rendering variant fields?

I have created a rendering variant in 'en' and enabled item fallback. But when I tried to access the rendering variant with other language like fr-fr, all the rendering variant fields are not ...
2 votes
0 answers
98 views

How to implement nested condition in Sitecore search Query Token?

Refereeing this nice post https://ggullentops.blogspot.com/2019/01/extending-sxa-search-query-tokens.html Above approach works well with simple conditions which generate the below SOLR query e.g. ...
2 votes
0 answers
163 views

Workflow is being assigned to datasource items that don't have an initial workflow assigned

I have added some SXA components to the page (say I have added a linklist SXA component to the Home item). I have also added the workflow to different Sitecore items (Home item is assigned a workflow ...
2 votes
0 answers
263 views

How do I get my SSR proxy to site resolve the LayoutService for my JSS/SXA Site?

We're on Sitecore 9.2, SXA 1.9, JSS 12. previously On 9.1, we had the following setup: JSS App sitting in /sitecore/content/myapp A site definition that mapped a hostName to our /myapp A JSS ...
  • 24.6k
2 votes
0 answers
68 views

If you add a rendering to a SXA cache settings item will it break personalization

As the title says. If you enable caching for a rendering in SXA using a CacheSetting item e.g. under /sitecore/content/My Client/EMEA/My Website/Presentation/Cache Settings Will this prevent ...
2 votes
0 answers
199 views

Responsive Image List in Rendering Variants

Background : I am using SXA 1.9 and Sitecore 9.2 to learn SXA. I am following youtube videos on SXA Rendering Variants by Short, ad-hoc, unofficial Sitecore SXA channel. On the blogs template, there ...
2 votes
0 answers
45 views

SXA Generate Multilingual Static Error Pages

I am using sitecore 9.1 with SXA 1.8 and when i tried to use the feature of generating static error pages in SXA, i found a folder created on the root of the iis site called "ErrorPages" and i found ...
  • 797
2 votes
0 answers
469 views

Build Scope Query to Get First level of Children

I am using Sitecore 9.1.1 and SXA 1.8.1 I have an item called Seat, this item is a parent to many other items on multiple levels of two templates, Topic Details and Topic Listing. In Seat (my parent ...
2 votes
0 answers
108 views

How to make a SXA component in the partial design to read data from the current page's local data folder?

What exactly needs to be written in the Data source of the partial design such that when the page using this design is previewed, it takes data source from current page's local data folder. I tried ...
2 votes
0 answers
385 views

In SXA, rendering variant - need to generate context item url

I have a list of item and by using reference variant, I'm able to loop the items with the multi-list values. Now each tile which is displayed should wrap with two fields (ie., image and title) with ...
2 votes
0 answers
437 views

Something missing from Sitecore package, how to find out what it is

I've been trying to hand off some content for our developers to test with. However, when they use the installation wizard to install my package, the installation fails. I checked their logs and am ...
2 votes
0 answers
388 views

Not able to load SXA Site after configuring its domain

We have many SXA Sites and we are trying to launch a new site with our domain https://domainA.info. We updated Host Name and Target Host Name fields on site definition item and published as well. The ...
2 votes
0 answers
619 views

FatalError Required validation not working

I am using SXA 1.8, and Sitecore 9.1 I am trying to add a validation for a Date type field where it is required, and the user cannot save the item unless this field has a value, I have copied ...
2 votes
0 answers
129 views

SXA Date Range Filter

I am using SXA 1.7 and when using Date Range Filter and choose start date equal to end date it doesn't return data. when i investigated this issue i found that it occurs when the field used is of ...
  • 797
2 votes
0 answers
492 views

Sitecore 9 Sxa Install throwing NullReferenceException Error

I have Sitecore 9 update 2 installed. I am trying to install SXA (Sitecore Experience Accelerator 1.7.1 rev. 180604 for 9.0). I have already installed SPE (Sitecore PowerShell Extensions-4.7.2 for ...
  • 379
2 votes
0 answers
329 views

Video Media item is not loading as per language query string parameter?

I have created media item and uploaded two different video in "English" and "Spanish" version. When accessing this media item, it is not loading the video as per the query string parameter, please ...

1
2 3 4 5 6