Questions tagged [sxa]

Anything related to the Sitecore Experience Accelerator (SXA)

Filter by
Sorted by
Tagged with
1
vote
1answer
259 views

Attempting to Export Creative Exchange through script web api

I'm attempting to follow the documentation for SXA in a CI/CD process. Configuration Details: Sitecore 9.1 (Standalone Config - My Local Dev) SXA 1.8 initial release PowerShell 5 Running on Windows ...
1
vote
1answer
428 views

How to write a custom controller for Sitecore SXA Search Box component?

We are using Sitecore 9.0.2, SXA 1.8.1 and Azure search. The SXA component Search Box works perfectly fine. In our application, we need to show the search results from other application along with ...
1
vote
1answer
291 views

Modify Url's in Sitecore SXA sitemap

Our application is on Sitecore 9.0.2 with SXA 1.8.1 we have written custom link provider and Item resolver to omit bucket folders in Url's in our application and is working as expected , we also ...
1
vote
0answers
207 views

Sitecore Items Services API requests from CD Server

The below Url is working fine in our development environment and we want to move the respective config changes to Production CD Server only in order to make those API's public. Will the below API ...
0
votes
0answers
122 views

Search checklist field data in the Content search API in Sitecore SXA

I would like to search checklist data through the Content search API in the Sitecore SXA. However, it is not searching any data based on checked value in checklist field. Sharing code : Template: Name ...
0
votes
4answers
210 views

How you render Page List data with multiple rendering variants?

I have a Query which returns a list of all "blog posts" sorted by date. I have a "Page List" variant-definition to display each blog post in the list, but how do I make the first ...
0
votes
1answer
464 views

SXA Search results Load more control

I am adding Search Results with Load More renderings. I need to display a number of items loaded with the total number of items returned from search API. Is there a way to get this info in SXA? I ...
0
votes
1answer
497 views

SXA server error page not working in Azure PaaS

We are using Sitecore 9.0.2 and SXA 1.7.1 We have configured a server error page in the field called "Server Error Page Link" in the "Settings" item. We generated the static error page (navigate to ...
0
votes
1answer
585 views

How we can create two column layout and assign partial page using sitecore sxa?

Right side part, i.e. partial page4 - its a reusable for many pages. In left side part -- we can add no of partial page. How can we achieve this structure using Sitecore SXA?
0
votes
1answer
236 views

Where the auto suggest results implemented in SXA?

I'm using Sitecore 9 update 1 with SXA 1.7, I configured the search box suggestion mode to be "ShowsPredictions", I know that the implementation is in Sitecore.XA.Foundation.VersionSpecific.Services....
0
votes
1answer
251 views

Partial design content not appearing in Page design

Using Sitecore 9.2 and SXA 1.9, I've created a Partial design which appears OK in the Experience Editor. I've then added the Partial design to a Page design but when I view that Page design in the ...
0
votes
1answer
226 views

SXA exported HTML - asset URLs broken

Exporting an SXA 1.8 site (SC9.1) with Creative Exchange generates the static files, however the asset URLs in the exported HTML contain hyphens, whilst the folder structure from the zip file contains ...
0
votes
3answers
1k views

General Link value in rendering variants

I'm using sitecore 9.1 and SXA 1.8. I am trying to read a field of type "General Link" in a rendering variant. I've already tried before to read it using NVelocity and it worked but is there a ootb ...
0
votes
0answers
141 views

SXA Boosting Rules not working

I'm using SXA 1.7 and Sitecore 9, I made a SXA boosting rule to a search scope and it works well on CM(Master Database), I publish the scope and I checked that it's published, but it's not reflecting ...
0
votes
1answer
592 views

Active Tests window receives __RequestVerificationToken error

In a development environment, when I attempt to open the Active Tests window from the Optimizaton tab of the Experience Editor, the window does not finish loading. I opened Chrome Developer Tools, ...
0
votes
2answers
176 views

How to allow requests to items underneath an JSON endpoint

We are using a JSON based contentstore for one of our projects. We are working with Sitecore 9.0 and SXA for generation JSON documents for our content stores. Now our client asks if we can allow calls ...
0
votes
0answers
234 views

Component's personalization rule applies only once

In our solution we're using custom personalization rule to show/hide components based on some criteria. This rule works fine but only for the first time the user visits the page after it's published ...
0
votes
1answer
291 views

Creative Exchange does not import page <body> style in SXA

With Creative Exchange styles can be edited in Components or in Page <body> tag. Components works fine out of the box. New styles are added to Sitecore and assigned to components after import ...
-3
votes
1answer
67 views

Login component as popup window in Sitecore SXA

I have implemented the login component in Sitecore SXA. It is coming properly on the page. Now the customer is asking about the feasibility of the login component as a pop window. Is it possible?

1 2
3