Skip to main content

Questions tagged [sxa]

Anything related to the Sitecore Experience Accelerator (SXA)

Filter by
Sorted by
Tagged with
0 votes
2 answers
145 views

how can we get general link field from rendering parameter in sitecore sxa using scriban

I am trying to access general link field from rendering parameter in sitecore sxa using scriban but it is accessing whole link tag with page id instead of url. how can get normal url? <a class=&...
Sharvan Gupta's user avatar
0 votes
1 answer
30 views

XP editor navigation bar not working in SXA site

We inherited a solution that consists of a number of sites build with MVC. The solution has been upgraded to 10.2(.1) and we have added a new headless site using SXA and JSS. So we have a dozen "...
Gatogordo's user avatar
  • 20.2k
0 votes
1 answer
25 views

SXA Responsive Image - null reference

We noticed that if an image is not published, pages containing that image in a Responsive Image rendering variant are broken. And not just missing the image - but actually broken. The site is running ...
Gatogordo's user avatar
  • 20.2k
0 votes
1 answer
67 views

Theme is not switched when overriding DoGetThemeItem

I am implementing this article so I can switch themes based on the a cookie or query string. My code is as follows. protected override Item DoGetThemeItem(Item item, DeviceItem device) { ...
William's user avatar
  • 103
0 votes
0 answers
41 views

backgroundImage images throws console errors on enabled CDN

We are facing issues on background image while using CDN. We have SXA website and enabled Background image but its throws console error while enabling azure cdn. Found that extra "/" is ...
Manish Dalwadi's user avatar
0 votes
1 answer
91 views

Setting up Sitecore sxastarter project in Linux/Ubuntu 22.04

I use Ubuntu for development. What is the best way to set up sxastarter project for Linux development in Connected mode or Sitecore first approach? Are there any resources available that focus on ...
Nimish's user avatar
  • 11
1 vote
2 answers
337 views

Media (Images) not loading and media dialog shows error

We have upgraded Sitecore 9.0.2 to Sitecore 9.3 and it is SXA based solution. And media search is not working after the upgrade. The Media dialog box shows an empty result and returns a response as ...
Sumit Helaiya's user avatar
1 vote
1 answer
226 views

Custom Page List Component always get same datasource value

We have recently upgraded the project from Sitecore 9.0.2 to Sitecore9.3. There is a component called Page List and we have created a custom component from it as per custom need and it was working ...
Sumit Helaiya's user avatar
0 votes
0 answers
34 views

Sitecore SXA All Facet values not reflecting

I am using Sitecore 10.1 SXA with Solr on Azure Kubernetes. On a Multicheck list filter, the facet values coming from sitecore_sxa_web_index exceed 100 values, hence facet.limit increased to 1000. ...
Tabbuu's user avatar
  • 75
1 vote
4 answers
239 views

Redirect map template not working in sitecore 10.2

In Sitecore 10.2 Sxa, I am trying to add redirection rules with redirect map, which is under the settings item. But when I try to add a redirect map , redirection does not work. What could be the ...
Sara Elgendy's user avatar
2 votes
0 answers
105 views

Not able to add same component twice inside the dynamic placeholder

I have created one component and inside that main component cshtml page, added one DynamicPlaceholder, to add another component twice for configurations. The first time, when I dragged and dropped the ...
Saket Singh's user avatar
0 votes
0 answers
22 views

SiteCore headless development material [duplicate]

I am learning SiteCore headless development but I don't know what is the best source for headless
Doaa Abdallah's user avatar
0 votes
2 answers
334 views

Sitecore - Remove related publish option [duplicate]

Is there any way to remove the related publish option or always uncheck this option when I publish?
Jack Noob's user avatar
1 vote
1 answer
233 views

How to setup a multilingual site with the same domain but different home items

I have a single SXA site with multiple language versions like English,German,French,Italian etc. Now, I have following requirement : Each language version must have it's own content node like below ...
Prabakaran Ganesan's user avatar
0 votes
1 answer
75 views

How to resolve page datasource of composite rendering in sitecore sxa

On the page item I have added Tabs composite component and on the tab item added Hero component and data source set from page data folder like page:Data/hero I am running logic on publish end event, ...
Anekar Vishal's user avatar
0 votes
3 answers
64 views

Generating Custom Error pages using SXA - Docker Container AKS

We are using Sitecore 10.2 with SXA and it is deployed on docker using AKS. We are trying to generate a static error page from the Site grouping site the error page is created but if we are again ...
Rameshkumar's user avatar
1 vote
0 answers
95 views

Custom SXA Rendering displaying Incorrect Data Source

I've built out a custom SXA component by cloning an existing component, creating a custom Controller/Repository/View and updating the template. The template has 3 fields on it, a Checkbox, a Droplist, ...
Verdoorn's user avatar
  • 143
0 votes
1 answer
172 views

Issue with links for a SXA Multisite when a site definition has multiple hostnames

I've got this odd issue with our Sitecore 10.2 with SXA implementation. I have a site definition that has multiple host names associated with it. On occasion, the links on the site will include the ...
soze's user avatar
  • 123
2 votes
1 answer
96 views

Refused to display 'https://www.google.com/' in a frame because it set 'X-Frame-Options' to 'sameorigin' in sitecore 10.3 XM in Sitecore 10.3

I am having issue in IFrame. IFrame cross domain url is not working in sitecore 10.3 XM. Refused to display 'https://www.google.com/' in a frame because it set 'X-Frame-Options' to 'sameorigin' I ...
rohit gupta's user avatar
1 vote
2 answers
699 views

Invalid graphql endpoint, Verify that 'layoutServiceHost' property in 'scjssconfig.json' file or appropriate environment variable is set

I am a newbie here. I was editing the .env file for adding the graphQLEndpoints. But in between something broke and I got this error. This is the scjssconfig.json file { "sitecore": { ...
hrupapara's user avatar
0 votes
1 answer
66 views

Can we add rendering in body-top placeholder in Partial design?

We would like to add one div at the top of #wrapper in Sitecore SXA 1.8. Would like to add extra div through Content Editor. I don't want to add in layout view. I tried to add metadata partial design ...
Ashish's user avatar
  • 912
2 votes
2 answers
230 views

Incorrect Canonical URL in Sitecore SXA Multisite - Domain Name gets appended twice

In our Sitecore 10.2 XM SXA website, the canonical URLs are not being generated properly - the domain name gets appended twice - <link rel="canonical" href="https://prod.*******....
Neha Pasi's user avatar
0 votes
1 answer
48 views

Control order of components added from page design on the assigned page

I have some pages previously created with some components added to the main placeholder. Then I created a new page design and partial design on which I added a new component to the main placeholder as ...
AME's user avatar
  • 689
1 vote
1 answer
83 views

How to change Media Library Theme Path(custom theme folder path) in existing FrontEnd code solution

I have requirement to setup theme for new microsite in our sitecore-SXA project so follow below steps do it, and it works fine too. npm config set @sxa:registry https://sitecore.myget.org/F/sc-npm-...
Rinku Jain's user avatar
0 votes
2 answers
73 views

Google search result adding language in the URL

We have added languageEmbedding : never in our Sitecore SXA site. We are not getting language in the URL when we open site directly. However, when we are searching any result on google and redirect ...
Nisha's user avatar
  • 411
1 vote
1 answer
56 views

Saving one language version of search scope item overwrites other languages versions of same item

I am working on a multilingual site in Sitecore and I need to filter search results by current language. I am using a search scope and I would like to have different versions of a search scope, one ...
user3564042's user avatar
0 votes
0 answers
47 views

Create Wildcard Pages with dynamic content [duplicate]

I'm trying to create a page with a Wildcard item that displays different content depending on the url. That's why I created an item with a controller inheriting VariantsController. But I can't change ...
YohanA's user avatar
  • 1
1 vote
1 answer
131 views

Sitecore SXA Multisite - Robots.txt is returning a 404

I have a Sitecore 10.2 site that, when accessing the site's robots.txt page, gives me a 404. I have filled out the Robots section in the Content Editor -> Settings page and have properly saved/...
Hamadyne's user avatar
0 votes
0 answers
150 views

Sitecore Experience editor error in xm cloud partial design

Looking for help on solving Experience editor error in xm cloud., We are using xm cloud + next js to build a website. Experience editor is not opening to do edits for partial design, whereas it is ...
Gunasekaran's user avatar
1 vote
0 answers
189 views

Dynamic placeholder for Left and Right column in Sitecore JSS NextJs Rendering Component

I have SXA-JSS Next.JS based component for Sitecore 10.3.0, I want to have 2 placeholders with the different key, but with a dynamic suffix. e.g. I need 2 equal columns. In CMS, I Created two ...
Praveen Soni's user avatar
1 vote
3 answers
427 views

Add class to body tag in partial design

I would like to add CSS class to body tag at partial design without changing MVC layout in Sitecore 9.1 SXA. Kindly someone assist me if this is possible.
Nisha's user avatar
  • 411
0 votes
1 answer
258 views

Get Datasource Item from Rendering with Powershell [duplicate]

I am looking for powershell script to get datasource item of a rendering. Right now I am getting path of datasource item. But since I am using SXA, I expect few paths like, local:/Data/Hero Banner ...
Vikrant Punwatkar's user avatar
1 vote
0 answers
35 views

Sitecore Search Scope Boosting - 400 Bad request

I have created a search scope that works very well. But I would like to make the search box to search the items based on the field value. So I add a new rule in the boosting section and it throws a ...
Jack Noob's user avatar
0 votes
0 answers
48 views

JSON template in Sitecore 10.1

Is there any alternate to JSON template in Sitecore 10.1?. We migrated to Sitecore 10.1 from Sitecore 8. One of the Rendering Variants is JSONResults, which includes JSON Template inside JSONResults. ...
Owais Ahmed's user avatar
1 vote
2 answers
280 views

Issue after using Opengraph.config file

After testing the code to use the opengraph class from this article. https://www.maartenwillebrands.nl/2021/10/05/sitecore-sxa-creating-a-proper-fallback-for-the-ogtitle-element/ I decided to remove ...
HamofChi's user avatar
0 votes
1 answer
44 views

Is there any way to add RawHTML in form elements on Sitecore sxa xm? [duplicate]

Im not getting the RawHTML element in the form element section.
Anoop Kumar's user avatar
1 vote
0 answers
58 views

SXA 10.2 SiteManager not resolving correctly in Azure PaaS XP environment

I'm at my wits end trying to figure out why my Sites are resolving (or not resolving) the way they are. A little background. This is a migration from SC 9.1.1 to SC 10.2. I've gone through the ...
soze's user avatar
  • 123
0 votes
0 answers
27 views

How to implement boost rules for SXA search results in Sitecore

We are using Sitecore 9.0 (solr 5.0), soon migrating to 10.2 (solr 6.3). I am referring Sitecore documents - https://doc.sitecore.com/xp/en/developers/93/platform-administration-and-architecture/...
SummiJ's user avatar
  • 27
1 vote
1 answer
56 views

Installing Sitecore SXA package spins endlessly on cloud

We have Sitecore 9.3 PAAS Azure environment and want to add SXA. We had to install PowerShell 6.1 version as the compatible version 6.0 gave errors and installation would not complete. We were ...
Shilpy Jogi's user avatar
1 vote
1 answer
434 views

Sitecore.XA.Foundation.Variants.Abstractions.Pipelines.GetVelocityTemplateRenderers is Missing in Sitecore 10.3

I am upgrading Sitecore from 9.1 to 10.3 and noticed the class Sitecore.XA.Foundation.Variants.Abstractions.Pipelines.GetVelocityTemplateRenderers is no more present in Sitecore.XA.Foundation.Variants....
Sitecoredev's user avatar
1 vote
1 answer
307 views

Images not loading in SXA site

using Sitecore 10.3 This is my local instance. I have two sites under /sitecore/content. One is from SXA, like this: sitecore |_content |_Tenant |_Site |_Home And the other is non-...
sukesh's user avatar
  • 3,146
0 votes
2 answers
438 views

Disable publish button for admin user

We would like to disable Publish button under the home menu in experience editor for admin users as well in Sitecore SXA. Tried approach : I went to core database /sitecore/content/Application/webedit/...
Nisha's user avatar
  • 411
2 votes
2 answers
638 views

SXA indexes not created after installing 10.3

I have installed 10.3 on my Windows 11 Pro machine by running the PowerShell script - XP0-SingleDeveloper.ps1. However, that doesn't install SXA. So, I had to install separate packages for SXA & ...
sukesh's user avatar
  • 3,146
0 votes
2 answers
337 views

Hide publish item from context menu

I am creating some scenarios where I need to hide Publish Item option from Context menu in Sitecore SXA. I have tried in core database to hide it under this path:- /sitecore/content/Applications/...
Ashish's user avatar
  • 912
1 vote
3 answers
344 views

Links on Auth Site are Appending Prod Targethostname URL

I have two Site groupings set up in Sitecore - Test Auth and Test Prod. Test Auth has a site URL of test1-sc10-auth.com, while Test Prod has a site URL of test1-sc10.com. However, whenever I click on ...
Owais Ahmed's user avatar
1 vote
2 answers
926 views

How to copy a Sitecore 10 site from one environment to another?

How can I copy a Sitecore 10 site from one environment to another? I've created a site package and installed it in the new environment, but the site isn't appearing in the SXA site manager. Is there ...
Owais Ahmed's user avatar
1 vote
1 answer
90 views

How to get results based on current context language using rendering variant Search Build Query?

I am using rendering variant query item to write the search build query to get the related items. I want to query items that should also match current user context language. I have tried using ...
HariWaghamare's user avatar
1 vote
1 answer
1k views

How to check custom database exist or not in Powershell script

We have created a custom database Preview in Sitecore Sxa. We need to check this database is exist or not through Sitecore Powershell script. Could someone let me know how we can check database exist ...
Nisha's user avatar
  • 411
1 vote
1 answer
253 views

Headless/SXA/NextJS - Add site module is not showing up my newly created headless module

We are using Sitecore-10.3/Headless/SXA/NextJS. Trying to add a new custom SXA headless module to my headless-SXA website but the newly created module is not showing up. Steps to reproduce Create a ...
Andi AR's user avatar
  • 763
2 votes
1 answer
1k views

Headless/SXA/Next.JS : Server error : TypeError: Cannot read properties of undefined (reading 'CustomVariant')

We are using Sitecore-10.3/Headless/SXA/NextJS. When we build a custom new component with few custom variants, we receive errors. We will not receive this when we use the "Default variant". ...
Andi AR's user avatar
  • 763

1
2
3 4 5
28