Questions tagged [sxa]

Anything related to the Sitecore Experience Accelerator (SXA)

Filter by
Sorted by
Tagged with
4
votes
2answers
214 views

Is there any way to check Page mode like edit/preview using Sitecore Rule?

Is there any way to check Page mode like edit/preview/normal using Sitecore Rule? I want to render specific field in rendering variant of SXA component based on page mode (editor/preview).
1
vote
0answers
32 views

SXA search result returns Error 400

I am using Sitecore 9.0.2 and SXA 1.7.1. Search results return Error 400 with response "Exception has been thrown by the target of an invocation." while facets return results as expected. any idea ...
0
votes
1answer
198 views

Glass mapper returning null for shared fields with values

I have an SXA site. It has language fallback enabled on the site node. Page and component datasource templates' standard values have had both their item level and field level fallback enabled for non-...
0
votes
1answer
152 views

Method not found: 'Void Sitecore.Mvc.Pipelines.Response.GetPageItem.GetPageItemProcessor..ctor(Sitecore.Abstractions.BaseClient)'

In Sitecore Experience Accelerator 1.9.0 rev. 190528 for Sitecore 9.2 getting below error: [MissingMethodException: Method not found: 'Void Sitecore.Mvc.Pipelines.Response.GetPageItem....
1
vote
0answers
28 views

Sitecore Form with Salesforce Connect - Custom validations for postcode using external API

The custom validation for the postcode validation using Sitecore forms for a simple contact form which connects to salesforce. I have seen multiple articles for the custom validation and also ...
1
vote
0answers
49 views

Adding hashtag to the internal link that leads to blog search page with tag filter search Sitecore SXA 1.9

The blog index page has all articles are listed and the filter based on tag that works with solr search. The search results based on sxatags filter will get added on the blog index page when apply ...
3
votes
0answers
59 views

Sitecore SXA and Fed Auth - Not picking the right provider

Sitecore Version: 9.1.1 I am trying to integrate SXA with Fed Auth and Azure B2C. I have followed the instructions on this question How can I get SXA login working with my Federated Authentication ...
2
votes
1answer
237 views

Create custom SXA Component

I'm struggling to create my first SXA component for an email form. Even after looking at several tutorials and Sitecore Doc It still doesn't work. I use Sitecore 9.2 and SXA 1.9. For now, as I ...
0
votes
1answer
35 views

Grid -Component Layout is missing in Presentation Details of Standard values

I am using Sitecore 9.1.1 with SXA 1.81. I need to set the Grid- Component Layout in the presentation details for my template standard values, but I am seeing the Component Layout as blank Does ...
1
vote
0answers
112 views

Blog posts with Tag Cloud filter does not work on the search results - Sitecore 9.2 and SXA 1.9

I have created the blog component based on the below link https://alan-null.github.io/2017/12/sxa-blog Somehow, the filter does not work using the SXA tags. What I have done: Created Blog Module ...
2
votes
0answers
51 views

How to implement nested condition in Sitecore search Query Token?

Refereeing this nice post https://ggullentops.blogspot.com/2019/01/extending-sxa-search-query-tokens.html Above approach works well with simple conditions which generate the below SOLR query e.g. ...
2
votes
1answer
71 views

Render Name value list using rendering variant fields

Is there any way to render Name value list field using rendering variant fields?
1
vote
0answers
26 views

Solr Computed Index field in Sitecore SXA Search Result rendering variant [duplicate]

Is there any way to render computed index field of solr using Search Result rendering variant in Sitecore SXA 1.9?
0
votes
0answers
123 views

Adding a new Site under a Tenant fails with message “Something went wrong. See SPE logs for more details.”

I've install Vanilla Sitecore 9.1.1 with Commerce 9.1 and SXA 1.8.1. I tried to create and new Site under a new Tenant. It gives me the following error: I dug into the logs and found this: 5656 16:...
0
votes
0answers
22 views

Adding a custom Button to the sxa-storefront delivery page

I'm trying to add a custom action method to customize the SXA-Storefront. I'm using the CheckoutController of the Sitecore.Commerce.XA.Feature.Cart while I make an ajax call to my custom Controller ...
0
votes
1answer
62 views

SXA search suggest throws error 500

I'm trying to implement the Sitecore SXA auto suggest search functionality, below is the setup <searchComponent name="suggest" class="solr.SuggestComponent"> <lst name="suggester"> &...
2
votes
1answer
183 views

Sitecore Dictionary Labels in SXA Rendering Variants?

How do I make use of Sitecore Dictionary Labels in SXA Rendering Variants? I want the CTA Text to come from Dictionary. It will have two texts namely "View More" and "View Less" in 3 languages.
1
vote
0answers
57 views

Sitecore SXA “ServiceLocator.ServiceProvider.GetService” [closed]

I'm following this guide to build a simple rendering. https://doc.sitecore.com/developers/sxa/17/sitecore-experience-accelerator/en/walkthrough--building-a-simple-rendering.html When I'm trying to ...
2
votes
1answer
72 views

Clone SXA OOB component javascript

I am using Sitecore 9.1 and SXA 1.8, I need to clone "component-search-results-count.js" in base theme to extend some functionality to the OOB "Search Result Count" component. How can I do that?
2
votes
1answer
99 views

Error in RenderingVariantCacheClearer after publishing page with custom Rendering Variants component

My goal is to set up a custom rendering. But I'm running into this error after publishing. I'm not sure where to look for the problem as I'm quite new. Is this a controller error or am I registering ...
0
votes
0answers
40 views

SXA Creative Exchange SASS Compilation Error

Have a blank Sitecore 9 sandbox setup running SXA 1.7 & a new custom theme. Exported and began setting up Creative Exchange. However, I get this error every time and SASS won't compile: Error ...
0
votes
1answer
71 views

SXA drop down filters reset button not working

I'm using in one page 3 SXA drop down filters (category, services, activity), search result and a reset button that clears the filters in the bellow script: function forceReset(){ if ($xa(".clear-...
0
votes
1answer
45 views

FuzzyLookupFactory is not working with Arabic words

I'm using Sitecore 9.1 and SXA 1.8, I'm using FuzzyLookupFactory for my suggester, and this is the configuration: <searchComponent name="suggest" class="solr.SuggestComponent"> <lst ...
6
votes
1answer
86 views

Remove inline style from sxa image tag in sitecore

I created rendering variant and inserted field like that: and the image rendered as : <img src="/master-site/-/media/Project/ADGEs/Master-Site/Register-Icon.svg" alt="" style="margin: 0px 0px;...
0
votes
0answers
64 views

SXA Multiple facets field name is not working

I'm using Sitecore 9.1 and SXA 1.8, I'm using search facet for sorting, I want to sort by three fields, I wrote the names of the fields lower case and comma-separated at the Facet Field Name as ...
0
votes
1answer
237 views

What are the Pros and Cons of using SXA? [duplicate]

The company I work for has purchased Sitecore XP1, and we will be basically starting from scratch to get all of our sites into Sitecore. I have been told that SXA is already included in our package, ...
1
vote
1answer
143 views

SXA Search functionality works only with the whole search query

I'm using Sitecore 9.1 and SXA 1.8, I implemented search functionality using Search box and Search results OOB SXA components, When I search with a sentence, it only returns the exact match for the ...
2
votes
1answer
66 views

SxaTags not rendering in Rendering Variants

I'm trying to render SxaTags through Reference in Rendering Variants but it won't render in the front end. I'm trying this in a component that is cloned from the existing Promo component. Sitecore ...
5
votes
1answer
45 views

Can you add the same rendering to multiple SXA Cache Settings items

Is it supported to add the same rendering to two (or more) different cache settings items? Currently, there is no warning if you do so, but I'm unsure if this is a valid thing to do or not?
2
votes
0answers
89 views

Workflow is being assigned to datasource items that don't have an initial workflow assigned

I have added some SXA components to the page (say I have added a linklist SXA component to the Home item). I have also added the workflow to different Sitecore items (Home item is assigned a workflow ...
1
vote
1answer
300 views

After upgrading to Sitecore 9.2 and SXA 1.9, why is Personalization is failing on all renderings?

After upgrading to Sitecore to 9.2 and SXA 1.9, personalisation on all renderings started to fail. When the page loads for the first time, the item is rendered as expected, however, any subsequent ...
1
vote
1answer
247 views

Image src attribute stripped from Responsive Image

I have an issue where the src attribute suddenly is missing from img tags when using the built in Responsive Image in SXA 1.9 on Sitecore 9.2. However the alt, srcset and sizes attribute works as ...
0
votes
1answer
153 views

After installation Sitecore 9.2 with SXA not able to create JSS Tenant and site

I have installed Sitecore 9.2 with supported SXA on my local environment, but not able to create JSS Tenant as describe in Sitecore help document. When we logged-in sitecore I can see the only Tenant ...
2
votes
1answer
149 views

Get Link Description in Variant

I am using SXA 1.9 I have a rendering variant that uses a plain old General Link. I can render the Link including description, but I need the link description on a different place in my variant, I did ...
1
vote
1answer
86 views

How to implement SXA Authentication in selected pages?

I am trying to enable login feature for selected pages in SXA site using existing header and footer components. There is an existing header component with option like a,b,c. I need to add login ...
3
votes
3answers
781 views

What is the fix for solr error 'undefined field _indexname' after building custom index in sitecore (v9.1.0)?

I created a new custom index named CUSTOM_SERVICES_INDEX using this command: C:\solr\solr-7.2.1\bin>solr.cmd create -c [custom index name] (cmd as administrator) then I created the config file ...
1
vote
1answer
294 views

How to add favicon (.ico) file for a site in Sitecore SXA

We are using sitecore 9.0 and SXA 1.8.1 We want to add a favicon for our site. There is an option available in the path /sitecore/content/Tenant/Site/Settings to upload the favicon, but when I try ...
0
votes
1answer
71 views

Trying to display the custom marker icon on the map component

I'm trying to display custom marker icon on the map component. However I see the default icon getting displayed on the map. Here's the detail that I have in sitecore Created a POI Type "A" (POI Icon ...
0
votes
1answer
68 views

Can I disable web editing of a Rendering Variant Reference field/Field

Is it possible within SXA to prevent web editing of a particular field? ie. I don't want them editing the value of the field highlighted below in Experience Editor, only in Content Editor. I did ...
1
vote
1answer
107 views

SXA Page List Item Css class field purpose

So when I created a new rendering variant for Page List I noticed there was an Item CSS class field. I expected this would add a class to my li elements of article-item but it does not. Is a Page ...
0
votes
0answers
38 views

SXA Map throwing 400 Bad Request

Working with Sitecore 9 (Update 1), SXA 1.7.1 and Azure Search. Components added on the page: Map, Location Finder, Search Results (all components have the same search signature). Search Query: ...
0
votes
0answers
25 views

Datefilter doesn't work when “from” and “to” dates are set to the same day

I'm using Sitecore 9.1.1 and SXA 1.8.1. I'm using the SXA datefilter component with the search result. I'm facing a problem that when I search with the same date in the from and to fields of the ...
1
vote
0answers
75 views

How do I get my SSR proxy to site resolve the LayoutService for my JSS/SXA Site?

We're on Sitecore 9.2, SXA 1.9, JSS 12. previously On 9.1, we had the following setup: JSS App sitting in /sitecore/content/myapp A site definition that mapped a hostName to our /myapp A JSS ...
3
votes
2answers
549 views

SXA Value cannot be null. Parameter name: siteInfo

I have installed sitecore commerce on my local machine.I have also added Tenant and SXA Site. Everything worked fine until i encountered with an issue when i click on the site, i am getting the ...
0
votes
1answer
45 views

Need to access search keyword in a custom rendering controller in SXA

We are using SXA 1.8 with Sitecore 9. And, we have the requirement to access the search keyword passed in the search-box in one of the custom-renderings. But unfortunately, SXA is appending the search ...
7
votes
1answer
407 views

How do I improve my SXA sites Google PageSpeed Insights Score?

Our client would like us to aim/achieve a particular Google PageSpeed Insights score. In particular, a score equal to or above 80/100 (mobile score) would be ideal. We are building the site with ...
2
votes
3answers
341 views

Install module on CD Could not find configuration node: databases/database[@id='master']

I am working on scaled installation of sitecore 9 update 2.On CD server, i needed to install the SXA module, for doing that i was suggested to use CD as CM by adding the "master connection string" in ...
0
votes
1answer
82 views

Create No Access Page for multi site

I am using sitecore 9.1 with SXA 1.8 , Is there a way to have access denied page for each site in SXA?
0
votes
1answer
110 views

SXA Component not appearing on published site on mobile devices

I'm using Sitecore 9.1.1 and SXA 1.8.1. I have a cloned component for the header of my site. This header component is added to the "Header" placeholder and its rendering variant contains a number of ...
1
vote
1answer
284 views

How to add SXA license to Sitecore instance?

I am newbie to Sitecore. I have Sitecore Experience Platform running on my development machine. I need to set up Sitecore Experience Accelerator for this instance. I have installed required packages ...

1 2 3
4
5
18