Questions tagged [xconnect]

For questions related to xConnect, the API service layer abstracting the storage architecture of xDB from those accessing xDB data.

Filter by
Sorted by
Tagged with
1
vote
2answers
34 views

How to get a contact with custom facet?

I am trying to get a sitecore contact with the custom facet. The custom facet is working fine I have verified it. The following code is running fine on Standalone and CM environment, but is throwing ...
0
votes
1answer
40 views

How do you add a sitecore contact in CM environment

I am using the below code to add a Sitecore contact which works fine in my Standalone environment but is causing issue on CM environment as the contact is coming null. Tracker.Current.Session....
1
vote
1answer
52 views

How do you properly query xdb for a contact by email?

I am trying to search an email in Sitecore Xdb using the code : var queryable = client.Contacts .Where(c => c.GetFacet<EmailAddressList>(EmailAddressList....
0
votes
1answer
35 views

XConnect: An error occured during resuming a previous index rebuild process

Does anyone have an idea about what could be causing this error? It happens after doing a re-build of the XConnect index. This is in Sitecore 9.3 2020-03-30 20:11:02.896 -05:00 [Error] An error ...
3
votes
0answers
66 views

xDB not tracking Custom Facet

Version: Sitecore 9.2 I have followed these tutorials: - https://himmatsinghdulawat.blogspot.com/2019/06/create-custom-facet-model-in-sitecore-9.html - How to properly configure a custom facet in ...
0
votes
0answers
23 views

How do I get SiteName populated for WebView facets?

I have CD server data getting collected by XConnect collection, but when it's serialized and saved to a shard, the WebView FacetData JSON is missing SearchKeywords and SiteName. Since SiteName is ...
1
vote
0answers
44 views

Can not start xConnect Index Worker during Sc 9.3 XP0 local installation - FormatException

During the SC 9.3 installation (XP0 local) via SIF and SIA I receive this cannot-start-service error at the last third of the installation: [--------------------------- XConnectXP0_StartServices [1] :...
0
votes
0answers
29 views

XDB: An error occurred when trying to create a controller of type 'DeviceProfilesController'

Using Sitecore 9.2 and SXA, XDB is giving us this error in the logs and is not recording data. XDB is enabled and the xconnect default.aspx page is viewable in a browser. Any ideas? Message: xDB ...
0
votes
0answers
40 views

Segmented lists - problem with rules

has anyone of you already worked with segmented lists? We have the problem that sometimes the rules are executed and sometimes not. We implemented a custom rule, which checks values in a custom ...
1
vote
1answer
36 views

How to programmatically trigger a goal to contact and then retrieve it in the same visit and in later visits

I want to trigger a goal programmatically to the website visitor/contact and retrieve this triggered goal during the contact's current visit and in his future visits. I could trigger the goal of using ...
1
vote
1answer
97 views

Sitecore 930 installation issue with parameter name Credential

I'm trying to install Sitecore 9.3.0 using SIA: https://tothecore.sk/2019/11/28/installing-sitecore-9-3-using-sitecore-install-assistant-sia/ and I keep getting this error: [------------ ...
1
vote
0answers
15 views

“Parent context is required for this entity type” when querying for Contact Interactions on xConnect OData

We are using Microsoft Power BI to mine into xConnect OData. We are interested, among other things, in the Interactions of our contacts. However, Power BI generates requests that cannot be fulfilled ...
0
votes
1answer
43 views

Sitecore 9.1 custom facets

I am upgrading my Sitecore 8.2 code to work with Sitecore 9.1 WE have custom facets and few custom facets have collection field like below code. public IElementCollection<IJobPreferenceElement&...
2
votes
0answers
117 views

Migrate SQL Database to xConnect

Environment: Sitecore 9.2.0 and Data Exchange Framework 3.0 I want to import the data from SQL Database to xConnect using the Data Exchange Framework. SQL DB has a table called Users which contains ...
0
votes
1answer
56 views

How to set profile values for a website visitor programmatically

Using Sitecore 9.1 I need to add profile values programmatically to a profile created under Marketing Control Panel. Once this is achieved, the idea is to use it for personalization by setting up ...
1
vote
2answers
31 views

Create the contact in XDB without Session.Abandon and save Engagement, behavior ,Interaction facets

What would be the best practice to save the Contact in XDB, At present if "Contact" not exists in XDB (validating by phone + email) and it submit the "Contact-us-Form" then I am using Session....
0
votes
1answer
111 views

XConnect Indexworker Solr error: parentFilter=filterCondition

I am running an out-of-the-box XP 9.3 installation (using the Sitecore Community Docker images) and get the following Solr related error in the XConnect Indexworker: 2020-01-27 15:27:38.096 +01:00 [...
0
votes
0answers
86 views

CPU spikes to 100%

Often getting the below error from my log files. Every time this error occurs the CPU spikes from 93% to 100%. Searched for the fixes and workaround but couldn't find any solution. After recycling ...
0
votes
1answer
32 views

Unable to create xDB contact on CM server

I am unable to create a contact in xDB in a scaled CM server with the below code, whereas the same code is working on the dev Server. I believe Sitecore.Analytics.Tracker.Current.Session.IdentifyAs ...
1
vote
0answers
33 views

Weird experience with Analytics with Sitecore 9.0.1 on Azure PaaS

We are having a weird experience with Analytics with Sitecore 9.0.1 on Azure PaaS. Looks like the data is being processed on a single date hence we are seeing more than 20K visits on Nov-21. Whereas ...
0
votes
1answer
32 views

xDB Data Migration Tool Error

I'm using xDB Data Migration Tool 2.0 to migrate data from MongoDB (Sitecore 8.2) to xconnect (Sitecore 9.0.2). The tool runs without errors for around 60k records. Then it breaks with Errors like ...
1
vote
0answers
34 views

XConnect Serilog Replacement

Our in house shop uses a homegrown logging library to centralize all of our application logs for reporting, searching, and support. XConnect comes equip with the Serilog out of box. Is there a way to ...
1
vote
1answer
103 views

Xdb.Collection.Shard0 Login failed for user

I have a Sitecore 9.3 instance. I installed on my local machine. After install, I moved my SQL databases to a server. I updated the connection strings and Sitecore itself is working fine. XConnect ...
0
votes
2answers
95 views

The HTTP response was not successful: InternalServerError

We are getting below error in sitecore 9.0.2 version on cd environment for getting interactions from xdb using xconnect In connectionstring for CD below entry was there <add name="xconnect....
1
vote
3answers
65 views

Assign Goals & Events to XDB contact on Submit of Contact-US Form in SItecore 9.1

In my website I have "contact us form" and 1 goal is trigger after custom-save-action executes. When a contact fill the form I am saving its details into XDB by using email-id as identity, if record ...
0
votes
1answer
24 views

XConnect client outside of Sitecore context is not binding to custom facets

I am trying to update & query an xDB contact via the XConnect Client API from a console application. I can query and retrieve the default facets e.g. PersonalInformation.FirstName ...
0
votes
1answer
56 views

Failed to start Marketing Automation service

I've an issue in installing Sitecore 9.2 in a machine where Sitecore is getting installed for the first time. On the middle of the installation, I'm getting Failed to start Marketing Automation ...
0
votes
0answers
57 views

Sitecore XConnect, Index Worker, XdbSearchUnavailableException

I am trying to search Xdb contacts on the basis of email id. using this code : var queryable = client.Contacts.Where(c => c.GetFacet<EmailAddressList>(EmailAddressList.DefaultFacetKey)....
0
votes
1answer
51 views

Sitecore xConnect client certificates renewal

In our Sitecore 9.2 PaaS solution, we are using self-signed client certificates and have added the AppSetting AllowInvalidClientCertificates=true to all xConnect roles as well as the PRC, CD and CM ...
1
vote
2answers
64 views

Problems sending “change of email address” email using EXM

I'm writing some code that will send 2 emails (using EXM) when a user updates their email address. 1 email goes to the original email address, and the other goes to the new email address. The ...
1
vote
0answers
32 views

XConnect custom predicate: XdbSearchUnavailableException after call is being made

I'm trying to create a custom predicate to search a particular profile in a contact's profile using Sitecore 9.0.1. Here's the code: public class ContactProfilMatches : ICondition, ...
1
vote
0answers
95 views

Clean install on Azure SQL Managed instance

I am trying to install Sitecore 9.2 vanilla on Azure with SQL Managed Instance but I am getting the following error { "status": "failed", "error": { "code": "ResourceDeploymentFailure", "...
1
vote
1answer
18 views

XconnectCollection Service Throwing shard connection errors after migrating dbs to high availability cluster

We had originally configured our XP1 instance to communicate directly to a single SQL server and everything was working correctly. Before going live we update the SQL server to be part of a high ...
1
vote
1answer
59 views

Unable to receive interaction events by specific definition id

I'm unable to receive interaction events by the specific definition id using (var client = SitecoreXConnectClientConfiguration.GetClient()) { try { var events = ...
1
vote
2answers
218 views

Azure WebApp XDB apps cannot find service 'KeyStoreProviders'

I'm upgrading from 9.0.2 (XM) to 9.2 (XP), so I got a fresh install of the XDB enviroments (Azure WebApps), but my xcollect, ma-ops, xc-search (Solr), and maybe other webapps give me the You do not ...
1
vote
1answer
141 views

WebDeploy unable to deploy package

Web Deploy is unable to deploy package. I have all the prerequistes installed and have double checked that the Sitecore psgallary and Sitecore gallery are trusted repos and I am not sure why I am not ...
4
votes
1answer
76 views

XConnect `The HTTP response was not successful: Forbidden` on Azure

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make .Net core 2.2 projects published on azure app service, not on the same instance of Sitecore azure connects to XConnect, I was ...
3
votes
1answer
92 views

How to replace `CertificateHttpClientHandlerModifier` to `X509Certificate2`

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on azure app service connects to XConnect which is also on Azure, am following this link ...
2
votes
1answer
84 views

Dynamics Connect custom fields sync - “This object is already associated with another model”

I am trying to sync custom fields from Dynamics Connector 3.0.0 to xConnect (Sitecore 9.2) I have extended xConnect model with my custom facet, mapped fecet definitions, value accessor sets etc, ...
3
votes
1answer
81 views

Connecting two Azure services to access XConnect

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on app service azure connects to XConnect which is also on Azure, am following this link ...
3
votes
1answer
56 views

When should I update contact facets?

I have the following scenario: Contacts will be interacting with pages on the site that will be tagged with topics. By interacting with a page in a topic, they themselves will become tagged with being ...
2
votes
1answer
105 views

List manager doesn't show contact in manual subscription

I have a question about List manager since I stuck here for a week and half. I have made xConnect to save contacts into xDB. I checked that there are saved contacts in SQL Management, which I already ...
3
votes
0answers
38 views

Connecting .Net Core 2.2 project to XConnect in Azure Sitecore 9.2

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project connects to XConnect, am following this link from Sitecore documentation. It worked fine in the .Net ...
7
votes
2answers
100 views

Updating model of custom facet

I created a custom contact facet and deployed it. Due to certain requirements, I need to change the data type from bool to string for those facets. Do you see any challenges there? And how I can ...
3
votes
2answers
89 views

Connecting console application to XConnect in Azure Sitecore 9.2

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a console application connects to XConnect, am following this link from Sitecore documentation. In the part shown in the ...
1
vote
0answers
80 views

Integration with AD B2C: Trigger Owin challenges by policy name

We're using Sitecore.NET 9.1.0. We're trying to trigger register, login and forgot password flows from Sitecore that will be used by end users of our website. After a successful login we want to ...
1
vote
1answer
42 views

Sitecore 9.2 xConnect Console Application throwing runtime error

There is one Console application code for creating contact in xConnects in Sitecore 9.2 at https://doc.sitecore.com/developers/92/sitecore-experience-platform/en/create,-retrieve,-and-search-contact-...
3
votes
0answers
24 views

Segmented list for contacts based on outcome for users imported through xConnect client

Sitecore 9.0.2 Hi All, I am trying to add an (out-of-box) outcome to xDB for real-time users and from historical data (a csv file). For real-time users, I am using Tracker to add the outcome. The ...
4
votes
2answers
65 views

Update Outcome using xConnect client

Sitecore: 9.0.2 I am trying to update xDB for contacts with the Outcome. The source of data is from third party, so I cannot go through Tracker. I am using the following code snippet Code snippet: ...
0
votes
0answers
25 views

Sitecore Analytics not working - Sitecore 9.1 [duplicate]

Post Installation of Sitecore 9.1 I copied the Sitecore Website folder to a different location and created a new site (say local.sitecore.com) based on that folder. Sitecore Analytics is not working ...

1
2 3 4 5
7