Questions tagged [xconnect]

For questions related to xConnect, the API service layer abstracting the storage architecture of xDB from those accessing xDB data.

Filter by
Sorted by
Tagged with
2 votes
1 answer
25 views

One Certificate for all instances in XP Scaled Installation - xDB Forbidden issue

I did an on-premise setup for Sitecore 9.3 XP Scaled environment. At the time of installation I created separate certificates using createcert.json file and common xconnect certificate thumbprint for ...
0 votes
2 answers
31 views

Xconnect Error after deploying custom model on Azure

I am using Sitecore 9.1 Azure. Recently I deployed the XConnect custom model and other required files on 5 roles referring to the link https://doc.sitecore.com/xp/en/developers/100/sitecore-experience-...
1 vote
1 answer
49 views

The specified type is not a valid facet type

I am creating custom facets in Sitecore 10.2. Below steps I have performed: Created custom facets. [FacetKey(DefaultFacetKey)] [Serializable] public class CustomFacet : Facet { ...
  • 1,912
2 votes
1 answer
24 views

How to check if AlwaysEncrypted is enabled on a Sitecore Collection Shards DB?

We would like to know whether AlwaysEncrypted feature is ON/OFF for our Collection shards DB in Sitecore. We are working on the Upgrade to 10.2
  • 153
1 vote
1 answer
52 views

Creating a personalization rule based on user LastLogin date

I have a requirement to create a personalization rule to change the rendering display based on whether the user is First Time user or New User. The first-time user will be decided if the users last ...
  • 427
0 votes
2 answers
31 views

Getting license error when running the command "Sitecore.XConnectSearchIndexer.exe -rr"

When we are trying to run the command Sitecore.XConnectSearchIndexer.exe -rr in the XC search indexer, we are getting the license missing error. We already placed the partner license which is already ...
  • 153
0 votes
1 answer
85 views

Sitecore 9.3 installation error Sitecore.XConnect.XdbCollectionUnavailableException System.Net.Sockets.SocketException

I am trying to install Sitecore 9.3 but getting below error Then I tried to view the complete error by executing Sitecore.MAEngine.exe, this gives the below error Error initializing XConnect client. ...
0 votes
0 answers
11 views

Sync Marketing List from Sitecore to CRM using Dynamic CRM Connector Module in Sitecore

I am working on Sitecore 10.2 and I have installed Sitecore Connect™ for Microsoft Dynamics 365 for Sales 7.0.0. Below is my requirement: Sync marketing list from CRM to Sitecore (I have checked in ...
  • 1,912
1 vote
1 answer
30 views

Data distribution between shards unequal

We're currently using Sitecore 10.0.1 with xConnect enabled on Azure PaaS. We have set up two shards DB, shard0 & shard1. Recently we have observed that data distribution between those DBs is ...
0 votes
0 answers
15 views

XDB Shard Databases in Azure Failover Group

Our client has a requirement for two copies of data. Can the shard databases be in an Azure failover group? First attempt, back up the original databases, then restore them to the primary and ...
0 votes
1 answer
44 views

How to configure Serilog filters in xConnect?

I would like to filter out some messages from being logged in xConnect - for example 'Failed to locate activity...'. I have tried this configuration but it does not seem to take effect: <Settings&...
  • 4,981
2 votes
3 answers
63 views

Contact is null

I am working on Sitecore 10.2 and trying to update facets in xDB. The below function is working fine on local but it is not working on VM. xDB is enabled on Sitecore instance. public bool ...
  • 1,912
0 votes
1 answer
45 views

Interactions not saving to xdb when processing custom events?

In my SC 9.3 solution I have a custom page event that I am firing, converting, and wanting to store in xdb. When I debug the code: I can see the events getting registered as expected I can inspect ...
0 votes
1 answer
23 views

Where to fire a custom XConnect event on page load?

I have a case where I want to fire a custom page event but only for a specific page template. This means that whichever pipeline I fire the event from, I need access to: Current page's template ID OR ...
0 votes
1 answer
45 views

Sitecore 10.1.1 installation issue - failed to start service 'Sitecore xconnect search indexer'

I have failed to install Sitecore 10.1.1 on my local. I've tried giving full permission to users. The license I believe is okay as well. There are the logs from the event viewer. Did anyone encounter ...
  • 1
0 votes
1 answer
43 views

How to store full URLs in page view events instead of just the path?

I have a case where I need page view events to store full URLs in the Url property instead of just the paths. For example, if I explore the Interactions table, inside the Events column, PageViewEvents ...
0 votes
2 answers
67 views

The HTTP response was not successful: NotFound

I searched from the whole site while I didn't find this topic yet... During the installation, we met this exception and failed. Can anybody help us with this issue? Huge thanks in advance! [Error] ...
0 votes
0 answers
23 views

Facets are not loaded correctly in Session after multiplies updates

I am using Sitecore 10.2, I have a scenario where user can update his contact data. I can confirm that data is getting saved in XDB. But in code when I remove the contact data from session and ...
  • 767
0 votes
1 answer
49 views

SC 10.2 Exception when trying to view xdb data on local installation, Invalid column name 'Converted'

I installed a local instance on Sitecore 10.2 using SIA, and I performed the upgrade scripts on the Core, master, and web databases, since it is a local instance I didn't really care about the ...
  • 501
0 votes
1 answer
87 views

SItecore Marketing automation is not working for OOB email opened event

I have created a Marketing Automation campaign and selected Send Email action for contacts. Post this action, I am adding a listener for 3 minutes where I have added a rule "Where contact opened ...
1 vote
1 answer
31 views

Sitecore 10.2 salesforce xConnect Client Endpoint [closed]

I am trying to connect Sitecore to salesfore during xConnect Client Endpoint I am getting this error I have given this following details also I tried to browse xconncet.dev.local from IIS in browser ...
  • 17
0 votes
0 answers
24 views

Searching for events of custom model type in XConnect

I have cloned this repo and updated it to run with Sitecore 10.1 (which is our current version): https://github.com/adeneys/cortex-processing-demo The above application has functionality to create a ...
0 votes
1 answer
41 views

Sitecore Marketing Automation Service is failing many times

Sitecore Marketing Automation Service is failing many times and a lot of certificates are getting generated. If we move this certificate and in IIS if we select another certificate and then again ...
0 votes
0 answers
35 views

How to populate "Other" facet property on xConnect Contact using the Data Exchange Framework?

I have a case where my xConnect contacts have multiple email addresses, phone numbers, and addresses in my xConnect contact. This question will focus on emails. This is a 9.3 install with DEF and ...
1 vote
2 answers
39 views

Non prod environments can share Common Service such as Xconnect and Processing

We have a 10 non production System Integration test environments. Right now we have common shared Solr server. Likewise Is it possible to have shared Xconnect and Processing Webapps for multiple non ...
0 votes
2 answers
77 views

How to retrieve Contact created date

I'm using Sitecore 9.1 update 1. When retrieving contacts via IAsyncQueryable<Contact> queryable = client.Contacts I don't see the created date of the contact. How can I programmatically get the ...
  • 85
0 votes
0 answers
83 views

Sitecore 8.x MongoDB Migration to 10.x using xDB Data Migration Tool 5.0.0

I tried a POC on Analytics DB migration from MongoDB to Connect using Sitecore_xDB_Data_Migration_Tool 5.0.0 for Sitecore 8.2 to Sitecore 10.x. I followed installation guide from below url https://dev....
3 votes
1 answer
238 views

XConnect Error While Sending The Request

I have installed a clean version of Sitecore XP0 of my local development machine and the logs are showing the following error: ManagedPoolThread #14 14:21:35 INFO Job ended: Sitecore.ListManagement....
0 votes
0 answers
89 views

Path Analyzer Error Sitecore.ContentTesting.Rules.Conditions.EntryPageCondition

We have upgraded to Sitecore 10.1 from Sitecore 8.2. We am getting the following error. ERROR [Path Analyzer] Error during aggregation. Exception: Sitecore.XConnect.Segmentation.ExpressionBuilder....
0 votes
1 answer
67 views

Experience Profile 403 error

The Experience Profile shows the correct data with no console errors when I logged into Sitecore for the first time but refreshing the page gives the error An error has occurred. The only way to see ...
4 votes
3 answers
215 views

Custom facet from a contact is coming null but when creating a new one Sitecore is complaining that the facet already exists

I'm trying to write a .aspx script to update an existing contact in the experience profile, the basic logic is: get the contact by e-mail get a custom facet from the contact if the facet is null ...
0 votes
1 answer
218 views

Local sitecore instance SSL certs expired

Sorry, this seems more simple than I am making it to be but I am just running into multiple errors after reading and trying multiple articles. So after my initial installation of Sitecore, my certs ...
0 votes
1 answer
73 views

How to implementing keyword search with xconnect contact facet search?

I am using Sitecore 10 and trying to implement keyword search with xConnect contact. I want to search for contacts that have email or phone number that contains the inputted keyword. Below is my ...
2 votes
1 answer
144 views

Very high xDB search indexer memory and out of memory crash

Recently my xDB search indexer service (XConnectSearchIndexer.exe) has been using all the server RAM and half the CPU until it runs out of memory crashes. It restarts and immediately starts to consume ...
0 votes
0 answers
24 views

Contacts in List Manager gets replaced by new ones in Sitecore 10.1.0

I followed the below documentation and added a custom submit action in Sitecore 10.1.0. https://doc.sitecore.com/xp/en/developers/93/sitecore-experience-manager/walkthrough--creating-a-custom-submit-...
  • 1
0 votes
0 answers
27 views

SC_Analytics_Cookie is the same for all users

I am using Sitecore 10.1 and when I try to access the published site all the analytics cookies in different browsers/ machines map to the same user. Any clue how to trouble shoot this issue?
  • 767
0 votes
0 answers
17 views

Do Pattern Cards work fine when my Sitecore page is being consumed as a HTML output

I have a headless implementation and my Site pages are loaded via a GET request to my Sitecore site which provides output as HTML to my client code. Is it possible for pattern cards and profile cards ...
0 votes
0 answers
40 views

Sitecore 9.3 install failed with XConnect search indexer service failing to start [duplicate]

Running into a major headache and roadblock I have been googling for a while. It looks like the other questions have different errors, and the closest one said it was a license expiration date issue, ...
0 votes
0 answers
19 views

Reloading Contact Facets In Session

I am using Sitecore 10.2, and i have a scenario where that facet is updated upon certain action from the user so i have followed the below documentation to update the user facet in database and in ...
  • 767
1 vote
0 answers
50 views

How do I track contacts and see their visits upon registering to my site?

This is the method I have to register a Contact and their facets to the xDb (I have also registered some of my personal facets). However upon registering, my known contacts visits and visit duration ...
2 votes
3 answers
76 views

Sitecore 10.1 standalone instance always brings 0 interactions

I've tried this code, taken almost directly from sitecore documentation (they are using Goal, I'm using PageViewEvent). var itemId = <some id of an Item in content>; using (var ...
1 vote
1 answer
1k views

Sitecore 10 Installation Error: Failed to Start Service 'Sitecore Marketing Automation Engine' while an instance of 9.0.2 also running on my system

Note: I have multiple Solr installed on my local environment one is for the previous version and now I have added Solr for Sitecore 10 on port 8984 So my Solr path for the Sitecore 10 is https://...
0 votes
0 answers
55 views

xconnect collections fails with invalid operation

I'm experiencing problems with sitecore experience analytics for sitecore 9.1. From my site log (see log1) I can see that analytics is trying to send data to xconnect, however xconnect is not ...
0 votes
1 answer
79 views

Performance issue on page load Sitecore.Analytics BLOCKED_TIME

Background of Infra/Software: Sitecore Product Version: 9.2 Sitecore XP Scaled topology used. Infrastructure Type: Azure App Service / PaaS inside Isolated ASE Issue: Experiencing slowness in Page ...
0 votes
1 answer
70 views

AllowInvalidCertificates error after turning on XDB

After turning on XDB in a Docker installation after upgrading from 9.0 u2 to 10.1.1. I get the following error. XDB works fine in a vanilla install using the same license. Any ideas?
  • 705
0 votes
0 answers
156 views

Login failure for collection user after migrating to Azure SQL

"login failed for collectionuser" errors appear after migrating our Sitecore 10.1.1 databases from self-hosted SQL Server on VM to Azure SQL Database. The site itself is working, but ...
1 vote
1 answer
86 views

Sitecore Collection databases not created in Prod xConnect Set up using SIF

While we are doing xConnect Prod set up, identified that following collection DBs are not created post SIF script execution. Missed collection DBs: 1.Xdb.Collection.Shard0 2.Xdb.Collection.Shard1 3....
  • 107
0 votes
0 answers
39 views

Sitecore Commit Session Pipeline for Sitecore 9.2

There is a requirement from one of the client to capture the live analytics data to extent the Sitecore commit session pipeline. I was analyzing the showconfig.aspx of 9.2 and found the following ...
  • 1
0 votes
0 answers
87 views

How can I get UploadedFile (upload from out of box Sitecore Form) Blob / fileContent?

How can I retrieve Filecontent from [sitecore_forms_filestorage].[FileStorage] based on id value? I tried the below code, but got a "_fileStorageProvider is null" error. Guid fieldid = Guid....
2 votes
2 answers
76 views

Set the value of custom Xdb field on custom Sitecore 9 form custom button click

I have created a Sitecore 9 form with a custom button as shown below: On click of this "Subscribe" button I am saving the email of the contact in Xdb (Experience profile). Also, I have ...

1
2 3 4 5
10