Skip to main content

Questions tagged [xconnect]

For questions related to xConnect, the API service layer abstracting the storage architecture of xDB from those accessing xDB data.

Filter by
Sorted by
Tagged with
17 votes
9 answers
24k views

xConnect The HTTP response was not successful: Unauthorized

I'm trying to initialize a connection between a .NET Core application and an xConnect installation. I ran into the following error: An unhandled exception of type 'Sitecore.XConnect....
mark DE Jong's user avatar
  • 1,001
3 votes
9 answers
11k views

Sitecore 9.3 Installation failing - 'Failed to start the Marketing Automation Engine service

I am trying to set up Sitecore 9.3 XP0 locally in a VM using SIA and it is failing at Step 67 of 92 with an error failed to start the marketing Automation Engine Service. System....
Deepak's user avatar
  • 41
22 votes
6 answers
7k views

The HTTP response was not successful: Forbidden

I have tried Sitecore 9 update 1 installation on my local Windows 10 and encountered this error: Exception: Sitecore.XConnect.XdbCollectionUnavailableException Message: The HTTP response was not ...
Helen P's user avatar
  • 221
17 votes
2 answers
2k views

Issues with XConnect certificate does not contain Private Key

I have a Windows Server 2016, SIF and Sitecore Fundamentals installed where I am trying to provision a Sitecore 9 XP1 Here is the error I am seeing CERT:\LocalMachine\My\...
Vinicius Deschamps's user avatar
14 votes
3 answers
5k views

Issue with Sitecore 9 certificate missing private key

Trying my best to get my Sitecore 9 instance running on Windows 8.1 with IIS 8.5. As mentioned in Sitecore guide, I am noticing lot of issues while installation. After solving a few of them, I ended ...
phani's user avatar
  • 804
5 votes
1 answer
3k views

xConnect WebApps on Azure PaaS not working

I installed the vanilla Sitecore 9.0 version from Marketplace on Azure PaaS with XP and extra small configuration and select the option self signed certificate for xConnect client certificate, but ...
Ashish Bansal's user avatar
11 votes
6 answers
14k views

Failed to start service Sitecore XConnect Search Indexer when installing Sitecore 9

While running SIF to install 9.0.1 the powershell script stops during the Install-SitecoreConfiguration @xconnectParams step which deploys the xConnect instance giving the following exception. ...
Jonathan Robbins's user avatar
10 votes
1 answer
856 views

How best can you scale xConnect to handle high traffic?

This is a follow on from questions about how best to get data out of xConnect (What is the preferable way to get contact information out of xConnect and to a consumer?) How should you approach ...
boro2g's user avatar
  • 575
9 votes
2 answers
413 views

Any Guidelines to choose between SQL or Mongo for xDB on Sitecore 9?

Want to check if we have any guidelines (metrics) helpful to decide either Mongo or SQL will be good fit while Upgrading to Sitecore 9, especially if the current version in below 7.5 (No Mongo). ...
Amitabh Vyas's user avatar
  • 2,554
7 votes
1 answer
293 views

What is the Identifier Source of a Contact After Upgrading to 9 / xConnect?

In Sitecore 8.x, when a contact is identified, it's done so just on a single string like an email address or username. In Sitecore 9.x (more specifically xConnect) when a contact is identified, there ...
Pete Navarra's user avatar
  • 14.7k
6 votes
2 answers
1k views

Getting list of contacts assigned to Contact / Segmened List in Sitecore 9.0.1 programatically

We are trying to get list of contacts programmatically in latest Sitecore 9.0.1. We want to show list of contacts on pages based on their linkage to certain list. We need to get the same list of ...
Peter Procházka's user avatar
5 votes
1 answer
341 views

Talking to xConnect in .Net vs .NetCore

Sitecore 9.1 .NetCore 2.1 .Net 4.7.1 Below you will find the hello world console app code to talk to xConnect. You pass it a thumbprint and a url and it will try to initialize a connection. The only ...
Chris Auer's user avatar
  • 13.1k
5 votes
1 answer
3k views

How to check whether my license file supports Sitecore 9 and xConnect

I am trying to install Sitecore 9 on my Windows 10 machine. I came across many issues during installation. Finally i stuck at almost last step where installation script tried to start xConnect service ...
Arvind Gehlot's user avatar
5 votes
2 answers
8k views

Troubleshooting "Could not create SSL/TLS secure channel" error in XConnect on Sitecore 9.1

I have a freshly-created Sitecore 9.1 instance. After setting up the xDB Migration Tool, I get the following error message when running the Troubleshooter: ERROR [Data Exchange] at Sitecore.Xdb....
Emanuele Ciriachi's user avatar
5 votes
3 answers
8k views

HTTP Error 403.16 - Forbidden- Sitecore xConnect

I installed Sitecore 9 for xP0 , but I'm facing an issue with xConnect I tried to Open the web https://sitecorexp1.xconnect and I see an error HTTP Error 403.16 - Forbidden Your client certificate is ...
saurabhb's user avatar
4 votes
4 answers
8k views

"Could not deploy package" error while installing Sitecore 9 update 2 setup on Remote server

I am facing below issue while installing Sitecore 9 update 2 on my Azure VM server, which doesn’t have any Visual Studio or SQL Management Studio installed. Error states : Microsoft.Data.Tools.Schema....
Abhishek's user avatar
  • 153
3 votes
1 answer
315 views

How to replace `CertificateHttpClientHandlerModifier` to `X509Certificate2`

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on azure app service connects to XConnect which is also on Azure, am following this link ...
Fatema elsayed's user avatar
2 votes
2 answers
812 views

Sitecore installation error - Dacpac file path: Instance failure. System.InvalidOperationException:

I'm trying to install Sitecore v9.1 update 1 with Sitecore SIF. I did install all the prerequisites. Everything looks fine. Also the script does install 7 databases (like MarketingAutomation, ...
Ercan Polat's user avatar
1 vote
1 answer
690 views

List Manager not indexing contacts after CSV import

I am using EXM, and trying to upload contacts via List Manager. After uploading csv I found that recipients are still 0 so I opened log file and I found some Exceptions like that and I would like if ...
Mariam Nasr's user avatar
0 votes
1 answer
682 views

Install xConnect Separately with Sitecore upgrade

I am looking to install xConnect only through SIF with 9.1.1. I am upgrading from Sitecore 8.2 so didn't had any preexisting xConnect setup. Following the upgrade process from Sitecore which says ...
Arun Kumar's user avatar
0 votes
1 answer
884 views

A parameter cannot be found that matches parameter name 'CertificateName'

I am trying to install Sitecore 9.0.2 in the local but when I try to install it using PS script I get below error (in screenshot) in the starting itself while running the command Install-...
Jumping Rabbit's user avatar
13 votes
2 answers
3k views

XConnect IndexWorker error "Tokens are incompatible, they have different set of shards."

The log for my IndexWorker is filling up with the following error: Tokens are incompatible, they have different set of shards Any ideas what might be causing this?
Richard Szalay's user avatar
12 votes
1 answer
2k views

Display custom facets in Sitecore Experience Profile version 9 or later

I am creating custom facet for saving contact information (Like Car Model, Variant, Color, etc) into XDB. I am successfully able to save and retrieve custom facets details with respective Contact. Now ...
Himmat Singh Dulawat's user avatar
12 votes
2 answers
3k views

Can I call the oData service directly in xConnect?

I've been playing round with Sitecore 9 recently and the xConnect api and had a question around oData. Underneath the api layer there is an oData service that can be reached via: https://...
Ian Graham's user avatar
  • 1,033
8 votes
3 answers
5k views

Getting exception "Sync token is no longer valid for [Contacts] / [Interactions] table" with xConnect Search Indexer

I had some trouble with xConnect at the beginning after I have installed Sitecore 9 Update 2. I had trouble with Sitecore xConnect Search Indexer Windows service particularly. It was a configuration ...
Peter Procházka's user avatar
7 votes
5 answers
804 views

Single contact showing in Sitecore Experience Profile

I've created an xConnect client API for Sitecore 9 that creates new contacts and sets the facet properties. I've added multiple contacts to xDB, however only one contact has shown in the Experience ...
Samir Ahran's user avatar
7 votes
1 answer
4k views

Experience Analytics fails on Sitecore 9.0.1

I am having trouble configuring the analytics engine on Sitecore 9 with a pretty standard install of Sitecore XP1. I'm using the self-signed certificates and none of the analytics graphs display ...
Ree-beck's user avatar
6 votes
1 answer
813 views

xConnect contact search by preferred email

Here is my code for searching contact by preferred mail. using (XConnectClient client = SitecoreXConnectClientConfiguration.GetClient()) { try { var queryable = client.Contacts ...
Anik Saha's user avatar
  • 475
6 votes
1 answer
747 views

Sitecore EXM insert Custom tokens issue

I am using Sitecore 9.0.1 and I am trying to insert custom tokens to email in EXM. I followed Sitecore's documentation and spent hours investigating possible solutions but somehow my tokens did not ...
Senad M.'s user avatar
6 votes
1 answer
599 views

Patching xConnect, AutomationEngine, IndexWorker configuration

Is there a way to patch xConnect, AutomationEngine, IndexWorker configuration in a way we do it for sitecore instance? I.e. configuration that resides in xConnect instance folders: \App_data\config\...
lebeg's user avatar
  • 475
6 votes
2 answers
2k views

ERROR Cannot start analytics Tracker

I get below error in Content Delivery Environment in Sitecore 9.0.2 11284 11:00:12 ERROR Cannot start analytics Tracker Exception: System.Net.Http.HttpRequestException Message: An error occurred ...
Ayyappan Krishnamoorthy's user avatar
6 votes
2 answers
5k views

Sitecore 9 Installation error "Failed to start service 'Sitecore xConnect Search Indexer"

I am trying to install Sitecore 9 in my Windows 10 box. At first attempt, it was failed with this exception. Failed to start service 'Sitecore xConnect Search Indexer' I got the one answer for ...
Arvind Gehlot's user avatar
5 votes
1 answer
169 views

Is there an automatic way to migrate engagement plans to marketing automation plans?

This question prompted when I was answering an Engagement Plans question. I couldn't find an answer anywhere nor an explicit mention that Marketing Automation Plans are essentially replacing ...
Marco's user avatar
  • 1,005
4 votes
2 answers
2k views

How to programatically add contact to a contact list in Sitecore 9.0u1

I need to programmatically add contact to a contact list. How to do this in Sitecore 9.0.1? I find a documentation. Here it says this below line will add contact to a list. Contact contact = ...
Anik Saha's user avatar
  • 475
4 votes
1 answer
523 views

Difference between xConnect model versions

I've deployed 2 versions of a custom xConnect model I created called DetailModel. According to the documentation, the xConnect models' unique name is name of model + version. The model’s full name (...
Koen Heye's user avatar
  • 1,626
3 votes
2 answers
2k views

Sitecore XP 9.1.1 certificates error

I get the following error from my CD Server(serverB) The certificate was not found. Store: My, Location: LocalMachine, FindType: FindByThumbprint, FindValue: """"", InvalidAllowed: False. Source: ...
Pavan Hatwar's user avatar
3 votes
1 answer
472 views

Very high xDB search indexer memory and out of memory crash

Recently my xDB search indexer service (XConnectSearchIndexer.exe) has been using all the server RAM and half the CPU until it runs out of memory crashes. It restarts and immediately starts to consume ...
Chris Auer's user avatar
  • 13.1k
3 votes
2 answers
450 views

Experience Analytics Error throwing System.Data.DataException error

I am in the upgrading process of Sitecore instance from 9.1 to 10.2 where the upgrade steps have been followed where I created a fresh 10.2.x instance and deployed the solution in to after the fact it ...
Arun Kumar's user avatar
3 votes
1 answer
337 views

Connecting two Azure services to access XConnect

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on app service azure connects to XConnect which is also on Azure, am following this link ...
Fatema elsayed's user avatar
3 votes
1 answer
2k views

Xdb.Collection.Shard0 Login failed for user

I have a Sitecore 9.3 instance. I installed on my local machine. After install, I moved my SQL databases to a server. I updated the connection strings and Sitecore itself is working fine. XConnect ...
Ethan Schofer's user avatar
3 votes
1 answer
527 views

What is the preferable way to get contact information out of xConnect and to a consumer?

In the xDB world (ie in 7.5/8) we created a typical MVC controller & view to allow us to get information to the browser via a json feed. Example data would be custom facets we could import from ...
boro2g's user avatar
  • 575
3 votes
1 answer
2k views

How to properly configure a custom facet in Sitecore 9.1

I have been trying the Sitecore samples to define a custom facet, and it all works if I do it outside from Sitecore. But when I want Sitecore to track the contacts and add data to the custom facet, I ...
freethinker6's user avatar
3 votes
4 answers
1k views

Failed to start the Marketing Automation Engine service - installation sitecore 10

I am trying to install sitecore 10 using garphic setup but i get error. I checked the logs of xconnect-log-MarketingAutomation and i found the below error, also i sarched about the error and i did ...
shimaa elsayed's user avatar
3 votes
3 answers
5k views

Can't start the 'Marketing Automation Engine' service

Can't start the Sitecore Marketing Automation Engine on my Sitecore 9.1 instance. When I try to do so, that's what I get on my log file: 19:02:11 15:56:15 ERROR Exception when executing agent ...
Hugo Santos's user avatar
  • 2,311
3 votes
3 answers
3k views

Sitecore 9 Experience profile dashboard shows contact name and email as "Unknown"

We are working on porting our site to Sitecore 9 Update 1. We have installed Sitecore 9 Update 1 with (WFFM) Web Forms For Marketers 9.0 Update-1 and Solr 6.6.2. Issue: The contacts are always shown ...
Pawan's user avatar
  • 80
2 votes
1 answer
764 views

Programmatically getting list of goals triggered through xConnect for certain contact

I would like to get check whether certain goal was triggered through xConnect for certain contact programmatically. We are using Sitecore 9.0.1. I have found this article: https://doc.sitecore.net/...
Peter Procházka's user avatar
2 votes
1 answer
679 views

Error with custom Page Event Model - Sitecore.XConnect.Schema.XdbModelException

Environment: Sitecore 9.3 I have created a custom Page Event. When I am trying to use it throws this error: 48856 14:48:01 ERROR Cannot execute 'sessionEnd:batch:ended' event Exception: System....
PSS's user avatar
  • 607
2 votes
1 answer
924 views

How do you properly query xdb for a contact by email?

I am trying to search an email in Sitecore Xdb using the code : var queryable = client.Contacts .Where(c => c.GetFacet<EmailAddressList>(EmailAddressList....
Gautam Aneja's user avatar
2 votes
1 answer
217 views

Capturing the close of a modal as an xDB event

I'm working on a scenario where I have a modal on a page, and if/when the user dismisses it, I want to make it such that the modal doesn't come back up for the user. The ideal scenario is to have this ...
Ken McAndrew's user avatar
  • 5,112
2 votes
2 answers
411 views

Experience Analytics Graphs are not loading in Sitecore 9.3

We are working on Sitecore 9.3 with SXA and having a scaled setup, 2 CMs, 4 CDs,1 Xconnect server, 1 Solr server, and initially, there were some errors on the Experience analytics tab, and that we ...
Rohan Bhateja's user avatar