Questions tagged [xconnect]

For questions related to xConnect, the API service layer abstracting the storage architecture of xDB from those accessing xDB data.

Filter by
Sorted by
Tagged with
1
vote
1answer
42 views

Unable to receive interaction events by specific definition id

I'm unable to receive interaction events by the specific definition id using (var client = SitecoreXConnectClientConfiguration.GetClient()) { try { var events = ...
0
votes
0answers
48 views

sitecore 9.2.0 install getting sqlcmd -P error [closed]

[![enter image description here][2]][2] I tried to install sitecore9.2.0 installed sqlserver2019 express edition and prerequesites as per installation guide,i am getting sqlcmd -P error in middle of ...
1
vote
2answers
64 views

Azure WebApp XDB apps cannot find service 'KeyStoreProviders'

I'm upgrading from 9.0.2 (XM) to 9.2 (XP), so I got a fresh install of the XDB enviroments (Azure WebApps), but my xcollect, ma-ops, xc-search (Solr), and maybe other webapps give me the You do not ...
1
vote
0answers
25 views

WebDeploy unable to deploy package

Web Deploy is unable to deploy package. I have all the prerequistes installed and have double checked that the Sitecore psgallary and Sitecore gallery are trusted repos and I am not sure why I am not ...
3
votes
0answers
40 views

XConnect `The HTTP response was not successful: Forbidden` on Azure

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make .Net core 2.2 projects published on azure app service, not on the same instance of Sitecore azure connects to XConnect, I was ...
2
votes
1answer
61 views

How to replace `CertificateHttpClientHandlerModifier` to `X509Certificate2`

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on azure app service connects to XConnect which is also on Azure, am following this link ...
2
votes
1answer
61 views

Dynamics Connect custom fields sync - “This object is already associated with another model”

I am trying to sync custom fields from Dynamics Connector 3.0.0 to xConnect (Sitecore 9.2) I have extended xConnect model with my custom facet, mapped fecet definitions, value accessor sets etc, ...
3
votes
1answer
46 views

Connecting two Azure services to access XConnect

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on app service azure connects to XConnect which is also on Azure, am following this link ...
2
votes
1answer
25 views

When should I update contact facets?

I have the following scenario: Contacts will be interacting with pages on the site that will be tagged with topics. By interacting with a page in a topic, they themselves will become tagged with being ...
2
votes
1answer
53 views

List manager doesn't show contact in manual subscription

I have a question about List manager since I stuck here for a week and half. I have made xConnect to save contacts into xDB. I checked that there are saved contacts in SQL Management, which I already ...
3
votes
0answers
33 views

Connecting .Net Core 2.2 project to XConnect in Azure Sitecore 9.2

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project connects to XConnect, am following this link from Sitecore documentation. It worked fine in the .Net ...
6
votes
2answers
75 views

Updating model of custom facet

I created a custom contact facet and deployed it. Due to certain requirements, I need to change the data type from bool to string for those facets. Do you see any challenges there? And how I can ...
3
votes
2answers
67 views

Connecting console application to XConnect in Azure Sitecore 9.2

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a console application connects to XConnect, am following this link from Sitecore documentation. In the part shown in the ...
1
vote
0answers
42 views

Integration with AD B2C: Trigger Owin challenges by policy name

We're using Sitecore.NET 9.1.0. We're trying to trigger register, login and forgot password flows from Sitecore that will be used by end users of our website. After a successful login we want to ...
1
vote
1answer
33 views

Sitecore 9.2 xConnect Console Application throwing runtime error

There is one Console application code for creating contact in xConnects in Sitecore 9.2 at https://doc.sitecore.com/developers/92/sitecore-experience-platform/en/create,-retrieve,-and-search-contact-...
3
votes
0answers
23 views

Segmented list for contacts based on outcome for users imported through xConnect client

Sitecore 9.0.2 Hi All, I am trying to add an (out-of-box) outcome to xDB for real-time users and from historical data (a csv file). For real-time users, I am using Tracker to add the outcome. The ...
2
votes
1answer
44 views

Update Outcome using xConnect client

Sitecore: 9.0.2 I am trying to update xDB for contacts with the Outcome. The source of data is from third party, so I cannot go through Tracker. I am using the following code snippet Code snippet: ...
0
votes
0answers
13 views

Sitecore Analytics not working - Sitecore 9.1 [duplicate]

Post Installation of Sitecore 9.1 I copied the Sitecore Website folder to a different location and created a new site (say local.sitecore.com) based on that folder. Sitecore Analytics is not working ...
2
votes
1answer
16 views

Solr XConnect Search Web Deploy package URL

I am trying to install Sitecore 9.2.0 XP with SOLR in ARM template. For that I need to put the web deploy package of "Solr XConnect Search Web Deploy package URL" in the place of "...
3
votes
2answers
57 views

Get Phone Number List Facet from IContactProcessingContext

I have a custom activity in marketing automation. Then I try to get phone number when user IContactProcessingContext, but context.Contact.GetFacet() return null. Any suggestions as to what I need to ...
0
votes
1answer
59 views

Sitecore Azure PaaS Client Certificate on ASE

I deployed Sitecore 9.2 on Azure PaaS and facing the issue with Client Certificate Authentication. The Azure hosting is on ASE with Isolated App Service Plan. It seems like CM server is not able to ...
0
votes
0answers
37 views

Stream does not support reading

Environment: Sitecore 9.0.2 Azure PAAS Scaled Issue: I have custom code which inserts data in xDB. The code is in production from past 2 weeks and I have successfully inserted 300,000 entries (3 ...
0
votes
0answers
19 views

Sync CRM Marketing list to XConnect issue

We are syncing the CRM marketing list to xconnect in Sitecore 9.1 for EXM. Marketing list is syncing in xconnect with facet "DynamicsMembership". The issue is that it creates a separate contact id. ...
1
vote
1answer
39 views

Invalid Model Type for Static Model Configuration

The tracker fails to start. All xConnect connections are failing from the web servers. Exception: System.Reflection.TargetInvocationException Message: Exception has been thrown by the target of an ...
2
votes
1answer
65 views

Failed to start service 'Sitecore XConnect Search Indexer - local.xconnect-IndexWorker

Hi I am trying to install Sitecore 9 using SIF and a PowerShell script provided with the ELearning Sitecore 9 developer foundations. I've had quite a few issue during this including getting Solr 6.6.2 ...
2
votes
2answers
70 views

Path Analyzer Site Maps

Running on Sitecore 9.0.2 in a multi site configuration and running into an issue when attempting to build a Site specific Map for Path Analyzer. All traffic is being recorded in the Global Maps -> ...
1
vote
1answer
39 views

Capture Session Timeout Event in Sitecore Marketing Automation

I am working on Sitecore 9.0.2 and we have a requirement to send a reminder email through marketing automation. We have a scenario where contact will land on registration page and provide email/...
0
votes
1answer
112 views

Unable to load Experience Analytics

Experience Analytics is not loading. I have checked the following :- Able to load xConnect with out any problem with valid certificate. Thumbprint is updated is xconnect website, connectionstring and ...
0
votes
2answers
66 views

How to load custom facet in EXM

does anyone know how to load EmailAddressList facet? I have created a custom rule for EXM in order to identify contacts I need to access EmailAddressList facet but when I execute this code it only ...
3
votes
0answers
35 views

Flow of data from email to the EXM dashboard [closed]

I am trying to understand the flow of data from the time a user opens/ click a link in the e-mail to the time it is displayed. I am listing my understanding below. Connecting the dots backwards: ...
-1
votes
1answer
24 views

Error Code: ERROR_APPPOOL_VERSION_MISMATCH

I am getting below error while installing sitecore 9.01. Error Code: ERROR_APPPOOL_VERSION_MISMATCH More Information: The application pool that you are trying to use has the 'managedRuntimeVersion' ...
0
votes
1answer
64 views

How to replace the root certificate for Sitecore 9?

On our local and DEV environment (Sitecore 9.0.1 and Commerce 9) we need to replace the root certificate with a new one, therefore all "child" certificates need to be recreated and replaced. Is there ...
7
votes
2answers
116 views

xConnect 100% CPU for hours

Sitecore 9.1 In the middle of some testing on my QA server, the xConnect IIS site went to 100% CPU and started chewing up RAM. Now for 14 hours, the CPU has not come down and the xConnect site has ...
0
votes
0answers
28 views

How to get Marketing Automation Activity Type language version

I am using Sitecore 9.2 The Marketing Automation Client fails for all other languages than "en". A request is made for /sitecore/api/ma/activitydescriptors?cultureName=en&sc_site=shell which ...
2
votes
1answer
42 views

Multiple instances of xConnect collection across different regions

Is it possible to host multiple instances of xConnect collection in different regions? We have 2 CD instances that are hosted in different regions and would like to have a xConnect collection hosted ...
2
votes
2answers
107 views

GeoIP Location data not coming in database and interaction object?

I am trying to implement geo-location-based personalization for my website and for this, I would like to test the data locally. I have enabled geolocation services from app-center and tested with the ...
3
votes
2answers
151 views

WARN Failed to create counter 'Sitecore.Analytics.XConnect\XConnect Model

We identify many repetitive warnings into Sitecore log files: WARN Failed to create counter 'Sitecore.Analytics.XConnect\XConnect Model Converter | Convert To XConnect Interaction Operations / sec'. ...
1
vote
2answers
359 views

Sitecore.XConnect.Operations.FacetOperationException

Activity: Uploading Contacts in xDB through xConnect by a scheduled task. Number of contacts: 8000+ Environment: Sitecore 9.0.2 XP0 The scheduler is synchronous. The contacts are getting imported ...
3
votes
1answer
49 views

How to update Tracker.Current

I have a Sitecore 9 form where a user submits a form and that contact will be saved in xDB. At the time of submitting I am checking in xDB is duplicate contact exist, on basis of First name, Last name,...
1
vote
2answers
229 views

The request was aborted: Could not create SSL/TLS secure channel on 9.0.2 XP0

Environment details: 9.0.2 XP0 What I am trying to do: I am trying to create an xConnect client from Sitecore context. What is the issue I am facing: The request was aborted: Could not create ...
2
votes
1answer
40 views

Sitecore Azure SQL DB Advisor recommendation - Drop unused indexes

As part of Sitecore 9.1 Azure hosting setup, I'm seeing few SQL DB Advisor recommendations in Azure to drop unused indexes on certain Sitecore tables that were created by Web deploy packages. Since ...
0
votes
1answer
147 views

Sitecore installation error - Dacpac file path: Instance failure. System.InvalidOperationException:

I'm trying to install Sitecore v9.1 update 1 with Sitecore SIF. I did install all the prerequisites. Everything looks fine. Also the script does install 7 databases (like MarketingAutomation, ...
3
votes
1answer
211 views

How to properly configure a custom facet in Sitecore 9.1

I have been trying the Sitecore samples to define a custom facet, and it all works if I do it outside from Sitecore. But when I want Sitecore to track the contacts and add data to the custom facet, I ...
2
votes
1answer
146 views

Experience Analytics dashboard gives errors

My Logs shows this error 2428 23:47:09 ERROR [Sitecore Services]: HTTP GET URL http://ffg.local/sitecore/api/ao/aggregates/all/786FBA3A4573445EA74504E3CA5E48C1/all?&dateGrouping=by-week&&dateFrom=23-...
4
votes
2answers
226 views

Install Sitecore 9.2 errors on Waiting for service 'Sitecore Marketing Automation Engine to start

Whilst trying to install Sitecore 9.2 using either SIF or SIA we are seeing both approaches error with: Waiting for service 'Sitecore Marketing Automation Engine - ###-MarketingAutomationService (###-...
5
votes
1answer
70 views

Sitecore Tracker not active for Forms in Ajax mode

Something really weird. I have a custom Submit action for my forms that works great. But when I try and access the Sitecore.Analytics.Tracker, it is null. But only when in Ajax mode. When Ajax is ...
2
votes
1answer
68 views

Contacts added by xConnect API not being enrolled in marketing automation

Has anyone had issues with contacts created via the xConnect API not enrolling in marketing automation plans? We've created a custom job which pulls in contact information from an external source and ...
3
votes
2answers
147 views

What is the proper troubleshooting technique for a “No known predicate type could be determined” error message?

As the question title suggests, I am looking for proper troubleshooting techniques in order to solve an error currently being experienced in a Sitecore 9.0.2 XP1 Topology Processing Role Server. The ...
0
votes
0answers
27 views

Sitecore Path Analyzer not showing data in habitat Home

I have installed Habitat Home solution in my system and facing an issue that PathAnalyzer is not showing any data, Whenever I open the path analyzer tab and enter the dates, I get an error, the filter ...
0
votes
1answer
84 views

Couldn't set avatar facet to contact in experience profile sitecore 9

I'm using Sitecore 9.1.1 and I am creating a Contact programmatically and set its facets. My problem is when I set the Avatar facet which is the picture of the contact. The following code is where I ...