Skip to main content

Questions tagged [xconnect]

For questions related to xConnect, the API service layer abstracting the storage architecture of xDB from those accessing xDB data.

Filter by
Sorted by
Tagged with
2 votes
1 answer
89 views

One Certificate for all instances in XP Scaled Installation - xDB Forbidden issue

I did an on-premise setup for Sitecore 9.3 XP Scaled environment. At the time of installation I created separate certificates using createcert.json file and common xconnect certificate thumbprint for ...
Amin Sayed's user avatar
1 vote
3 answers
93 views

Xconnect Error after deploying custom model on Azure

I am using Sitecore 9.1 Azure. Recently I deployed the XConnect custom model and other required files on 5 roles referring to the link https://doc.sitecore.com/xp/en/developers/100/sitecore-experience-...
Sitecoredev's user avatar
1 vote
1 answer
178 views

The specified type is not a valid facet type

I am creating custom facets in Sitecore 10.2. Below steps I have performed: Created custom facets. [FacetKey(DefaultFacetKey)] [Serializable] public class CustomFacet : Facet { ...
Swati Gupta's user avatar
  • 3,185
2 votes
1 answer
66 views

How to check if AlwaysEncrypted is enabled on a Sitecore Collection Shards DB?

We would like to know whether AlwaysEncrypted feature is ON/OFF for our Collection shards DB in Sitecore. We are working on the Upgrade to 10.2
Astle's user avatar
  • 411
1 vote
1 answer
146 views

Creating a personalization rule based on user LastLogin date

I have a requirement to create a personalization rule to change the rendering display based on whether the user is First Time user or New User. The first-time user will be decided if the users last ...
Debaparna's user avatar
  • 497
0 votes
2 answers
261 views

Getting license error when running the command "Sitecore.XConnectSearchIndexer.exe -rr"

When we are trying to run the command Sitecore.XConnectSearchIndexer.exe -rr in the XC search indexer, we are getting the license missing error. We already placed the partner license which is already ...
Astle's user avatar
  • 411
0 votes
1 answer
208 views

Sitecore 9.3 installation error Sitecore.XConnect.XdbCollectionUnavailableException System.Net.Sockets.SocketException

I am trying to install Sitecore 9.3 but getting below error Then I tried to view the complete error by executing Sitecore.MAEngine.exe, this gives the below error Error initializing XConnect client. ...
Bhupesh Khandelwal's user avatar
1 vote
1 answer
128 views

Data distribution between shards unequal

We're currently using Sitecore 10.0.1 with xConnect enabled on Azure PaaS. We have set up two shards DB, shard0 & shard1. Recently we have observed that data distribution between those DBs is ...
Mustafa Bohra's user avatar
1 vote
0 answers
34 views

XDB Shard Databases in Azure Failover Group

Our client has a requirement for two copies of data. Can the shard databases be in an Azure failover group? First attempt, back up the original databases, then restore them to the primary and ...
Gary Williams's user avatar
0 votes
1 answer
625 views

How to configure Serilog filters in xConnect?

I would like to filter out some messages from being logged in xConnect - for example 'Failed to locate activity...'. I have tried this configuration but it does not seem to take effect: <Settings&...
Mark Gibbons's user avatar
  • 5,642
2 votes
3 answers
218 views

Contact is null

I am working on Sitecore 10.2 and trying to update facets in xDB. The below function is working fine on local but it is not working on VM. xDB is enabled on Sitecore instance. public bool ...
Swati Gupta's user avatar
  • 3,185
1 vote
2 answers
167 views

Interactions not saving to xdb when processing custom events?

In my SC 9.3 solution I have a custom page event that I am firing, converting, and wanting to store in xdb. When I debug the code: I can see the events getting registered as expected I can inspect ...
Marcel Gruber's user avatar
0 votes
1 answer
165 views

Where to fire a custom XConnect event on page load?

I have a case where I want to fire a custom page event but only for a specific page template. This means that whichever pipeline I fire the event from, I need access to: Current page's template ID OR ...
Marcel Gruber's user avatar
1 vote
1 answer
211 views

Sitecore 10.1.1 installation issue - failed to start service 'Sitecore xconnect search indexer'

I have failed to install Sitecore 10.1.1 on my local. I've tried giving full permission to users. The license I believe is okay as well. There are the logs from the event viewer. Did anyone encounter ...
kivel's user avatar
  • 11
0 votes
1 answer
120 views

How to store full URLs in page view events instead of just the path?

I have a case where I need page view events to store full URLs in the Url property instead of just the paths. For example, if I explore the Interactions table, inside the Events column, PageViewEvents ...
Marcel Gruber's user avatar
1 vote
2 answers
418 views

The HTTP response was not successful: NotFound

I searched from the whole site while I didn't find this topic yet... During the installation, we met this exception and failed. Can anybody help us with this issue? Huge thanks in advance! [Error] ...
TooYoung's user avatar
3 votes
1 answer
296 views

SC 10.2 Exception when trying to view xdb data on local installation, Invalid column name 'Converted'

I installed a local instance on Sitecore 10.2 using SIA, and I performed the upgrade scripts on the Core, master, and web databases, since it is a local instance I didn't really care about the ...
Muradious's user avatar
  • 531
0 votes
1 answer
241 views

SItecore Marketing automation is not working for OOB email opened event

I have created a Marketing Automation campaign and selected Send Email action for contacts. Post this action, I am adding a listener for 3 minutes where I have added a rule "Where contact opened ...
Rashmi936's user avatar
1 vote
1 answer
41 views

Sitecore 10.2 salesforce xConnect Client Endpoint [closed]

I am trying to connect Sitecore to salesfore during xConnect Client Endpoint I am getting this error I have given this following details also I tried to browse xconncet.dev.local from IIS in browser ...
Monit's user avatar
  • 17
0 votes
1 answer
49 views

Searching for events of custom model type in XConnect

I have cloned this repo and updated it to run with Sitecore 10.1 (which is our current version): https://github.com/adeneys/cortex-processing-demo The above application has functionality to create a ...
Dean OBrien's user avatar
  • 1,635
0 votes
1 answer
101 views

Sitecore Marketing Automation Service is failing many times

Sitecore Marketing Automation Service is failing many times and a lot of certificates are getting generated. If we move this certificate and in IIS if we select another certificate and then again ...
Pavan Toshniwal's user avatar
1 vote
2 answers
53 views

Non prod environments can share Common Service such as Xconnect and Processing

We have a 10 non production System Integration test environments. Right now we have common shared Solr server. Likewise Is it possible to have shared Xconnect and Processing Webapps for multiple non ...
Santosh Poojari's user avatar
0 votes
2 answers
129 views

How to retrieve Contact created date

I'm using Sitecore 9.1 update 1. When retrieving contacts via IAsyncQueryable<Contact> queryable = client.Contacts I don't see the created date of the contact. How can I programmatically get the ...
Nele's user avatar
  • 85
3 votes
1 answer
1k views

XConnect Error While Sending The Request

I have installed a clean version of Sitecore XP0 of my local development machine and the logs are showing the following error: ManagedPoolThread #14 14:21:35 INFO Job ended: Sitecore.ListManagement....
Michael Edwards's user avatar
0 votes
1 answer
198 views

Experience Profile 403 error

The Experience Profile shows the correct data with no console errors when I logged into Sitecore for the first time but refreshing the page gives the error An error has occurred. The only way to see ...
Owais Ahmed's user avatar
4 votes
3 answers
454 views

Custom facet from a contact is coming null but when creating a new one Sitecore is complaining that the facet already exists

I'm trying to write a .aspx script to update an existing contact in the experience profile, the basic logic is: get the contact by e-mail get a custom facet from the contact if the facet is null ...
André Andrade's user avatar
0 votes
1 answer
1k views

Local sitecore instance SSL certs expired

Sorry, this seems more simple than I am making it to be but I am just running into multiple errors after reading and trying multiple articles. So after my initial installation of Sitecore, my certs ...
user1566783's user avatar
0 votes
1 answer
129 views

How to implementing keyword search with xconnect contact facet search?

I am using Sitecore 10 and trying to implement keyword search with xConnect contact. I want to search for contacts that have email or phone number that contains the inputted keyword. Below is my ...
truongdsbui's user avatar
3 votes
1 answer
472 views

Very high xDB search indexer memory and out of memory crash

Recently my xDB search indexer service (XConnectSearchIndexer.exe) has been using all the server RAM and half the CPU until it runs out of memory crashes. It restarts and immediately starts to consume ...
Chris Auer's user avatar
  • 13.1k
0 votes
0 answers
37 views

Contacts in List Manager gets replaced by new ones in Sitecore 10.1.0

I followed the below documentation and added a custom submit action in Sitecore 10.1.0. https://doc.sitecore.com/xp/en/developers/93/sitecore-experience-manager/walkthrough--creating-a-custom-submit-...
Asif's user avatar
  • 1
0 votes
0 answers
28 views

SC_Analytics_Cookie is the same for all users

I am using Sitecore 10.1 and when I try to access the published site all the analytics cookies in different browsers/ machines map to the same user. Any clue how to trouble shoot this issue?
NAli's user avatar
  • 875
0 votes
0 answers
43 views

Sitecore 9.3 install failed with XConnect search indexer service failing to start [duplicate]

Running into a major headache and roadblock I have been googling for a while. It looks like the other questions have different errors, and the closest one said it was a license expiration date issue, ...
FilleehJ's user avatar
1 vote
0 answers
93 views

How do I track contacts and see their visits upon registering to my site?

This is the method I have to register a Contact and their facets to the xDb (I have also registered some of my personal facets). However upon registering, my known contacts visits and visit duration ...
Yong Qin Foo's user avatar
3 votes
3 answers
171 views

Sitecore 10.1 standalone instance always brings 0 interactions

I've tried this code, taken almost directly from Sitecore documentation (they are using Goal, I'm using PageViewEvent). var itemId = <some id of an Item in content>; using (var client = Sitecore....
Yiannis Vavouranakis's user avatar
2 votes
3 answers
2k views

Sitecore 10 Installation Error: Failed to Start Service 'Sitecore Marketing Automation Engine' while an instance of 9.0.2 also running on my system

Note: I have multiple Solr installed on my local environment one is for the previous version and now I have added Solr for Sitecore 10 on port 8984 So my Solr path for the Sitecore 10 is https://...
Tabish Usman's user avatar
0 votes
1 answer
192 views

Performance issue on page load Sitecore.Analytics BLOCKED_TIME

Background of Infra/Software: Sitecore Product Version: 9.2 Sitecore XP Scaled topology used. Infrastructure Type: Azure App Service / PaaS inside Isolated ASE Issue: Experiencing slowness in Page ...
Ratish K R's user avatar
0 votes
1 answer
188 views

AllowInvalidCertificates error after turning on XDB

After turning on XDB in a Docker installation after upgrading from 9.0 u2 to 10.1.1. I get the following error. XDB works fine in a vanilla install using the same license. Any ideas?
RReilley's user avatar
  • 755
0 votes
0 answers
409 views

Login failure for collection user after migrating to Azure SQL

"login failed for collectionuser" errors appear after migrating our Sitecore 10.1.1 databases from self-hosted SQL Server on VM to Azure SQL Database. The site itself is working, but ...
Daniel Govier's user avatar
2 votes
1 answer
248 views

Sitecore Collection databases not created in Prod xConnect Set up using SIF

While we are doing xConnect Prod set up, identified that following collection DBs are not created post SIF script execution. Missed collection DBs: 1.Xdb.Collection.Shard0 2.Xdb.Collection.Shard1 3....
Thamizh's user avatar
  • 327
0 votes
0 answers
127 views

How can I get UploadedFile (upload from out of box Sitecore Form) Blob / fileContent?

How can I retrieve Filecontent from [sitecore_forms_filestorage].[FileStorage] based on id value? I tried the below code, but got a "_fileStorageProvider is null" error. Guid fieldid = Guid....
user7749's user avatar
2 votes
2 answers
111 views

Set the value of custom Xdb field on custom Sitecore 9 form custom button click

I have created a Sitecore 9 form with a custom button as shown below: On click of this "Subscribe" button I am saving the email of the contact in Xdb (Experience profile). Also, I have ...
Niti Chauhan's user avatar
1 vote
1 answer
310 views

Sitecore analytics on local dev machine not capturing data

I've been working through setting up XConnect on a local machine. Over a few days I've dug through the logs and fixed configuration issues (broken connections strings copied from another environment ...
Tim's user avatar
  • 33
2 votes
1 answer
94 views

How to mock XConnect contact

I'm writing unit tests and using Moq as a mocking tool. In a previous question I was advised to use IXdbContext to mock the XConnect client, which works just fine. However, I run into problems if I ...
TheHvidsten's user avatar
  • 1,004
2 votes
3 answers
125 views

How to Migrate Custom Facet with Complex Type from SC8.2 to SC9.3

We are having Custom Facet with Complex type in 8.2, that needs to be Migrated to Sitecore 9.3 Followed below Link for creating facet. https://doc.sitecore.com/en/developers/91/sitecore-experience-...
Parvathi Somanahalli's user avatar
0 votes
1 answer
203 views

Resolve Sitecore.XConnect.Operations.FacetOperationException - should CDs share common redis cache?

The logs of my site are getting full with Sitecore.XConnect.Operations.FacetOperationException. The site uses Sitecore 9.2 in a load-balanced setup on azure with CD1 in UK South and CD2 in UK West ...
Matthew Dresser's user avatar
2 votes
2 answers
98 views

When does xDB identify a contact when loading a page?

We have a script on the page for a 3rd party analytics system and want to send the contact ID to it. Will that be available on page load of the first request that xDB identifies the contact? Does that ...
Vinu Krishnaswamy's user avatar
0 votes
2 answers
157 views

Sitecore CommerceInitialize Environment API call fails with Failed to get connection for Sitecore

I'm running the Postman collection to call Sitecore Commerce (9.0.3 with Sitecore 9.0.2) API methods on my solution. I call GetToken which runs successfully, followed by CleanEnvironment (which ...
Matthew Dresser's user avatar
0 votes
1 answer
333 views

No such core:xdb

I am getting a no such core:xdb error when trying to rebuild xdb Sitecore.Xdb.Collection.Search.Solr.Failures.SolrResponseException: { "responseHeader":{ "status":400, &...
user avatar
1 vote
0 answers
85 views

xConnect get PatternCards for contact

I want to use xconnect to download pattern cards. The contact has pattern cards (I checked in his profile). I extended contact download with ContactBehaviorProfile. Below is my code ...
Jan Nowak's user avatar
  • 311
0 votes
1 answer
117 views

InteractionAggregation Pipeline doesn't trigger in Sitecore 9.3

I am working on custom analytics aggregation in Sitecore 9.3. I have done all the code and configuration but my custom CentralLoginProcessor is not executing. config file: <?xml version="1.0&...
Kanniyappan Krishnan's user avatar

1
2
3 4 5
11