All Questions

Filter by
Sorted by
Tagged with
70 votes
7 answers
48k views

How do you setup a 404 and 500 error page for missing files and media items?

When navigating to a url such as www.website.com/missing.pdf and www.website.com/-/media/missing.pdf you will either receive the IIS 404 Server Error message or a Sitecore document not found page. ...
Michael West's user avatar
  • 18.2k
22 votes
1 answer
24k views

How can I get started learning Sitecore?

I'm about to start on a Sitecore project in 6-8 weeks time. I have extensive ASP.NET MVC experience (4 years) and know the ins-and-outs of web development fairly well. I am scheduled for official ...
Mark Cassidy's user avatar
  • 25.2k
46 votes
1 answer
5k views

How can I connect with the Sitecore Community?

I'm looking to get more involved in the Sitecore community. I'm interested in any local, regional or global Sitecore User Groups, events, online resources, anywhere where the community is active and ...
Mark Cassidy's user avatar
  • 25.2k
10 votes
2 answers
2k views

Issue elevating SPE Console in 9.1 Azure PaaS

I have a relatively clean install of Sitecore PowerShell Extensions v 5.0 in my environment, which is running Sitecore 9.1 on Azure PaaS. As far as I can tell, everything in the install seems to be ...
Bic's user avatar
  • 550
27 votes
3 answers
3k views

Sitecore IP Geo location Service-Personalization with Geo-based conditions does not work

Sitecore Personalization using GEO IP is not executed . I have activated "Sitecore IP Geo location Service" and followed all steps needed to activate the service for Sitecore instance (8.1 update 1) ...
Haneen Daoud's user avatar
17 votes
9 answers
24k views

xConnect The HTTP response was not successful: Unauthorized

I'm trying to initialize a connection between a .NET Core application and an xConnect installation. I ran into the following error: An unhandled exception of type 'Sitecore.XConnect....
mark DE Jong's user avatar
  • 1,001
21 votes
3 answers
7k views

Global.asax Application_Start not hit after upgrade to Sitecore 8.2

We noticed the Application_Start in the Global asax is no longer hit after the upgrade to Sitecore 8.2. Does anyone have an idea what may have caused this? My global.asax.cs: public class Global : ...
Nico Grms's user avatar
  • 575
14 votes
3 answers
17k views

Analytics "Tracker.Current is not initialized"

I set up my analytics tracker code as someone noted to me in another question, but when I went through my site and did a login, then some stuff, then logged out (causing a session abandon), the ...
Ken McAndrew's user avatar
  • 5,102
7 votes
1 answer
2k views

Workflow without lock and edit option

Is it possible to have workflow without lock and edit option. Also the item version should increment only it had reached the final workflow state.
PVM's user avatar
  • 963
3 votes
9 answers
11k views

Sitecore 9.3 Installation failing - 'Failed to start the Marketing Automation Engine service

I am trying to set up Sitecore 9.3 XP0 locally in a VM using SIA and it is failing at Step 67 of 92 with an error failed to start the marketing Automation Engine Service. System....
Deepak's user avatar
  • 41
41 votes
3 answers
2k views

What should I expect in the MVP nomination or first-time application process?

There has been a considerable amount of traffic on Sitecore Slack Chat, Sitecore Stack Exchange, and even Twitter as to what should people experience when submitting applications or nominations for ...
Michael West's user avatar
  • 18.2k
31 votes
5 answers
7k views

What does the "Publish related items" checkbox do in Sitecore?

When you publish an item in Sitecore through the Publish item dialog, you are offered several options. You can choose between Smart publish or Republish, you can also choose whether to Publish ...
Phil Burton's user avatar
  • 1,314
23 votes
2 answers
4k views

Is it possible to use any personalisation rules without xDB

Is it possible to make use of any of the component personalisation rules without xDB being enabled? e.g. to swap/hide a component depending on the current date? I'm not interested in tracking the ...
Matthew Dresser's user avatar
16 votes
2 answers
4k views

Disable xDB tracking for single requests

I am using our own Sitecore Error Manager in a Sitecore 8.2 project. If an item is not found or an error occurs, our error page is called within the current client request. This error handler calls a ...
Pascal Mathys's user avatar
11 votes
2 answers
3k views

Create controller rendering in SXA

As a test, I wanted to create a rendering for an SXA site. It had to be added to the toolbox and have a controller, model, and view. I read this Creating new renderings that are compatible with SXA ...
Gatogordo's user avatar
  • 20.1k
10 votes
2 answers
3k views

XP Scaled (XP1) how to validate installed application in each server are correct?

I am trying to install Sitecore 9.1 in distributed (on premises) architecture, I have 4 servers: 1-cd 1-cm 1-solr 1-sql,reporting and processing I tweaked the script to install each separately ...
Avinash J's user avatar
  • 313
7 votes
2 answers
4k views

Creating custom data attribute for Sitecore form fields

How to implement html data attribute for Sitecore forms? For example in the styling section, I would like to add custom input for data attribute. Any help is much appreciated.
Naga Dinesh's user avatar
3 votes
3 answers
3k views

Sitecore 9 forms redirecting to formbuilder link on submit

I am having an issue when submitting a form when there is no redirect. Basically i have a contact us form and eventually will implement a email action. But every time i click the submit button even ...
jsPlayer's user avatar
  • 203
25 votes
3 answers
8k views

Installing 9.1 XP0 - Sorry, there was an error : unauthorized_client

After installing 9.1 I see the following error on the login screen: Steps I followed: Updated XP0-SingleDeveloper with ".dev.sc.local" to the site names Ran the installation using XP0-...
Michael West's user avatar
  • 18.2k
22 votes
4 answers
7k views

How can I disable xDB?

If I don't have a working connection to MongoDB and I don't want to use xDB functionality. Currently, my logs are being filled with errors. What is the configuration needed to disable xDB?
Ben Golden's user avatar
  • 3,313
21 votes
3 answers
778 views

Engagement Plans: Why is a user not added to an engagement plan until the session of a user is timed out?

In short my question is: Why is a user not added to an engagement plan until the session of a user is timed out? My setup: I am running Sitecore 8.1.3 and I have created a simple engagement plan, ...
pwind's user avatar
  • 963
15 votes
2 answers
2k views

Rebuilding Sitecore Core Index on Azure search throwing exceeding index limitation exception

I am using Azure search service (Pricing Tier: Standard with 15 Million docs/partition) connected to Sitecore 8.2 instance. It is throwing me an error when I try to build Sitecore core index: ...
TomCat's user avatar
  • 333
9 votes
4 answers
2k views

Filter (Checklist) component shows ids of facets not values in SXA

Introduction We are using Sitecore 9 Update 2 with SXA 1.7.1. We have implemented "Download Center" using OOTB search components from SXA. We would like to show "Title" value of Checklist field ...
Peter Procházka's user avatar
5 votes
4 answers
1k views

No contact created in MongoDB when session is closed

8.2 update 0. I have changed session to be 1 minute instead of the default 20 minutes. When I log into the site, in incognito, surf around and close the browser. No contact is ever created in the ...
Chris Auer's user avatar
  • 13.1k
47 votes
5 answers
35k views

Is there a way to reset Sitecore admin password from database level?

I forgot my Sitecore admin password and was thinking a way to reset from database level. Is there a SQL query to reset Sitecore admin password ?
scFootsteps's user avatar
  • 3,851
33 votes
3 answers
2k views

How do I reference Sitecore binaries from NuGet?

I've heard through the grapevine that Sitecore DLL's can be referenced through the use of NuGet Packages. I found Sitecore.NuGet, but I don't think that's the right option. I also found this blog ...
Pete Navarra's user avatar
  • 14.6k
28 votes
6 answers
6k views

How to change item templates and retain existing data

We are refactoring our project and are trying to clean up the usages of templates throughout the project. There are a number of templates that are very similar that could all be using the same data ...
jammykam's user avatar
  • 13.8k
22 votes
6 answers
7k views

The HTTP response was not successful: Forbidden

I have tried Sitecore 9 update 1 installation on my local Windows 10 and encountered this error: Exception: Sitecore.XConnect.XdbCollectionUnavailableException Message: The HTTP response was not ...
Helen P's user avatar
  • 221
20 votes
1 answer
2k views

Sitecore Content deliveries and Solr with High availability

I'm trying to find a recommendation from Sitecore in terms of configuring Solr for high availability and how to use it properly with Sitecore. Does anybody know where I can find it? If not, I'm ...
Vicent Galiana's user avatar
18 votes
3 answers
9k views

Configuring Sitecore to display PDFs in browser

Currently, when a user clicks on a PDF link on my site (served from the Media Library), the browser will download the PDF file. I'd like to change the behavior from downloading to opening in browser (...
Ed Schwehm's user avatar
  • 3,036
15 votes
2 answers
1k views

Server role config with ContentManagement,Processing,Reporting not working

We wanted to setup a server as ContentManagement,Processing and Reporting instance. As we can combine roles, we changed the config accordingly. <add key="role:define" value="ContentManagement,...
Gatogordo's user avatar
  • 20.1k
14 votes
3 answers
3k views

How to rebuild the analytics index without rebuilding the entire reporting database?

In Sitecore 8.1.3, is it possible to rebuild the analytics index without rebuilding the entire reporting database as specified in doc.sitecore.net? I have an analytics index that is more or less ...
pwind's user avatar
  • 963
13 votes
4 answers
2k views

Image not published in data source item (Sitecore 8.1)

Sitecore 8.1 update 2: Our content authors noticed that in a certain constellation newly uploaded images would not get published. So the content author is in Experience Editor, adds a component which ...
z00mable's user avatar
  • 621
13 votes
1 answer
1k views

What class indexes the _content index field

Until I answered a question wrong yesterday, I didn't know that the field _content in the index had the content of all indexable fields in Sitecore. You would have thought that would be the first ...
Chris Auer's user avatar
  • 13.1k
12 votes
4 answers
13k views

MediaRequestProtection: An invalid/missing hash value was encountered

My Sitecore error logs contain messages such as: ERROR MediaRequestProtection: An invalid/missing hash value was encountered. The expected hash value... What would be causing this? This is only ...
G Killian's user avatar
  • 1,309
10 votes
4 answers
7k views

502 - Web server received an invalid response while acting as a gateway or proxy server

I've noticed the 502 error after deployment to Azure question, but it appears to be related to a failed deployment and rollback of databases - not what we're seeing here. I am getting the above ...
Mark Cassidy's user avatar
  • 25.2k
10 votes
1 answer
4k views

How do I set up my Sitecore MVC Post form and receive a confirmation page

I have not ever had to submit a form in Sitecore before, in my previous experience I used WFFM, thus I didn't have to create or process forms. My form is simply to take in some information and ...
Paul T. Rykiel's user avatar
10 votes
4 answers
2k views

Sitecore Publishing Service does not show the languages and seeing 404 errors

After installing the Sitecore Publishing Service 2.0 and the associated module, I'm receiving a number of 404 errors in the browser console and the languages are missing from the publishing dialog. ...
Michael West's user avatar
  • 18.2k
10 votes
2 answers
7k views

Is it possible to get page rendering result programmatically ?

I need to get all HTML page content that sitecore generate for an page item. But I need to do it programmatically just for some special tests. I can of course just use URL but it is not good for me. ...
Arbejdsglæde's user avatar
10 votes
4 answers
5k views

Azure Web App Redis timeout exceptions when under load

We are performance testing our Sitecore hosted in azure web apps (2 CD S3) which uses Premium Redis. There are no error during normal UAT and SIT. However, on performance testing there are quiet a ...
Nil Pun's user avatar
  • 2,293
10 votes
6 answers
17k views

Powershell get all items that use a template

The title pretty much says it all - I've looked at the docs but I just keep finding Get-Item and Get-ItemTempate. Lets say I have a template with id 123456, I want to get all items that are using ...
Percy's user avatar
  • 285
8 votes
2 answers
2k views

Sitecore SXA Search Result Sorting by date

How to sort/filter search result in Sitecore SXA by __created date or __updated date to retrieve recent search items
mahboob's user avatar
  • 83
7 votes
1 answer
2k views

How to get Sitecore.Context.User after redirect from Azure ADb2c login?

I am on Sitecore 9.1 Initial Release and SXA 1.8. Implemented a custom processor for Azure ADB2C Login. I can login perfectly and fetch the claims and stuff. But on redirect to /myaccount page , I ...
Abhay Dhar's user avatar
  • 1,655
6 votes
3 answers
4k views

'sqlcmd' is not recognized at CreateShardApplicationDatabaseServerLoginSqlCmd step

I'm trying to install Sitecore 9 Update 1 XP0 topology and everything looks great until the step CreateShardApplicationDatabaseServerLoginSqlCmd The server I am running the installation was ...
Vinicius Deschamps's user avatar
6 votes
3 answers
1k views

SIF Installation throwing Password Validation Failed exception

We are trying to install Sitecore 9.0.1 rev 171219 (XP0) on-premise. Everything goes fine until it tries to create Sitecore.Messaging Database. As the installation have already created ...
Amitabh Vyas's user avatar
  • 2,554
5 votes
4 answers
2k views

Sitecore PowerShell extensions module compatibility with Sitecore 9.2

I am trying to install the Sitecore PowerShell extensions module in Sitecore 9.2. While installing this module, I received a w3wp crash error as: When I try to run any script, I am receiving "...
SurendrA SharmA's user avatar
5 votes
2 answers
4k views

Sitecore multisite cross links not resolved with proper hostname

I've multisite solution setup, and sites config looks like below: <sites> <site name="localhost" hostName="local.com" scheme="http" notFoundItem="not-found" enableTracking="true" ...
nari447's user avatar
  • 407
5 votes
4 answers
9k views

Audit log for seeing who updated content when

Hopefully a simple question - is there any kind of ready-made audit log built into Sitecore so I can see who edited content when? I know without versioning the content, the last updated date/user ...
Ken McAndrew's user avatar
  • 5,102
4 votes
3 answers
3k views

How to check Sitecore.xDB.base in license file?

I am upgrading Sitecore 8.0 to 8.1. In Sitecore 8.1 Sitecore.xDB.base key is required. So how can i check that Sitecore.xDB.base key is exists in license file?
user2753438's user avatar
3 votes
1 answer
1k views

Reading a value from an WFFM Upload file field

I'm having trouble reading the value from a Web Forms For Marketeers Upload File field within my Custom Save Action. As I understand it I should just be able to do this in the Save action Execute ...
Adam Seabridge's user avatar

15 30 50 per page
1
2 3 4 5
27