All Questions

Filter by
Sorted by
Tagged with
1
vote
1answer
36 views

Link Database - rebuild specific items instead of whole database

Anyone know if there is a way to rebuild specific items in link database through a custom script targeting specific items to rebuild links to? OOB Sitecore only supports rebuilding the whole link ...
0
votes
0answers
28 views

Solr - sort results based on the distance (lat and long) and search keyword relevance

I am working on the search functionality where I am trying to sort the results based on the distance and search keyword relevance but it is not working as expected. When I try with the search keyword ...
0
votes
2answers
37 views

Sitecore 10.1 standalone instance always brings 0 interactions

I've tried this code, taken almost directly from sitecore documentation (they are using Goal, I'm using PageViewEvent). var itemId = <some id of an Item in content>; using (var ...
6
votes
1answer
181 views

How to configure multisite in Sitecore Next.js application?

How do you implement a multisite setup with Sitecore and Next.js, with a Sitecore First Approach? Do we need to create separate Next.js apps for each site or we can we configure it in the same default ...
0
votes
1answer
23 views

Information disclosure security issue

There is one security issue reported by Qualys scan. When we hit the url - https://hostnamecd/api/sitecore/image, it shows the page shown in below screenshot. Instead, it should result in custom 404 ...
2
votes
2answers
93 views

Send tracking data to Sitecore CDP

I am currently working with Sitecore CDP. I have Sitecore site .when user visit the site , I need to capture the user Interactions using Sitecore CDP, In Official Document I found JavaScript snippet ...
0
votes
0answers
45 views

JSS General Link With Search Field

I am trying to use Sitecore Field General Link With Search in Sitecore JSS NextJS. Although when I am trying to search & select the Sitecore Item in the General Link Field, I am getting the ...
0
votes
1answer
80 views

Sitecore 10 Installation Error: Failed to Start Service 'Sitecore Marketing Automation Engine' while an instance of 9.0.2 also running on my system

Note: I have multiple solr installed on my local environment one is for previous version and now I have added solr for sitecore 10 on port 8984 So my solr path for the sitecore 10 is https://localhost:...
0
votes
0answers
47 views

Glass Cast issues for Contextitem after upgrading from Sitecore 8.1 to Sitecore 10.1.2

I am trying to migrate Sitecore items from Sitecore 8.1 to Sitecore 10.1.2. During migration I have the following exception: 'Item' does not contain a definition for 'GetContextItem' and no ...
1
vote
1answer
33 views

Sitecore Scheduled task runs on startup

I'm using Sitecore 9.3, I have a custom scheduled task for rebuilding the Sitecore search index at night. My project is hosted on Azure environment, I noticed that if I restart the CM app service then ...
0
votes
0answers
37 views

xconnect collections fails with invalid operation

I'm experiencing problems with sitecore experience analytics for sitecore 9.1. From my site log (see log1) I can see that analytics is trying to send data to xconnect, however xconnect is not ...
1
vote
0answers
29 views

"Cannot use import statement outside a module"

When running gulp I get the following error: My node version is 17.1.0 Gulp CLI Version is 2.3.0 Local gulp is 4.0.2
0
votes
1answer
28 views

Share Index across multiple site

We are using SXA to build 4 sites under same talent for example site A , B , C and D. We have requirement to show the news articles created under any of these sites to be shown to rest of the sites , ...
0
votes
0answers
28 views

Sitecore 9.3 - parts of CM stopped working, JavaScript errors in console

It seems that any place the Sitecore CM where a modal dialog would pop up has stopped working and I haven't been able to figure out why. I see the same behavior in both Chrome and FireFox. The error ...
0
votes
1answer
41 views

Enable Robot Detection in 10.1 Forms

After upgrading from 9.3 to 10.1, the 'Robot detection enabled' checkbox is uncheackable in form settings. Compared with docs: Xdb enabled XdbTracking enabled AutoDetectBots enabled @Html.Sitecore()....
2
votes
1answer
30 views

Components not visible after upgrade to Sitecore 10.1

I have upgraded from Sitecore 8.2 to Sitecore 10.1. The layouts are rendered fine but none of the components are rendering. Seems like the placeholders are not working. Some of the components are ...
1
vote
1answer
21 views

Nothing happening when running "sxa init"

hoping someone can help. I have successfully installed the SXA CLI as the pre-perquisites to setting up an SXA theme in Sitecore 10.1, I'm following the next steps but hitting a snag I think when ...
0
votes
0answers
28 views

Why does publishing of events in a Sitecore bucket stop working after 100+ events were created and published one day?

In a bucket in Sitecore, users have been creating and publishing events with no problem. On one day in September 2021, a user created and published more than 100 events over three hours. All these ...
0
votes
1answer
31 views

How do I force the Sitecore FieldRenderer or Glass.Mapper, when rendering rich text fields, to always render absolute urls for my API?

I have an API in Sitecore that takes content from Sitecore and provides it to an external non-Sitecore site. While retrieving content, the API renders a rich text field using a glass mapper. This rich ...
0
votes
1answer
40 views

Performance issue on page load Sitecore.Analytics BLOCKED_TIME

Background of Infra/Software: Sitecore Product Version: 9.2 Sitecore XP Scaled topology used. Infrastructure Type: Azure App Service / PaaS inside Isolated ASE Issue: Experiencing slowness in Page ...
1
vote
1answer
47 views

A/B testing of components using Glass Mapper return "Data source invalid."

I am using Sitecore 9.3 with Glass Mapper 5.8.177 and component A/B testing does not work for me. I set up a simple component that works perfectly fine until I begin creating variants for A/B testing ...
1
vote
0answers
40 views

Install Sitecore 10 without admin access to SQL Server or user sa

I want to install Sitecore but not having user admin user for SQL Server. Anyway of installing this with Windows authentication.
0
votes
1answer
67 views

ASP.NET Webforms with Sitecore 10.2

Last year we have upgraded our Sitecore instance to version 9.3. We still have some renderings developed in ASP.Net Webforms (otherwise we are using ASP.Net MVC). Now we want to upgrade to Sitecore 10....
1
vote
2answers
49 views

Does sitecore 10.1 support wffm(webform for marketers)?

Getting error on adding wffm form rendering on presentation details.Tried to install wffm modules but nothing worked at my end.Can anyone tell me does sitecore 10.1 support wffm forms?
0
votes
1answer
34 views

Nested dynamic placeholder conversion

I am trying to convert the non-Fortis module of Dynamic Placeholders into the new in 9.x Sitecore Dynamic Placeholders with the format of PlaceholderName-{Rendering guid}-0 using C#. I can easily ...
0
votes
1answer
43 views

JSS Containers setup, CM container does not start or attempt to start

I'm following the JSS walkthrough with container and I'm running into an issue running the up.ps1 script. Most of the script runs fine, but when it goes to start the containers the cm container doesn'...
0
votes
0answers
29 views

How to display the JSON content of a SXA page in a sequential order in Sitecore 9.0.1?

We have a Sitecore SXA website. Sitecore version is 9.0.1, SXA version is 1.7. I am fetching the json data of a page by using default Sitecore resolvers and appending ?sc_device=json. But ...
0
votes
1answer
44 views

TDS overwrites existing model

I am new to TDS. I have a template which has a ContentList field of type TreeList. This field is allowed to select any page template. When I map this changes in TDS(Visual Studio) the tds generates a ...
0
votes
0answers
37 views

Sitecore Lighthouse Setup

We are trying to Setup Lighthouse(https://github.com/Sitecore/Sitecore.Demo.Platform/blob/main/docs/Usage.md) environment on Azure VM We were able to execute all the steps to provision Demo ...
0
votes
1answer
41 views

Can rebuilt index take my site down [closed]

Some of my pages are not appearing in search results. I tried publish the page but that doesn't work. I think I need to rebuild the index. I am being cautious here, will my site go down until rebuild ...
0
votes
1answer
51 views

NuGet Restore not Working When Building Sitecore Images

I'm trying to spin up the following Sitecore environment using docker: https://github.com/Sitecore/docker-examples/tree/develop/custom-images I've already run the Init.ps1 script that fills in all the ...
0
votes
1answer
30 views

Specify default rendering for placeholder in partial design

We have a partial design with an empty placeholder that is being pre-filled with one of its allowed renderings upon page creation. It is not clear where exactly it is being specified for this ...
0
votes
1answer
32 views

Sitecore 8.1 - few media files getting downloaded

We are working on Sitecore 8.1 instance where we have got a security issue. As per the issue, few media files are getting downloaded directly when we hit the url. Example - https://hostname/-/media/...
0
votes
0answers
61 views

Getting Started template - Unable to find package Microsoft.Build.CentralPackageVersions. No packages exist with this id in source(s): Nuget, Sitecore

Getting Started template Sitecore 10 While running up.ps1 getting below errors: C:\build\Directory.Build.targets : warning : Unable to load the service index for source https://api.nuget.org/v3/index....
1
vote
0answers
84 views

Could not find add method: AddIndex (type: Sitecore.ContentSearch.ContentSearchConfiguration)

We are setting up a new Sitecore 9.3 instance on a server, making the respective connection string changes and getting the below error while loading the Sitecore login page: Error: Could not find add ...
0
votes
1answer
30 views

Getting Started template Sitecore 10- running up.ps1 - failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0

Trying to do local Sitecore 10 setup using Getting Started Template. While running up.ps1 getting error failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0: ...
0
votes
1answer
42 views

Getting Started Template - File in use by another process [duplicate]

So I am doing the walkthrough: https://doc.sitecore.com/en/developers/101/developer-tools/walkthrough--using-the-getting-started-template.html Everything seems to work just fine (the occasional ...
0
votes
1answer
42 views

Powershell script to update the template but retain all the field values and rendering

I need to change the template of multiple items in a folder but need to retain the field values and rendering and layout details. I was able to change the template and retain the field values. But how ...
0
votes
1answer
28 views

Glass Mapper GetLayoutItem depreciated method

We are updating GlassMapper from 4 to 5. Since the GlassController is depreciated in new version and we have used GetLayoutItem in many places. Can it be replaced with MvcContext.GetContextItem from ...
0
votes
1answer
17 views

Sitecore Custom language causing issue while switching an item in the newly created custom language

I have created a new language "en-JP" and used the below entry in LanguageDefinitions.config file <language id="en" region="JP" codepage="65001" encoding=&...
0
votes
0answers
29 views

Including width/height in JSS JSON response for Image field

Hopefully a simple question to answer. I am looking in to adding the Width and Height values of a image to the JSS JSON response for an Image field. Is there an out-of-the-box way using some config ...
1
vote
1answer
25 views

Sitecore 10.2 Horizon Internal Server Error

After installing Sitecore 10.2 Horizon I got this error. I compared this with Sitecore 10.1 Horizn web.config and found a change for modules="AspNetCoreModuleV2". Here is the section <...
2
votes
1answer
131 views

When Sitecore Developer Certificate will expire?

I wonder how long I can use the Sitecore developer certificate, somebody tells me that it might be expired next year, but here I see other answers https://community.sitecore.com/community?id=...
2
votes
0answers
28 views

How to make a component support a datasource item as well as being on a partial design [VueJS]

I'd like to make a component reusable whether it is a standard component with a datasource item specified, or on a partial design with no datasource and so it should fall back to using the routeData ...
0
votes
0answers
116 views

Sitecore Docker 10.2 on Windows 11

I am trying to build Sitecore 10.2 for containers on my Windows 11 system. Quite surprised when I got this message: 2017-10.2-20H2: Pulling from sxp/nonproduction/mssql-developer image operating ...
0
votes
0answers
30 views

Docker getting started template: You are not authorized to perform the task you are attempting. You may need to be assigned additional permissions

Hi when i tried to run the docker getting started template from Sitecore i got following error Your login is complete. You can close the browser tab now. Login information has been saved. Populating ...
0
votes
1answer
95 views

Glass Cast issues after upgrading from Sitecore 8.1 to Sitecore 10.1.2

I am trying to migrate Sitecore items from Sitecore 8.1 to Sitecore 10.1.2. During migration I have got an error as 'Item' does not contain a definition for 'GlassCast' and no accessible extension ...
0
votes
1answer
55 views

Cannot find any service with service name 'MSSQLSERVER' on docker-compose build

Has anyone ever run into the error below when running a build for Sitecore 10.1? It used to work fine and now this error pops up. I'm adding SPE and SXA to MSSQL. Again, it just started breaking but ...
0
votes
1answer
48 views

Programatically change all renderings with specific rendering parameter

I'm new to Sitecore powershell and I would like to know what's the best way to get all the items on my content tree that have a specific rendering parameter set so I can replace it with another value ...
0
votes
1answer
42 views

How to publish page with datasources

I have a need to publish a page in Sitecore with all of the items referenced in its rendering's data sources. The selectable options when publishing an item are the following: Publish Subitems - This ...

15 30 50 per page
1
3 4
5
6 7
215