All Questions

Filter by
Sorted by
Tagged with
0 votes
2 answers
96 views

How to find out if a rendering is used in any page

Using Sitecore 10.1.3 We have an existing application which uses both SXA default & custom renderings. There are 100+ renderings and many are not in use any more. For each rendering, I would ...
sukesh's user avatar
  • 3,131
1 vote
0 answers
62 views

Field Key under Sitecore Forms Conditional Setting not updating on duplicating [closed]

I have form section on which some conditions are applied. when i am duplicating section to create new one then Field Key under Sitecore Forms Conditional Setting not updating due to which conditions ...
akshay's user avatar
  • 11
1 vote
2 answers
63 views

How to provide a select list in the web application

I have a headless rendering based on this template: Heading: Single-line Text Description: Single-Line Text Background: Droplist (source: is an enum folder) I have a sample item: The droplist works ...
Bridgette Ryan's user avatar
0 votes
0 answers
29 views

NullReferenceException on Sitecore.Data.Eventing.Remote.MovedItemRemoteEvent

On my 9.0.2 Sitecore Reporting site, I saw this error in the logs: ERROR Exception while handling event Sitecore.Data.Eventing.Remote.MovedItemRemoteEvent Exception: System.NullReferenceException ...
Marcel Gruber's user avatar
0 votes
2 answers
47 views

SXA Component creation: "Access to the path is denied error" [closed]

There is a local Sitecore 10.3 Docker setup with SXA and SPE (6.4). Component creation fails with access denied powershell error trying to create the view .cshtml file: New-Item : Access to the path '...
Serhii Shushliapin's user avatar
2 votes
1 answer
57 views

Unhandled exception error when trying to login with Sitecore CLI

I have this error when trying login to sitecore using CLI. Unhandled exception. System.IO.FileNotFoundException: The configuration file 'cdp.config.json' was not found and is not optional. at ...
Umar Luqman's user avatar
1 vote
0 answers
41 views

Sitecore 10.2 Integration with Azure B2C using Owin Middleware

I am using an ASP.NET MVC application to connect to AD using owin middleware. This is the startup class: try { IdentityModelEventSource.ShowPII = true; app.SetDefaultSignInAsAuthenticationType(...
Shrinivasan's user avatar
1 vote
1 answer
100 views

Unicorn throws error in content delivery - Could not find base site 'shell' for site 'unicorn'

Sitecore throws below error when loading newly setup instance. Message: Could not find base site 'shell' for site 'unicorn'. Source: Sitecore.Kernel It is mentioned in Git that this issue is fixed in ...
Meghan's user avatar
  • 427
3 votes
2 answers
87 views

Configuring Sitecore Publishing Service to update multiple custom indexes

I'm currently trying to set up the Sitecore Publishing Service on an instance of Sitecore 10.1 (the page for all of the downloads and instructions is here) Without the publishing service, we rely on 4 ...
Joe Dowland's user avatar
1 vote
0 answers
47 views

Sitecore campaign triggered doesn't show results in the report

I'm trying to trigger a campaign via API. There are no issues in the logs, the code runs with no issues, but I don't see any results in the respective campaign report, it always says "No Data ...
sns's user avatar
  • 403
2 votes
1 answer
102 views

My Solr health check during docker compose up is failing in my local xm cloud instance

I am having an issue with starting my XM Cloud Local Docker instance, using the up.ps1 script. It looks to be stopping specifically at this health check: test: ["CMD", "powershell",...
Bridgette Ryan's user avatar
5 votes
1 answer
71 views

Content Hub Date Time Field not displaying Time option

I am using Sitecore Content Hub and in one of the Content Types we have defined the Field type Datetime Field: However, last two days I observed that while selecting the date the time option does not ...
Himmat Singh Dulawat's user avatar
1 vote
3 answers
145 views

Sitecore in-place upgrade best approach suggestions [closed]

We are planing to upgrade Sitecore 9.3 to 10.3 and the approach we have chosen is an in-place upgrade (Update Sitecore on existing 9.3 instance). The 9.3 application is running in Azure. Could some ...
Reddy's user avatar
  • 125
1 vote
0 answers
52 views

How to retain the session value in sitecore 10.2

How to retained the session, when i clicked the media url session is null. I have developed external based authentication, I stored value on session, When i clicked the media url or Pdf url(used ...
Hasanshali's user avatar
2 votes
0 answers
31 views

Access Denied Error After Configuring "Require Login"

I'm having a problem with Sitecore 10. I made a page that should only be seen by people who log in. I used the require login setting for this page from the security editor. But it's not working the ...
Owais Ahmed's user avatar
0 votes
2 answers
46 views

Sitecore XP 10.3.1, Sitecore Headless Services Server XP 21.0.587

I have created article detail page. On that page I have dropped a placeholder where I am dropping nextArticle Component. What will be the best approach to get only one article in the nextArticle. We ...
Parshant's user avatar
0 votes
0 answers
17 views

Sitecore Redirect to Original Page After Login or SSO Authentication

I'm working with Sitecore 10 and facing an issue with user redirection post-login and SSO authentication. I have implemented a custom HttpRequestProcessor to check if the user is authenticated and ...
Owais Ahmed's user avatar
1 vote
0 answers
32 views

Editing in Pages is disabled for this site. Please contact your site administrator

Somehow I got into this issues after running some cleanup database in Control Panel. Whenever I open any sites under pages.sitecorecloud.io, I always get this warning dialog "Editing in Pages is ...
rayray's user avatar
  • 71
0 votes
0 answers
56 views

Correct User Logged In, but Sitecore.Context.User Returns extranet\Anonymous and IsAuthenticated is False

I'm working with Sitecore 10 and encountering a peculiar issue with user authentication. On the Sitecore login page, the correct logged-in user's name is displayed in the top right corner, indicating ...
Owais Ahmed's user avatar
1 vote
0 answers
29 views

Sitecore 10: "Permission Denied" Error After Setting "Require Login" with Azure SSO

I have successfully set up Azure SSO on my Sitecore 10 instance. However, I'm encountering an issue with restricting access to certain pages. Steps I followed: Set up Azure SSO - This is working ...
Owais Ahmed's user avatar
2 votes
1 answer
44 views

What's the best way to register components into the component builder from other directories?

I'm working on a monorepo solution which would have a set of Shared components one level above the site folder. I'm looking at updating scripts\generate-component-builder\plugins\components.ts per the ...
Mark Gibbons's user avatar
  • 5,582
0 votes
1 answer
57 views

How SXA resolves the Sitecore.Context.Database.Name

I noticed a thing in SXA that on the new publishing target-based CD we have 2 connection strings like <add name="web" ...../> and <add name="preview" ..../>. When the ...
Jumping Rabbit's user avatar
1 vote
1 answer
53 views

Add new link to sitecore/admin page without changing any existing sitecore files [duplicate]

We have created a new .aspx page to download some files from which are created by another service in the root node. We have placed this page in the *sitecore\admin* folder and is working fine. the ...
Shaurya's user avatar
  • 457
2 votes
1 answer
42 views

Make background color of sitecore form configurable from sitecore

I am using Sitecore MVC form in rendering and the requirement is to make user capable of changing form back ground. Need suggestions to achieve it. Can we use rendering param in Sitecore form? Can we ...
Rashmi Ranjan's user avatar
5 votes
1 answer
89 views

Glassmapper Set outputHeightWidth = true by default

I have a requirement where I need to display the image height and width tags on images. This is also a performance ranking factor for Google Lighthouse. By default, this is set to false in Glassmapper ...
Kode's user avatar
  • 243
1 vote
1 answer
68 views

Rendering Host not opening in my local after taking latest XM Cloud repo

I have download the latest repo from https://github.com/sitecorelabs/xmcloud-foundation-head and successfully created by local docker instance, but when I try to run npm run start:connected it ...
Nelson's user avatar
  • 50
0 votes
1 answer
60 views

SOLR issue - Install Sitecore 10.3

I'm facing the issue while installing the Sitecore 10.3 on my local. In the first step followed prerequisites step and install SOLR at the time SOLR is not installing it stuck on the 3rd out of 20. ...
Rameshkumar's user avatar
2 votes
1 answer
97 views

Federated Authentication with Space in Site Name

I have several SXA sites with spaces in the site name. When enabling federated login for a site containing a space in the name I get the following error on the redirect. "Site from query string ...
creativeflood's user avatar
2 votes
0 answers
36 views

Items deleted in Content Hub that were synced to Sitecore XM Cloud via CMP are not deleted in Sitecore XM Cloud

We are using CMP to push assets from Content Hub into XM Cloud. The sync from Content Hub to XM Cloud works properly. However, we have observed that when assets are deleted or archived in Content Hub, ...
Ed Schwehm's user avatar
  • 3,036
0 votes
0 answers
97 views

Sitecore SXA search ordering with Solr

I'm trying to understand how results are ordered when using a SXA Search results component without using a Default sort order option or a Sort result component. I need this for a site search, where ...
z00mable's user avatar
  • 621
0 votes
2 answers
92 views

Can I Get any Item in specific language

I am working on implementing tagging on the website, where we require English values for certain fields while the site is in Arabic. We retrieve items through GraphQL. For some components, we have ...
Muddassir Pasta's user avatar
1 vote
1 answer
60 views

Deployment in XM cloud from Gitlab

We are moving code repo from Github to Gitlab. It was just simple project without any much customization. So we were using github connecttion in xm cloud i.e out of the box setup provided in xm cloud ...
Sitecoredev's user avatar
1 vote
1 answer
37 views

How do you resolve: GetEdmModel cannot be called more than once error?

I have tried rebuilding the solution and deploying it. The deploy task finishes but I get the above error when the unicorn sync begins as the site cannot be accessed. I've searched online and cannot ...
Rob Connolly's user avatar
1 vote
1 answer
40 views

Is it good practice to use bucket items with Children?

I need to be able to build a navigation component, using items that are under a bucket. There is a requirement in which the navigation would require different levels of nesting. I was wondering if it'...
minkz96's user avatar
  • 13
1 vote
0 answers
43 views

SPE is not working [closed]

When I run PowerShell, I am getting below error. What could be the reason? Please assist. SItecore 9.2 and SPE 5.0
Rashmi Ranjan's user avatar
1 vote
1 answer
48 views

"Send Email Compaign Message" action is not working when I select DropdownListField as SelectEmailField

I am using sitecore 10.3 and working with sitecore forms "Send Email Compaign Message" Action. it is working and e-mails are sent when I select "Email" Field but it is not working ...
shimaa elsayed's user avatar
1 vote
1 answer
55 views

Custom hidden field for Sitecore Forms isn't maintaining value on submit

I have a custom hidden field. The model uses a rendering parameter on the page to set the value of the hidden field, and the same form is used on multiple pages which is why I'm using a rendering ...
Erica Stockwell-Alpert's user avatar
1 vote
1 answer
86 views

Implementing Google Recaptcha on Sitecore Forms 10.3 Headless with React JS

could someone please explain or share the documentation or articles for implementing Google Recaptcha on Sitecore Forms 10.3 Headless with React JS? I haven't found any useful articles related to it. ...
Abdul Lathif's user avatar
1 vote
1 answer
44 views

Sitecore Form Number Field with plus and minus icon

I need Sitecore Form Number Field with plus and minus icon that will increment and decrement entered value. How to get this kind of field. Any OOTB filed can be used with some minor updates.
Archit's user avatar
  • 11
0 votes
0 answers
49 views

Custom General Link - Sitecore 10.2

I have created the "Custom General Link" field type by duplicating the "General Link," as I have to add one additional control property that is "Telephone". I followed ...
Saket Singh's user avatar
2 votes
1 answer
46 views

How can I patch Sitecore Identity Server 7 App Insights Instrumentation Key?

I have managed to patch settings like CertThumbprint and the ConnectionString by setting environment variables in the following style: Sitecore_Sitecore__IdentityServer__CertificateThumbprint ...
djh's user avatar
  • 23
1 vote
1 answer
32 views

Item versions to create by date [closed]

We have requirement to show some text content (rich text field) based on revision date updated (date field). Latest updated content (sorted by date in descending) will be shown at the top . So content ...
Akshay D's user avatar
1 vote
1 answer
63 views

add component in experience editor not working

I am trying to add a component in experience editor in sxa project. On clicking add here button, the below popup is coming I am expecting this list of available rendering is there any configuration ...
Vinesh's user avatar
  • 127
0 votes
0 answers
15 views

Show Fltered result in SItecore Form [duplicate]

I have Sitecore form with 5 rows. Each row have some image and description. I Have dropdown on top and I want to show/filter rows with images and description based on value selected in dropdown. So ...
Anuj's user avatar
  • 1
1 vote
0 answers
33 views

item version history to create items with Date field [closed]

We have requirement to show some text content (rich text field) based on revision date updated (date field). Latest updated content (sorted by date in descending) will be shown at the top . So content ...
Akshay D's user avatar
0 votes
1 answer
36 views

404 Error when building map

My path analyzer doesn't have any data. it is showing me like the image below. Could I know how to redeploy the map and rebuild the historical data?
Jack Noob's user avatar
1 vote
1 answer
65 views

"Coveo.UI.Components.Models.IBaseComponentProperties.Id" is not supported by "SitecoreIdMapper"

I'm new to Coveo and it's integration into Sitecore. We're currnently in the process of upgrading a 9.2 instance to 10.3. The search was working, but was missing a few things when we compared with the ...
Anthony's user avatar
  • 133
0 votes
1 answer
69 views

Login to Sitecore using Azure AD integration

We are using Sitecore 10.1.1. We have integrated Azure AD with Sitecore so that users can use their Azure accounts to login to Sitecore. Everything worked fine for all users, and then we got a request ...
litika chib's user avatar
0 votes
0 answers
43 views

Unable to access subpages in multisite NextJS+XM Cloud

So I have 2 sites under 1 project. My project was created by using https://github.com/sitecorelabs/xmcloud-foundation-head which already had multisite plugin installed and I'm able to setup the ...
rayray's user avatar
  • 71
0 votes
0 answers
28 views

Logging to Application Insights [duplicate]

I am trying to add Application Insights telemetry to a SiteCore project in Visual Studio 2019 using the steps documented in the following article, and have configured the connection string in the ...
Rohan's user avatar
  • 1

15 30 50 per page
1
3 4
5
6 7
261